Subject: [spring] Fwd: New Version Notification for draft-hu-spring-yang-00.txt

From: [email-masked]
Date: Mon, 9 Mar 2015 09:07:07 +0800

Hi, ALL

Below is a new draft about YANG data model for segment routing. Comments 
welcome.

Thanks.
Regards.
Fangwei

----- 转发人 HuFangWei175772/user/zte_ltd 时间 2015-03-09 09:04 -----

[email-masked] 
2015-03-06 15:42

收件人
"fangwei hu" <[email-masked]>, "Fangwei Hu" 
<[email-masked]>, "Frank Feng" <[email-masked]>, "Ran 
Chen" <[email-masked]>, "Frank Feng" <[email-masked]>, "Ran 
Chen" <[email-masked]>
抄送

主题
New Version Notification for draft-hu-spring-yang-00.txt

A new version of I-D, draft-hu-spring-yang-00.txt
has been successfully submitted by Fangwei Hu and posted to the
IETF repository.

Name:                            draft-hu-spring-yang
Revision:                00
Title:                           YANG Data model for Segment Routing
Document date:           2015-03-05
Group:                           Individual Submission
Pages:                           14
URL:            
http://www.ietf.org/internet-drafts/draft-hu-spring-yang-00.txt
Status:         https://datatracker.ietf.org/doc/draft-hu-spring-yang/
Htmlized:       http://tools.ietf.org/html/draft-hu-spring-yang-00

Abstract:
   This document defines a YANG data model for segment routing
   technology.  The data model covers configuration data and event
   notifications.

Please note that it may take a couple of minutes from the time of 
submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Tue, 17 Mar 2015 09:45:40 +0000

Hi Authors,

The YANG model that you have proposed addresses the use case where we want to  pushing configs to every individual  SPRING nodes via a centralized entity.
What I want to address here is the fact that a SPRING node can act as a mapping server (a single point of configuration for all the SPERING and non-SPRING nodes).

+--------------+    +----------------------------+
|  Manually |    |      SDN controller   |
+-------------+    +-----+----------------------+
               |             |
         +--- v-----------v--------+
         |   <push-Configs> |
         +----------------+--------+
                             |
                             |
     +----+             +--v--+
     | N1  +-----------+ N2  |  Mapping server
     +-+--+            +--+--+
         |                      |
         |                      |
         |                      |
     +-+--+              +- --+
     |  N3+--------------+ N4 |
     +----+              ++---+
                       Non-SPRING

To consider this use case in your model I suggest you add another encapsulation layer for you model,
<config-nodes>
<node> // with the ID the node can identify the configs addressed for it and the other node-leafs configs translate them and  advertise them using the Binding TLV.
<id>xx</node>
             // reste of node configs SRGB(required) , node-INDEX(required) , Adjacencies(not required/) , flags …
</node>
</node>
xxx
</node>
</node>
xxx
</node>
…..
<config-nodes>

Bests.
GUEDREZ Rabah.

De : spring [mailto:[email-masked]] De la part de [email-masked]
Envoyé : lundi 9 mars 2015 02:07
À : [email-masked]
Objet : [spring] Fwd: New Version Notification for draft-hu-spring-yang-00.txt

Hi, ALL

Below is a new draft about YANG data model for segment routing. Comments welcome.

Thanks.
Regards.
Fangwei

----- 转发人 HuFangWei175772/user/zte_ltd 时间 2015-03-09 09:04 -----
[email-masked]<mailto:[email-masked]>

2015-03-06 15:42

收件人

"fangwei hu" <[email-masked]<mailto:[email-masked]>>, "Fangwei Hu" <[email-masked]<mailto:[email-masked]>>, "Frank Feng" <[email-masked]<mailto:[email-masked]>>, "Ran Chen" <[email-masked]<mailto:[email-masked]>>, "Frank Feng" <[email-masked]<mailto:[email-masked]>>, "Ran Chen" <[email-masked]<mailto:[email-masked]>>

抄送

主题

URL:            http://www.ietf.org/internet-drafts/draft-hu-spring-yang-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: [email-masked]
Date: Wed, 18 Mar 2015 08:53:38 +0800

Hi,guedrez

Thanks for your comment.  We will update it in the next version.
 
Regards.
Fangwei

<[email-masked]> 
发件人:  "spring" <[email-masked]>
2015-03-17 17:45

收件人
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>
抄送

主题
Re: [spring] Fwd: New Version Notification for draft-hu-spring-yang-00.txt

Hi Authors,
 
The YANG model that you have proposed addresses the use case where we want 
to  pushing configs to every individual  SPRING nodes via a centralized 
entity.
What I want to address here is the fact that a SPRING node can act as a 
mapping server (a single point of configuration for all the SPERING and 
non-SPRING nodes).

To consider this use case in your model I suggest you add another 
encapsulation layer for you model,
<config-nodes>
<node> // with the ID the node can identify the configs addressed for it 
and the other node-leafs configs translate them and  advertise them using 
the Binding TLV.
<id>xx</node>
             // reste of node configs SRGB(required) , 
node-INDEX(required) , Adjacencies(not required/) , flags …
</node>
</node>
xxx
</node>
</node>
xxx
</node>
…..
<config-nodes>

Bests.
GUEDREZ Rabah.

De : spring [mailto:[email-masked]] De la part de 
[email-masked]
Envoyé : lundi 9 mars 2015 02:07
À : [email-masked]
Objet : [spring] Fwd: New Version Notification for 
draft-hu-spring-yang-00.txt

Hi, ALL 

Thanks. 
Regards.
Fangwei 

----- 转发人 HuFangWei175772/user/zte_ltd 时间 2015-03-09 09:04 ----- 

[email-masked] 
2015-03-06 15:42 

收件人
"fangwei hu" <[email-masked]>, "Fangwei Hu" <[email-masked]
>, "Frank Feng" <[email-masked]>, "Ran Chen" <[email-masked]
>, "Frank Feng" <[email-masked]>, "Ran Chen" <[email-masked]
> 
抄送

主题

Title:                                  YANG Data model for Segment 
Routing

Abstract:

The IETF Secretariat

Ce message et ses pieces jointes peuvent contenir des informations 
confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez 
recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages 
electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou 
falsifie. Merci.

This message and its attachments may contain confidential or privileged 
information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and 
delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been 
modified, changed or falsified.
Thank you.
_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring