Subject: Re: [spring] Modeling SRGB configuration for draft-ietf-spring-sr-yang

From: Pushpasis Sarkar <[email-masked]>
Date: Fri, 31 Jul 2015 05:37:18 +0000

My strong preference is Option 2. It simplifies migration and network consolidation usecases. Also it is very relevant in MSDC kind of use cases where a single node can be part of two different topologies running two different SR protocol. Index-management becomes much easier in each of the usecases.

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 22, 2015 at 10:49 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [spring] Modeling SRGB configuration for draft-ietf-spring-sr-yang

Hi WG,

In the current version of the config Yang model for SR, the SRGB list is configured at SR top level, so it is agnostic to the routing protocol.
We had some comment in Dallas on difficulties that having common label range shared between protocols could lead to.
During discussion in our design team, some point was also raised on routing protocol migrations that may be safer using a per protocol SRGB (so configuration the SRGB at IGP level rather than globally).

We would like to hear from the WG about the preference and arguments for both approaches :
Approach 1) keep SRGB configuration at top level, and so routing protocols will share the same label space (today proposal)
Approach 2) move SRGB configuration to protocols, each routing protocol manages its own label space.

Thanks to provide your feedback in order to solve this issue and have a consensus.

[Orange logo]<http://www.orange.com/>

Stephane Litkowski
Network Architect
Orange/SCE/EQUANT/IBNF/ENDD/NDE
Orange Expert Future Networks
phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20>
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20>
[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 31 Jul 2015 05:44:42 +0000

I tend to agree that proposal 2 is for migration, so would vote for option 2.

From: spring on behalf of Pushpasis Sarkar
Date: Friday 31 July 2015 07:37
To: Stephane Litkowski, "[email-masked]<mailto:[email-masked]>"
Subject: Re: [spring] Modeling SRGB configuration for draft-ietf-spring-sr-yang

Hi WG,

Stephane Litkowski
Network Architect