Subject: Re: [spring] working group last call for draft-ietf-spring-segment-routing

From: <[email-masked]>
Date: Fri, 7 Aug 2015 08:18:11 +0000

Hi Stefano, all

As an individual contributor, as part of the WG last call, I've reviewed the document. Please find enclosed some comments prefixed with Bruno:

The main comment is that I found the use of the SR algorithm to be under-specified.
 - In particular, section 3.2 (IGP-Prefix Segment, Prefix-SID) does not talk about it but only refers to the IGP shortest-path. (which BTW translated into 2 SR algorithms a few months ago, so you may need to also update the text about shortest path routing. e.g. " A packet injected anywhere within the SR/IGP domain with an active Prefix-SID will be forwarded along the shortest-path to that prefix." Does it refer to the original algo 0 or the new algo 1 ?).

Thanks,
Bruno

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of John G. Scudder
> Sent: Wednesday, July 22, 2015 3:12 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: [mpls] working group last call for draft-ietf-spring-segment-routing
> 
> Dear SPRING WG (and cc MPLS, OSPF, IS-IS, 6MAN, please include SPRING
> in replies per the reply-to):
> 
> As we discussed at the SPRING meeting yesterday, working group last call
> has been requested for draft-ietf-spring-segment-routing. Please reply to
> the list with your comments, including although not limited to whether or
> not you support advancing the document to RFC. Non-authors are especially
> encouraged to comment.
> 
> In consideration of the fact that a number of WG calls are going on
> concurrently, we will end the call on August 31, 2015.
> 
> Authors, please indicate whether you are aware of any relevant IPR and if
> so, whether it has been disclosed. (Please do this even if you've done it
> before, thanks for your help.)
> 
> Thanks,
> 
> --Bruno and John
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 7 Aug 2015 08:47:47 +0000

John,

As an author, I'm not aware of non-disclosed IPR.
Note that there are disclosed IPR: https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-spring-segment-routing
For some reason they do not appear on all tools pages. I have opened a case.

Thanks,
Bruno

> From: John G. Scudder  Sent: Wednesday, July 22, 2015 3:12 PM
> To: [email-masked]