Subject: Re: [spring] [mpls] working group last call for draft-ietf-spring-segment-routing

From: <[email-masked]>
Date: Fri, 4 Sep 2015 13:58:11 +0000

Hi,

I'm not aware of any IPR

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of John G. Scudder
Sent: Wednesday, July 22, 2015 15:12
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] working group last call for draft-ietf-spring-segment-routing

Dear SPRING WG (and cc MPLS, OSPF, IS-IS, 6MAN, please include SPRING in replies per the reply-to):

As we discussed at the SPRING meeting yesterday, working group last call has been requested for draft-ietf-spring-segment-routing. Please reply to the list with your comments, including although not limited to whether or not you support advancing the document to RFC. Non-authors are especially encouraged to comment.

In consideration of the fact that a number of WG calls are going on concurrently, we will end the call on August 31, 2015.

Authors, please indicate whether you are aware of any relevant IPR and if so, whether it has been disclosed. (Please do this even if you've done it before, thanks for your help.)

Thanks,

--Bruno and John

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Mon, 7 Sep 2015 14:04:09 +0000

Hi Brian,

to me, the main document describing segment routing is draft-ietf-spring-segment-routing. Within this document we describe the architecture and main functions.

draft-spring-segment-routing-mpls describes its instantiation to the mpls dataplane and draft-previdi-6man-segment-routung-header describes its ipv6 instantiation.

Therefore, wouldn't be ok to have draft-previdi listed as informative in the segment routing architecture draft?

Thanks.

s.

On Jul 24, 2015, at 10:49 AM, Brian E Carpenter <[email-masked]> wrote:
> Hi,
> 
> It seems very strange to me that [I-D.previdi-6man-segment-routing-header]
> is an Informative reference. Surely it is Normative (i.e., required reading
> for an implementer)?
> 
> That leads to another comment. As we know, if 6man accepts that I-D, it will
> certainly be on the basis that the header is strictly confined to a
> "consenting adults" domain (e.g. without middleboxes that can't deal with
> strange extension headers, without MTU size & fragmentation problems, etc.).
> But in draft-ietf-spring-segment-routing, there seems to be no definition
> of a segment-routing domain, what happens at its boundaries, etc. The word
> "domain" is used but without clear definition. I believe that is of normative
> importance (i.e. it's not a use case issue) and is needed here so that
> draft-previdi- can build on it.
> 
>    Brian
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 7 Sep 2015 15:50:15 +0000

Hi Stefano, Brian, 
I agree with Stefano - the overall architecture should be normative for the subordinate data plane realizations (MPLS, IPv6) but not vice versa. 
Thanks,
Acee
> On Sep 7, 2015, at 10:04 AM, Stefano Previdi (sprevidi) <[email-masked]> wrote:
> 
> Hi Brian,
> 
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 9 Sep 2015 07:37:58 +0000

Chris,

<sorry for being late on this one>

I will put back the original Mirror Segment section in the draft. In fact we did have a text for it in the very first instance of the draft (draft-filsfils-rtgwg-segment-routing-00)

Thanks.
s.

On Aug 7, 2015, at 5:09 PM, Chris Bowers <[email-masked]> wrote:

> All,
> 
> It appears that section 3.6.3 of this draft which covers using the binding-sid to advertise a mirroring context got dropped between draft-ietf-spring-segment-routing-00 and draft-ietf-spring-segment-routing-01, in February.    Presumably this was done because it didn't have any text in it.  The text for the section in the draft-00 version read "TBD".
> 
> I would like to request that this section be put back into the draft.  I propose the following text for this section.
> 
> 3.6.3 Mirroring Context
> The Binding SID is used to advertise the context label for egress node protection. As described in draft-bowers-spring-advertising-lsps-with-sr,  a node B  providing egress node protection for a protected node A advertises a segment associated with A's context identifier using the Binding SID with the mirror context flag set .  In the event of a failure, a point of local repair (PLR) diverting traffic from A to B pushes that segment on the traffic.  B then uses that segment to interpret underlying segments or labels in the context of A.
> 
> Thanks,
> Chris
> 
> Sent: Wednesday, July 22, 2015 8:12 AM
> To: [email-masked]

---

From: <[email-masked]>
Date: Mon, 28 Sep 2015 09:44:22 +0000

Hi,

During WGLC, comments have been sent and 2 versions of the drafts published (-04, -05).

Can you check whether your comments have been taken into account?  (as some comments have not been fully resolved on the mailing list)

Thanks,
-- Bruno

> From: John G. Scudder > Sent: Wednesday, July 22, 2015 3:12 PM
> 
> As we discussed at the SPRING meeting yesterday, working group last call has
> been requested for draft-ietf-spring-segment-routing. Please reply to the list
> with your comments, including although not limited to whether or not you
> support advancing the document to RFC. Non-authors are especially
> encouraged to comment.
> 
> In consideration of the fact that a number of WG calls are going on
> concurrently, we will end the call on August 31, 2015.
> 
> Authors, please indicate whether you are aware of any relevant IPR and if so,
> whether it has been disclosed. (Please do this even if you've done it before,
> thanks for your help.)
> 
> Thanks,
> 
> --Bruno and John