Subject: [spring] Query related to SR Architecture

From: Usman Latif <[email-masked]>
Date: Tue, 15 Sep 2015 07:44:53 +0000 (UTC)

Hi,

I have a basic question around SPRING/SR.

How can an IP/MPLS carrier in the market today deploy SPRING in their core network without SR being able to support efficient multicast routing in the network?
Are we not restricting carriers by proposing the SPRING/SR architecture when we know it does not efficiently support routing of multicast traffic?

I would like get some feedback on this point

thanks,
Usman

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 15 Sep 2015 09:02:36 +0000

Hi,

if you're an operator (SP, content, etc) and looking for a multicast solution, maybe you should have a look at BIER WG.

Thanks.

s.

On Sep 15, 2015, at 9:44 AM, Usman Latif <[email-masked]> wrote:

> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 15 Sep 2015 12:07:22 +0200

Stefano,

How SR controller is to be aware about amount of multicast traffic on a per
link basis in a given network to wisely select optimal paths for unicast ?

Are you advocating completely disjoined topologies for unicast and
multicast ? If so it would be great to document it somewhere ... perhaps
even as BCP.

Of course there are more solutions for engineered coexistance of both in
the same topology, but just saying go to BIER IMHO is not sufficient :)

Best,
R.
Hi,

if you're an operator (SP, content, etc) and looking for a multicast
solution, maybe you should have a look at BIER WG.

Thanks.

s.

On Sep 15, 2015, at 9:44 AM, Usman Latif <[email-masked]> wrote:

> How can an IP/MPLS carrier in the market today deploy SPRING in their
core network without SR being able to support efficient multicast routing
in the network?
> Are we not restricting carriers by proposing the SPRING/SR architecture
when we know it does not efficiently support routing of multicast traffic?

---

From: Usman Latif <[email-masked]>
Date: Tue, 15 Sep 2015 10:09:03 +0000 (UTC)

Thanks Stefano,
Although PIM based IP multicast or draft-rosen is an option for an MPLS based carrier to continue to provide mutlicast without it being label switched multicast, my understanding is that BIER introduces a bit indexed method of replication without needing intermediate routers to participate in the state.

The obvious question then would be, if a carrier decided to use SR (alongwith BIER), e.g. can BIER coexisting with SPRING/SR provide the same level of convergence/SLA for multicast traffic in existing MPLS-based core networks that a carrier would otherwise achieve using P2MP-TE (with node/link FRR)?
In other words, would potentially TI-FRR (using SR) be applicable to BIER based multicast as well ?

RegardsUsman

      From: Stefano Previdi (sprevidi) <[email-masked]>
 To: Usman Latif <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
 Sent: Tuesday, 15 September 2015, 19:02
 Subject: Re: [spring] Query related to SR Architecture
   
Hi,

Thanks.

s.

---

From: Usman Latif <[email-masked]>
Date: Tue, 15 Sep 2015 10:18:41 +0000 (UTC)

I tend to agree with Robert - The point is if we are going to advocate source routing for both unicast (using SR) and multicast (using BIER) then we have to have a comparative analysis done for what that entails in terms of existing carriers using MPLS in their core and using LDP/RSVP-TE for "both unicast and multicast at the sametime" and being able to achieve traffic engineering and fast rerouting capability for both types of traffic at the sametime using one set of protocol.
If SR and BIER are disjoint from each other, then are we providing the same (or better) level of service from a protocol perspective to the carriers to meet their demands for unicast and multicast at the sametime?
The reason I bring this up is because it would probably be the last resort for a carrier to have to deploy both SR/BIER as well as LDP/RSVP to meet their demands around both multicast and unicast traffic.

thanks,Usman

      From: Robert Raszuk <[email-masked]>
 To: stefano previdi <[email-masked]> 
Cc: Usman Latif <[email-masked]>; [email-masked]; "[email-masked]" <[email-masked]> 
 Sent: Tuesday, 15 September 2015, 20:07
 Subject: Re: [spring] Query related to SR Architecture
   
Stefano,How SR controller is to be aware about amount of multicast traffic on a per link basis in a given network to wisely select optimal paths for unicast ?Are you advocating completely disjoined topologies for unicast and multicast ? If so it would be great to document it somewhere ... perhaps even as BCP.Of course there are more solutions for engineered coexistance of both in the same topology, but just saying go to BIER IMHO is not sufficient :)Best,
R.Hi,

Thanks.

s.