Subject: [spring] [SPRING] Query related to SR Architecture

From: Gaurav agrawal <[email-masked]>
Date: Wed, 9 Sep 2015 10:38:06 +0000

Hi,

We would like to have a label stack with only two labels such a way that service label is a top label  and the bottom label would be SR destination node label. This is to make sure each intermediate node perform the specified service based on the top label while reaching the destination.
We would appreciate if anyone could clarify whether SR architecture could allow a service label to be a top label in a label stack.

Thanks and Regards,
Gaurav Agrawal
[Company_logo]

Mobile: +91-7838700296
Email: [email-masked]<mailto:[email-masked]>
Huawei Technologies Co., Ltd.

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 9 Sep 2015 11:30:54 +0000

Gaurav,
Not sure I understand the context for your requirement.
But to the best of my understanding your requirement does not match MPLS architecture.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: spring [mailto:[email-masked]] On Behalf Of Gaurav agrawal
Sent: Wednesday, September 09, 2015 1:38 PM
To: [email-masked]
Cc: Anil Kumar S N (VRP Network BL); Vinod Kumar S 70786
Subject: [spring] [SPRING] Query related to SR Architecture

Hi,

Thanks and Regards,
Gaurav Agrawal
[Company_logo]

Mobile: +91-7838700296

---

From: Gaurav agrawal <[email-masked]>
Date: Wed, 9 Sep 2015 12:39:28 +0000

Dear Alexander,

Thanks for your inputs. Let me further elaborate on the subject.

The requirement is to make every node on the path to destination to perform a specific service(Service could be anything).

Currently Service label can only follow a Node Label, because of which to let every node perform same service, SR Label stack expects to have node and service label for each transit node, this results in huge label stack.

If we can push a service label prior to node label & each intermediate node can perform below operation:
1) Pop Service Label & perform/schedule the service.
2) Decide the further forwarding based on Node Label
3) Push the service label back to stack.

With this we needn't repeat the service label for each transit node thereby making the SR Label stack COMPACT.

We can derive many optimized implementation by having this.

So, we would like to hear from You and MPLS/SPRING community about our view point.

Thanks and Regards,
Gaurav Agrawal
[Company_logo]

Mobile: +91-7838700296

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Wednesday, September 09, 2015 5:01 PM
To: Gaurav agrawal
Cc: Anil Kumar S N (VRP Network BL); Vinod Kumar S 70786; [email-masked]; [email-masked]
Subject: RE: [SPRING] Query related to SR Architecture

Gaurav,

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

Hi,

Thanks and Regards,
Gaurav Agrawal
[Company_logo]

Mobile: +91-7838700296