Subject: [spring] draft-ietf-spring-segment-routing-05

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Wed, 23 Sep 2015 06:19:22 +0000

Hi Authors,

Can we add below section, let me know your opinion.

3.5.3.  Bundle Adjacency Segments

  A number of physical interfaces can be bundled to be a
   a logical interface. Adj-SIDs can be used in order to represent individual member interface
  of a logical bundle interface. The few advantages of the bundled interface are expansion of
  interface bandwidth,  increase the link reliability and flow load sharing.

   IGP extensions may carry bundle member ID to map Adj-SIDs to each member interface
   of a bundled logical interface. On demand basis a device might choose to advertize
   only one Adj-SID for bundled logical interface or along with one Adj-SID to
   bundled logical interface a device can advertize Adj-SID to each member
   interface of bundled logical interface.

Thanks & Regards
Anil S N

"Be liberal in what you accept, and conservative in what you send" - Jon Postel

---

From: Rob Shakir <[email-masked]>
Date: Thu, 24 Sep 2015 08:30:31 -0400

Anil,

Thanks for the mail.

On September 23, 2015 at 02:19:54, Anil Kumar S N (VRP Network BL) ([email-masked]) wrote:
> interface bandwidth, increase the link reliability and flow load sharing=

Can you expand on why you think this adds to what is said in 3.5.1? This document is not intended to be an exhaustive list of all of the things that one could do with SR, and my feeling is that §3.5.1 adequately covers the Adj-SID use case.

Thanks,
r.

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Thu, 24 Sep 2015 13:05:55 +0000

Hi Rob,
	
	Thanks for reverting back the mail. 

If there is a desire to control traffic flows on individual bundle interface, 
information about each of the bundle members interface is required to be flooded 
using IGP extension. Segment routing framework is generic and flexible enough to handle this. 
IGP extension need to support it.

There exist an ISIS Draft to handle it which I got to know yesterday from Les Ginsberg
Advertising L2 Bundle Member Link Attributes in IS-IS
draft-ginsberg-isis-l2bundles-00.txt

I feel it's better to have all related information in one draft rather than having multiple drafts 
To distribute related information.

One small use case would be monitoring availability of bundle interface availability.

We can find reference to it in "Segment Routing Use Cases"
6.1.  Monitoring a remote bundle

   +--+    _   +--+                    +-------+
   |  |   { }  |  |---991---L1---662---|       |
   |MS|--{   }-|R1|---992---L2---663---|R2 (72)|
   |  |   {_}  |  |---993---L3---664---|       |
   +--+        +--+                    +-------+

            Probing all the links of a remote bundle	

Thanks & Regards
Anil S N

“Be liberal in what you accept, and conservative in what you send” - Jon Postel

> -----Original Message-----
> From: spring [mailto:[email-masked]] On Behalf Of Rob Shakir
> Sent: 24 September 2015 18:01
> To: [email-masked]; Anil Kumar S N
> (VRP Network BL)
> Cc: [email-masked]
> Subject: Re: [spring] draft-ietf-spring-segment-routing-05
> 
> Anil,
> 
> Thanks for the mail.
> 
> > A number of physical interfaces can be bundled to be a a logical
> > interface. Adj-SIDs can be used in order to represent individual
> > member interface of a logical bundle interface. The few advantages of
> > the bundled interface are expansion of interface bandwidth, increase
> > the link reliability and flow load sharing=
> 
> Can you expand on why you think this adds to what is said in 3.5.1?
> This document is not intended to be an exhaustive list of all of the
> things that one could do with SR, and my feeling is that §3.5.1
> adequately covers the Adj-SID use case.
> 
> Thanks,
> r.
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Rob Shakir <[email-masked]>
Date: Fri, 25 Sep 2015 09:22:36 +0100

On 24 September 2015 at 09:09:00, Anil Kumar S N (VRP Network BL) ([email-masked]) wrote:
> […snip…]

Right - but this draft does not seek to catalogue every possible use of SR - since it could not possibly do this (given that some will be invented in the future). The examples within it give sufficient motivation for the types of SID that are defined which, IMHO, is their intention.

I think it would be best to finalise this document with what is there. Perhaps my co-authors will disagree.

r.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Fri, 25 Sep 2015 08:29:36 +0000

I agree.

s.

---

From: "Ahmed Bashandy (bashandy)" <[email-masked]>
Date: Sat, 26 Sep 2015 09:50:02 -0700

Totally agree

We expect lots of applications and use cases to come.
Let's close this document

Ahmed

---

From: Ebben Aries <[email-masked]>
Date: Mon, 28 Sep 2015 14:53:30 -0600

+1 to Rob's comment here

Just because use cases come along while another draft is in flight
shouldn't mean you have to loop back to the initial draft.  If this was
the case, you're prolonging an already lengthy process.  There are
likely many more to come in the future that have not been thought of yet....

On 09/25/2015 02:22 AM, Rob Shakir wrote:
> https://urldefense.proofpoint.com/v1/url?u=https://www.ietf.org/mailman/listinfo/spring&k=ZVNjlDMF0FElm4dQtryO4A%3D%3D%0A&r=GJQFPrZyyh453ywaGV%2FvoQ%3D%3D%0A&m=iHfJlJW%2FL4TlTdzDDLsURt1PgCZ0SxsuqCo%2BvMo%2F6aQ%3D%0A&s=6e218431a9c85e2b85037955a8b78442a48f34373701dbff963e658251e612ff
>

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Tue, 29 Sep 2015 03:00:08 +0000

This use case was presented in Segment routing use case draft which is adopted by IETF. 
I feel this is important and basic requirement for Segment routing. 
IMHO : This can be incorporated. I feel it's not too late to add. 
Hope authors and community agree to my opinion.

Thanks & Regards
Anil S N

> From: spring [mailto:[email-masked]] On Behalf Of Ebben Aries
> Sent: 29 September 2015 02:24
> To: Rob Shakir; [email-masked];
> Anil Kumar S N (VRP Network BL)
> Cc: [email-masked]
> >> If there is a desire to control traffic flows on individual bundle
> >> interface, information about each of the bundle members interface is
> >> required to be flooded using IGP extension. Segment routing
> framework
> >> is generic and flexible enough to handle this.
> > Right - but this draft does not seek to catalogue every possible use
> of SR - since it could not possibly do this (given that some will be
> invented in the future). The examples within it give sufficient
> motivation for the types of SID that are defined which, IMHO, is their
> intention.
> >
> https://urldefense.proofpoint.com/v1/url?u=https://www.ietf.org/mailma
> >
> n/listinfo/spring&k=ZVNjlDMF0FElm4dQtryO4A%3D%3D%0A&r=GJQFPrZyyh453ywa
> > GV%2FvoQ%3D%3D%0A&m=iHfJlJW%2FL4TlTdzDDLsURt1PgCZ0SxsuqCo%2BvMo%2F6aQ%
> >
> 3D%0A&s=6e218431a9c85e2b85037955a8b78442a48f34373701dbff963e658251e612
> > ff
> >
>