Subject: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

From: <[email-masked]>
Date: Thu, 14 Apr 2016 07:50:34 +0000

Dear WG,

As we discussed at our meeting last week, working group adoption has been requested for draft-ginsberg-spring-conflict-resolution.
Please reply to the list with your comments, including although not limited to whether or not you support adoption.

Thanks,

--John and Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 14 Apr 2016 07:55:07 +0000

> From:  [email-masked] > Sent: Thursday, April 14, 2016 9:51 AM
> 
> Dear WG,
> 
> As we discussed at our meeting last week, working group adoption has been
> requested for draft-ginsberg-spring-conflict-resolution.

We will end the call on April 29, 2016.

> Thanks,
> 
> --John and Bruno
> 
> 
> 
> __________________________________________________________
> __________________________________________________________
> _____
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites
> ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez
> le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Thu, 14 Apr 2016 08:48:34 +0000

as co-author, I support the WG adoption of this draft
s.

> On Apr 14, 2016, at 9:50 AM, [email-masked] wrote:
> 
> Dear WG,
>

---

From: Peter Psenak <[email-masked]>
Date: Thu, 14 Apr 2016 10:58:37 +0200

Support the WG adoption as co-author.

thanks,
Peter

On 4/14/16 09:50 , [email-masked] wrote:
> .

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 14 Apr 2016 11:02:39 +0000

I support WG adoption. The conflict resolution document is required for
standard SID conflict error handling across all protocols and vendors.
Thanks,
Acee

On 4/14/16, 3:50 AM, "spring on behalf of [email-masked]"
<[email-masked] on behalf of [email-masked]> wrote:

>Please reply to the list with your comments, including although not
>limited to whether or not you support adoption.
>
>Thanks,
>
>--John and Bruno
>
>
>
>__________________________________________________________________________
>confidentielles ou privilegiees et ne doivent donc
>pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
>recu ce message par erreur, veuillez le signaler
>a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
>electroniques etant susceptibles d'alteration,
>information that may be protected by law;

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 14 Apr 2016 15:39:55 +0000

Support as co-author.

   Les

> -----Original Message-----
> From: spring [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Thursday, April 14, 2016 12:55 AM
> To: [email-masked]
> Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption
> call
> 
> > As we discussed at our meeting last week, working group adoption has
> > been requested for draft-ginsberg-spring-conflict-resolution.
> > confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> > exploites ou copies sans autorisation. Si vous avez recu ce message
> > par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> > que les pieces jointes. Les messages electroniques etant susceptibles
> > d'alteration, Orange decline toute responsabilite si ce message a ete altere,
> deforme ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or
> > privileged information that may be protected by law; they should not
> > be distributed, used or copied without authorisation.

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 14 Apr 2016 11:25:03 -0700

Yes/support, very much needed guideline on conflict resolution!

---

From: "Ahmed Bashandy (bashandy)" <[email-masked]>
Date: Thu, 21 Apr 2016 16:29:07 -0700

Support. Very much needed

Ahmed

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Fri, 22 Apr 2016 13:04:24 +0000

Support.

Regards,
Nagendra

---

From: <[email-masked]>
Date: Mon, 25 Apr 2016 08:38:29 +0000

+1

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, April 14, 2016 09:51
To: [email-masked]
Subject: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Dear WG,

Thanks,

--John and Bruno

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jon Mitchell <[email-masked]>
Date: Mon, 25 Apr 2016 12:44:34 -0400

Support adoption...

-Jon

---

From: Martin Horneffer <[email-masked]>
Date: Tue, 26 Apr 2016 15:14:12 +0200

Support.

 From an operator's point of view I see strong need for covering this topic.

Best regards, Martin

---

From: Uma Chunduri <[email-masked]>
Date: Wed, 27 Apr 2016 23:31:23 +0000

Dear Authors,

Have few comments on the draft:

1.
        As I indicated during meeting - I am not sure why we have to club  verification of SIDs advertised through regular protocol reachability
                prefixes and the ranges advertised through 'Mapping Server'  (SRMS). I didn't see any compelling reason to do this.
                 SIDs advertised through reachability prefixes doesn't have ranges unlike SRMS advertisements.
                 As SRMS advertisements are primarily for nodes which are not SR capable and  I feel we should not mix this with nodes which are SR capable.

        This isolation helps restricting the resolution work primarily for multiple SRMS entries advertised through one node or multiple nodes.
                SRMS advertisements are indeed little bit unique in that you are advertising "configuration" on behalf of node X from node Y
                with ranges (both prefix ranges and SID ranges).

2.
                Regarding  the scope of conflict resolution:

       Section 1

           "   The problem to be addressed is protocol independent i.e., segment
        related advertisements may be originated by multiple nodes using
        different protocols and yet the conflict resolution MUST be the same
        on all nodes regardless of the protocol used to transport the
        advertisements."

        Section 3.2.8
          "   o  In cases where multiple routing protocols are in use mapping
      entries advertised by all routing protocols MUST be included."

      This sounds like we are seeking to resolve conflicting entries outside and across the protocols?
      Each IGP has separate mechanism for advertising mapping entry and I this is not clear with the current version of the draft how we can cross verify SID/Prefix conflict across  the protocol.
     Can you clarify this?

--
Uma C.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, April 14, 2016 12:55 AM
To: [email-masked]
Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

> From:  [email-masked]<mailto:[email-masked]> > Sent: Thursday, April 14, 2016 9:51
> AM
>
> Dear WG,
>

> d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sun, 1 May 2016 05:10:33 +0000

Uma -

We are indeed defining conflict resolution across all the SID advertisements regardless of source (protocol or SRMS) - as the sections you have quoted clearly state.

Why? Because we need consistent use of SIDs in the forwarding plane. From forwarding perspective it matters not whether the SID was advertised by protocol instance #1 or #2 or by an SRMS. What matters is that the SID I use to determine what label I install in my forwarding plane is the same SID that my neighbors will use. Otherwise forwarding will be broken.

   Les

From: spring [mailto:[email-masked]] On Behalf Of Uma Chunduri
Sent: Wednesday, April 27, 2016 4:31 PM
To: [email-masked]; [email-masked]
Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Dear Authors,

1.

2.

       Section 1

        Section 3.2.8

--
Uma C.