Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

From: Uma Chunduri <[email-masked]>
Date: Tue, 3 May 2016 22:59:29 +0000

Les,

With all due respects, cross protocol verification  of prefix and SID conflicts as an "architectural change"  and it can severely impact the existing implementations (at least the one I work on).
Also I have couple of cases where current version of the draft is not clear about resolution.

IMO, first we need clarity with in a protocol instance resolution rules before going to resolve the same across protocols (I mentioned few cases below) .
Separation of reachability advertisements and SRMS would help "cross protocol" verification of the ranges and SRMS is not applicable to all protocols.

In-line [Uma]:

--
Uma C.

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 10:11 PM
To: Uma Chunduri; [email-masked]; [email-masked]
Subject: RE: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Uma -

We are indeed defining conflict resolution across all the SID advertisements regardless of source (protocol or SRMS) -

[Uma]: While you can theoretically do anything for current implementation this kind of cross protocol verification is a new architectural requirement.
               Because it seems "a central entity" need to gather all different protocol instances SRMS advertisements and should settle with resolution.

-          Also note SRMS is not applicable for BGP but it seems all prefix SIDs need to be verified  with IGP instances SRMS advertisements. Is this true? While the document mostly talks about these and compares with prefix advertisement.

-          Algorithm proposed needs more clarity: Take Section 3.2.4

o

                      "   1.  Smaller range wins

             2.  IPv6 entry wins over IPv4 entry
             ...
        "
                 What happens in case of prefix conflict or SID conflict with only prefix advertisements (range 1).  Say multiple prefixes have same SID in one protocol instance and in different protocols.
                 I see 2 levels of resolution required viz., one at within the protocol and one among the protocols.  No discussion on this.
                 Similarly in case of SID conflict  (range 1), it's not specified which protocol's SID need to be considered.  Are you assuming some sort of Admin distance play a role in resolution?
 I don't see any discussion in the document  and needs more clarity there too.

o   Also what happens if a prefix or SID conflict happens with SRMS range 1 and a prefix  advertisement (2 cases)

a.       of one protocol and

b.      multiple protocols?

-          On the below assumption: (Section 3.2.4)

                                         "This has the nice property that a single misconfiguratoion of an SRMS

                 entry with a large range will not be preferred over a large number of

                 SIDs advertised in prefix reachability advertisements."

While anything can happen in theory, I found it bit odd to see why SRMS entry is being advertised and for the same prefix, SID is also advertised through reachability advertisements?

This is against the spirit of SRMS advertisement, isn't it? While this can happen, it seems we are claiming resolution solution by focusing more on  this case in the current version of the document.

This is one of the reasons of my first comment below. You got to separate the reachability advertisements and SRMS advertisements; as in principle these are defined for different purposes. I don't see we  need algorithm to prefer reachability advertisement over SRMS advertisement (if we don't compare these 2 categories).

as the sections you have quoted clearly state.

Why? Because we need consistent use of SIDs in the forwarding plane. From forwarding perspective it matters not whether the SID was advertised by protocol instance #1 or #2 or by an SRMS.

What matters is that the SID I use to determine what label I install in my forwarding plane is the same SID that my neighbors will use. Otherwise forwarding will be broken.

   Les

From: spring [mailto:[email-masked]] On Behalf Of Uma Chunduri
Sent: Wednesday, April 27, 2016 4:31 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Dear Authors,

Have few comments on the draft:

1.
        As I indicated during meeting - I am not sure why we have to club  verification of SIDs advertised through regular protocol reachability
                prefixes and the ranges advertised through 'Mapping Server'  (SRMS). I didn't see any compelling reason to do this.
                 SIDs advertised through reachability prefixes doesn't have ranges unlike SRMS advertisements.
                 As SRMS advertisements are primarily for nodes which are not SR capable and  I feel we should not mix this with nodes which are SR capable.

        This isolation helps restricting the resolution work primarily for multiple SRMS entries advertised through one node or multiple nodes.
                SRMS advertisements are indeed little bit unique in that you are advertising "configuration" on behalf of node X from node Y
                with ranges (both prefix ranges and SID ranges).

2.
                Regarding  the scope of conflict resolution:

       Section 1

           "   The problem to be addressed is protocol independent i.e., segment
         related advertisements may be originated by multiple nodes using
         different protocols and yet the conflict resolution MUST be the same
         on all nodes regardless of the protocol used to transport the
         advertisements."

        Section 3.2.8
          "   o  In cases where multiple routing protocols are in use mapping
      entries advertised by all routing protocols MUST be included."

      This sounds like we are seeking to resolve conflicting entries outside and across the protocols?
      Each IGP has separate mechanism for advertising mapping entry and I this is not clear with the current version of the draft how we can cross verify SID/Prefix conflict across  the protocol.
     Can you clarify this?

--
Uma C.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, April 14, 2016 12:55 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

> From:  [email-masked]<mailto:[email-masked]> > Sent: Thursday, April 14, 2016 9:51
> AM
>
> Dear WG,
>
> As we discussed at our meeting last week, working group adoption has
> been requested for draft-ginsberg-spring-conflict-resolution.
> Please reply to the list with your comments, including although not
> limited to whether or not you support adoption.

We will end the call on April 29, 2016.

> Thanks,
>
> --John and Bruno
>
>
>
> __________________________________________________________
> __________________________________________________________
> _____
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> que les pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or
> privileged information that may be protected by law; they should not
> be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and
> delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have
> been modified, changed or falsified.
> Thank you.
>
> _______________________________________________
> spring mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/spring

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 4 May 2016 16:38:01 +0000

Uma -

To restate, the problem being addressed here is to guarantee consistent use of SIDs in the forwarding plane network-wide in the presence of conflicting advertisements. The set of advertisements includes both SIDs advertised in protocol prefix reachability advertisements and SRMS advertisements because problems occur based upon inconsistencies in what is installed in the forwarding plane of different routers. It matters not whether Router A used a SID advertised by a protocol prefix reachability advertisement or by an SRMS advertisement - what matter is whether the SID used is consistent with what the neighbors of Router A use. So simply ensuring that OSPF (for example) resolves SIDs in a consistent way does not fully address the problem space.

More inline.

From: Uma Chunduri [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 3:59 PM
To: Les Ginsberg (ginsberg); [email-masked]; [email-masked]
Subject: RE: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Les,

[Les:] It is quite correct - and I can confirm based on personal experience - that support for conflict resolution is a significant effort.

In-line [Uma]:

--
Uma C.

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 10:11 PM
To: Uma Chunduri; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Uma -

-          Also note SRMS is not applicable for BGP but it seems all prefix SIDs need to be verified  with IGP instances SRMS advertisements. Is this true? While the document mostly talks about these and compares with prefix advertisement.
[Les:] The issue is protocol agnostic.

o

                      "   1.  Smaller range wins

[Les:] The full set of rules specified in the draft provide deterministic resolution in all cases. You have snipped only the first two rules. If a preference is not obtained based on the first two rules you continue on to rule #3, then rule #4, etc.

                 Similarly in case of SID conflict  (range 1), it's not specified which protocol's SID need to be considered.  Are you assuming some sort of Admin distance play a role in resolution?
[Les:] No - admin distance plays no role here.

a.       of one protocol and

b.      multiple protocols?

[Les:] The source of the SID advertisement (what protocol/protocol instance or whether it is SRMS based) plays no role. The tie breaker rules as defined are complete and provide a deterministic answer in all cases.

If you believe that is not true please provide a specific example where you apply all the rules in the order specified and still do not determine the preferred entry.

[Les:] There are two legitimate use cases for SRMS:

1)To advertise SIDs for non-SR capable nodes

2)As a global provisioning tool

Let's examine the first case. I have an LDP enabled network and I begin introducing SR capable nodes. At a given moment in time Router A is NOT SR capable and SRMS advertisements cover prefix SIDs for the addresses associated with Router A.

I then upgrade Router A to become SR capable. Because I want to do "make-before-break" I do not immediately remove the SRMS advertisements covering the addresses associated with Router A. I upgrade A, add configuration of SIDs locally on Router A, and verify that the advertisements originating from protocols on Router A are correct. If an inconsistency is introduced when configuring the SIDs on Router A then I will have an SRMS advertisement and a prefix-reachability advertisement that conflict. Until the conflict is corrected we use the conflict resolution rules to provide deterministic forwarding behavior.

This to me is a normal and expected upgrade scenario.

[Les:] I disagree - hopefully my comments have helped you to understand why.

   Les

   Les

Dear Authors,

1.

2.

       Section 1

        Section 3.2.8

--
Uma C.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 4 May 2016 19:10:49 +0200

Les,

Your draft represents a view from only a single domian perspective and a
lot of wording there seems to imply that conflict resolution must be global
per router and does not depend on the  RIB/FIB context.

Perhaps you are not considering identical SIDs to be used for example by
L3VPN customers connecting to SP network with BGP or OSPF and wishing to
use SR within their sites.

Is this accidental or on purpose ?

Can't customers connecting to a given network's different RIBs (via VRFs)
use the same SIDs as other customers or for that matter SP itself ? Nothing
breaks if they do - as their forwarding is hidden under the SP forwarding,
but I see no place in your document to relax conflict resolution in those
deployments.

Same for CSC.

Thx,
R.

On Sun, May 1, 2016 at 7:10 AM, Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> Uma –
>
>
>
> We are indeed defining conflict resolution across all the SID
> advertisements regardless of source (protocol or SRMS) – as the sections
> you have quoted clearly state.
>
>
>
> Why? Because we need consistent use of SIDs in the forwarding plane. From
> forwarding perspective it matters not whether the SID was advertised by
> protocol instance #1 or #2 or by an SRMS. What matters is that the SID I
> use to determine what label I install in my forwarding plane is the same
> SID that my neighbors will use. Otherwise forwarding will be broken.
>
>
>
>    Les
>

---

From: Uma Chunduri <[email-masked]>
Date: Fri, 6 May 2016 20:16:35 +0000

Les,

2 quick things.

1.

                                           >2)As a global provisioning tool

                         I am hearing #2 for the first time. I don't see this either  discussed earlier in the WG list  or captured in architecture document

                         https://tools.ietf.org/html/draft-ietf-spring-segment-routing-07. Even in the protocol extensions document for example

                         https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extensions-06#section-2.4 we always discussed this from non-SR

                         capable nodes PoV. So I request to add this in architecture document before factoring this for solution in conflict resolution.

2.       Also this is the first time ever we have a requirement for cross protocols verification we ought to discuss the implications of this

and protocols involved (with in AS or otherwise) in the architecture document (at least briefly).

--
Uma C.

From: spring [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Wednesday, May 04, 2016 9:38 AM
To: Uma Chunduri; [email-masked]; [email-masked]
Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Uma -

More inline.

From: Uma Chunduri [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 3:59 PM
To: Les Ginsberg (ginsberg); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Les,

In-line [Uma]:

--
Uma C.

Uma -

o

                      "   1.  Smaller range wins

a.       of one protocol and

b.      multiple protocols?

   Les

   Les

Dear Authors,

1.

2.

       Section 1

        Section 3.2.8

--
Uma C.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 11 May 2016 11:46:04 +0000

> On May 6, 2016, at 10:16 PM, Uma Chunduri <[email-masked]> wrote:
> 
> Les,
>  
> 2 quick things.
>  
> 1.        
>                          I am hearing #2 for the first time. I don’t see this either  discussed earlier in the WG list  or captured in architecture document 

using a SRMS for advertising SID on behalf of SR capable nodes does not introduce any change in the SR architecture so not sure what we need to document here.

> and protocols involved (with in AS or otherwise) in the architecture document (at least briefly).

the architecture draft is data-pane agnostic so I presume you refer to draft-ietf-spring-segment-routing-mpls.

with the ipv6 data-plane SR conflicts are in fact solved by ipv6 addressing techniques ;-)

s.

> To restate, the problem being addressed here is to guarantee consistent use of SIDs in the forwarding plane network-wide in the presence of conflicting advertisements. The set of advertisements includes both SIDs advertised in protocol prefix reachability advertisements and SRMS advertisements because problems occur based upon inconsistencies in what is installed in the forwarding plane of different routers. It matters not whether Router A used a SID advertised by a protocol prefix reachability advertisement or by an SRMS advertisement – what matter is whether the SID used is consistent with what the neighbors of Router A use. So simply ensuring that OSPF (for example) resolves SIDs in a consistent way does not fully address the problem space.
>  
> More inline.
>  
> With all due respects, cross protocol verification  of prefix and SID conflicts as an “architectural change”  and it can severely impact the existing implementations (at least the one I work on). 
>  
> [Les:] It is quite correct – and I can confirm based on personal experience – that support for conflict resolution is a significant effort.
>  
> Separation of reachability advertisements and SRMS would help “cross protocol” verification of the ranges and SRMS is not applicable to all protocols.
>  
>  
> In-line [Uma]:
>  
> --
> Uma C.
>  
> We are indeed defining conflict resolution across all the SID advertisements regardless of source (protocol or SRMS) –
>  
>                Because it seems “a central entity” need to gather all different protocol instances SRMS advertisements and should settle with resolution. 
>  
>                       “   1.  Smaller range wins
>              …
>         “
>                  Similarly in case of SID conflict  (range 1), it’s not specified which protocol’s SID need to be considered.  Are you assuming some sort of Admin distance play a role in resolution? 
> [Les:] No – admin distance plays no role here.
>  
>  I don’t see any discussion in the document  and needs more clarity there too.
>                                          “This has the nice property that a single misconfiguratoion of an SRMS
>                  SIDs advertised in prefix reachability advertisements.”
> This is against the spirit of SRMS advertisement, isn’t it? While this can happen, it seems we are claiming resolution solution by focusing more on  this case in the current version of the document.
>  
> Let’s examine the first case. I have an LDP enabled network and I begin introducing SR capable nodes. At a given moment in time Router A is NOT SR capable and SRMS advertisements cover prefix SIDs for the addresses associated with Router A.
> I then upgrade Router A to become SR capable. Because I want to do “make-before-break” I do not immediately remove the SRMS advertisements covering the addresses associated with Router A. I upgrade A, add configuration of SIDs locally on Router A, and verify that the advertisements originating from protocols on Router A are correct. If an inconsistency is introduced when configuring the SIDs on Router A then I will have an SRMS advertisement and a prefix-reachability advertisement that conflict. Until the conflict is corrected we use the conflict resolution rules to provide deterministic forwarding behavior.
>  
> This is one of the reasons of my first comment below. You got to separate the reachability advertisements and SRMS advertisements; as in principle these are defined for different purposes. I don’t see we  need algorithm to prefer reachability advertisement over SRMS advertisement (if we don’t compare these 2 categories).
>  
>  
>  
> [Les:] I disagree – hopefully my comments have helped you to understand why.
>  
>    Les
>  
>  
> To: [email-masked]; [email-masked]
> From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
> To: [email-masked]
> > From:  [email-masked] > Sent: Thursday, April 14, 2016 9:51
> > AM
> >
> > Dear WG,
> >
> > [email-masked]
> [email-masked]
> [email-masked]

---

From: Uma Chunduri <[email-masked]>
Date: Thu, 12 May 2016 17:49:55 +0000

Stefano,

Thanks for your response.

               > sure what we need to document here.

My point below: We are creating a conflict resolution solution for a non-existing requirement of using  SRMS viz.,  ">2)As a global provisioning tool". 
From your statement above, it seems you have less interest to make this as a requirement/scope of SRMS; I am more aligned in that path....

	> the architecture draft is data-pane agnostic so I presume you refer to draft-ietf-spring-segment-routing-mpls.

AFAIS,  https://tools.ietf.org/html/draft-ietf-spring-segment-routing-08  talks about both data planes right from abstract to multiple places (which it ought to). 
I leave this to you/WG on where you want to document this -but IMO conflict resolution "solution document" in the current form potentially introducing fundamental 
requirements  to the system like cross protocol verification (with in/across AS). Perhaps some discussion should be there in data plane document then.

--
Uma C.

-----Original Message-----
From: Stefano Previdi (sprevidi) [mailto:[email-masked]] 
Sent: Wednesday, May 11, 2016 4:46 AM
To: Uma Chunduri
Cc: Les Ginsberg (ginsberg); [email-masked]; [email-masked]
Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

                       

s.

> advertisements regardless of source (protocol or SRMS) –
>  
> 1)To advertise SIDs for non-SR capable nodes 2)As a global 
> provisioning tool
>  
> > From:  [email-masked] > Sent: Thursday, April 14, 2016 
> > 9:51 AM
> >
> > Dear WG,
> >
> > confidentielles ou privilegiees et ne doivent donc pas etre 
> > diffuses, exploites ou copies sans autorisation. Si vous avez recu 
> > ce message par erreur, veuillez le signaler a l'expediteur et le 
> > detruire ainsi que les pieces jointes. Les messages electroniques 
> > etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> >
> > If you have received this email in error, please notify the sender 
> > and delete this message and its attachments.
> > As emails may be altered, Orange is not liable for messages that 
> > have been modified, changed or falsified.
> > Thank you.
> >
> ______________________________________________________________________
> ___________________________________________________
>

---

From: Peter Psenak <[email-masked]>
Date: Thu, 12 May 2016 20:02:50 +0200

Hi Uma,

>  From your statement above, it seems you have less interest to make this as a requirement/scope of SRMS; I am more aligned in that path....

as a matter of fact, SRMS is a SID provisioning tool, whether you like 
it or not. It provides all the functionality that is required for such 
provisioning tool. You can not restrict its usage to SR/LDP interop case.

thanks,
Peter

---

From: Uma Chunduri <[email-masked]>
Date: Thu, 12 May 2016 18:19:33 +0000

Peter,

        > as a matter of fact, SRMS is a SID provisioning tool, whether you like it or not.

It's not about your or my linking - I was talking about what's the defined scope so far (architecture doc or protocol docs)
and how you want to extend the scope.
Well, if you want to extend the current scope of SRMS as a "">2)As a global provisioning tool" -
Plz. do so but not while providing conflict resolution solution.

               > It provides all the functionality that is required for such provisioning tool.
        >You can not restrict its usage to SR/LDP interop case.

I didn't restrict anything - Plz. see SRMS stuff so far:

1. https://tools.ietf.org/html/draft-ietf-spring-segment-routing-08#section-3.6
        " 3.6.1.  Mapping Server

         A Remote-Binding SID S advertised by the mapping server M for remote
        prefix R attached to non-SR-capable node N signals the same
        information as if N had advertised S as a Prefix-SID.  Further
        details are described in the SR/LDP interworking procedures
         ([I-D.ietf-spring-segment-routing-ldp-interop]."

2. ISIS: https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extensions-06#section-2.4
                " This functionality is called the
                        'Mapping Server' and it's used when, in a heterogeneous network,
                              not all nodes are capable of advertising their own SIDs/Labels."

3. OSPF: https://tools.ietf.org/html/draft-ietf-ospf-segment-routing-extensions-08#section-4
                "   In some cases it is useful to advertise attributes for a range of
                prefixes.  The Segment Routing Mapping Server, which is described in
                [I-D.filsfils-spring-segment-routing-ldp-interop<https://tools.ietf.org/html/draft-ietf-ospf-segment-routing-extensions-08>], is an example
                where we need a single advertisement to advertise SIDs for multiple
                prefixes from a contiguous address range."

Again, plz. extend the scope first and consider the same in resolution solution. I am fine with it.

--
Uma C.

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]]
Sent: Thursday, May 12, 2016 11:03 AM
To: Uma Chunduri; Stefano Previdi (sprevidi)
Cc: Les Ginsberg (ginsberg); [email-masked]; [email-masked]
Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG adoption call

Hi Uma,

>  From your statement above, it seems you have less interest to make this as a requirement/scope of SRMS; I am more aligned in that path....

as a matter of fact, SRMS is a SID provisioning tool, whether you like it or not. It provides all the functionality that is required for such provisioning tool. You can not restrict its usage to SR/LDP interop case.

thanks,
Peter

> I leave this to you/WG on where you want to document this -but IMO
> conflict resolution "solution document" in the current form potentially introducing fundamental requirements  to the system like cross protocol verification (with in/across AS). Perhaps some discussion should be there in data plane document then.
>
> --
> Uma C.
>
>
> Cc: Les Ginsberg (ginsberg); [email-masked]<mailto:[email-masked]>;
>> On May 6, 2016, at 10:16 PM, Uma Chunduri <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Les,
>>
>> 2 quick things.
>>
>> 1.
>> From: spring [mailto:[email-masked]] On Behalf Of
>> [email-masked]<mailto:[email-masked]>
>>> From:  [email-masked]<mailto:[email-masked]> > Sent: Thursday, April 14, 2016
>>> 9:51 AM
>>>
>>> Dear WG,
>>>
>> _____________________________________________________________________
>> _ ___________________________________________________
>>

---

From: Peter Psenak <[email-masked]>
Date: Fri, 13 May 2016 09:31:01 +0200

Uma,

I don't know whether you need a text in the draft/RFC to use some 
functionality one way or the other. The fact is that SRMS is a SID 
provisioning tool. You can use it for SR/LDP interoperability, but you 
can also use it in a SR only network to provide SIDs from a central 
place instead of configuring them on each device. There is nothing that 
prevents you to use it one way or the other. The fact that SRMS is 
defined in the SR/LDP interop drfat does not mean it is restricted to be 
used for that purpose.

I let authors of the SR architecture drafts to decide whether they want 
to add the text. As an author of the OSPF SR draft, I do not see 
anything in the text that you put below that would contradict what I'm 
saying here.

thanks,
Peter

On 5/12/16 20:19 , Uma Chunduri wrote:
> It's not about your or my linking - I was talking about what's the
> defined scope so far (architecture doc or protocol docs)
> _https://tools.ietf.org/html/draft-ietf-spring-segment-routing-08#section-3.6_
>
> /" //3.6.1.  Mapping Server/
> ///A Remote-Binding SID S advertised by the mapping server M for remote/
> ///prefix R attached to non-SR-capable node N signals the same/
> ///information as if N had advertised S as a Prefix-SID.  Further/
> ///details are described in the SR/LDP interworking procedures/
> ///([I-D.ietf-spring-segment-routing-ldp-interop].//"/
> 2. ISIS:
> _https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extensions-06#section-2.4_
>
> /" //This functionality is called the/
> /////'Mapping Server' and it's used when, in a heterogeneous network,/
> ///////not all nodes are capable of advertising their own SIDs/Labels.//"/
> 3. OSPF:
> _https://tools.ietf.org/html/draft-ietf-ospf-segment-routing-extensions-08#section-4_
>
> /"//   In some cases it is useful to advertise attributes for a range of/
> ///prefixes.  The Segment Routing Mapping Server, which is described in/
> ///[//I-D.filsfils-spring-segment-routing-ldp-interop/
> <https://tools.ietf.org/html/draft-ietf-ospf-segment-routing-extensions-08>/],
> is an example/
> ///where we need a single advertisement to advertise SIDs for multiple/
> ///prefixes from a contiguous address range.//"/
>> AFAIS,https://tools.ietf.org/html/draft-ietf-spring-segment-routing-08  talks
> about both data planes right from abstract to multiple places (which it
> ought to).
>> Cc: Les Ginsberg (ginsberg);[email-masked] <mailto:[email-masked]>;
>>[email-masked] <mailto:[email-masked]>
>>> On May 6, 2016, at 10:16 PM, Uma Chunduri <[email-masked] <mailto:[email-masked]>> wrote:
>>>
>>> Les,
>>>
>>> 2 quick things.
>>>
>>> 1.
>>>https://tools.ietf.org/html/draft-ietf-spring-segment-routing-07. Even
> in the protocol extensions document for example
>>> To: Uma Chunduri;[email-masked] <mailto:[email-masked]>;
> [email-masked] <mailto:[email-masked]>
>>> To restate, the problem being addressed here is to guarantee consistent use of SIDs in the forwarding plane network-wide in the presence of conflicting advertisements. The set of advertisements includes both SIDs advertised in protocol prefix reachability  advertisements and SRMS advertisements because problems occur based
> upon inconsistencies in what is installed in the forwarding plane of
> different routers. It matters not whether Router A used a SID advertised
> by a protocol prefix reachability advertisement or by an SRMS
> advertisement – what matter is whether the SID used is consistent with
> what the neighbors of Router A use. So simply ensuring that OSPF (for
> example) resolves SIDs in a consistent way does not fully address the
> problem space.
>>>
>>> More inline.
>>>
>>> To: Les Ginsberg (ginsberg);[email-masked] <mailto:[email-masked]>;
>>>[email-masked] <mailto:[email-masked]>
>>> To: Uma Chunduri;[email-masked] <mailto:[email-masked]>;
> [email-masked] <mailto:[email-masked]>
>>> I then upgrade Router A to become SR capable. Because I want to do “make-before-break” I do not immediately remove the SRMS advertisements covering the addresses associated with Router A. I upgrade A, add configuration of SIDs locally on Router A, and  verify that the advertisements originating from protocols on Router A
> are correct. If an inconsistency is introduced when configuring the SIDs
> on Router A then I will have an SRMS advertisement and a
> prefix-reachability advertisement that conflict. Until the conflict is
> corrected we use the conflict resolution rules to provide deterministic
> forwarding behavior.
>>>
>>> To:[email-masked] <mailto:[email-masked]>;
> [email-masked] <mailto:[email-masked]>
>>>[email-masked] <mailto:[email-masked]>
>>> To:[email-masked] <mailto:[email-masked]>
>>>> From:[email-masked] <mailto:[email-masked]> > Sent:
> Thursday, April 14, 2016
>>>> 9:51 AM
>>>>
>>>> Dear WG,
>>>>
>>>>[email-masked] <mailto:[email-masked]>
>>> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur  et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>>>
>>>[email-masked] <mailto:[email-masked]>
>>>[email-masked] <mailto:[email-masked]>
>>[email-masked] <mailto:[email-masked]>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sat, 14 May 2016 17:03:48 +0000

Uma -

I'd like to close this point of discussion as regards the conflict-resolution draft.

For the record, I agree with Peter. But from the standpoint of conflict resolution it matters not for what purpose SRMS is being used - we have to consider SRMS advertisements as well as SIDs associated w prefix advertisements. I hope that point has been clearly explained.

If you wish to continue the discussion with the architecture draft authors as to whether further discussion of SRMS as a network provisioning tool should/should not be added to a document please feel free to do so - but I would ask that you do so in another thread.
Thanx.

   Les

> From: Peter Psenak (ppsenak)
> Sent: Friday, May 13, 2016 12:31 AM
> functionality one way or the other. The fact is that SRMS is a SID provisioning
> tool. You can use it for SR/LDP interoperability, but you can also use it in a SR
> only network to provide SIDs from a central place instead of configuring them
> on each device. There is nothing that prevents you to use it one way or the
> other. The fact that SRMS is defined in the SR/LDP interop drfat does not
> mean it is restricted to be used for that purpose.
> 
> I let authors of the SR architecture drafts to decide whether they want to add
> the text. As an author of the OSPF SR draft, I do not see anything in the text
> that you put below that would contradict what I'm saying here.
> 
> thanks,
> Peter
> 
> 
> > defined scope so far (architecture doc or protocol docs) and how you
> > want to extend the scope.
> > Well, if you want to extend the current scope of SRMS as a "">2)As a
> > global provisioning tool" - Plz. do so but not while providing
> > conflict resolution solution.
> > ///A Remote-Binding SID S advertised by the mapping server M for
> > remote/ ///prefix R attached to non-SR-capable node N signals the
> > same/ ///information as if N had advertised S as a Prefix-SID.
> > Further/ ///details are described in the SR/LDP interworking
> > procedures/ ///([I-D.ietf-spring-segment-routing-ldp-interop].//"/
> > 2. ISIS:
> > /" //This functionality is called the/ /////'Mapping Server' and it's
> > used when, in a heterogeneous network,/ ///////not all nodes are
> > capable of advertising their own SIDs/Labels.//"/ 3. OSPF:
> > ///prefixes.  The Segment Routing Mapping Server, which is described
> > in/ ///[//I-D.filsfils-spring-segment-routing-ldp-interop/
> > ///where we need a single advertisement to advertise SIDs for
> > multiple/ ///prefixes from a contiguous address range.//"/ Again, plz.
> > extend the scope first and consider the same in resolution solution. I
> > am fine with it.
> > --
> > Uma C.
> > Subject: Re: [spring] draft-ginsberg-spring-conflict-resolution - WG
> > adoption call Hi Uma, On 5/12/16 19:49 , Uma Chunduri wrote:
> >> Stefano,
> >>
> >>        > using a SRMS for advertising SID on behalf of SR capable nodes does
> not introduce any change in the SR architecture so not
> >>                 > sure what we need to document here.
> >>
> >> My point below: We are creating a conflict resolution solution for a non-
> existing requirement of using  SRMS viz.,  ">2)As a global provisioning tool".
> >>  From your statement above, it seems you have less interest to make this
> as a requirement/scope of SRMS; I am more aligned in that path....
> >>        > the architecture draft is data-pane agnostic so I presume you refer
> to draft-ietf-spring-segment-routing-mpls.
> >>
> > about both data planes right from abstract to multiple places (which
> > it ought to).
> >> conflict resolution "solution document" in the current form potentially
> introducing fundamental requirements  to the system like cross protocol
> verification (with in/across AS). Perhaps some discussion should be there in
> data plane document then.
> >>
> >> --
> >> Uma C.
> >>
> >>
> >>> On May 6, 2016, at 10:16 PM, Uma Chunduri
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> >>>
> >>> Les,
> >>>
> >>> 2 quick things.
> >>>
> >>> 1.
> >>>                           I am hearing #2 for the first time. I
> >>>don’t see this either  discussed earlier in the WG list  or captured
> >>>in architecture document
> >>>https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extension
> >>>s-06#section-2.4
> > we always discussed this from non-SR
> >>>                           capable nodes PoV. So I request to add this in architecture
> document before factoring this for solution in conflict resolution.
> >>
> >>
> >> using a SRMS for advertising SID on behalf of SR capable nodes does not
> introduce any change in the SR architecture so not sure what we need to
> document here.
> >>
> >>
> >>
> >>>
> >>> 2.       Also this is the first time ever we have a requirement for cross
> protocols verification we ought to discuss the implications of this
> >>> To restate, the problem being addressed here is to guarantee
> >>> consistent use of SIDs in the forwarding plane network-wide in the
> >>> presence of conflicting advertisements. The set of advertisements
> >>> includes both SIDs advertised in protocol prefix reachability
> >>> advertisements and SRMS advertisements because problems occur
> based
> > different routers. It matters not whether Router A used a SID
> > advertised by a protocol prefix reachability advertisement or by an
> > SRMS advertisement – what matter is whether the SID used is consistent
> > with what the neighbors of Router A use. So simply ensuring that OSPF
> > (for
> >>> With all due respects, cross protocol verification  of prefix and SID
> conflicts as an “architectural change”  and it can severely impact the existing
> implementations (at least the one I work on).
> >>>
> >>> [Les:] It is quite correct – and I can confirm based on personal
> experience – that support for conflict resolution is a significant effort.
> >>>
> >>> IMO, first we need clarity with in a protocol instance resolution rules
> before going to resolve the same across protocols (I mentioned few cases
> below) .
> >>> Separation of reachability advertisements and SRMS would help “cross
> protocol” verification of the ranges and SRMS is not applicable to all
> protocols.
> >>>
> >>>
> >>> In-line [Uma]:
> >>>
> >>> --
> >>> Uma C.
> >>>
> >>> [Uma]: While you can theoretically do anything for current
> implementation this kind of cross protocol verification is a new architectural
> requirement.
> >>>                 Because it seems “a central entity” need to gather all different
> protocol instances SRMS advertisements and should settle with resolution.
> >>>
> >>> -          Also note SRMS is not applicable for BGP but it seems all prefix SIDs
> need to be verified  with IGP instances SRMS advertisements. Is this true?
> While the document mostly talks about these and compares with prefix
> advertisement.
> >>>                   What happens in case of prefix conflict or SID conflict with only
> prefix advertisements (range 1).  Say multiple prefixes have same SID in one
> protocol instance and in different protocols.
> >>>                   I see 2 levels of resolution required viz., one at within the
> protocol and one among the protocols.  No discussion on this.
> >>>
> >>> [Les:] The full set of rules specified in the draft provide deterministic
> resolution in all cases. You have snipped only the first two rules. If a
> preference is not obtained based on the first two rules you continue on to
> rule #3, then rule #4, etc.
> >>>
> >>>                   Similarly in case of SID conflict  (range 1), it’s not specified which
> protocol’s SID need to be considered.  Are you assuming some sort of Admin
> distance play a role in resolution?
> >>> [Les:] The source of the SID advertisement (what protocol/protocol
> instance or whether it is SRMS based) plays no role. The tie breaker rules as
> defined are complete and provide a deterministic answer in all cases.
> >>> If you believe that is not true please provide a specific example where
> you apply all the rules in the order specified and still do not determine the
> preferred entry.
> >>>
> >>>
> >>> While anything can happen in theory, I found it bit odd to see why SRMS
> entry is being advertised and for the same prefix, SID is also advertised
> through reachability advertisements?
> >>> This is against the spirit of SRMS advertisement, isn’t it? While this can
> happen, it seems we are claiming resolution solution by focusing more on
> this case in the current version of the document.
> >>>
> >>> Let’s examine the first case. I have an LDP enabled network and I begin
> introducing SR capable nodes. At a given moment in time Router A is NOT SR
> capable and SRMS advertisements cover prefix SIDs for the addresses
> associated with Router A.
> >>> I then upgrade Router A to become SR capable. Because I want to do
> >>> “make-before-break” I do not immediately remove the SRMS
> >>> advertisements covering the addresses associated with Router A. I
> >>> upgrade A, add configuration of SIDs locally on Router A, and
> >>> verify that the advertisements originating from protocols on Router
> >>> A
> > are correct. If an inconsistency is introduced when configuring the
> > SIDs on Router A then I will have an SRMS advertisement and a
> > corrected we use the conflict resolution rules to provide
> > deterministic forwarding behavior.
> >>>
> >>> This is one of the reasons of my first comment below. You got to
> separate the reachability advertisements and SRMS advertisements; as in
> principle these are defined for different purposes. I don’t see we  need
> algorithm to prefer reachability advertisement  over SRMS advertisement (if
> we don’t compare these 2 categories).
> >>>
> >>>
> >>>
> >>> Why? Because we need consistent use of SIDs in the forwarding plane.
> From forwarding perspective it matters not whether the SID was advertised
> by protocol instance #1 or #2 or by an SRMS.
> >>>
> >>> What matters is that the SID I use to determine what label I install in my
> forwarding plane is the same SID that my neighbors will use. Otherwise
> forwarding will be broken.
> >>>
> >>>     Les
> >>>
> >>>
> >>>          As I indicated during meeting - I am not sure why we have to club
> verification of SIDs advertised through regular protocol reachability
> >>>                  prefixes and the ranges advertised through 'Mapping Server'
> (SRMS). I didn't see any compelling reason to do this.
> >>>                   As SRMS advertisements are primarily for nodes which are not
> SR capable and  I feel we should not mix this with nodes which are SR
> capable.
> >>>
> >>>          This isolation helps restricting the resolution work primarily for
> multiple SRMS entries advertised through one node or multiple nodes.
> >>>                  SRMS advertisements are indeed little bit unique in that you are
> advertising "configuration" on behalf of node X from node Y
> >>>        Each IGP has separate mechanism for advertising mapping entry and
> I this is not clear with the current version of the draft how we can cross verify
> SID/Prefix conflict across  the protocol.
> >>>       Can you clarify this?
> >>>
> >>>
> >>> --
> >>> Uma C.
> >>>
> >>>
> >>> Sent: Thursday, April 14, 2016 12:55 AM  To:[email-masked]
> >>><mailto:[email-masked]>
> >>>> From:[email-masked]
> <mailto:[email-masked]> > Sent:
> > Thursday, April 14, 2016
> >>>> 9:51 AM
> >>>>
> >>>> Dear WG,
> >>>>
> >>>> As we discussed at our meeting last week, working group adoption
> >>>> has been requested for draft-ginsberg-spring-conflict-resolution.
> >>>> etant susceptibles d'alteration, Orange decline toute responsabilite si
> ce message a ete altere, deforme ou falsifie. Merci.
> >>>>
> >>>> privileged information that may be protected by law; they should
> >>>> not be distributed, used or copied without authorisation.
> __________
> >>> _ _ ___________________________________________________
> >>>
> >>> detruire ainsi que les pieces jointes. Les messages
> >>> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.

---

From: <[email-masked]>
Date: Wed, 18 May 2016 11:57:27 +0000

Hi Les,

Please see inline.

> From: Les Ginsberg (ginsberg) [mailto:[email-masked]] > Sent: Saturday, May 14, 2016 7:04 PM
> 
> Uma -
> 
> For the record, I agree with Peter. But from the standpoint of conflict
> resolution it matters not for what purpose SRMS is being used

In order for all nodes to consider the same SR data during the SR-conflict algo, what matters is whether all node within a domain MUST support SRMS or not,.
So 2 options:
- SRMS is mandatary to implement or to deploy consistently, and this need to be stated somewhere, e.g. in spring-conflict-resolution. (e.g. in the early days, this was not the case for all implementations)
- the SR-conflict algo is defined in a way to give the same result, for a Prefix-SID, with partial SRMS deployment. This may be feasible is SID-Prefix info are given strict priority over SRMS.

Thanks,
--Bruno

> - we have to
> consider SRMS advertisements as well as SIDs associated w prefix
> advertisements. I hope that point has been clearly explained.
> 
> If you wish to continue the discussion with the architecture draft authors as
> to whether further discussion of SRMS as a network provisioning tool
> should/should not be added to a document please feel free to do so - but I
> would ask that you do so in another thread.
> Thanx.
> 
>    Les
> 
> 
> adoption
> > call
> provisioning
> > >>adoption call
> > >>> adoption call
> > >>> Also I have couple of cases where current version of the draft is not
> clear
> > about resolution.
> > >>>
> > >>> o   Also what happens if a prefix or SID conflict happens with SRMS
> range
> > 1 and a prefix  advertisement (2 cases)
> > >>> a.       of one protocol and
> > >>> b.      multiple protocols?
> > >>>
> > >>> adoption call
> > >>>        This sounds like we are seeking to resolve conflicting entries
> outside
> > and across the protocols?
> > >>>adoption call
> privileged

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.