Subject: [spring] draft-ietf-spring-conflict-resolution - Preference Algorithm

From: <[email-masked]>
Date: Thu, 12 May 2016 15:22:30 +0000

Hi authors, all

As an individual contributor, please find below some feedback to trigger discussion on the Preference Algorithm defined in §3.2.4.

>   1.  Smaller range wins
Looks ok to me, as this gives preference to Prefix-SID advertisement from SR routers which speaks for themselves/their own loopback/their own IP prefix advertisement; rather than SRMS advertisement which speaker for others. IOW, to know Brian's SID, I'd rather believe Brian himself rather than George.

Also, this gives preference to SR nodes rather than LDP nodes (SRMS entries). Over the time/SR deployment, as more nodes gets SR, the number of nodes negatively impacted by the wrong configuration change is reduced.

Alternatively, I'd be fine to prefer Prefix-SID advertisement over SRMS advertisement. Actually, I'd propose to add this as rule 0. "0. Prefer Prefix-SID Sub-TLV over SID/Label Binding TLV"
I've been told OSPF can't make the distinction, but I'm not sure to see the issue.

> 4.  Smaller prefix length wins
I'd rather have longer prefix length wins, and move this higher in position 3 (*). Indeed, we usually primarily care to reach a specific egress node i.e. loopbacks destinations, which have the longest possible prefix length.
(*) It needs to be after IPv6 wins, to not conflict with it, as IPv6 have longer prefixes.

>   3.  Smaller algorithm wins

>   5.  Smaller starting address (considered as an unsigned integer

       value) wins

I'm fine with this order, to privilege prefix diversity (typically for algo 0 or 1) rather than algo diversity. (on the basis that to reach a node N, we need a SID for this node, while to follow algo N, we can use a combinations of segments from other algo).

So in summary, I'd propose discussing the following
OLD:

   1.  Smaller range wins

   2.  IPv6 entry wins over IPv4 entry

   3.  Smaller algorithm wins

   4.  Smaller prefix length wins

   5.  Smaller starting address (considered as an unsigned integer value) wins

   6.  Smaller starting SID wins

NEW:

   0.  Prefix-SID Sub-TLV wins over SID/Label Binding TLV

   1.  Smaller range wins

   2.  IPv6 entry wins over IPv4 entry

   3.  Longer prefix length wins

   4.  Smaller algorithm wins

   5.  Smaller starting address (considered as an unsigned integer value) wins

   6.  Smaller starting SID wins

Thanks,
Regards,
-- Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sat, 14 May 2016 18:06:51 +0000

Bruno  -

Thanx for your comments - inline.

From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, May 12, 2016 8:23 AM
To: [email-masked]
Subject: [spring] draft-ietf-spring-conflict-resolution - Preference Algorithm

Hi authors, all

[Les:] (I don't see the OSPF issue either.)
This change is certainly possible. One reason we did not choose this direction is because it is just as possible to misconfigure local SID configuration associated with a prefix advertisement as it is to misconfigure an SRMS advertisement. In the event we are migrating nodes from being non-SR capable to SR capable we could have:

1.1.1.1/32 100 range 1 !SRMS advertisement
1.1.1.1/32 1000 range 1 !Prefix advertisement - added when a Node becomes SR capable

It seems more consistent to resolve based on the attributes of the advertisement rather than its source.

[Les:] I am fine with this change. I think the existing rules just used "smaller" as the tie breaker in all cases, but you have a point that in this case "longer" makes more sense.

   Les

       value) wins

   1.  Smaller range wins

NEW:

   1.  Smaller range wins

Thanks,
Regards,
-- Bruno

Thank you.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 14 May 2016 19:27:09 +0000

Hi Les, Bruno,

See one inline.

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>
Date: Saturday, May 14, 2016 at 2:06 PM
To: Bruno Decraene <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] draft-ietf-spring-conflict-resolution - Preference Algorithm

Bruno  -

Thanx for your comments – inline.

From: spring [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, May 12, 2016 8:23 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [spring] draft-ietf-spring-conflict-resolution - Preference Algorithm

Hi authors, all

>   1.  Smaller range wins
Looks ok to me, as this gives preference to Prefix-SID advertisement from SR routers which speaks for themselves/their own loopback/their own IP prefix advertisement; rather than SRMS advertisement which speaker for others. IOW, to know Brian’s SID, I’d rather believe Brian himself rather than George.

Alternatively, I’d be fine to prefer Prefix-SID advertisement over SRMS advertisement. Actually, I’d propose to add this as rule 0. “0. Prefer Prefix-SID Sub-TLV over SID/Label Binding TLV”
I’ve been told OSPF can’t make the distinction, but I’m not sure to see the issue.

[Les:] (I don’t see the OSPF issue either.)

If it is a range advertisement, it is actually easier to detect in OSPF since a separate top-level TLV is used. For Prefix-SID, OSPF has the M-flag identifying mapping server advertisement.

Thanks,
Acee

1.1.1.1/32 100 range 1 !SRMS advertisement
1.1.1.1/32 1000 range 1 !Prefix advertisement – added when a Node becomes SR capable

> 4.  Smaller prefix length wins
I’d rather have longer prefix length wins, and move this higher in position 3 (*). Indeed, we usually primarily care to reach a specific egress node i.e. loopbacks destinations, which have the longest possible prefix length.
(*) It needs to be after IPv6 wins, to not conflict with it, as IPv6 have longer prefixes.

[Les:] I am fine with this change. I think the existing rules just used “smaller” as the tie breaker in all cases, but you have a point that in this case “longer” makes more sense.

   Les

       value) wins

I’m fine with this order, to privilege prefix diversity (typically for algo 0 or 1) rather than algo diversity. (on the basis that to reach a node N, we need a SID for this node, while to follow algo N, we can use a combinations of segments from other algo).

So in summary, I’d propose discussing the following
OLD:

   1.  Smaller range wins

NEW:

   1.  Smaller range wins

Thanks,
Regards,
-- Bruno

Thank you.

---

From: <[email-masked]>
Date: Wed, 18 May 2016 11:57:04 +0000

Hi Les,

Thanks for your quick replay.
Inline [Bruno]

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Saturday, May 14, 2016 8:07 PM
To: DECRAENE Bruno IMT/OLN; [email-masked]<mailto:[email-masked]>
Subject: RE: [spring] draft-ietf-spring-conflict-resolution - Preference Algorithm

Bruno  -

Hi authors, all

[Les:] (I don't see the OSPF issue either.)
This change is certainly possible. One reason we did not choose this direction is because it is just as possible to misconfigure local SID configuration associated with a prefix advertisement as it is to misconfigure an SRMS advertisement.
[Bruno] Agreed. My reasoning was that:
- Assuming we have a policy "ignore overlap only" or "by prefix/FEC", it seems better to give priority to SR nodes over LDP nodes, as the number of SR nodes should grow and hopefully should rapidly becomes the majority.
- SRMS will typically be redundant. So there is twice as much chance to misconfigure a SRMS announcement. Also, it's likely that any meaningful change of configuration in one SRMS would conflict with the second SRMS, until the second SRMS configuration be updated. And both are not likely to be updated atomically. (And I'm assuming that one MS may be atomically changed from one config to another, which may not be granted for all implementations)

Still to be discussed. Does not seem to make a big difference since the smaller range has preference.

In the event we are migrating nodes from being non-SR capable to SR capable we could have:

[Bruno]Thanks

-- Bruno

   Les

       value) wins

   1.  Smaller range wins

NEW:

   1.  Smaller range wins

Thanks,
Regards,
-- Bruno

Thank you.