Subject: [spring] I-D Action: draft-ietf-spring-sr-oam-requirement-02.txt

From: [email-masked]
Date: Fri, 01 Jul 2016 08:19:06 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Source Packet Routing in Networking of the IETF.

        Title           : OAM Requirements for Segment Routing Network
        Authors         : Nagendra Kumar
                          Carlos Pignataro
                          Nobo Akiya
                          Ruediger Geib
                          Greg Mirsky
                          Stephane Litkowski
	Filename        : draft-ietf-spring-sr-oam-requirement-02.txt
	Pages           : 7
	Date            : 2016-07-01

Abstract:
   This document describes a list of functional requirement for OAM in
   Segment Routing (SR) based network.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-spring-sr-oam-requirement/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-spring-sr-oam-requirement-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-sr-oam-requirement-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: David Allan I <[email-masked]>
Date: Fri, 1 Jul 2016 16:12:29 +0000

Hi

I looked over this and have a few modest suggestions....

1) Could be clarified a bit...
   REQ#2:   The SR OAM packet MUST follow exactly the same path as
            dataplane traffic
Suggested change
   REQ#2:   An SR OAM packet MUST follow exactly the same path as
            the dataplane traffic it is intended to instrument.
We could also argue about "exact path", as best we can do is in the nodal sense.... 

2)  Delete REQ 3 and REQ 4
Reason: Clarity. Packets do not discover anything, systems can. If the system implements ECMP and/or UCMP and the OAM system meets requirement 2, you're done.

3) REQ5, question...
	When you say available, is this in the sense that the path meets a specified criteria of information transfer capability?  Depending on the answer I may suggest an edit or two...and it may be necessary to include a definition of availability. (definition, not specification as we'll argue till the cows come home :-)

4) REQ9, clarification
	The current text reads like the CC mechanism itself failed, not what it was instrumenting. Suggested tweak...
   REQ#9:   In case of any path failure detected with continuity check, SR OAM SHOULD
            support rapid Connectivity Fault localization to isolate the
            node on which the failure occurs.

5) REQ11
	Just reads strange.... for example, an edge node may not be adjacent to a failure therefore confining actions to edge nodes makes no sense.  If the actual intention is to include all consequent actions of OAM states, there will be a few requirements that fall out of this. Something to discuss.

There is also the imbedded assumption that transactions are both p2p and bi-directional. I would like to see

REQxx 		OAM probes may be unidirectional or bi-directional.
REQxx+1 	OAM probes must be able to instrument p2p, mp2p and p2mp paths.

My 2 cents, hope it is useful.
Dave

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 01, 2016 8:19 AM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] I-D Action: draft-ietf-spring-sr-oam-requirement-02.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 7 Jul 2016 04:14:38 +0000

Hi Dave,
many thanks for your thorough review and insightful comments. Apologies for the delayed response as we been tied in with other activities. Will discuss and continue work after the meeting.

	Regards,
		Greg

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Friday, July 01, 2016 9:12 AM
To: [email-masked]
Subject: Re: [spring] I-D Action: draft-ietf-spring-sr-oam-requirement-02.txt

Hi

3) REQ5, question...

4) REQ9, clarification

5) REQ11

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 01, 2016 8:19 AM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] I-D Action: draft-ietf-spring-sr-oam-requirement-02.txt

Abstract: