Subject: [spring] WGLC for draft-ietf-spring-oam-usecase

From: <[email-masked]>
Date: Mon, 12 Sep 2016 16:30:08 +0000

Dear SPRING WG,

The authors have indicated that draft-ietf-spring-oam-usecase is ready for WGLC.

Please send your comments to [email-masked] on whether this use case is ready to be sent to the IESG as an informational draft. We will plan to end the WGLC on September 26.

* Please comment as silence counts as a lack of interest. In the absence of WG support and review, this document will not be sent to the IESG. *

You may also be interested in an implementation report: https://tools.ietf.org/html/draft-leipnitz-spring-pms-implementation-report-00

This document has 2 disclosed IPR: https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-spring-oam-usecase

We are also polling for knowledge of implementations of part or all of what this document describe. Please inform the mailing list, the chairs, or only one of the chairs.

Finally, if you want to volunteer to be Document Shepherd for this document, please let us know.

Regards,

--Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Martin Horneffer <[email-masked]>
Date: Mon, 26 Sep 2016 14:01:31 +0200

Hello everyone,

speaking as co-worker of one of the editors: From my own viewpoint I 
think this document makes a lot of sense and is in a good state. I'm not 
aware of any problemwith the current state of the document. And there 
already is an implementation report. The document should be sent to the 
IESG.

The only reason not to do so might be to abandon SPRING usecase 
documents at all. But since we have bee asked to produce usecase 
documents and went along that track so far, we should IMHO proceed by 
promoting this document as well.

Best regards, Martin

Am 12.09.16 um 18:30 schrieb [email-masked]:
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: "Faisal Iqbal (faiqbal)" <[email-masked]>
Date: Tue, 27 Sep 2016 04:13:03 +0000

Hi,
This is a useful and very well-written document. I have some minor comments and possible syntax corrections for the authors.

Minor:
------
In my opinion, the document should further explain if it's proposing a new system or outlining what must be there in existing systems. Do we want to implement such a data plane validation or enhance/reuse BFD for that purpose?

Note in Page 5: Why will the PMS host not be part of MPLS domain? Isn't it given because a) solution applies to IGP and host will be part of IGP, and b) The top label is for path from PMS to LER I so there is an MPLS path there

Paragraph 1, Page 8: "The PMS further could be enabled to send MPLS OAM packets with the label stack and address information identical to those of the monitoring packets to any node of the MPLS domain". Can you please clarify this? I don't understand the use case.

Section 6 mentions the applicability of this solution for LDP but leaves out RSVP-TE tunnels. Won't it also be beneficial in monitoring active RSVP-TE tunnels as well?

Syntax:
-------
Paragraph 2 on Page 3 should read "This document describes a system of using MPLS data plane pat monitoring capabilities" instead of "This document describes illustrates a system of using MPLS data plane pat monitoring capabilities"

Paragraph 2, Page 3: Change "The use case introduced here" to "The use cases introduced here"

Paragraph 5, Page 3: Shouldn't it read "pre-Segment Routing (SR) based technology" instead of "pre-Segment based Routing (SR) technology"?

Paragraph 5, Page 3: Change "domains complete MPLS topology" to "domain's complete MPLS topology"

Paragraph 5, Page 3: Change "domains forwarding plane" to "domain's forwarding plane"

Paragraph 2, Page 4: Change "recongise an execute" to "recognise and execute"

Paragraph 4, Page 4: Change "The MPLS path monitoring system may be a any server" to "The MPLS path monitoring system may be at any server"

Paragraph 2, Page 5: Change "monitor the path of it to LER j and then receive the packet back" to "monitors its path to LER j and then receives the packet back"

Bullet 3, Page 7": Remove "to" from "The path LER j to PMS to must be available"

Regards,
Faisal Iqbal

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Martin Horneffer
Sent: Monday, September 26, 2016 8:02 AM
To: [email-masked]
Subject: Re: [spring] WGLC for draft-ietf-spring-oam-usecase

Hello everyone,

speaking as co-worker of one of the editors: From my own viewpoint I think this document makes a lot of sense and is in a good state. I'm not aware of any problemwith the current state of the document. And there already is an implementation report. The document should be sent to the IESG.

The only reason not to do so might be to abandon SPRING usecase documents at all. But since we have bee asked to produce usecase documents and went along that track so far, we should IMHO proceed by promoting this document as well.

Best regards, Martin

Am 12.09.16 um 18:30 schrieb [email-masked]:
> * Please comment as silence counts as a lack of interest. In the 
> absence of WG support and review, this document will not be sent to 
> the IESG. *
>
> You may also be interested in an implementation report: 
> https://tools.ietf.org/html/draft-leipnitz-spring-pms-implementation-r
> eport-00
>
> This document has 2 disclosed IPR: 
> https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-sp
> ring-oam-usecase
>
> ______________________________________________________________________
> ___________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

 

Faisal Iqbal
ENGINEER.SOFTWARE ENGINEERING
[email-masked]
Tel: +1 613 254 3853
Cisco Systems, Inc.
2000 Innovation Drive
KANATA
K2K 3E8
Canada
cisco.com

Think before you print.
This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.
Please click here for Company Registration Information.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, September 12, 2016 12:30 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WGLC for draft-ietf-spring-oam-usecase

Dear SPRING WG,

Regards,

--Bruno

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 30 Sep 2016 10:39:51 +0000

Hi Faisal,

thanks for your review and comments. My remarks in line below, marked [RG].

Regards, Ruediger

-----Ursprüngliche Nachricht-----
Von: spring [mailto:[email-masked]] Im Auftrag von Faisal Iqbal (faiqbal)
Gesendet: Dienstag, 27. September 2016 06:13
An: [email-masked]; [email-masked]
Cc: [email-masked]
Betreff: Re: [spring] WGLC for draft-ietf-spring-oam-usecase

Hi,

Minor:
------

[RG] The outlined system works with MPLS as is today. BFD could be implemented as part of a PMS to monitor a path. I'll add text to state that (in that case, scalability has to be regarded and determination of the failing path). 

Note in Page 5: Why will the PMS host not be part of MPLS domain? Isn't it given because a) solution applies to IGP and host will be part of IGP, and b) The top label is for path from PMS to LER I so there is an MPLS path there.

[RG] It is just one option that the PMS is not part of the MPLS domain (the latter is the best option for a realization). It should be part of the IGP domain. But a design with a PMS neither being part of the MPLS domain, nor being part of the IGP domain is possible. I'll clarify that.

[RG] I'll add some text. MPLS OAM allows to detect routing of packets along ECMP paths. So there are choices, if a path between LERi - LSRx/LSRy - LER j is to be monitored: either detect a desired path crossing, say, LSRx to be used 
- by MPLS OAM and only send the monitoring packet with Label LERy and a suitable IP dest address from LERj or
- use a Label stack (LSRx) and LSRj (PHP will have removed the former).

[RG] Let's add a "possibly also RSVP-TE" here, I don't know for sure. Deutsche Telekom developed such a system for an LDP signaled MPLS domain. I can't discuss how to build it for RSVP-TE signaled tunnels (and don't want to be obliged to do that).

Syntax: [RG] will be picked up for the next version....
-------
Paragraph 2 on Page 3 should read "This document describes a system of using MPLS data plane pat monitoring capabilities" instead of "This document describes illustrates a system of using MPLS data plane pat monitoring capabilities"

Regards,
Faisal Iqbal

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Martin Horneffer
Sent: Monday, September 26, 2016 8:02 AM
To: [email-masked]
Subject: Re: [spring] WGLC for draft-ietf-spring-oam-usecase

Hello everyone,

Best regards, Martin

 

Faisal Iqbal

Think before you print.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, September 12, 2016 12:30 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WGLC for draft-ietf-spring-oam-usecase

Dear SPRING WG,

Regards,

--Bruno