Subject: [spring] Discussions on ESI filtering procedure in SRv6 EVPN (defined in draft-dawra-idr-srv6-vpn-03)

From: <[email-masked]>
Date: Wed, 7 Feb 2018 15:29:27 +0800 (CST)

Hi folks,

I have some questions on ESI filtering procedure of draft-dawra-idr-srv6-vpn-03 to discuss together with you.

1) The ESI Label(Arg.FE2) is included in the DIP, following the draft above.

 and the ESI filtering procedures is similar to MPLS EVPN with ESI-label lookup.

 so it's a little complex in both data plane and control plane.

 but, if we introduce a End.ESI SID and make the SIP carry the End.ESI SID, 

 the data plane and control plane is more simpler.

 and The ESI-filtering procedures is that:

    in the egress PE, the SIP is compared with the corresponding End.ESI SID of each outputing AC, 

    when they are the same, the packet passed, otherwise the packet dropped.

 This is very similar to PBB EVPN ESI-filtering, where S-BMAC take the place of End.ESI SID

  How do you think this method?

2) If the Source ESI is carried on the bottom of the SID stack in the SRH,

  and we don't expect that the service SID is the bottom of the SID stack in the SRH,

  we can do the ESI-filtering as the following:

    in the egress PE, the source-ESI is compared with the corresponding ESI of each outputing AC, 

    the packet passed if they are the same, otherwise the packet dropped.

  the ESI in SRH can be used to do differentiated procedures for some pre-configured source-ESIs,

  for example, we can mirror a specified ESI's packets to a server,

  it seems that the differentiated procedures based on source-ESI is not supportted in current SRv6 EVPN procedures. 

  but both the two method can do this.  

  Is there something important I missed?

3) In current SRv6 EVPN procedures, when the BUM packets is replicated on the core Nodes,

  it means that the ESI-label is upstream-assigned, and the dataplane is complex,

  but the above two methods are as simple as the ingress-replication scenario.

  so maybe it's an advantage of the above two methods?

Best Regards,

Wang Yubao

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Wed, 21 Feb 2018 15:27:52 +0000

Hi,

This solution does not work since an ESI spans over more than one EVI.
With an ESI SID, the egress PE won’t know the VPN to import coming packets.

If we want to go down that road, we need to have an SID per ESI/EVI.

The way we are doing it is very similar. By combining 2 information, an per ESI/EVI SID create is used in forwarding.
It is funny that you think the forwarding will be better since you are getting to same situation.
In fact, the packet transports an unique SID… so I don’t get why it is complex.
Regards
Patrice Brissette
From: "[email-masked]" <[email-masked]>
Date: Wednesday, February 7, 2018 at 2:29 AM
To: "[email-masked]" <[email-masked]>, "Clarence Filsfils (cfilsfil)" <[email-masked]>, "Darren Dukes (ddukes)" <[email-masked]>, Patrice Brissette <[email-masked]>, "Pablo Camarillo (pcamaril)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Discussions on ESI filtering procedure in SRv6 EVPN (defined in draft-dawra-idr-srv6-vpn-03)

Hi folks,

Best Regards,

Wang Yubao