Subject: Re: [spring] Benoit Claise's No Objection on draft-ietf-spring-segment-routing-msdc-08: (with COMMENT)

From: Gaurav Dawra <[email-masked]>
Date: Tue, 6 Feb 2018 04:54:32 -0800

Thanks Beniot for the comments.

Please see inline [Gaurav]

> On Jan 11, 2018, at 1:30 AM, Benoit Claise <[email-masked]> wrote:
> 
> Benoit Claise has entered the following ballot position for
> draft-ietf-spring-segment-routing-msdc-08: No Objection
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-msdc/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> OPS DIR review from Tina:
> 
> I found this document well written to be READY for publication as an
> informational document.
> 
> Some nits:
> 
> 4.2 eBGP Labeled Unicast (RFC8277)
> 
> Each node peers with its neighbors via a eBGP session
> 
> should be
> 
> Each node peers with its neighbors via an eBGP session
[Gaurav] Will address in next revision.
> 
> 7.  Addressing the open problems
> 
> the same could be re-used in context of
>   other domains as well
> 
> A period is missing in the end.
> 
[Gaurav] ACK.

> Are the centralized controller and centralized agent the same components?
[Gaurav]  Yes in this context.
> 
> Even though the design in this document is specified for same domain, it would
> be useful to develop an approach for inter-domain without leaking intra-domain
> topology and policy.
> 
> Have this feature been included or being aligned with carrier grade FIB in
> FD.io VPP https://wiki.fd.io/view/VPP ?
> [Gaurav] Apologies, which specific feature?

Cheers,

Gaurav
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Tina Tsou <[email-masked]>
Date: Tue, 06 Feb 2018 15:33:03 +0000

Dear Gaurav,

Please scroll down to see the reply in line.

On Tue, Feb 6, 2018 at 4:54 AM Gaurav Dawra <[email-masked]> wrote:

> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html
I meant the technology described by this document.

At FD.io CSIT TOI meeting now, see segment routing is on the list, but
cannot find more detail whether msdc is included.

> --
Thank you, Tina

---

From: Gaurav Dawra <[email-masked]>
Date: Mon, 12 Feb 2018 09:48:41 -0800

Tina,

I am adding Pablo. He will respond to below comment.

Cheers,

Gaurav

> On Feb 6, 2018, at 7:33 AM, Tina Tsou <[email-masked]> wrote:
> 
> Dear Gaurav,
> 
> On Tue, Feb 6, 2018 at 4:54 AM Gaurav Dawra <[email-masked] <mailto:[email-masked]>> wrote:
> > On Jan 11, 2018, at 1:30 AM, Benoit Claise <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html <https://www.ietf.org/iesg/statement/discuss-criteria.html>
> > https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-msdc/ <https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-msdc/>
> >
> >
> >
> > FD.io VPP https://wiki.fd.io/view/VPP <https://wiki.fd.io/view/VPP> ?
> At FD.io <http://fd.io/> CSIT TOI meeting now, see segment routing is on the list, but cannot find more detail whether msdc is included.
> 
> Cheers,
> 
> Gaurav
> >
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/spring <https://www.ietf.org/mailman/listinfo/spring>
> 
> -- 
> Thank you, Tina

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Wed, 14 Feb 2018 22:21:01 +0000

Hello Tina,

VPP has data-plane support for SR both over MPLS[1] and IPv6 [2].
Regarding support for BGP-Prefix-SID, well since VPP does not have a routing stack, it does not support BGP at all. That said, I’m well aware of several ongoing opensource projects that are trying to get a control plane to VPP where the BGP-Prefix-SID most likely will be introduced.

The CSIT project is related to automated performance measurement for VPP. I’m working with the CSIT team to get all the SR code tested in CSIT.

Thank you.

Cheers,
Pablo.

[1]. https://docs.fd.io/vpp/18.04/srmpls_doc.html
[2]. https://docs.fd.io/vpp/18.04/srv6_doc.html

From: Gaurav Dawra <[email-masked]>
Date: Monday, 12 February 2018 at 18:48
To: Tina Tsou <[email-masked]>
Cc: "Benoit Claise (bclaise)" <[email-masked]>, The IESG <[email-masked]>, Tina Tsou <[email-masked]>, Alvaro Retana <[email-masked]>, Bruno Decraene <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Pablo Camarillo (pcamaril)" <[email-masked]>
Subject: Re: [spring] Benoit Claise's No Objection on draft-ietf-spring-segment-routing-msdc-08: (with COMMENT)

Tina,

Cheers,

Gaurav

On Feb 6, 2018, at 7:33 AM, Tina Tsou <[email-masked]<mailto:[email-masked]>> wrote:

Dear Gaurav,

On Tue, Feb 6, 2018 at 4:54 AM Gaurav Dawra <[email-masked]<mailto:[email-masked]>> wrote:
Thanks Beniot for the comments.

> On Jan 11, 2018, at 1:30 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
>
[Gaurav] ACK.

> FD.io<http://FD.io> VPP https://wiki.fd.io/view/VPP ?

At FD.io<http://fd.io/> CSIT TOI meeting now, see segment routing is on the list, but cannot find more detail whether msdc is included.

Cheers,

Gaurav
> [email-masked]<mailto:[email-masked]>
--
Thank you, Tina

---

From: Tina Tsou <[email-masked]>
Date: Wed, 14 Feb 2018 23:48:01 +0000

Dear Pablo,

Thanks for the update.

I will keep an eye on the CSIT process.

On Wed, Feb 14, 2018 at 2:21 PM Pablo Camarillo (pcamaril) <
[email-masked]> wrote:

> Regarding support for BGP-Prefix-SID, well since VPP does not have a
> routing stack, it does not support BGP at all. That said, I’m well aware of
> several ongoing opensource projects that are trying to get a control plane
> to VPP where the BGP-Prefix-SID most likely will be introduced.
>
>
>
> The CSIT project is related to automated performance measurement for VPP.
> I’m working with the CSIT team to get all the SR code tested in CSIT.
>
>
>
> Thank you.
>
>
>
> Cheers,
>
> Pablo.
>
>
>
> *From: *Gaurav Dawra <[email-masked]>
> *Date: *Monday, 12 February 2018 at 18:48
> *To: *Tina Tsou <[email-masked]>
> *Cc: *"Benoit Claise (bclaise)" <[email-masked]>, The IESG <
> [email-masked]>, Tina Tsou <[email-masked]>, Alvaro Retana <
> [email-masked]>, Bruno Decraene <[email-masked]>, "
> [email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>,
> "Pablo Camarillo (pcamaril)" <[email-masked]>
> *Subject: *Re: [spring] Benoit Claise's No Objection on
> draft-ietf-spring-segment-routing-msdc-08: (with COMMENT)
>
>
>
> Tina,
>
>
>
> At FD.io <http://fd.io/> CSIT TOI meeting now, see segment routing is on
> the list, but cannot find more detail whether msdc is included.
>
>
> Cheers,
>
> Gaurav
> >
Thank you, Tina