Subject: Re: [spring] Section 9.1 of the draft draft-filsfils-spring-segment-routing-policy (IP/Optical)

From: Jeff Tantsura <[email-masked]>
Date: Thu, 01 Mar 2018 10:13:32 -0800

Hi Ketan,

Thanks for responding.

I’m completely with you here, drafts are complimentary, moreover, draft poi extensively uses and references policy draft. 

My only request is to reference draft poi for the use cases that are relevant, such as section 9.1.

Hope this makes sense and clarifies the intentions. 

Thanks!

Cheers,

Jeff

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thursday, March 1, 2018 at 09:14
To: Jeff Tantsura <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: SPRING WG <[email-masked]>
Subject: RE: Section 9.1 of the draft (IP/Optical)

Hi Jeff/All,

Perhaps there is some misunderstanding on the content in the policy draft and let me try to clarify the same.

Section 4 of the policy draft introduces and describes the different Segment Types. We wanted to introduce a segment type to indicate in general a “non-IP” link that may be used to divert traffic into a link/segment as a part of an explicit segment list. This type of link could be an optical transport path, or some Layer-2 link/channel, or such. In the previous rev 04, we introduced a new Segment Type 12 for this purpose but after review/feedback, we realized that this was not necessary. Hence in the 05 version, it is clarified that Segment Type 5 or 7 may be used as such.

Section 9.1 is actually an illustration of the use-case of such a layer-2 segment type used for an SR Policy as described above. Even if the example is integrated-DWDM interface, it is clarified that the same applies for any other layer-2 or “non-IP” link representation on the router. The policy draft provides the SR Policy framework and definition.

The poi draft is very important IMHO as it covers and explains the optical transport SR Policies along with their use-cases. This draft actually specifies the Optical Transport SR policy in the form of Transport Segments – it introduces this new type of transport segment and SR policy as it references the policy draft. It also talks about the Optical Transport Policy being used through its BSID in the IP layers. This maps to Segment Type 1 in the policy draft – just similar to a SR Policy between IP segments. It is absolutely correct that the poi draft specifies the control plane extensions and TLV for the optical transport segments and capabilities. The policy draft does not do this.

So I do believe the policy and poi drafts are complementary.

Thanks,

Ketan

From: Jeff Tantsura [mailto:[email-masked]] 
Sent: 01 March 2018 03:09
To: [email-masked]; [email-masked]
Cc: SPRING WG <[email-masked]>
Subject: Section 9.1 of the draft (IP/Optical)

Hello authors of draft-filsfils-spring-segment-routing-policy(further references as policy draft),

We, authors of draft-anand-spring-poi-sr draft(further referenced as poi draft) have noted that section 9.1 of 04 version of the policy draft now has IP/Optical use case, that is in great details described in the poi draft. It also references policy draft and in details explains how it could be used in IP/Optical case.

All control plane extensions needed for the solution to work are defined in the poi draft.

Rather than having 2 different drafts trying to specify same technology, we think that for the IP/Optical case a reference (normative) to the poi draft would be in place.

Thanks and looking forward to working with you!

Cheers,

Jeff on behalf of co-authors

P.S. Since Clarence is on the both drafts, I’d let him speak for himself.

---

From: "Clarence Filsfils (cfilsfil)" <[email-masked]>
Date: Fri, 2 Mar 2018 09:37:48 +0100

Jeff,

For sure. It was our intention to have this reference. It is absolutely 
obvious that it must be. The point of the section 9.1 and especially the 
new SID that we defined is to provide the proper support/context for the 
POI draft and hence the reference is clear.

Cheers,
Clarence

On 01/03/2018 19:13, Jeff Tantsura wrote:
> Hi Ketan,
> 
> Thanks for responding.
> 
> I’m completely with you here, drafts are complimentary, moreover, draft 
> poi extensively uses and references policy draft.
> 
> *From: *"Ketan Talaulikar (ketant)" <[email-masked]>
> *Date: *Thursday, March 1, 2018 at 09:14
> *To: *Jeff Tantsura <[email-masked]>, 
> "[email-masked]" 
> <[email-masked]>, 
> "[email-masked]" <[email-masked]>
> *Cc: *SPRING WG <[email-masked]>
> *Subject: *RE: Section 9.1 of the draft (IP/Optical)
> 
> Hi Jeff/All,
> 
> Perhaps there is some misunderstanding on the content in the policy 
> draft and let me try to clarify the same.
> 
> Section 4 of the policy draft introduces and describes the different 
> Segment Types. We wanted to introduce a segment type to indicate in 
> general a “non-IP” link that may be used to divert traffic into a 
> link/segment as a part of an explicit segment list. This type of link 
> could be an optical transport path, or some Layer-2 link/channel, or 
> such. In the previous rev 04, we introduced a new Segment Type 12 for 
> this purpose but after review/feedback, we realized that this was not 
> necessary. Hence in the 05 version, it is clarified that Segment Type 5 
> or 7 may be used as such.
> 
> Section 9.1 is actually an illustration of the use-case of such a 
> layer-2 segment type used for an SR Policy as described above. Even if 
> the example is integrated-DWDM interface, it is clarified that the same 
> applies for any other layer-2 or “non-IP” link representation on the 
> router. The policy draft provides the SR Policy framework and definition.
> 
> The poi draft is very important IMHO as it covers and explains the 
> optical transport SR Policies along with their use-cases. This draft 
> actually specifies the Optical Transport SR policy in the form of 
> Transport Segments – it introduces this new type of transport segment 
> and SR policy as it references the policy draft. It also talks about the 
> Optical Transport Policy being used through its BSID in the IP layers. 
> This maps to Segment Type 1 in the policy draft – just similar to a SR 
> Policy between IP segments. It is absolutely correct that the poi draft 
> specifies the control plane extensions and TLV for the optical transport 
> segments and capabilities. The policy draft does not do this.
> 
> *From:*Jeff Tantsura [mailto:[email-masked]]
> *Sent:* 01 March 2018 03:09
> *To:* [email-masked]; 
> [email-masked]
> *Cc:* SPRING WG <[email-masked]>
> *Subject:* Section 9.1 of the draft (IP/Optical)
> 
> We, authors of draft-anand-spring-poi-sr draft(further referenced as poi 
> draft) have noted that section 9.1 of 04 version of the policy draft now 
> has IP/Optical use case, that is in great details described in the poi 
> draft. It also references policy draft and in details explains how it 
> could be used in IP/Optical case.
> 
> Rather than having 2 different drafts trying to specify same technology, 
> we think that for the IP/Optical case a reference (normative) to the poi 
> draft would be in place.
>

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 2 Mar 2018 08:39:03 +0000

Hi Jeff,

Thanks for clarifying and we should definitely add the reference to the POI draft in sec 9.1. I’ll work with other authors to incorporate the same in the next rev.

Also thanks for pointing this out as it helps indeed to clarify the relationship between these two drafts and the both draft authors’ intentions.

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 01 March 2018 23:44
To: Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]; [email-masked]
Cc: SPRING WG <[email-masked]>
Subject: Re: Section 9.1 of the draft draft-filsfils-spring-segment-routing-policy (IP/Optical)

Hi Ketan,

Thanks for responding.

Cheers,
Jeff
From: "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 1, 2018 at 09:14
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: SPRING WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: Section 9.1 of the draft (IP/Optical)

Hi Jeff/All,

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 01 March 2018 03:09
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: SPRING WG <[email-masked]<mailto:[email-masked]>>
Subject: Section 9.1 of the draft (IP/Optical)

Cheers,

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 02 Mar 2018 09:58:22 -0800

Ketan,

Thank you for addressing my comments.

Always a pleasure working with you! 

Cheers,

Jeff

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Friday, March 2, 2018 at 00:39
To: Jeff Tantsura <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: SPRING WG <[email-masked]>
Subject: RE: Section 9.1 of the draft draft-filsfils-spring-segment-routing-policy (IP/Optical)

Hi Jeff,

Thanks,

Ketan

Hi Ketan,

Thanks for responding.

Thanks!

Cheers,

Jeff

Hi Jeff/All,

Thanks,

Ketan

Cheers,

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 02 Mar 2018 09:59:08 -0800

Thanks Clarence, we are on the same page then.

Cheers,
Jeff
On 3/2/18, 00:37, "Clarence Filsfils (cfilsfil)" <[email-masked]> wrote:

    Jeff,

    Cheers,
    Clarence