Subject: [spring] Fwd: New Version Notification for draft-ietf-spring-segment-routing-mpls-12.txt

From: "Ahmed Bashandy (bashandy)" <[email-masked]>
Date: Thu, 08 Mar 2018 09:17:42 -0800

Hi,

Here is a new version of the draft. This version has non-trivial changes 
from the previous one. Here is a summary of the changes
- Specifications of the rules governing SRGB and SRLB
- Specification of how to translate a SID index into a label
- Specification of what a router do when receiving an SRGB advertisement 
that does not conform to the rules
- Handling incoming label collision
- Handling outgoing label collision
- Rules governing redistribution of routes that have SR-MPLS SIDs

Thanks

Ahmed

-------- Original Message --------
Subject: 	New Version Notification for 
draft-ietf-spring-segment-routing-mpls-12.txt
Date: 	Fri, 23 Feb 2018 05:06:46 -0800
From: 	<[email-masked]>
To: 	Ahmed Bashandy <[email-masked]>, Bruno Decraene 
<[email-masked]>, Clarence Filsfils <[email-masked]>, 
"Stefano Previdi" <[email-masked]>, Rob Shakir <[email-masked]>, 
"Stephane Litkowski" <[email-masked]>

A new version of I-D, draft-ietf-spring-segment-routing-mpls-12.txt
has been successfully submitted by Ahmed Bashandy and posted to the
IETF repository.

Name:		draft-ietf-spring-segment-routing-mpls
Revision:	12
Title:		Segment Routing with MPLS data plane
Document date:	2018-02-23
Group:		spring
Pages:		24
URL:            https://www.ietf.org/internet-drafts/draft-ietf-spring-segment-routing-mpls-12.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-mpls/
Htmlized:       https://tools.ietf.org/html/draft-ietf-spring-segment-routing-mpls-12
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-spring-segment-routing-mpls-12
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-segment-routing-mpls-12

Abstract:
    Segment Routing (SR) leverages the source routing paradigm.  A node
    steers a packet through a controlled set of instructions, called
    segments, by prepending the packet with an SR header.  In the MPLS
    dataplane, the SR header is instantiated through a label stack. This
    document specifies the forwarding behavior to allow instantiating SR
    over the MPLS dataplane.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Rob Shakir <[email-masked]>
Date: Thu, 08 Mar 2018 17:28:45 +0000

Hi Ahmed,

Thanks for the update to the WG.

Would it be possible for you and the authors of
draft-ietf-spring-conflict-resolution to clarify what the intention is for
that draft when compared to this one? The additions in sections 2.5. and
2.6 of this draft seem to cover the same material as covered in that draft
- and the conflict resolution draft has expired.

Thank you!
r.

On Thu, Mar 8, 2018 at 6:17 PM Ahmed Bashandy (bashandy) <[email-masked]>
wrote:

> From: <[email-masked]> <[email-masked]>
> To: Ahmed Bashandy <[email-masked]> <[email-masked]>, Bruno
> Decraene <[email-masked]> <[email-masked]>,
> Clarence Filsfils <[email-masked]> <[email-masked]>, "Stefano
> Previdi" <[email-masked]> <[email-masked]>, Rob Shakir
> <[email-masked]> <[email-masked]>, "Stephane Litkowski"
> <[email-masked]> <[email-masked]>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: "Ahmed Bashandy (bashandy)" <[email-masked]>
Date: Thu, 08 Mar 2018 10:56:37 -0800

As you mentioned draft-ietf-spring-conflict-resolution has already expired.
draft-ietf-spring-segment-routing-mpls covers local label collision only 
that is totally independent of any routing protocols and is a lot simpler.

Ahmed

On 3/8/2018 9:28 AM, Rob Shakir wrote:
> draft-ietf-spring-conflict-resolution to clarify what the intention is 
> for that draft when compared to this one? The additions in sections 
> 2.5. and 2.6 of this draft seem to cover the same material as covered 
> in that draft - and the conflict resolution draft has expired.
>
> Thank you!
> r.
>
>
> On Thu, Mar 8, 2018 at 6:17 PM Ahmed Bashandy (bashandy) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>     Hi,
>
>     Here is a new version of the draft. This version has non-trivial
>     changes from the previous one. Here is a summary of the changes
>     - Specification of what a router do when receiving an SRGB
>     advertisement that does not conform to the rules
>     From: 	<[email-masked]> <mailto:[email-masked]>
>     To: 	Ahmed Bashandy <[email-masked]>
>     <mailto:[email-masked]>, Bruno Decraene
>     <[email-masked]> <mailto:[email-masked]>,
>     Clarence Filsfils <[email-masked]>
>     <mailto:[email-masked]>, "Stefano Previdi"
>     <[email-masked]> <mailto:[email-masked]>, Rob Shakir
>     <[email-masked]> <mailto:[email-masked]>, "Stephane Litkowski"
>     <[email-masked]>
>     <mailto:[email-masked]>
>
>
>
>     URL:https://www.ietf.org/internet-drafts/draft-ietf-spring-segment-routing-mpls-12.txt
>     Status:https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-mpls/
>     Htmlized:https://tools.ietf.org/html/draft-ietf-spring-segment-routing-mpls-12
>     Htmlized:https://datatracker.ietf.org/doc/html/draft-ietf-spring-segment-routing-mpls-12
>     Diff:https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-segment-routing-mpls-12
>
>     Abstract:
>     until the htmlized version and diff are available attools.ietf.org  <http://tools.ietf.org>.
>
>     The IETF Secretariat
>
>
>
>     [email-masked] <mailto:[email-masked]>

---

From: Rob Shakir <[email-masked]>
Date: Thu, 08 Mar 2018 18:58:29 +0000

Thank you.

It would be great if reviewers of the updated -12 of this draft could
review with this in mind, such that we ensure that the content in this
draft matches the content in the conflict resolution draft.

Many thanks,
r.

On Thu, Mar 8, 2018 at 7:56 PM Ahmed Bashandy (bashandy) <[email-masked]>
wrote:

> On Thu, Mar 8, 2018 at 6:17 PM Ahmed Bashandy (bashandy) <
> [email-masked]> wrote:
>
>>
>> Hi,
>>