Subject: [spring] Comments on draft-cheng-spring-mpls-path-segment-01

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 11 Mar 2018 13:43:38 +0000

Dear authors of draft-cheng-spring-mpls-path-segment-01, and I have a few comments.

1.       From my POV, the draft addresses the problem of identifying an incoming SR LSP at the tail-end node.

a.       This problem is real because SR LSPs, by their very nature, are MP2P (merging) LSPs.

b.       The draft does not try to solve the problem of SR LSP identification in transit nodes.

2.       The draft proposes two solutions (one-label and two-label) for the above-mentioned problem, and the authors expect the WG to discuss these solutions and to select the preferred one. As I see it:

a.       Both uses cases discussed in Section 3 of the draft can be addressed with any of these solutions

b.       IMHO and FWIW, as long as SR-MPLS leaves multicast out of scope (as mentioned in Section 6 of the SR Architecture<https://tools.ietf.org/html/draft-ietf-spring-segment-routing-15> draft), any future issue with identification of SR LSPs that can be addressed with the two-label solution can also be addressed with the one-label solution

c.       The two-label solution requires support of upstream-allocated labels and context-specific label spaces, i.e., adds substantial implementation complexity. The one-label solution can be implemented using just per platform label space of downstream-allocated labels.

d.       Based on these considerations, my preference (FWIW) is for one-label solution.

3.       The draft lists both the already mentioned SR Architecture draft and the SR-MPLS<https://tools.ietf.org/html/draft-ietf-spring-segment-routing-mpls-12> draft as Informative references, but the SRV6 Routing Header<https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-09> draft appears as a Normative reference. From my POV, the first two documents MUST be Normative references and the last one - an Informative reference, because the draft only deals with SR-MPLS.

Hopefully,  these notes can be useful.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 12 Mar 2018 10:14:42 +0800

Hi Alexander,

Thank you very much for your comments.

Maybe some issue happened on the mail system. 

I can only see the first sentence of your mail as the follows. 

Could you resend your email?

B.R.

Weiqiang Cheng

发件人: Alexander Vainshtein [mailto:[email-masked]] 
发送时间: 2018年3月11日 21:44
收件人: [email-masked]
抄送: Michael Gorokhovsky; Shell Nakash; Ron Sdayoor; Hemmy Yona; Dmitry
Valdman; Stewart Bryant; [email-masked]
主题: Comments on draft-cheng-spring-mpls-path-segment-01

Dear authors of draft-cheng-spring-mpls-path-segment-01, and I have a few
comments.

1.       From my POV, the draft addresses the problem of identifying an
incoming SR LSP at the tail-end node=

---

From: Mach Chen <[email-masked]>
Date: Tue, 13 Mar 2018 11:21:55 +0000

Hi Sasha,

Many thanks for your valuable comments!

Please see my responses inline...

> 
> From: spring [mailto:[email-masked]] On Behalf Of Alexander
> Vainshtein
> Sent: Sunday, March 11, 2018 9:44 PM
> To: [email-masked]
> Cc: [email-masked]; Shell Nakash <[email-masked]>; Michael
> Gorokhovsky <[email-masked]>; Dmitry Valdman
> <[email-masked]>; Stewart Bryant <[email-masked]>;
> Ron Sdayoor <[email-masked]>; Hemmy Yona
> <[email-masked]>
> Subject: [spring] Comments on draft-cheng-spring-mpls-path-segment-01
> 

Yes, that's the intention.

> 2. The draft proposes two solutions (one-label and two-label) for the above-
> mentioned problem, and the authors expect the WG to discuss these solutions
> and to select the preferred one. As I see it:
> a. Both uses cases discussed in Section 3 of the draft can be addressed with any
> of these solutions b. IMHO and FWIW, as long as SR-MPLS leaves multicast out
> of scope (as mentioned in Section 6 of the SR Architecture draft), any future
> issue with identification of SR LSPs that can be addressed with the two-label
> solution can also be addressed with the one-label solution c. The two-label
> solution requires support of upstream-allocated labels and context-specific
> label spaces, i.e., adds substantial implementation complexity. The one-label
> solution can be implemented using just per platform label space of
> downstream-allocated labels.

I also have the same preference as yours. 

> 3. The draft lists both the already mentioned SR Architecture draft and the SR-
> MPLS draft as Informative references, but the SRV6 Routing Header draft
> appears as a Normative reference. From my POV, the first two documents
> MUST be Normative references and the last one - an Informative reference,
> because the draft only deals with SR-MPLS.

Agree, will update it in the next revision.

> Hopefully,  these notes can be useful.

Very useful, as always!

Thanks,
Mach

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 13 Mar 2018 11:30:25 +0000

Mach,
Lots of thanks for a prompt and very encouraging response!
One more question: 

Do you and your colleagues plan to define the mechanism for distribution of the Path Segment ID in IGP?
(Usually such mechanisms are defined in dedicated drafts separately for OSPF and ISIS, but, at least, it should be nice to mention the fact in the draft).

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Mach Chen
Sent: Tuesday, March 13, 2018 1:22 PM
To: Alexander Vainshtein <[email-masked]>; [email-masked]
Cc: [email-masked]; Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Dmitry Valdman <[email-masked]>; Stewart Bryant <[email-masked]>; Ron Sdayoor <[email-masked]>; Hemmy Yona <[email-masked]>
Subject: Re: [spring] Comments on draft-cheng-spring-mpls-path-segment-01

Hi Sasha,

> <[email-masked]>; Stewart Bryant 
> <[email-masked]>; Ron Sdayoor <[email-masked]>; 
> Hemmy Yona <[email-masked]>
> incoming SR LSP at the tail-end node.
> a. This problem is real because SR LSPs, by their very nature, are 
> MP2P
> (merging) LSPs.

> 2. The draft proposes two solutions (one-label and two-label) for the 
> above- mentioned problem, and the authors expect the WG to discuss 
> these solutions and to select the preferred one. As I see it:
> a. Both uses cases discussed in Section 3 of the draft can be 
> addressed with any of these solutions b. IMHO and FWIW, as long as 
> SR-MPLS leaves multicast out of scope (as mentioned in Section 6 of 
> the SR Architecture draft), any future issue with identification of SR 
> LSPs that can be addressed with the two-label solution can also be 
> addressed with the one-label solution c. The two-label solution 
> requires support of upstream-allocated labels and context-specific 
> label spaces, i.e., adds substantial implementation complexity. The 
> one-label solution can be implemented using just per platform label space of downstream-allocated labels.

> 3. The draft lists both the already mentioned SR Architecture draft 
> and the SR- MPLS draft as Informative references, but the SRV6 Routing 
> Header draft appears as a Normative reference. From my POV, the first 
> two documents MUST be Normative references and the last one - an 
> Informative reference, because the draft only deals with SR-MPLS.

Very useful, as always!

Thanks,
Mach

> Email:   [email-masked]

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 13 Mar 2018 15:52:05 +0000

We recently published a 00 version, undergoing an update to be published during IETF week (presented @ LSR WG). 
It addresses label stack reduction for any non-shortest path LSPs including an optional path traffic statistics.

https://www.ietf.org/mail-archive/web/dmm/current/msg03162.html 

It would help for SRH more when it comes to TE path. Check out DMM WG (3GPP SA2 study & proposals) discussions off late.

Best,
--
Uma C.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
Sent: Tuesday, March 13, 2018 4:30 AM
To: Mach Chen <[email-masked]>
Cc: [email-masked]; Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Dmitry Valdman <[email-masked]>; [email-masked]; Stewart Bryant <[email-masked]>; Ron Sdayoor <[email-masked]>; Hemmy Yona <[email-masked]>
Subject: Re: [spring] Comments on draft-cheng-spring-mpls-path-segment-01

Mach,

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Mach Chen
Sent: Tuesday, March 13, 2018 1:22 PM
To: Alexander Vainshtein <[email-masked]>; [email-masked]
Cc: [email-masked]; Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Dmitry Valdman <[email-masked]>; Stewart Bryant <[email-masked]>; Ron Sdayoor <[email-masked]>; Hemmy Yona <[email-masked]>
Subject: Re: [spring] Comments on draft-cheng-spring-mpls-path-segment-01

Hi Sasha,

Very useful, as always!

Thanks,
Mach

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.
___________________________________________________________________________

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 13 Mar 2018 15:57:21 +0000

Sorry, minor correction:

3GPP SA2 ==> 3GPP CT4

And it helps most of the proposals including SRH, SR-MPLS, LISP, ILA (?) ..

Best,
--
Uma C.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Uma Chunduri
Sent: Tuesday, March 13, 2018 8:52 AM
To: Alexander Vainshtein <[email-masked]>; Mach Chen <[email-masked]>
Cc: [email-masked]; Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Dmitry Valdman <[email-masked]>; [email-masked]; Stewart Bryant <[email-masked]>; Ron Sdayoor <[email-masked]>; Hemmy Yona <[email-masked]>
Subject: Re: [spring] Comments on draft-cheng-spring-mpls-path-segment-01

Best,
--
Uma C.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
Sent: Tuesday, March 13, 2018 4:30 AM
To: Mach Chen <[email-masked]>
Cc: [email-masked]; Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Dmitry Valdman <[email-masked]>; [email-masked]; Stewart Bryant <[email-masked]>; Ron Sdayoor <[email-masked]>; Hemmy Yona <[email-masked]>
Subject: Re: [spring] Comments on draft-cheng-spring-mpls-path-segment-01

Mach,

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Mach Chen
Sent: Tuesday, March 13, 2018 1:22 PM
To: Alexander Vainshtein <[email-masked]>; [email-masked]
Cc: [email-masked]; Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Dmitry Valdman <[email-masked]>; Stewart Bryant <[email-masked]>; Ron Sdayoor <[email-masked]>; Hemmy Yona <[email-masked]>
Subject: Re: [spring] Comments on draft-cheng-spring-mpls-path-segment-01

Hi Sasha,

Very useful, as always!

Thanks,
Mach

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 13 Mar 2018 16:17:17 +0000

Uma,

Lots of thanks for bringing the draft in question<https://www.ietf.org/id/draft-ct-isis-nspfid-for-sr-paths-00.txt> to my attention.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

-----Original Message-----
From: Uma Chunduri [mailto:[email-masked]]
Sent: Tuesday, March 13, 2018 5:52 PM
To: Alexander Vainshtein <[email-masked]>; Mach Chen <[email-masked]>
Cc: [email-masked]; Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Dmitry Valdman <[email-masked]>; [email-masked]; Stewart Bryant <[email-masked]>; Ron Sdayoor <[email-masked]>; Hemmy Yona <[email-masked]>
Subject: RE: Comments on draft-cheng-spring-mpls-path-segment-01

Best,

--

Uma C.

-----Original Message-----

To: Mach Chen <[email-masked]<mailto:[email-masked]>>

Cc: [email-masked]<mailto:[email-masked]>; Shell Nakash <[email-masked]<mailto:[email-masked]>>; Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>; Dmitry Valdman <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Stewart Bryant <[email-masked]<mailto:[email-masked]>>; Ron Sdayoor <[email-masked]<mailto:[email-masked]>>; Hemmy Yona <[email-masked]<mailto:[email-masked]>>

Mach,

One more question:

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

Email:   [email-masked]<mailto:[email-masked]>

-----Original Message-----

To: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Cc: [email-masked]<mailto:[email-masked]>; Shell Nakash <[email-masked]<mailto:[email-masked]>>; Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>; Dmitry Valdman <[email-masked]<mailto:[email-masked]>>; Stewart Bryant <[email-masked]<mailto:[email-masked]>>; Ron Sdayoor <[email-masked]<mailto:[email-masked]>>; Hemmy Yona <[email-masked]<mailto:[email-masked]>>

Hi Sasha,

> To: [email-masked]<mailto:[email-masked]>

> Cc: [email-masked]<mailto:[email-masked]>; Shell Nakash <[email-masked]<mailto:[email-masked]>>; Michael

> Gorokhovsky <[email-masked]<mailto:[email-masked]>>; Dmitry Valdman

> <[email-masked]<mailto:[email-masked]>>; Stewart Bryant

> <[email-masked]<mailto:[email-masked]>>; Ron Sdayoor <[email-masked]<mailto:[email-masked]>>;

> Hemmy Yona <[email-masked]<mailto:[email-masked]>>

> Dear authors of draft-cheng-spring-mpls-path-segment-01, and I have a

> few comments.

> b. The draft does not try to solve the problem of SR LSP

> identification in transit nodes.

> d. Based on these considerations, my preference (FWIW) is for

> one-label solution.

Very useful, as always!

Thanks,

Mach

> Email:   [email-masked]<mailto:[email-masked]>

spring mailing list

[email-masked]<mailto:[email-masked]>

spring mailing list

[email-masked]<mailto:[email-masked]>

---

From: Mach Chen <[email-masked]>
Date: Wed, 14 Mar 2018 03:07:23 +0000

Hi Sasha,

Thanks for your prompt response!

Section 2.1.1 discusses some potential directions for Path segment ID assignment and distribution, there are several ways that can be used. IGP based solution is good for the case where more nodes within the domain needs to learn the Path Segment ID. For the use cases as mentioned in Section 3, the nodes that need to learn the Path Segment ID are mainly the ingress LSR. For a centralized model, the centralized controller may also need to learn the Path Segment ID. So, for these use case, a point-2-point model (e.g., BGP) or request/reply model (e.g., PCEP) seems more suitable.  How do you think?

Best regards,
Mach

> From: Alexander Vainshtein [mailto:[email-masked]]
> Sent: Tuesday, March 13, 2018 7:30 PM
> <[email-masked]>; [email-masked]
> (Usually such mechanisms are defined in dedicated drafts separately for OSPF
> and ISIS, but, at least, it should be nice to mention the fact in the draft).
> 
> Regards,
> Sasha
> 
> Office: +972-39266302
> Cell:      +972-549266302
> This e-mail message is intended for the recipient only and contains information
> which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you
> have received this transmission in error, please inform us by e-mail, phone or
> fax, and then delete the original and all copies thereof.