Subject: [spring] About draft-ali-spring-srv6-oam-00

From: Huzhibo <[email-masked]>
Date: Wed, 16 May 2018 04:56:10 +0000

Hi,
draft-ali-spring-srv6-oam-00 says The OAM packets are identified by setting the O-bit in SRH，But I Notice the latest I-D.6man-segment-routing-header has removed O-bit in the SRH extension header. I want to confirm that draft-ali-spring-srv6-oam-00 will also remove o-bit or keep the o-bit in the later version?
Ths
ZhiBo Hu

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 16 May 2018 11:55:08 +0000

Hi ZhiBo,

Excellent question. Thanks for asking.

  *   O-bit was removed as part of comments during LC of https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-12 draft. The comment was that the bit is defined but its usage is not defined.
  *   The plan to bring O-bit definition from SRH specification and O-bit usage from Network Programming document to draft-ali-spring-srv6-oam-00.
  *   Please also note that to keep implementations unaffected, the O-bit position will be kept at the same place as it was defined in the SRH specification.
  *   Please stay tuned to a v01; it will be soon.

Should the WG has any other question, we will be glad to address them in v01.

Thanks

Regards … Zafar

From: Huzhibo <[email-masked]>
Date: Wednesday, May 16, 2018 at 12:56 AM
To: "Zafar Ali (zali)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Lizhenbin <[email-masked]>, Yangang <[email-masked]>
Subject: About draft-ali-spring-srv6-oam-00

Hi,

---

From: Loa Andersson <[email-masked]>
Date: Tue, 29 May 2018 15:48:01 +0200

Folks,

I thought we had an agreement to remove the O-bit. As ZhiBo Hu points
out other drafts drops it.

The obvious reason to not use an O-bit is that if it ever is part of
what an multipath functions hash on it will csue OAM traffic and
"normal" traffic to use different paths. This defeats the idea with
OAM traffic.

/Loa

On 2018-05-16 06:56, Huzhibo wrote:
> Hi,
> 
> draft-ali-spring-srv6-oam-00 says The OAM packets are identified by 
> setting the O-bit in SRH，But I Notice the latest 
> I-D.6man-segment-routing-headerhas removed O-bit in the SRH extension 
> header. I want to confirm that draft-ali-spring-srv6-oam-00 will also 
> remove o-bit or keep the o-bit in the later version?
> 
> Ths
> 
> ZhiBo Hu
> 
> 
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Tue, 29 May 2018 17:11:52 +0000

Hi Loa,

Thanks for your question.

O-bit "move" from SRH draft to this SRv6 OAM draft is part of a comment received an agreement made during the LC of the SRH draft. Please review the mail chain https://www.ietf.org/mail-archive/web/ipv6/current/msg30131.html. There was never a suggestion or agreement to "remove" O-bit or SRH.Flags field.

Load balancing and ECMP in an SRv6 network are explained in https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-13#section-4.4. An implementation is expected to use the minimum of (source, dest) address and flow label in the outer IPv6 header to compute the hash. RFC6437 describes the use of flow labels to compute a hash for IPv6 packets.

Thanks

Regards … Zafar

From: Loa Andersson <[email-masked]>
Date: Tuesday, May 29, 2018 at 9:48 AM
To: Huzhibo <[email-masked]>, "Zafar Ali (zali)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Lizhenbin <[email-masked]>, Yangang <[email-masked]>
Subject: Re: [spring] About draft-ali-spring-srv6-oam-00

Folks,

/Loa

[email-masked]<mailto:[email-masked]>

--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64