Subject: Re: [spring] Request WG adoption for draft-xuclad-spring-sr-service-chaining-01

From: "徐小虎(义先)" <[email-masked]>
Date: Thu, 03 May 2018 12:07:13 +0800

Hi SPRING WG co-chairs,
I wonder what the current status of this WG adoption request.
Best regards,Xiaohu------------------------------------------------------------------From:徐小虎(义先) <[email-masked]>Send Time:2018年4月4日(星期三) 09:45To:SPRING WG List <[email-masked]>Cc:[email-masked] <[email-masked]>Subject:Request WG adoption for draft-xuclad-spring-sr-service-chaining-01

Hi SPRING WG co-chairs,
We authors believe this draft (https://tools.ietf.org/html/draft-xuclad-spring-sr-service-chaining-01) has been stable enough and therefore we would like to request a WG adoption call for it.
We believe this work belongs to SPRING WG since the concept of service segment has been mentioned in the Segment Routing architecture from day one and the approaches as described in this draft are exactly to leverage the stateless source routing capability of segment routing to achieve a stateless SFC. To some extent, SFC can be looked as a special case of source routing as it requires the selected traffic to traverse an ordered list of service nodes.

We believe the SFC WG review is still needed after the adoption since we still hope to reuse the NSH for some special purposes (e.g., use it as a metadata container). 
BTW, implementations based on this draft have existed, as noted in section 8 of the draft.
Best regards,Xiaohu (on behalf of coauthors)

---

From: <[email-masked]>
Date: Thu, 3 May 2018 07:21:24 +0000

Hi Xiaohu,

We’d like to first clarify the content of the new charter.

Best regards,
--Bruno

From: spring [mailto:[email-masked]] On Behalf Of ???(??)
Sent: Thursday, May 03, 2018 6:07 AM
To: ???(??); SPRING WG List
Subject: Re: [spring] Request WG adoption for draft-xuclad-spring-sr-service-chaining-01

Hi SPRING WG co-chairs,

Best regards,
Xiaohu
------------------------------------------------------------------
From:徐小虎(义先) <[email-masked]<mailto:[email-masked]>>
Send Time:2018年4月4日(星期三) 09:45
To:SPRING WG List <[email-masked]<mailto:[email-masked]>>
Cc:[email-masked] <[email-masked]<mailto:[email-masked]>>
Subject:Request WG adoption for draft-xuclad-spring-sr-service-chaining-01

Hi SPRING WG co-chairs,

Best regards,
Xiaohu (on behalf of coauthors)

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Martin Horneffer <[email-masked]>
Date: Fri, 4 May 2018 10:16:00 +0200

Dear chairs and group,

may I ask about the status of 
draft-filsfils-spring-segment-routing-policy-05?

With the rechartering discussion I got the impression that nobody was 
doubting that this work belongs in the SPRING wg. Would it be ready for 
a wg adoption call now?

Best regards, Martin

Am 03.05.18 um 09:21 schrieb [email-masked]:
> *From:*spring [mailto:[email-masked]] *On Behalf Of *???(??)
> *Sent:* Thursday, May 03, 2018 6:07 AM
> *To:* ???(??); SPRING WG List
> *Subject:* Re: [spring] Request WG adoption for 
> draft-xuclad-spring-sr-service-chaining-01
>
> Hi SPRING WG co-chairs,
>
>     To:SPRING WG List <[email-masked] <mailto:[email-masked]>>
>
>     Cc:[email-masked] <[email-masked] <mailto:[email-masked]>>
>
>     Subject:Request WG adoption for
>     draft-xuclad-spring-sr-service-chaining-01
>
>     Hi SPRING WG co-chairs,
>
>     We authors believe this draft
>     (https://tools.ietf.org/html/draft-xuclad-spring-sr-service-chaining-01)
>     has been stable enough and therefore we would like to request a WG
>     adoption call for it.
>
>     We believe this work belongs to SPRING WG since the concept of
>     service segment has been mentioned in the Segment Routing
>     architecture from day one and the approaches as described in this
>     draft are exactly to leverage the stateless source routing
>     capability of segment routing to achieve a stateless SFC. To some
>     extent, SFC can be looked as a special case of source routing as
>     it requires the selected traffic to traverse an ordered list of
>     service nodes.
>
>     We believe the SFC WG review is still needed after the adoption
>     since we still hope to reuse the NSH for some special purposes
>     (e.g., use it as a metadata container).
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: "Bernier, Daniel" <[email-masked]>
Date: Fri, 4 May 2018 12:14:44 +0000

Hello SPRING chairs,

When do you think this clarification of the charter might have progressed enough to provide an update on the WG adoption of draft-xuclad-spriong-sr-service-chaining ?

Knowing that MPLS WG and SPRING WG chairs have agreed that draft-xuclad-spring-sr-service-chaining should remain in SPRING

Cheers,

- Dan B

________________________________
From: spring <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Thursday, May 3, 2018 3:21 AM
To: 徐小虎(义先); SPRING WG List
Subject: Re: [spring] Request WG adoption for draft-xuclad-spring-sr-service-chaining-01

Hi Xiaohu,

Best regards,
--Bruno

Hi SPRING WG co-chairs,

Best regards,
Xiaohu

Hi SPRING WG co-chairs,

Best regards,

---

From: <[email-masked]>
Date: Fri, 4 May 2018 12:34:27 +0000

[+Martin]

Hello Daniel,

Chairs have initiated the discussion of a proposed charter with our AD. At this stage, I think that Martin would be in the best position to answer your question. However, the process may involve multiple persons and be iterative so my guess is that proposing an ETA is difficult.

That being said, charter update and WG adoption should not be seen as delaying the work.
Authors are encouraged to keep working on the document and engage the discussion with the WG.

Cheers,
--Bruno

From: Bernier, Daniel [mailto:[email-masked]]
Sent: Friday, May 04, 2018 2:15 PM
To: DECRAENE Bruno IMT/OLN; ???(??); SPRING WG List
Subject: Re: [spring] Request WG adoption for draft-xuclad-spring-sr-service-chaining-01

Hello SPRING chairs,

Cheers,

- Dan B

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>

Hi Xiaohu,

Best regards,
--Bruno

Hi SPRING WG co-chairs,

Best regards,
Xiaohu

Hi SPRING WG co-chairs,

Best regards,

Thank you.

---

From: <[email-masked]>
Date: Fri, 4 May 2018 12:39:36 +0000

Dear Martin,

Chairs have discussed this document and we are progressing toward WG adoption call, pending two points which are underway.
That being said, I'm listed as a co-author of this document, so Rob has the lead on this one.

Again, charter update and WG adoption should not be seen as delaying the work.
Authors are encouraged to keep working on the document and engage the discussion with the WG.

Best regards,
--Bruno

 > -----Original Message-----
 > From: Martin Horneffer [mailto:[email-masked]]
 > Sent: Friday, May 04, 2018 10:16 AM
 > To: DECRAENE Bruno IMT/OLN; SPRING WG List; Rob Shakir
 > Subject: status of draft-filsfils-spring-segment-routing-policy-05
 > 
 > Dear chairs and group,
 > 
 > ________________________________________________________________________________
 > _________________________________________
 > >

---

From: Rob Shakir <[email-masked]>
Date: Fri, 04 May 2018 15:09:40 +0000

I'd echo Bruno's comments here, WG adoption should not delay this work.

I would very much like to see some discussion amongst the working group of
how we can scope the documents that are produced relating to SR-TE policy.
It's an area with much interest, and (from the document) a number of
different facets. Today, we have a 50 page RFC that touches on traffic
steering, path calculation, counters/measurement, and use cases -- a
discussion as to whether we need to have this all in one document, or
whether there is a set of complimentary documents that the WG can develop
which make this work more addressable (and prioritises core elements to
reach stability) would be very welcome.

It's also clear that with the number of contributors, this document has
evolved over time -- some editorial work to unify the definitions of
identification (e.g., there are multiple sections that discuss what can
identify a policy - one simply saying a BSID cannot), and validity might be
useful to improve readability and simplify reviews as we move this document
into the WG.

These are not concrete requests that must happen, but this document doesn't
need to be WG adopted to discuss items such as this.

Cheers,
r.

On Fri, May 4, 2018 at 5:39 AM <[email-masked]> wrote:

> Dear Martin,
>
> Chairs have discussed this document and we are progressing toward WG
> adoption call, pending two points which are underway.
>  > >     (
> https://tools.ietf.org/html/draft-xuclad-spring-sr-service-chaining-01)
>  > > Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou
>  > privilegiees et ne doivent donc
>  > > pas etre diffuses, exploites ou copies sans autorisation. Si vous
> avez recu ce message par
>  > erreur, veuillez le signaler
>  > > a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant
>  > susceptibles d'alteration,
>  > > This message and its attachments may contain confidential or
> privileged information that may be
>  > protected by law;
>  > > If you have received this email in error, please notify the sender
> and delete this message and its
>  > attachments.
>  > > As emails may be altered, Orange is not liable for messages that have
> been modified, changed
>  > or falsified.
>  > > Thank you.
>  > >
>  > >
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;