Subject: [spring] [Editorial Errata Reported] RFC7855 (5384)

From: RFC Errata System <[email-masked]>
Date: Fri, 8 Jun 2018 01:11:00 -0700 (PDT)

The following errata report has been submitted for RFC7855,
"Source Packet Routing in Networking (SPRING) Problem Statement and Requirements".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5384

--------------------------------------
Type: Editorial
Reported by: James Bensley <[email-masked]>

Section: 3.3.1.1.1

Original Text
-------------
      C1k has a link to C2j iff k = j.

         The core nodes of a given region are directly connected.
         Inter-region links only connect core nodes of the same plane.

      {C1k has a link to C1j} iff {C2k has a link to C2j}.

Corrected Text
--------------
      C1k has a link to C2j if k = j.

         The core nodes of a given region are directly connected.
         Inter-region links only connect core nodes of the same plane.

      {C1k has a link to C1j} if {C2k has a link to C2j}.

Notes
-----
Does "iff" mean something special that is different to "if" or is this a typo? If the former, should it be called out in a glossary?

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7855 (draft-ietf-spring-problem-statement-08)
--------------------------------------
Title               : Source Packet Routing in Networking (SPRING) Problem Statement and Requirements
Publication Date    : May 2016
Author(s)           : S. Previdi, Ed., C. Filsfils, Ed., B. Decraene, S. Litkowski, M. Horneffer, R. Shakir
Category            : INFORMATIONAL
Source              : Source Packet Routing in Networking
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 8 Jun 2018 09:58:19 +0100

James,

I believe "iff" was intended as written.

https://en.wikipedia.org/wiki/If_and_only_if

Adrian

> -----Original Message-----
> From: spring [mailto:[email-masked]] On Behalf Of RFC Errata System
> Sent: 08 June 2018 09:11
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [spring] [Editorial Errata Reported] RFC7855 (5384)
> 
> Does "iff" mean something special that is different to "if" or is this a typo?
If the
> former, should it be called out in a glossary?
> 
> Instructions:
> -------------
> Title               : Source Packet Routing in Networking (SPRING) Problem
Statement
> and Requirements
> Author(s)           : S. Previdi, Ed., C. Filsfils, Ed., B. Decraene, S.
Litkowski, M.
> Horneffer, R. Shakir
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: James Bensley <[email-masked]>
Date: Mon, 18 Jun 2018 08:30:19 +0100

> https://en.wikipedia.org/wiki/If_and_only_if

Hi Adrian,

That seems like a handy acronym and I'm not against it's use. I'm just
questioning how commonly used it is in networking circles and thus,
whether this document should have a glossary or not? After a quick
scan of "recent" RFCs it's not in common use (only one other RFC apart
from this one);

$ for i in `seq 5000 8500`; do wget
"https://www.rfc-editor.org/rfc/rfc$i.txt"; done

$ grep " iff " *.txt | awk '{print $1}' | uniq
rfc7242.txt:
rfc7855.txt:

Cheers,
James.

---

From: Rob Shakir <[email-masked]>
Date: Mon, 18 Jun 2018 07:19:27 -0700

iff is common language in most technical/academic documentation I believe.
Whilst I am sympathetic to wanting to ensure that RFCs are as easy to parse
as possible for as wide an audience as possible I think that we have to
have some level at which we assume the reader can refer to external
references should they not be familiar with the terminology used. The RFC
Editor team is good at keeping authors honest around this bar.

James - I would encourage you to review the documents that are in last call
in the working group for these kinds of clarifications if you have time
please. Making these edits before we cut an RFC is preferable.

Thanks!
r.

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 19 Jun 2018 07:49:00 +0000

I concur with Rob.
And here is a reference to the Merriam-Webster dictionary<https://www.merriam-webster.com/dictionary/iff> that defines the term.
As opposed to some other abbreviations, it is, AFAIK, quite unambiguous.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: spring [mailto:[email-masked]] On Behalf Of Rob Shakir
Sent: Monday, June 18, 2018 5:19 PM
To: James Bensley <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]>; Alvaro Retana <[email-masked]>; [email-masked]> <[email-masked] <[email-masked]>; [email-masked]; [email-masked]; Rob Shakir <[email-masked]>; Martin Vigoureux <[email-masked]>
Subject: Re: [spring] [Editorial Errata Reported] RFC7855 (5384)

iff is common language in most technical/academic documentation I believe. Whilst I am sympathetic to wanting to ensure that RFCs are as easy to parse as possible for as wide an audience as possible I think that we have to have some level at which we assume the reader can refer to external references should they not be familiar with the terminology used. The RFC Editor team is good at keeping authors honest around this bar.

James - I would encourage you to review the documents that are in last call in the working group for these kinds of clarifications if you have time please. Making these edits before we cut an RFC is preferable..

Thanks!
r.
On Mon, Jun 18, 2018, 12:30 AM James Bensley <[email-masked]<mailto:[email-masked]>> wrote:

Hi Adrian,

Cheers,
James.

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: James Bensley <[email-masked]>
Date: Tue, 19 Jun 2018 08:52:17 +0100

On 18 June 2018 at 15:19, Rob Shakir <[email-masked]> wrote:
> as possible for as wide an audience as possible I think that we have to have
> some level at which we assume the reader can refer to external references
> should they not be familiar with the terminology used. The RFC Editor team
> is good at keeping authors honest around this bar.
>

On the case - just submitted a minor typo to the authors of
draft-ietf-isis-segment-routing-msd-12, I'm still reading through all
the drafts.

Cheers,
James.