Subject: [spring] [Editorial Errata Reported] RFC8355 (5380)

From: RFC Errata System <[email-masked]>
Date: Wed, 6 Jun 2018 00:21:00 -0700 (PDT)

The following errata report has been submitted for RFC8355,
"Resiliency Use Cases in Source Packet Routing in Networking (SPRING) Networks".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5380

--------------------------------------
Type: Editorial
Reported by: James Bensley <[email-masked]>

Section: 3.2

Original Text
-------------
An alternative protection strategy consists in management-free local
   protection that is aimed at providing a repair for the destination
   based on the shortest path to the destination.

Corrected Text
--------------
An alternative protection strategy exists in management-free local
 protection

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8355 (draft-ietf-spring-resiliency-use-cases-12)
--------------------------------------
Title               : Resiliency Use Cases in Source Packet Routing in Networking (SPRING) Networks
Publication Date    : March 2018
Author(s)           : C. Filsfils, Ed., S. Previdi, Ed., B. Decraene, R. Shakir
Category            : INFORMATIONAL
Source              : Source Packet Routing in Networking
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: James Bensley <[email-masked]>
Date: Wed, 6 Jun 2018 08:53:12 +0100

On 6 June 2018 at 08:21, RFC Errata System <[email-masked]> wrote:
> Original Text
> -------------
> An alternative protection strategy consists in

Alternatively, "consists of", is "in" the wrong preposition here?

Kind regards,
James.

---

From: Rob Shakir <[email-masked]>
Date: Wed, 6 Jun 2018 01:00:10 -0700

Hi James,

Thanks for reporting this.

I think that "consists in" is actually what is meant here. The Cambridge
dictionary
<https://dictionary.cambridge.org/dictionary/english/consist-in-sth> definition
is a useful reference.

IMHO, the intention of this sentence is to say that the important/necessary
characteristic of the alternate strategy is that it provides protection
along the shortest path. This might not be the most common English, but it
does seem to be correct.

The RFC Editor folks are likely to be the experts here -- I'd welcome their
comment too.

Thanks,
r.

---

From: Megan Ferguson <[email-masked]>
Date: Wed, 6 Jun 2018 09:39:11 -0700

Hi Rob and James,

Regarding “consist in”:

While this construction appears in past RFCs and is not incorrect, we find a number of readers are not 
familiar with it and think that an error exists.  We would not update text that uses it appropriately;
however, the familiarity issue may be something to keep in mind for future writing.

Please let us know if we can be of further assistance.

RFC Editor/mf

On Jun 6, 2018, at 1:00 AM, Rob Shakir <[email-masked]> wrote:

> I think that "consists in" is actually what is meant here. The Cambridge dictionary definition is a useful reference.
> 
> IMHO, the intention of this sentence is to say that the important/necessary characteristic of the alternate strategy is that it provides protection along the shortest path. This might not be the most common English, but it does seem to be correct.
> 
> The RFC Editor folks are likely to be the experts here -- I'd welcome their comment too.
> 
> Thanks,
> r.
>

---

From: James Bensley <[email-masked]>
Date: Thu, 7 Jun 2018 15:51:34 +0100

Hi Megan, Rob,

Thank you both for your responses. This does indeed seem valid English
syntax however, it doesn't seem to be used much in common parlance.

Apologies for the noise.

Also, last sentence of RFC7855 on page 3:

   Hence, the policy is instantiated in the packet header and does not
   requires any policy state in midpoints and tail-ends.

"require" ?

Kind regards,
James.

---

From: Megan Ferguson <[email-masked]>
Date: Thu, 7 Jun 2018 23:52:35 -0700

Hi James,

Yes - looks like a legitimate error/typo.  Feel free to submit an editorial errata report and we can verify it.

RFC Editor/mf