Subject: Re: [spring] [ippm] New Draft draft-gandhi-spring-udp-pm

From: Greg Mirsky <[email-masked]>
Date: Tue, 17 Jul 2018 12:30:31 -0700

Hi Rakesh,
thank you for bringing this draft up for discussion. There was not enough
time to ask questions at the SPRING WG meeting and this is a very good
opportunity.
I understand that you've proposed to use RFC 6374 to encode PM operations
and measurements. Also, you've referenced work on OWAMP and TWAMP. But I
don't find any reference to STAMP
<https://tools.ietf.org/html/draft-ietf-ippm-stamp-01>in the draft. How
would you position STAMP, its optional extensions
<https://tools.ietf.org/html/draft-mirsky-ippm-stamp-option-tlv-01>, and YANG
model <https://tools.ietf.org/html/draft-ietf-ippm-stamp-yang-01> in
comparison with your new draft?

Regards,
Greg

On Tue, Jul 17, 2018 at 6:57 AM, Rakesh Gandhi (rgandhi) <
rgandhi=[email-masked]> wrote:

> Hi WG,
>
>
>
> We like to introduce following new draft that was presented to SPRING WG
> yesterday.
>
>
>
> This draft defines IP/UDP path for sending probe query messages for delay
> and loss measurement that is agnostics to data plane (SR-MPLS/SRv6/IP) and
> does not require to bootstrap PM session.
>
>
>
> https://datatracker.ietf.org/doc/draft-gandhi-spring-udp-pm/
>
>
>
> You may find presentation in the following package (it is the second
> draft).
>
>
>
> https://datatracker.ietf.org/meeting/102/materials/slides-
> 102-spring-13-performance-measurement-in-sr-networks-00
>
>
>
> We welcome your comments and suggestions.
>
>
>
> Thanks,
>
> Rakesh (On behalf of authors and contributors)
>
>
>
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>
>

---

From: Mach Chen <[email-masked]>
Date: Tue, 24 Jul 2018 03:31:38 +0000

Hi Authors,

The draft-gandhi-spring-udp-pm-01 defines a new C flag as following:

3.1.2.1.  Loss Measurement Flags

   An LM message carries Data Format Flags (DFlags) as defined in
   [RFC6374].  New Flag is defined in this document for Color (C) in the
   DFlags field as follows.

                              +-+-+-+-+
                              |X|B|C|0|
                              +-+-+-+-+

                          Data Format Flags

   The Flag C indicates the Color of the counters in the LM probe
   message [RFC6374] when using Alternate-Marking method defined in
   [RFC8321].
-------------

As defined in Section 4.2 of [RFC8321], could you consider to define more than one flag or a TLV to carry Block number instead?

Best regards,
Mach

From: ippm [mailto:[email-masked]] On Behalf Of Rakesh Gandhi (rgandhi)
Sent: Tuesday, July 17, 2018 9:57 PM
To: [email-masked]
Subject: [ippm] New Draft draft-gandhi-spring-udp-pm

Hi WG,

We like to introduce following new draft that was presented to SPRING WG yesterday.

This draft defines IP/UDP path for sending probe query messages for delay and loss measurement that is agnostics to data plane (SR-MPLS/SRv6/IP) and does not require to bootstrap PM session.

You may find presentation in the following package (it is the second draft).

https://datatracker.ietf.org/meeting/102/materials/slides-102-spring-13-performance-measurement-in-sr-networks-00

Thanks,