Subject: [spring] Nesting of Path Segments

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 18 Jul 2018 09:13:09 +0000

Dear authors of the Path Segment in SR-MPLS<https://tools.ietf.org/html/draft-cheng-spring-mpls-path-segment-02> draft,

My colleagues and I have a question about possibility of nesting of path segments in SR LSPs.

One relevant use case is shown in the embedded diagram below. It shows a network comprised of 3 domains and a bi-directional SR-TE path that crosses these domains and is comprised of bi-directional SR-TE LSPs in each of these domains.

It is not clear to us whether such constructs are in our out of scope of the draft, because it states in Section 2.1:

   When Path Segment is used, a Path label MUST be inserted at the ingress node
   and MUST immediately follow the last label of the SR path.

This seems to suggest that only one Path label will be iserted by the ingress node.

Your timely feedback would be highly appreciated.

Regards, and lots of thanks in advance,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 18 Jul 2018 11:52:14 +0000

Sorry, found some typos in the diagram.
Corrected diagram can be found below.
Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

From: Alexander Vainshtein
Sent: Wednesday, July 18, 2018 1:07 PM
To: [email-masked]' <[email-masked]>
Cc: Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Ron Sdayoor ([email-masked]) <[email-masked]>; Rotem Cohen ([email-masked]) <[email-masked]>; [email-masked]' <[email-masked]>
Subject: RE: Nesting of Path Segments

Dear all,
After sending my previous email I've noticed that label stacks in the diagram can be somewhat reduced if X-to-Y BSID would refer to combined X-to-Y path + X-to-Y Path SID and the same for Y-to-Z. The modified diagram is shown below. In addition to compression it also fixes a (Y-to-X Path SID added in the last stack).

However, even with the modified diagram, A would have to insert both A-to-Z Path SID and A-to-X Path SIDs in the stack, and Z would have to handle both Y-to-Z and A-to-Z Path SIDs on receive. (OAM packets for Y-to-Z path would not include A-to-Z Path SID, of course).

Such a scheme, if allowed, could be used, e.g., for monitoring packet loss (or delay) not just end-to-end but also on each separate sub-path.

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]<mailto:[email-masked]>

From: Alexander Vainshtein
Sent: Wednesday, July 18, 2018 12:13 PM
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>
Cc: Shell Nakash <[email-masked]<mailto:[email-masked]>>; Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>; Ron Sdayoor ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; Rotem Cohen ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Nesting of Path Segments

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]<mailto:[email-masked]>

---

From: 程伟强<[email-masked]>
Date: 18 Jul 2018 20:01:29 +0800

Hi Sasha,

Thanks a lot for your comments. 

It is very valuable to add the nesting of path segment solution.

We can add some content about it in next version. 

B.R.

Weiqiang Cheng

发件人: Alexander Vainshtein

时间: 2018/07/18(星期三)19:52

收件人: draft-cheng-spring-mpls-path-segment.authors;

抄送人: Shell Nakash;Michael Gorokhovsky;Ron Sdayoor;Rotem Cohen;spring;

主题: RE: Nesting of Path Segments 

 

Regards, 

Sasha 

Office: +972-39266302 

Cell:      +972-549266302 

 

Dear all, 

After sending my previous email I’ve noticed that label stacks in the diagram can be somewhat reduced if X-to-Y BSID would refer to combined X-to-Y path + X-to-Y Path SID and the same for Y-to-Z. The modified  diagram is shown below. In addition to compression it also fixes a (Y-to-X Path SID added in the last stack). 

 

Sasha 

Office: +972-39266302 

Cell:      +972-549266302 

 

 Cc: Shell Nakash <[email-masked]>; Michael Gorokhovsky <[email-masked]>; Ron Sdayoor ([email-masked])  <[email-masked]>; Rotem Cohen ([email-masked]) <[email-masked]>; [email-masked]

Dear authors of the  Path Segment in SR-MPLS draft, 

 

Sasha 

Office: +972-39266302 

Cell:      +972-549266302