Subject: [spring] Will CSPF be affected by ISIS Overload bit ...?

From: Girish Pattanaik <[email-masked]>
Date: Wed, 19 Dec 2018 23:41:31 +0530

Hi All,

My self Girish Pattanaik, am working as a Techlead in IPI India.

As we know Today, the use cases of the O bit in ISIS have evolved beyond
its original meaning and intention. Its widely used by administrators .As
per understanding setting overload bit on transit  will only affect the SPF
calculation on head end,

So now point is, will it also affect the *CSPF* calculation?, And if not
then how will we handle this overload bit  scenario for CSPF.?

I didn’t find this any such scenario has mentioned  in your current draft,
so mailing you to get the appropriate answer for this.

*Cheers!!*

*Girish Pattanaik*

-- 
.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 19 Dec 2018 22:34:13 +0100

Girish,

Overload bit or max metric router LSA indicate that given node should be
removed from topology calculations so by default it applies to both SFP and
constrained SPF.

However some vendors have knobs to still allow such nodes to be included
into CSPF if you configure so explicitly.

Example: mpls traffic-eng path-selection overload allow
<https://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/fs_isovr.html#wp1032917>

So IMO by default you should not consider this transit router for both SPF
& CSPF, but it will rather not be set hard in stone in the draft/RFC as
there are obviously use cases to allow to override this default behavior.

Thx
R.

On Wed, Dec 19, 2018 at 10:23 PM Girish Pattanaik <
[email-masked]> wrote:

> .._______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Girish Pattanaik <[email-masked]>
Date: Thu, 20 Dec 2018 18:57:30 +0530

Thanks a lot Robert,

Cheers!!

Girish Pattanaik

*From:* Robert Raszuk [mailto:[email-masked]]
*Sent:* Thursday, December 20, 2018 3:04 AM
*To:* Girish Pattanaik
*Cc:* SPRING WG List
*Subject:* Re: [spring] Will CSPF be affected by ISIS Overload bit ...?

Girish,

Example: *mpls traffic-eng path-selection overload allow
<https://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/fs_isovr.html#wp1032917>*

Thx
R.

Hi All,

*Cheers!!*

*Girish Pattanaik*

-- 
.

---

From: <[email-masked]>
Date: Thu, 27 Dec 2018 08:43:33 +0000

Hi,

Speaking as a big user of OL bit for ops and design purpose, yes CSPF needs to take it into account.

Brgds,

From: spring [mailto:[email-masked]] On Behalf Of Girish Pattanaik
Sent: Wednesday, December 19, 2018 19:12
To: [email-masked]
Cc: Girish Pattanaik
Subject: [spring] Will CSPF be affected by ISIS Overload bit ...?

Hi All,

As we know Today, the use cases of the O bit in ISIS have evolved beyond its original meaning and intention. Its widely used by administrators .As per understanding setting overload bit on transit  will only affect the SPF calculation on head end,
So now point is, will it also affect the CSPF calculation?, And if not then how will we handle this overload bit  scenario for CSPF.?

I didn’t find this any such scenario has mentioned  in your current draft, so mailing you to get the appropriate answer for this.

Cheers!!
Girish Pattanaik

..

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.