Subject: [spring] draft-gandhi-spring-rfc6374-srpm-mpls return path

From: Stewart Bryant <[email-masked]>
Date: Thu, 14 Feb 2019 14:43:41 +0000

I am not quite sure what it means to do a two way path measurement in 
MPLS SR since MPLS SR defines a per packet unidirectional path. However, 
assuming that this makes sense,  I don't see how the return path 
information is carried in the RFC6374 message. The draft does not ask 
IANA for any new types. Now it has been a long time since we wrote 
RFC6374, but I don't remember the design having the capability you require.

Please could clarify how the return path operates in an MPLS SR environment?

Best Regards

- Stewart

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Fri, 22 Feb 2019 22:37:13 +0000

Hi Stewart,

Thanks for your comments.

There is a companion draft where this TLV is defined. We can add reference/text to indicate this.
https://tools.ietf.org/html/draft-gandhi-spring-rfc6374-srpm-udp-00#section-3.2.3.1

Hope this answers your question.

Thanks,
Rakesh

On 2019-02-14, 9:43 AM, "spring on behalf of Stewart Bryant" <[email-masked] on behalf of [email-masked]> wrote:

    
    Best Regards
    
    - Stewart
    
    _______________________________________________
    spring mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spring

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Feb 2019 12:24:53 +0000

Hi Rakesh

Yes, that reference would be useful.

- Stewart