Subject: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

From: <[email-masked]>
Date: Wed, 20 Feb 2019 09:03:35 +0000

Hi SPRING WG,

This email initiates a two week call for working group adoption for draft-cheng-spring-mpls-path-segment.

Please indicate your support, comments, or objection, for adopting this draft as a working group item by March 6th 2019.
We are particularly interested in hearing from working group members that are not co-authors of this draft.
We are also looking for volunteers who would be ready to perform a technical review of this work at some later stage, such as before or during WG the last call.

Additionally, there are currently 7 authors listed on this document. Please trim this to <= 5 front-page authors, utilising a "Contributors" section if required for the others. An approach to achieving this would be to list ~2 editors as the front-page authors.

In parallel to this adoption call, I will send an IPR call for this document. We will need all authors and contributors to confirm their IPR position on this document.

(1) https://tools.ietf.org/html/draft-cheng-spring-mpls-path-segment

Thanks,
--Bruno & Rob.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Wed, 20 Feb 2019 11:51:32 +0000

To answer a question, the emails previously sent on the mailing list over a week ago will be considered as part of the adoption call.

That being said, if you are a non-author and your previous support is strong enough to be willing to improve the document, you are very welcome to volunteer to perform a _technical_ review of this draft at some later stage, such as before or during WG the last call.

Thanks,
--Bruno
-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, February 20, 2019 10:04 AM
To: SPRING WG
Cc: [email-masked]
Subject: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

Thanks,
--Bruno & Rob.

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: stefano previdi <[email-masked]>
Date: Mon, 25 Feb 2019 10:13:24 +0100

I support the adoption of this draft as WG item.

Thanks.
s.

> On Feb 20, 2019, at 10:03 AM, [email-masked] wrote:
> 
> Hi SPRING WG,
>

---

From: "徐小虎(义先)" <[email-masked]>
Date: Mon, 25 Feb 2019 17:25:14 +0800

I support the adoption of this draft.

Xiaohu

------------------------------------------------------------------
From:bruno.decraene <[email-masked]>
Send Time:2019年2月20日(星期三) 17:03
To:SPRING WG <[email-masked]>
Cc:[email-masked] <[email-masked]>
Subject:[spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

Thanks,
--Bruno & Rob.

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 25 Feb 2019 08:50:50 -0800

Hi,

The draft defines useful functionality however doesn’t talk about implications wrt MSD (RFC8491/8476)
PSID is an additional label in the stack, it has implications to the MSD signaling, PCE computation, what happens when egress expects PSID but ingress can’t impose one and similar cases.

I support the adoption.

Cheers,
Jeff

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 25 Feb 2019 09:14:04 -0800

Hi Bruno, Authors, et al.,
I support the adoption of the document by SPRING WG.
I've made comments to the draft and will share the text addressing them
before the week's end.

Regards,
Greg

On Wed, Feb 20, 2019 at 1:03 AM <[email-masked]> wrote:

> Please indicate your support, comments, or objection, for adopting this
> draft as a working group item by March 6th 2019.
> We are also looking for volunteers who would be ready to perform a
> technical review of this work at some later stage, such as before or during
> WG the last call.
>
> Additionally, there are currently 7 authors listed on this document.
> Please trim this to <= 5 front-page authors, utilising a "Contributors"
> section if required for the others. An approach to achieving this would be
> to list ~2 editors as the front-page authors.
>
> In parallel to this adoption call, I will send an IPR call for this
> document. We will need all authors and contributors to confirm their IPR
> position on this document.
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: Mach Chen <[email-masked]>
Date: Tue, 26 Feb 2019 02:50:20 +0000

Hi Jeff,

Thanks for your support and the comments!

The comments will be addressed in future version.

Best regards,
Mach

From: Jeff Tantsura [mailto:[email-masked]]
Sent: Tuesday, February 26, 2019 12:51 AM
To: SPRING WG <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi,

I support the adoption.

Cheers,
Jeff
On Feb 20, 2019, 1:03 AM -0800, [email-masked]<mailto:[email-masked]>, wrote:

Hi SPRING WG,

Thanks,
--Bruno & Rob.

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 26 Feb 2019 21:23:30 -0000

Bruno, all,

I didn't pay much attention to this work when it first came out, but looking
more closely now, I think there is a useful function described here.

Obviously there is some polish needed, but that's OK at this stage in the
process and doesn't stop adoption.

I support the WG picking this up.

Adrian

-----Original Message-----
From: spring <[email-masked]> On Behalf Of
[email-masked]
Sent: 20 February 2019 11:52
To: SPRING WG <[email-masked]>
Subject: Re: [spring] Working Group Adoption Call for
draft-cheng-spring-mpls-path-segment

To answer a question, the emails previously sent on the mailing list over a
week ago will be considered as part of the adoption call.

That being said, if you are a non-author and your previous support is strong
enough to be willing to improve the document, you are very welcome to
volunteer to perform a _technical_ review of this draft at some later stage,
such as before or during WG the last call.

Thanks,
--Bruno
-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, February 20, 2019 10:04 AM
To: SPRING WG
Cc: [email-masked]
Subject: [spring] Working Group Adoption Call for
draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

This email initiates a two week call for working group adoption for
draft-cheng-spring-mpls-path-segment.

Please indicate your support, comments, or objection, for adopting this
draft as a working group item by March 6th 2019.
We are particularly interested in hearing from working group members that
are not co-authors of this draft.
We are also looking for volunteers who would be ready to perform a technical
review of this work at some later stage, such as before or during WG the
last call.

Additionally, there are currently 7 authors listed on this document. Please
trim this to <= 5 front-page authors, utilising a "Contributors" section if
required for the others. An approach to achieving this would be to list ~2
editors as the front-page authors.

Thanks,
--Bruno & Rob.

____________________________________________________________________________
_____________________________________________

Ce message et ses pieces jointes peuvent contenir des informations
confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou
falsifie. Merci.

This message and its attachments may contain confidential or privileged
information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and
delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been
modified, changed or falsified.
Thank you.

____________________________________________________________________________
_____________________________________________

Ce message et ses pieces jointes peuvent contenir des informations
confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou
falsifie. Merci.

This message and its attachments may contain confidential or privileged
information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and
delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been
modified, changed or falsified.
Thank you.

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 27 Feb 2019 04:20:21 +0000

Hello,

I support the adoption of this draft by the WG. I have some comments which I would like to bring to the author's and WG though - some of these were raised when this draft was presented in Bangkok but I don't see them addressed as yet.

1) Sec 2.
A Path Segment is a single label that is assigned from the Segment
   Routing Local Block (SRLB) or Segment Routing Global Block (SRGB) of
   the egress node of an SR path.

KT> Why can't the Path Segment be allocated from the dynamic MPLS label pool on the egress node? Can this be added as discussed in Bangkok? This mode would help achieve a good scalability for SR Policies along with the option of using SRLB. On the other hand, I do not understand the use-case for allocating Path Segments from the SRGB. If there is none, do we want to preclude SRGB usage for Path Segments?

2) Can the authors clarify on the relationship and usage of Path Segment with Entropy label (https://tools.ietf.org/html/draft-ietf-mpls-spring-entropy-label-12)? There are examples of nested segments. Similarly, the draft could use some text to discuss the MSD capabilities of the headend when enabling path segment usage.

3) This seems SR/MPLS specific to me. Is that correct? If so, why put reference to SRv6 documents in there as that would create confusion?

Thanks,
Ketan

-----Original Message-----
From: spring <[email-masked]> On Behalf Of [email-masked]
Sent: 20 February 2019 14:34
To: SPRING WG <[email-masked]>
Cc: [email-masked]
Subject: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

Thanks,
--Bruno & Rob.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.