Subject: [spring] draft-filsfils-spring-srv6-network-programming

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Thu, 14 Feb 2019 08:55:54 +0000

Dear Spring,

We have submitted a new revision of draft-filsfils-spring-srv6-network-programming. There are several minor updates to the document, mainly addressing ICMP and having better alignment with SRH draft. Also, based on WG feedback, we have split the document moving the illustrations into a new informational draft.
As always, any feedback or question is more than welcome.
https://datatracker.ietf.org/doc/draft-filsfils-spring-srv6-network-programming/
https://datatracker.ietf.org/doc/draft-filsfils-spring-srv6-net-pgm-illustration/

We believe that the content of both drafts is mature and has been stable since the first revision in March 2017. We are tracking several opensource and vendor proprietary implementations. Some of these have actually participated in a public interop more than a year ago.
For these reasons we believe that both documents are ready to progress and be adopted by the working group.

Thanks,
Pablo (on behalf of authors&contributors)

Subject: New Version Notification for draft-filsfils-spring-srv6-network-programming-07.txt
From: <[email-masked]>
To: Satoru Matsushima <[email-masked]>, "Pablo Camarillo Garvia" <[email-masked]>, John Leddy <[email-masked]>, " [email-masked]" <[email-masked]>, Pablo Camarillo <[email-masked]>, Clarence Filsfils <[email-masked]>, Daniel Voyer <[email-masked]>, Zhenbin Li <[email-masked]>
Date: Thu, 14 Feb 2019 00:40:09 -0800

A new version of I-D, draft-filsfils-spring-srv6-network-programming-07.txt
has been successfully submitted by Pablo Camarillo and posted to the
IETF repository.

Name:		draft-filsfils-spring-srv6-network-programming
Revision:	07
Title:		SRv6 Network Programming
Document date:	2019-02-14
Group:		Individual Submission
Pages:		42
URL:            https://www.ietf.org/internet-drafts/draft-filsfils-spring-srv6-network-programming-07.txt
Status:         https://datatracker.ietf.org/doc/draft-filsfils-spring-srv6-network-programming/
Htmlized:       https://tools.ietf.org/html/draft-filsfils-spring-srv6-network-programming-07
Htmlized:       https://datatracker.ietf.org/doc/html/draft-filsfils-spring-srv6-network-programming
Diff:           https://www.ietf.org/rfcdiff?url2=draft-filsfils-spring-srv6-network-programming-07

Abstract:
   This document describes the SRv6 network programming concept and its
   most basic functions.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

Subject: New Version Notification for draft-filsfils-spring-srv6-net-pgm-illustration-00.txt
From: <[email-masked]>
To: Zhenbin Li <[email-masked]>, Robert Raszuk <[email-masked]>, David Lebrun <[email-masked]>, Bruno Decraene <[email-masked]>, Pablo Camarillo Garvia <[email-masked]>, John Leddy <[email-masked]>, Dirk Steinberg <[email-masked]>, Pablo Camarillo <[email-masked]>, "Clarence Filsfils" <[email-masked]>, Satoru Matsushima <[email-masked]>
Date: Thu, 14 Feb 2019 00:38:16 -0800

A new version of I-D, draft-filsfils-spring-srv6-net-pgm-illustration-00.txt
has been successfully submitted by Pablo Camarillo and posted to the
IETF repository.

Name:		draft-filsfils-spring-srv6-net-pgm-illustration
Revision:	00
Title:		Illustrations for SRv6 Network Programming
Document date:	2019-02-14
Group:		Individual Submission
Pages:		23
URL:            https://www.ietf.org/internet-drafts/draft-filsfils-spring-srv6-net-pgm-illustration-00.txt
Status:         https://datatracker.ietf.org/doc/draft-filsfils-spring-srv6-net-pgm-illustration/
Htmlized:       https://tools.ietf.org/html/draft-filsfils-spring-srv6-net-pgm-illustration-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-filsfils-spring-srv6-net-pgm-illustration

Abstract:
   This document illustrates how SRv6 Network Programming
   [I-D.filsfils-spring-srv6-network-programming] can be used to create
   interoperable and protected overlays with underlay optimization and
   service programming.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 27 Feb 2019 08:31:23 +0000

Support.  The content of these drafts has been stable for a while, I think they are ready to progress.

I have some comments regarding to PSP, USP and USD flavors in draft-filsfils-spring-srv6-network-programming-07.

1:            What is the motivation for introducing the USD flavor?  With USD, then the END, END.T and END.X can be the last SID?

2:            In section-4.1<https://tools.ietf.org/html/draft-filsfils-spring-srv6-network-programming-06#section-4.1> , 4.2 and 4.3, the document says that End, End.X, End.T can not be the last SID of SID list.

                But in section-4.21.2<https://tools.ietf.org/html/draft-filsfils-spring-srv6-network-programming-06#section-4.21.2>, the End, End.X, and End.T can be the last SID when there is another SRH following.

                Even, in that case, the last SID of the SID list MUST be SID of End, End.X, and End.T, correct?

                If End, End.X, End.T can not be the last SID of SID list, then USP of End, End.X, End.T can not work.

So I think the text should be: End, End.X, and End.T SID can be the last SID if (1) it has USD flavor or (2) it has USP flavor while there is another SRH following it.

Thanks,
Cheng

From: spring [mailto:[email-masked]] On Behalf Of Pablo Camarillo (pcamaril)
Sent: Thursday, February 14, 2019 4:56 PM
To: [email-masked]
Subject: [spring] draft-filsfils-spring-srv6-network-programming

Dear Spring,

Thanks,

---

From: Lizhenbin <[email-masked]>
Date: Fri, 1 Mar 2019 03:30:02 +0000

SRv6 network programming is an important work for the network evolution. After refining many times the draft is already stable.
Besides the implementation and inter-op test info proposed, this week it was published that there was already the commercial deployment of SRv6.
Hope the draft can be adopted by the working group as the co-author.

Best Regards,
Zhenbin (Robin)

Dear Spring,

Thanks,