Subject: [spring] How to support OAM on SR networks ?

From: tech_kals Kals <[email-masked]>
Date: Wed, 13 Mar 2019 10:49:34 +0530

Hi experts,

Am so curious to know about how OAM can be supported on segment-routing
networks ?

I think, MPLS OAM is not possible with SR as network infrastructure doesn't
have any LSP state.

With SDN controller in place, do we really need traditional OAM ?

Assume, SDN controller can identify the issue on the network, and it can
configure an alternate path on the defected node.

If SDN controller can do OAM, but at what cost (like BGP-LS) ?

Thanks,

__Kals__

---

From: tech_kals Kals <[email-masked]>
Date: Fri, 15 Mar 2019 10:44:25 +0530

Hi,

Can someone have a look at this issue ?

thanks,
__kals__

On Wed, Mar 13, 2019 at 10:49 AM tech_kals Kals <[email-masked]> wrote:

> I think, MPLS OAM is not possible with SR as network infrastructure
> doesn't have any LSP state.
>
>

---

From: tech_kals Kals <[email-masked]>
Date: Fri, 15 Mar 2019 10:45:36 +0530

please ignore my previous email..

hi,

can someone answer my question please ?

thanks,
kals

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Fri, 15 Mar 2019 05:34:12 +0000

Hi,

Please read https://datatracker.ietf.org/doc/rfc8287/ and https://datatracker.ietf.org/doc/rfc8403/. And they will answer your questions.

Thanks

Regards … Zafar

On Wed, Mar 13, 2019 at 10:49 AM tech_kals Kals <[email-masked]<mailto:[email-masked]>> wrote:
Hi experts,

Am so curious to know about how OAM can be supported on segment-routing networks ?

I think, MPLS OAM is not possible with SR as network infrastructure doesn't have any LSP state.

Assume, SDN controller can identify the issue on the network, and it can configure an alternate path on the defected node.

Thanks,

__Kals__

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 20 Mar 2019 02:05:31 +0000

Hi Kals,

Path Segment can be used for identifying a LSP/SR Path in SR-MPLS networks.

With a path segment, use cases like passive Packet loss measurement, bidirectional path association can be done in SR-MPLS.

You can read the document of Path Segment[1], which becomes a WG document recently.

Basically, a Path Segment is inserted at the bottom of the label stack(as long as it can be read by the egress node).

Also, for easier identifying an SRv6 SID list, SR candidate path, SR policy, an SRv6 Path Segment is proposed in [2]’

Hope my answers help you.

[1]. https://tools.ietf.org/html/draft-ietf-spring-mpls-path-segment-00
[2]. https://tools.ietf.org/html/draft-li-spring-srv6-path-segment-00

Thanks,
Cheng

From: spring [mailto:[email-masked]] On Behalf Of tech_kals Kals
Sent: Friday, March 15, 2019 1:16 PM
To: Stefano Previdi (sprevidi) <[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]>; Ahmed Bashandy (bashandy) <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: Re: [spring] How to support OAM on SR networks ?

hi,

thanks,
kals

On Fri, Mar 15, 2019 at 10:44 AM tech_kals Kals <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

thanks,
__kals__

Thanks,

__Kals__