Subject: Re: [spring] Flow Label in End.DX4 (draft-filsfils-spring-srv6-network-programming-07

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Wed, 6 Mar 2019 09:20:59 +0000

Hi Kentaro,

The pseudocode is correct. The hash is based on the outer IPv6 header (SA, DA, and Flow Label) before popping it.

Thanks,
Pablo.

From: spring <[email-masked]> on behalf of Kentaro Ebisawa <[email-masked]>
Reply-To: Kentaro Ebisawa <[email-masked]>
Date: Thursday, 21 February 2019 at 05:32
To: "[email-masked]" <[email-masked]>
Subject: [spring] Flow Label in End.DX4 (draft-filsfils-spring-srv6-network-programming-07

Hi

In 4.9 End.DX4 (draft-filsfils-spring-srv6-network-programming-07), I noticed it requires Flow Label to be included in the hash in "after" poping IPv6 header.

> 3. ELSE IF ENH = 4 ;; Ref2
> 4. pop the (outer) IPv6 header and its extension headers
> 5. forward to layer-3 adjacency bound to the SID S ;; Ref3
 ...
> Ref3: Selected based on a hash of the packet’s header (at least SA, DA, Flow Label)

Since IPv6 packet is already poped,  I think it might not be appropriate to mandate use of Flow Label in this case but using "identification field" for DX4. (unlike DX6)

Is this intentional or just a typo when copying from DX6?

Thanks,
--
Kentaro Ebisawa <[email-masked]>

---

From: "Kentaro Ebisawa" <[email-masked]>
Date: Sun, 10 Mar 2019 06:24:16 +0000

Hi Pablo,

Why does the hash needs to be based on the outer IPv6 header?

I understand there are some cases using outer IPv6 header (especially 
Flow Label) will be suitable.
But I was not sure why we want to specifically limit the hash fields to 
outer IPv6 in the draft, since there might be some cases you want  to 
use inner IPv4 header fields.

For example, one might want to use DX4 for IPv4 over SRv6 tunnel which 
IPv6 SA/DA would be same for all packets and thus inner IPv4 header 
might have more entropy.

Also, some hardware (ASIC/FPGA) implementation might want to chose using 
inner IPv4 to reduce memory consumption by not keeping the already poped 
outer IPv6 header fields or the hash calculated from it.

------ Original Message ------
From: "Pablo Camarillo (pcamaril)" <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" 
<[email-masked]>
Sent: 2019/03/06 18:20:59
Subject: Re: [spring] Flow Label in End.DX4 
(draft-filsfils-spring-srv6-network-programming-07

>Hi Kentaro,
>
>
>
>The pseudocode is correct. The hash is based on the outer IPv6 header 
>(SA, DA, and Flow Label) before popping it.
>
>
>
>Thanks,
>
>Pablo.
>
>
>
>Subject: [spring] Flow Label in End.DX4 
>(draft-filsfils-spring-srv6-network-programming-07
>
>
>
>Hi
>
>
>
>In 4.9 End.DX4 (draft-filsfils-spring-srv6-network-programming-07), I 
>noticed it requires Flow Label to be included in the hash in "after" 
>poping IPv6 header.
>
>
>
>Since IPv6 packet is already poped,  I think it might not be 
>appropriate to mandate use of Flow Label in this case but using 
>"identification field" for DX4. (unlike DX6)
>
>
>