Subject: Re: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 5 Mar 2019 10:00:04 -0500

Like many others, I also support adoption, this draft is important for
SR-MPLS path protection and PM.

Cheers,
Andy

On Wed, Feb 20, 2019 at 4:03 AM <[email-masked]> wrote:

> Hi SPRING WG,
>
> This email initiates a two week call for working group adoption for
> draft-cheng-spring-mpls-path-segment.
>
> Please indicate your support, comments, or objection, for adopting this
> draft as a working group item by March 6th 2019.
> We are particularly interested in hearing from working group members that
> are not co-authors of this draft.
> We are also looking for volunteers who would be ready to perform a
> technical review of this work at some later stage, such as before or during
> WG the last call.
>
> Additionally, there are currently 7 authors listed on this document.
> Please trim this to <= 5 front-page authors, utilising a "Contributors"
> section if required for the others. An approach to achieving this would be
> to list ~2 editors as the front-page authors.
>
> In parallel to this adoption call, I will send an IPR call for this
> document. We will need all authors and contributors to confirm their IPR
> position on this document.
>
> (1) https://tools.ietf.org/html/draft-cheng-spring-mpls-path-segment
>
> Thanks,
> --Bruno & Rob.
>
>
>
> _________________________________________________________________________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou
> falsifie. Merci.
>
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and
> delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been
> modified, changed or falsified.
> Thank you.
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 6 Mar 2019 10:20:52 +0530

Hi Bruno,

I support adoption of this work in Spring.
This would also give us confidence in progressing the related work in PCE.

Thanks!
Dhruv

---

From: Ron Bonica <[email-masked]>
Date: Wed, 6 Mar 2019 16:44:04 +0000

Support

> -----Original Message-----
> From: spring <[email-masked]> On Behalf Of
> [email-masked]
> Sent: Wednesday, February 20, 2019 4:04 AM
> To: SPRING WG <[email-masked]>
> Cc: [email-masked]
> Subject: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-
> path-segment
> 
> Hi SPRING WG,
> 
> This email initiates a two week call for working group adoption for draft-
> cheng-spring-mpls-path-segment.
> 
> Please indicate your support, comments, or objection, for adopting this draft
> as a working group item by March 6th 2019.
> We are also looking for volunteers who would be ready to perform a technical
> review of this work at some later stage, such as before or during WG the last
> call.
> 
> Additionally, there are currently 7 authors listed on this document. Please trim
> this to <= 5 front-page authors, utilising a "Contributors" section if required
> for the others. An approach to achieving this would be to list ~2 editors as the
> front-page authors.
> 
> In parallel to this adoption call, I will send an IPR call for this document. We will
> need all authors and contributors to confirm their IPR position on this
> document.
> 
> (1) https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dcheng-2Dspring-2Dmpls-2Dpath-
> 2Dsegment&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-
> AWF2EfpHcAwrDThKP8&m=N-
> 0aFLKosQHXcxirzbKvWFVlauAxjdB7xFOGfBho_KQ&s=CWg2Oifuuf6Ge1tnfD2
> DaCyloRAnwYG3dvTAxYbVjB4&e=
> 
> Thanks,
> --Bruno & Rob.
> 
> 
> ___________________________________________________________
> ___________________________________________________________
> ___
> 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou
> copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le
> signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this
> message and its attachments.
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_spring&d=DwICAg&c=HAkYuh63rsuhr6
> Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-
> AWF2EfpHcAwrDThKP8&m=N-
> 0aFLKosQHXcxirzbKvWFVlauAxjdB7xFOGfBho_KQ&s=_kVbWxhqpObsc-Zp-
> XA9-cIeNekDSxDBplvQIL884ik&e=

---

From: Shraddha Hegde <[email-masked]>
Date: Thu, 7 Mar 2019 00:26:22 +0000

Path segment has multiple useful use cases.
I support the WG adoption of this draft.

Few comments
1. The fact that service labels appear below path-segment should be clearly mentioned.
At the egress, multiple labels may have to be looked-up and popped for UHP cases. This may need
special hardware capability. This egress processing needs to be explained in the draft.

2. The ability to have a globally significant path-ID representation is very useful
for various accounting purposes. I believe, we should continue to have globally scoped
path-segment.

3. The path-segment should be pushed in a packet only when egress is capable of 
processing the path-segment. This aspect needs to be explained in this draft.

Rgds
Shraddha

-----Original Message-----
From: spring <[email-masked]> On Behalf Of [email-masked]
Sent: Wednesday, February 20, 2019 2:34 PM
To: SPRING WG <[email-masked]>
Cc: [email-masked]
Subject: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

This email initiates a two week call for working group adoption for draft-cheng-spring-mpls-path-segment.

Please indicate your support, comments, or objection, for adopting this draft as a working group item by March 6th 2019.
We are particularly interested in hearing from working group members that are not co-authors of this draft.
We are also looking for volunteers who would be ready to perform a technical review of this work at some later stage, such as before or during WG the last call.

Additionally, there are currently 7 authors listed on this document. Please trim this to <= 5 front-page authors, utilising a "Contributors" section if required for the others. An approach to achieving this would be to list ~2 editors as the front-page authors.

In parallel to this adoption call, I will send an IPR call for this document. We will need all authors and contributors to confirm their IPR position on this document.

(1) https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dcheng-2Dspring-2Dmpls-2Dpath-2Dsegment&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=fghPD_5Ecs8TYVskFZ0y6Npv0QXqX0-pLlGysClTjls&s=z8A_nYKmKXm0-42sVmn6BDxD3rSl6dJUudnCulEvofk&e=

Thanks,
--Bruno & Rob.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
spring mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_spring&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=fghPD_5Ecs8TYVskFZ0y6Npv0QXqX0-pLlGysClTjls&s=lf5L9lWYG4dgqnmDcTGYmbZd8iu-r73dEq-0IOsnaq8&e=

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Thu, 7 Mar 2019 08:35:15 +0000

Hi Ketan, 

Thank you for your support and comments, please see my reply inline.

Regards,
Cheng

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Ketan Talaulikar (ketant)
Sent: Wednesday, February 27, 2019 12:20 PM
To: [email-masked]; SPRING WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hello,

I support the adoption of this draft by the WG. I have some comments which I would like to bring to the author's and WG though - some of these were raised when this draft was presented in Bangkok but I don't see them addressed as yet.

1) Sec 2.
A Path Segment is a single label that is assigned from the Segment
   Routing Local Block (SRLB) or Segment Routing Global Block (SRGB) of
   the egress node of an SR path.

KT> Why can't the Path Segment be allocated from the dynamic MPLS label pool on the egress node? Can this be added as discussed in Bangkok? This mode would help achieve a good scalability for SR Policies along with the option of using SRLB. On the other hand, I do not understand the use-case for allocating Path Segments from the SRGB. If there is none, do we want to preclude SRGB usage for Path Segments?

[Cheng] Yes, path segment can be allocated from dynamic MPLS lable pool as we answered you at Bangkok. We will add text to specify that. Regarding SRGB, We won't suggest to allocate path segment from SRGB due to scalability consideration, but we don't stop people to do that.

2) Can the authors clarify on the relationship and usage of Path Segment with Entropy label (https://tools.ietf.org/html/draft-ietf-mpls-spring-entropy-label-12)? There are examples of nested segments. Similarly, the draft could use some text to discuss the MSD capabilities of the headend when enabling path segment usage.

[Cheng] Regarding EL, I think it can be pushed before or after path segment, it does not matter. But we would suggest to place path segment before EL.
Only need to make sure that path segment to be read by the egress node.
Thus, it should be placed after the "routing segment（adj/node/prefix）" pointing to the egress node.

Thanks, will add text to describe MSD.

3) This seems SR/MPLS specific to me. Is that correct? If so, why put reference to SRv6 documents in there as that would create confusion?
[Cheng] Correct, will delete those references.

Thanks,
Ketan

-----Original Message-----
From: spring <[email-masked]> On Behalf Of [email-masked]
Sent: 20 February 2019 14:34
To: SPRING WG <[email-masked]>
Cc: [email-masked]
Subject: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

Thanks,
--Bruno & Rob.

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 7 Mar 2019 11:01:47 +0000

Thanks Cheng for your clarifications.

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Chengli (Cheng Li)
Sent: 07 March 2019 14:05
To: Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]; SPRING WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi Ketan, 

Regards,
Cheng

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Ketan Talaulikar (ketant)
Sent: Wednesday, February 27, 2019 12:20 PM
To: [email-masked]; SPRING WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hello,

1) Sec 2.

Thanks,
Ketan

-----Original Message-----
From: spring <[email-masked]> On Behalf Of [email-masked]
Sent: 20 February 2019 14:34
To: SPRING WG <[email-masked]>
Cc: [email-masked]
Subject: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

Thanks,
--Bruno & Rob.

---

From: <[email-masked]>
Date: Thu, 7 Mar 2019 12:25:32 +0000

Hi authors, WG,

draft-cheng-spring-mpls-path-segment has been accepted as a WG document.
Please republish as draft-ietf-spring-mpls-path-segment with no more than 5 front-page authors.

As this is now a WG document, please engage discussions to resolve past and future comments and update the document accordingly.

Thanks,
--Bruno & Rob.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, February 20, 2019 10:04 AM
To: SPRING WG
Cc: [email-masked]
Subject: [spring] Working Group Adoption Call for draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

Thanks,
--Bruno & Rob.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Thu, 7 Mar 2019 21:24:36 +0800

Thanks a lot.
We will generate a new version with no more than 5 front-page authors.

B.R.
Weiqiang Cheng

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2019年3月7日 20:26
收件人: [email-masked]
抄送: SPRING WG
主题: RE: Working Group Adoption Call for
draft-cheng-spring-mpls-path-segment

Hi authors, WG,

draft-cheng-spring-mpls-path-segment has been accepted as a WG document.
Please republish as draft-ietf-spring-mpls-path-segment with no more than 5
front-page authors.

As this is now a WG document, please engage discussions to resolve past and
future comments and update the document accordingly.

Thanks,
--Bruno & Rob.

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, February 20, 2019 10:04 AM
To: SPRING WG
Cc: [email-masked]
Subject: [spring] Working Group Adoption Call for
draft-cheng-spring-mpls-path-segment

Hi SPRING WG,

review of this work at some later stage, such as before or during WG the
last call.

Additionally, there are currently 7 authors listed on this document. Please
trim this to <= 5 front-page authors, utilising a "Contributors" section if
required for the others. An approach to achieving this would be to list ~2
editors as the front-page authors.

Thanks,
--Bruno & Rob.

____________________________________________________________________________
_____________________________________________

Ce message et ses pieces jointes peuvent contenir des informations
confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
exploites ou copies sans autorisation. Si vous avez recu ce message par
erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou
falsifie. Merci.

____________________________________________________________________________
_____________________________________________

Ce message et ses pieces jointes peuvent contenir des informations
confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
exploites ou copies sans autorisation. Si vous avez recu ce message par
erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou
falsifie. Merci.