Subject: [spring] Which SID is used to represent links when both of them have same IP address.

From: tech_kals Kals <[email-masked]>
Date: Tue, 12 Mar 2019 11:04:52 +0530

Hi experts,

Would like to know which SID can be used for the interfaces which are
having same IP address and have different VRFs.

Assume there are two interfaces on the same router.

Both are having same IP address and they are differentiated using VRF.

So, the config looks as shown below.

eth1 ----> VRF1: 20.1.1.1/24

eth2 ----> VRF2: 20.1.1.1/24

Which SID can be used to represent these links ? Can we use AdjSID ?

Thanks,

Kaliyaperumal K

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 12 Mar 2019 14:42:10 +0000

As per https://tools.ietf.org/html/rfc8402#section-3.1

“The context for an IGP-Prefix
   segment includes the prefix, topology, and algorithm.  “

Clearly two different VRFs are different topologies. Therefore destinations in one VRF will have different SIDs from destinations in another VRF i.e., clearly the same prefix does not represent the same destination in this case.

   Les

From: tech_kals Kals <[email-masked]>
Sent: Monday, March 11, 2019 10:35 PM
To: Clarence Filsfils (cfilsfil) <[email-masked]>; [email-masked]; [email-masked]; ask-segment-routing(mailer list) <[email-masked]>; Stefano Previdi (sprevidi) <[email-masked]>; Ahmed Bashandy (bashandy) <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: Which SID is used to represent links when both of them have same IP address.

Hi experts,

Would like to know which SID can be used for the interfaces which are having same IP address and have different VRFs.

eth1 ----> VRF1: 20.1.1.1/24<http://20.1.1.1/24>

eth2 ----> VRF2: 20.1.1.1/24<http://20.1.1.1/24>

Thanks,

Kaliyaperumal K

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 12 Mar 2019 14:42:10 +0000

Les

Hi experts,

Thanks,

Kaliyaperumal K

---

From: Paul Mattes <[email-masked]>
Date: Tue, 12 Mar 2019 16:58:26 +0000

Someone else can correct me, but I believe that the two VRFs would represent two different instances of SR. One SR instance would have an adjacency SID that represented forwarding over the first interface, and the other would have an adjacency SID that represented forwarding over the other. Those adjacency SIDs would be in different namespaces, just like 20.1.1.1 is the same value in different IP namespaces. You can’t forward from one VRF to the other with SR, any more than you can do IP forwarding from one VRF to another and expect the addressing to work correctly.

        pdm

From: spring <[email-masked]> On Behalf Of tech_kals Kals
Sent: Monday, March 11, 2019 10:35 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Stefano Previdi (sprevidi) <[email-masked]>; Ahmed Bashandy (bashandy) <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: [spring] Which SID is used to represent links when both of them have same IP address.

Hi experts,

eth1 ----> VRF1: 20.1.1.1/24<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2F20.1.1.1%2F24&data=02%7C01%7Cpamattes%40microsoft.com%7Cbb88aeb277f6418cc97408d6a6acaa4a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636879657851335415&sdata=bAeUclL1KvT1CbZqQ4s5VOEXCEw3EUbP%2B%2Bvh4zdv%2Bcg%3D&reserved=0>

eth2 ----> VRF2: 20.1.1.1/24<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2F20.1.1.1%2F24&data=02%7C01%7Cpamattes%40microsoft.com%7Cbb88aeb277f6418cc97408d6a6acaa4a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636879657851345424&sdata=lhl8vA1K5Dq2WYJtztUuIxymjI7CrBwIf4qycCLPZJQ%3D&reserved=0>

Thanks,

Kaliyaperumal K

---

From: Paul Mattes <[email-masked]>
Date: Tue, 12 Mar 2019 16:58:26 +0000

pdm

Hi experts,

Thanks,

Kaliyaperumal K

---

From: Yu Tianpeng <[email-masked]>
Date: Tue, 12 Mar 2019 17:31:23 +0000

Hi,
Brief answer below:
Each vrf can be steered into a sr policy.
In the sr policy you can use prefix or adj sids or combination.
There is no much mystery if you know RSVP TE well. A sr policy gives
similar capabilities of a RSVP TE tunnel but aimed to be simplified without
maintaining signaling status along the path. SR aims to be simplified.
You can also steer traffic into different sr policies per destination ip or
even more criterias.
Cheers,
Tim

On Tue, 12 Mar 2019, 05:36 tech_kals Kals, <[email-masked]> wrote:

> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>