Subject: [spring] Questions on Segment Routing

From: tech_kals Kals <[email-masked]>
Date: Wed, 6 Mar 2019 09:26:35 +0530

Hi Experts,

I have few questions on Segment Routing. Can you please clarify my doubts.

1) How OAM can be done in segment-routed networks ?

     I think, MPLS OAM is not possible with SR as network infrastructure
doesn't have any LSP state.

     With SDN controller in place, do we really need traditional OAM ?

     SDN controller can do OAM, but at what cost (like BGP-LS) ?

2) How will the traffic handoff happen from aggregate network to core
network ?

    core is running RSVP-TE, so IP handoff  can be done on edge router ?

    I don't think, SDN controller can control RSVP enabled routers. So, how
it is to make end-to-end TE i.e from Aggregate router to Core Router ?

3) can prefix sid be used to replace VRF in L3VPN scenario? (or any other
way in SR can avoid vrf ?)

     Assume, on a router there are two interfaces. one is 10.1.1.0 VRF-1,
another one is VRF2-10.1.1.0.

     Which SID should I use to differentiate them? Can I use, prefix SID in
this case ?

     Is the below will work ?

     Eth1 - VRF-1: 10.1.1.0  == Prefix SID: 1000

     Eth2 - VRF-2: 10.1.1.0  == Prefix SID: 2000

4) How to handle multicast/broadcast using SR ?

5) SRv6 stacking ipv6 SRH might hit MTU limit somewhere in the network.

     Is my understanding correct ?

6) Does VRRP work with SR ? how fault would be propagated in a necklace
topology?

7) Is there any known issues related to interop with different vendors ?

8) While programming Node-SID on MPLS ILM table, can I assume node-SID
would always be programmed with SWAP operation except on PHP node?

Thanks,

__kals__

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 6 Mar 2019 05:33:04 +0000

Kals,
Some short answers reflecting my personal understandings
1. LSP Ping and Traceroute work just fine with SR-MPLS. Therefore on-demand OAM is not a problem.
2. There are several options for proactive OAM in SR-MPLS, including usage of Path Segments.
3. Prefix SIDs are NOT a replacement for BGP/MPLS IP VPNs.

Thumb typed by Sasha Vainshtein

________________________________
From: spring <[email-masked]> on behalf of tech_kals Kals <[email-masked]>
Sent: Wednesday, March 6, 2019 5:56:35 AM
To: [email-masked]; Stefano Previdi (sprevidi); [email-masked]; Ahmed Bashandy (bashandy); Les Ginsberg (ginsberg); Peter Psenak (ppsenak); [email-masked]; [email-masked]
Subject: [spring] Questions on Segment Routing

Hi Experts,

     I think, MPLS OAM is not possible with SR as network infrastructure doesn't have any LSP state.

2) How will the traffic handoff happen from aggregate network to core network ?

    I don't think, SDN controller can control RSVP enabled routers. So, how it is to make end-to-end TE i..e from Aggregate router to Core Router ?

3) can prefix sid be used to replace VRF in L3VPN scenario? (or any other way in SR can avoid vrf ?)

     Assume, on a router there are two interfaces. one is 10.1.1.0 VRF-1, another one is VRF2-10.1.1.0.

     Which SID should I use to differentiate them? Can I use, prefix SID in this case ?

     Is the below will work ?

6) Does VRRP work with SR ? how fault would be propagated in a necklace topology?

8) While programming Node-SID on MPLS ILM table, can I assume node-SID would always be programmed with SWAP operation except on PHP node?

Thanks,

__kals__

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: tech_kals Kals <[email-masked]>
Date: Fri, 8 Mar 2019 10:32:54 +0530

Hi Alexander,

Thank you so much for your response.

Am looking answer for other questions as well. Can someone please reply if
you can.

Thanks in advance.

Regards,
Kaliyaperumal K

On Wed, Mar 6, 2019 at 11:03 AM Alexander Vainshtein <
[email-masked]> wrote:

> ------------------------------
> *From:* spring <[email-masked]> on behalf of tech_kals Kals <
> [email-masked]>
> *Sent:* Wednesday, March 6, 2019 5:56:35 AM
> *To:* [email-masked]; Stefano Previdi (sprevidi);
> [email-masked]; Ahmed Bashandy (bashandy); Les Ginsberg (ginsberg);
> Peter Psenak (ppsenak); [email-masked]; [email-masked]
> *Subject:* [spring] Questions on Segment Routing
>
> Hi Experts,
>
> it is to make end-to-end TE i..e from Aggregate router to Core Router ?
>
>
>

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 13 Mar 2019 05:40:35 +0000

Hi Kaliyaperumal,

May I suggest some pointers to resources which would help you?

https://datatracker.ietf.org/wg/spring/documents/

More specifically, pertaining to your questions below:
https://datatracker.ietf.org/doc/rfc8402/
https://datatracker.ietf.org/doc/rfc8403/
https://datatracker.ietf.org/doc/rfc8426/
https://datatracker.ietf.org/doc/draft-ietf-6man-segment-routing-header/
https://datatracker.ietf.org/doc/draft-voyer-6man-extension-header-insertion/
https://datatracker.ietf.org/doc/draft-dukes-spring-mtu-overhead-analysis/

There are several others in an around the areas of your questions.

For Interop, I would suggest looking up EANTC reports of their tests.

Besides this, if you were to search the web, you would find other resources that gives you further information that are design and deployment specific.

Hope this helps.

Thanks,
Ketan

From: spring <[email-masked]> On Behalf Of tech_kals Kals
Sent: 08 March 2019 10:33
To: Alexander Vainshtein <[email-masked]>
Cc: Les Ginsberg (ginsberg) <[email-masked]>; [email-masked]; Ahmed Bashandy (bashandy) <[email-masked]>; tech_kals Kals <[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]>; ask-segment-routing(mailer list) <[email-masked]>; Stefano Previdi (sprevidi) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>
Subject: Re: [spring] Questions on Segment Routing

Hi Alexander,

Am looking answer for other questions as well. Can someone please reply if you can.

Thanks in advance.

Regards,
Kaliyaperumal K

On Wed, Mar 6, 2019 at 11:03 AM Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:
Kals,

________________________________
From: spring <[email-masked]<mailto:[email-masked]>> on behalf of tech_kals Kals <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, March 6, 2019 5:56:35 AM
To: [email-masked]<mailto:[email-masked]>; Stefano Previdi (sprevidi); [email-masked]<mailto:[email-masked]>; Ahmed Bashandy (bashandy); Les Ginsberg (ginsberg); Peter Psenak (ppsenak); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [spring] Questions on Segment Routing

Hi Experts,

     Is the below will work ?

Thanks,

__kals__

---

From: tech_kals Kals <[email-masked]>
Date: Thu, 14 Mar 2019 10:09:30 +0530

Hi Ketan,

Thanks for your reply.

Sure, I will go through them.

Meanwhile, let us wait if someone can answer to my questions.

thanks,
__kals__

On Wed, Mar 13, 2019 at 11:10 AM Ketan Talaulikar (ketant) <[email-masked]>
wrote:

> Besides this, if you were to search the web, you would find other
> resources that gives you further information that are design and deployment
> specific.
>
>
>
> Hope this helps.
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *tech_kals Kals
> *Sent:* 08 March 2019 10:33
> *To:* Alexander Vainshtein <[email-masked]>
> *Cc:* Les Ginsberg (ginsberg) <[email-masked]>; [email-masked];
> Ahmed Bashandy (bashandy) <[email-masked]>; tech_kals Kals <
> [email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]>;
> ask-segment-routing(mailer list) <[email-masked]>; Stefano
> Previdi (sprevidi) <[email-masked]>; Peter Psenak (ppsenak) <
> [email-masked]>
> *Subject:* Re: [spring] Questions on Segment Routing
>
>
>
> Hi Alexander,
>
>
>
>     I don't think, SDN controller can control RSVP enabled routers.
> So, how it is to make end-to-end TE i..e from Aggregate router to Core
> Router ?
>
>
>