Subject: [spring] Additional SRv6 Deployment, Interop and Implementation - FW: New Version Notification for draft-matsushima-spring-srv6-deployment-status-01.txt

From: "Zafar Ali (zali)" <[email-masked]>
Date: Thu, 9 May 2019 00:50:40 +0000

Hi All,

A new version of draft-matsushima-spring-srv6-deployment-status has been posted.

The diffs include public announcement from Iliad and Cisco of the deployment of SRv6 in Italy:
https://newsroom.cisco.com/press-release-content?type=webcontent&articleId=1978361

The deployment includes interoperating multiple hardware implementations of SRv6 drafts among Cisco ASR 9000, Cisco NCS 5500 and Iliad's NodeBox. This is in addition to SRv6 deployment on hardware boxes in production networks at Softbank and China Telecom. Several other deployments are in preparation.

The diffs also include details on successful SRv6 interop testing among multiple hardware implementations at EANTC 2019. Specifically, five different implementations of various SRv6 drafts, including SRH draft, interoperated successfully.

The draft also lists various implementations of SRH and other SRv6 drafts, including:

  *   Cisco: Multiple hardware platforms and 3 OS
  *   Linux: Kernal and srext module
  *   FD.io: VPP
  *   Apps: Snort, iptables and nftables, tcpdump and Wireshark
  *   Huawei: Multiple hardware platforms
  *   Iliad: NodeBox
  *   Barefoot: Tofino NPU

Details can be found in the draft.

In addition to EANTC 2019, multiple implementations of SRv6 successfully interoperated at Sigcom 2018, EANTC 2018, etc.

Please advise of any comments and any missing implementation, interop event, etc.

Thanks

Regards ... Zafar (on behalf of co-authors)

From: "[email-masked]" <[email-masked]>
Date: Wednesday, May 8, 2019 at 7:43 PM
To: "Zafar Ali (zali)" <[email-masked]>, "Clarence Filsfils (cfilsfil)" <[email-masked]>, Zhenbin Li <[email-masked]>, Satoru Matsushima <[email-masked]>
Subject: New Version Notification for draft-matsushima-spring-srv6-deployment-status-01.txt

A new version of I-D, draft-matsushima-spring-srv6-deployment-status-01.txt
has been successfully submitted by Zafar Ali and posted to the
IETF repository.

Name:                  draft-matsushima-spring-srv6-deployment-status
Revision:              01
Title:                      SRv6 Implementation and Deployment Status
Document date:               2019-05-08
Group:                  Individual Submission
Pages:                   18
URL:            https://www.ietf.org/internet-drafts/draft-matsushima-spring-srv6-deployment-status-01.txt
Status:         https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/
Htmlized:       https://tools.ietf.org/html/draft-matsushima-spring-srv6-deployment-status-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-matsushima-spring-srv6-deployment-status
Diff:           https://www.ietf.org/rfcdiff?url2=draft-matsushima-spring-srv6-deployment-status-01

Abstract:
   This draft provides an overview of IPv6 Segment Routing (SRv6)
   deployment status.  It lists various SRv6 features that have been
   deployed in the production networks.  It also provides an overview of
   SRv6 implementation and interoperability testing status.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Ca By <[email-masked]>
Date: Thu, 9 May 2019 06:25:29 -0700

Thank you for sharing this.

While deployment and interop are clearly shown, as an operator evaluating
if SRv6 is useful or not, i would like to see the real world performance
characteristics. I believe the document would be more useful if it not only
showed what and how, but also the performance under various scenarios vs
alternate approach. How is L3VPN performance in terms of pps and
convergence time impact vs alternative MPLS approaches?

As operators, we have choices, and simply knowing that something is
deployed is helpful, but not as helpful as knowing it was deployed and
demonstrably performed better than alternatives across key quantitative
metrics

CB

On Wed, May 8, 2019 at 5:51 PM Zafar Ali (zali) <[email-masked]> wrote:

> The deployment includes interoperating multiple hardware implementations
> of SRv6 drafts among Cisco ASR 9000, Cisco NCS 5500 and Iliad's NodeBox.
> This is in addition to SRv6 deployment on hardware boxes in production
> networks at Softbank and China Telecom. Several other deployments are in
> preparation.
>
>
>
> The diffs also include details on successful SRv6 interop testing among
> multiple hardware implementations at EANTC 2019. Specifically, five
> different implementations of various SRv6 drafts, including SRH draft,
> interoperated successfully.
>
>
>
>    - Cisco: Multiple hardware platforms and 3 OS
>    - Linux: Kernal and srext module
>    - FD.io: VPP
>    - Apps: Snort, iptables and nftables, tcpdump and Wireshark
>    - Huawei: Multiple hardware platforms
>    - Iliad: NodeBox
>    - Barefoot: Tofino NPU
>
>
>
> In addition to EANTC 2019, multiple implementations of SRv6 successfully
> interoperated at Sigcom 2018, EANTC 2018, etc.
>
>
>
> *From: *"[email-masked]" <[email-masked]>
> *Date: *Wednesday, May 8, 2019 at 7:43 PM
> *To: *"Zafar Ali (zali)" <[email-masked]>, "Clarence Filsfils (cfilsfil)"
> <[email-masked]>, Zhenbin Li <[email-masked]>, Satoru
> Matsushima <[email-masked]>
> *Subject: *New Version Notification for
> draft-matsushima-spring-srv6-deployment-status-01.txt
>
>
>
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-matsushima-spring-srv6-deployment-status-01.txt
>
> Status:
> https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/
>
> Htmlized:
> https://tools.ietf.org/html/draft-matsushima-spring-srv6-deployment-status-01
>
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-matsushima-spring-srv6-deployment-status
>
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-matsushima-spring-srv6-deployment-status-01
>
>
>
> Abstract:
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>