Subject: [spring] draft-ietf-spring-srv6-network-programming-01 : ENH = No Next Header

From: Ron Bonica <[email-masked]>
Date: Wed, 24 Jul 2019 11:46:18 +0000

Authors,

The END.DX2, END.DX2V, END.DT2U, END.DT2M SIDs

  *   All carry Ethernet Payload
  *   All required the ENH to be equal to 59 (No Next Header)

In any context other than SRv6, No Next Header means that there is no next header. In SRv6, No next header means that the next header is Ethernet.

                                                                                                                                  Ron

Juniper Business Use Only

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Wed, 24 Jul 2019 13:41:49 +0000

Ron,

This statement is incorrect. As already explained in the mailer, the SID identifies the packet processing that must be done on egress.
The IPv6 No Next Header indicates that there is no further Internet Protocol header to be processed before the encapsulated packet.

Multiple options were discussed on the list with no clear consensus. The authors suggest keeping NH=59 for this use.
Note that SRv6 uses also the IPv6 No Next Header (59) for other non-IP payloads different from ethernet (e.g. Unstructured PDUs -draft-ietf-dmm-srv6-mobile-uplane-05)

Cheers,
Pablo.

From: spring <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Date: Wednesday, 24 July 2019 at 13:47
To: SPRING WG <[email-masked]>
Subject: [spring] draft-ietf-spring-srv6-network-programming-01 : ENH = No Next Header

 In SRv6, No next header means that the next header is Ethernet.