Subject: [spring] Questions about the life span of Path Segment

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 24 Jul 2019 15:27:51 +0000

Dear colleagues,
I have a couple of questions about the life span of the Path Segment.

Suppose that some entity has computed and instantiated an SR LP that follows a specific path from the ingress node to the  egress node across a single IGP domain. This path is expressed as a sequence of valid IGP Segments (e.g., Node and/or Adjacency segments) .
Suppose also that a Path Segment has been allocated by the egress node for this path, and the ingress node is aware of this and inserts the label acting as the SID for the Path segments immediately after the last SID of the path.

Now my questions:

1.       What happens to the Path Segment when one of the IGP segments defining the original path fails?

a.       To the best of my understanding the path itself becomes invalid

b.       Will the Path Segment that identifies the now invalid path be retained indefinitely, or would it be invalidated as well and the label acting as its SID released?

2.       Suppose that the entity that has computed and instantiated the original path re-computes it and instantiate a new valid path.

a.       Should the new path (that replaces the invalidated original one) be allocated with the same Path Segment as the original path, or should a new Path Segment be allocated for it?

b.       If the Path Segment allocated for the invalidated path is released (see (1b) above), can the label that identified it be re-used as the Path Segment ID immediately, or only after some delay?

>From my POV the answers to these questions do not depend on the actual method by which the Path Segments are allocated and propagated from the egress node to the ingress one.
And while my questions explicitly mention IGP Segments that define the SR LSP for which the Path Segment is allocated, the desired behavior should not depend on the type of segments used in the definition of the path.

Your feedback would be highly appreciated.

Regards, and lots of thanks in advance,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 26 Jul 2019 15:39:14 +0000

Hi Sasha,

Many thanks for you comments and sorry for my delay. Please see my reply inline.

Cheng

________________________________
发件人: spring [[email-masked]] 代表 Alexander Vainshtein [[email-masked]]
发送时间: 2019年7月24日 23:27
收件人: [email-masked]
抄送: [email-masked]
主题: [spring] Questions about the life span of Path Segment

Dear colleagues,

Now my questions:

[Cheng] Agree. But IMO, the path segment has the same life circle with the associated LSP. so it MAY not be invalid in FRR since the egress, ingress even the controller does not know that until the Reroute is triggered, then it should be treated as invalid.

[Cheng] Honestly, I think it depends on implementation. The the LSP fails, then the related Path Segment is invalid. But when the Rerouted LSP is installed, the path segment should be allocated, and we don't make any assumption of the value of the path segment. It CAN be the same value as the previous one.

[Cheng] Same as above. As long as the information is synchronized between the controller and the data plane, any value is OK. But the same path segment should be recommended.

[Cheng] It depends on the implementation. Just to make sure that the path segment can be available.

[Cheng] Sure.

Regards, and lots of thanks in advance,
[Cheng] Thank you as well for valuable comments.
Sasha

Office: +972-39266302
Cell:      +972-549266302