Subject: [spring] draft-ietf-spring-srv6-network-programming-01 - Effective Next Header (ENH)

From: Ron Bonica <[email-masked]>
Date: Wed, 24 Jul 2019 11:36:27 +0000

Authors,

The END.DX2, END.DX2V, END.DT2U, END.DT2M, END.DX4, END.DT4, END.DX6, END.DT6 SIDs all reference the Effective Next Header (ENH). The ENH is the first upper-layer header beyond the IPv6 header chain.

In many cases, the ENH immediately follows the SRH. In these cases, it is easy to identify the ENH and SID processing is easy.

In other cases, the ENH does not immediately follow the SRH. In these cases, SID processing is more difficult because the ENH cannot be identified without reading ahead to the end of the extension header chain.

In one final case, when an ESP header falls between the SRH and the ENH, SID processing becomes very difficult because the ENH cannot be identified until the payload is decrypted.

At very least, you should address these issues in the document. At best, you should consider encoding these "destination SIDs" in IPv6 Destination options.

                                                                                                                  Ron

Juniper Business Use Only

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Wed, 24 Jul 2019 13:36:49 +0000

Ron,

As we already explained on the mailer a few weeks ago, the next big change for the NET-PGM draft is the alignment of pseudocodes with the SRH draft.

Thanks,
Pablo.

From: spring <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Date: Wednesday, 24 July 2019 at 13:36
To: SPRING WG <[email-masked]>
Subject: [spring] draft-ietf-spring-srv6-network-programming-01 - Effective Next Header (ENH)

Authors,

At very least, you should address these issues in the document. At best, you should consider encoding these “destination SIDs” in IPv6 Destination options.

                                                                                                                  Ron