Subject: [spring] Comments on <draft-ietf-spring-srv6-network-programming-01>

From: Xiejingrong <[email-masked]>
Date: Wed, 10 Jul 2019 02:54:29 +0000

Hi,

I remember there had been lots of discussions on the list about two points,
One is the definition of ENH, the other is the use of Next Header 59.
Seems like this rev doesn't accept any of them, but make them clear in text.
They work for me.

But one point I am even more confused:
   The SRv6 Endpoint Behavior numbers are maintained by the working
   group until the RFC is published.  Note to the RFC Editor: Remove
   this paragraph before publication.

Why does this document say to create a new registry, but hold the Behavior numbers privately ?
We need the IANA registry be created and allocation from the registry.

Thanks
Jingrong

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Wed, 10 Jul 2019 13:24:51 +0000

Hi Jingrong,

The behaviours numbers are not hold privately: they are hold by the working group until the RFC is published and therefore the new IANA registry is created. After that, the registry is maintained by IANA with the registration procedure described in the draft.

If the paragraph in the draft is not clear, please feel free to propose a new one.

Note that Loa and Shuping particularly asked to clarify this. In Prague I met with them and we updated the following:

  *   SRv6 Endpoint Behavior sub-registry; second range: Changed registration procedure from “IETF Review” to “Specification required”
  *   Added paragraph clarifying who is maintaining the initial entries until the registry is created by IANA

Regards,
Pablo.

From: spring <[email-masked]> on behalf of Xiejingrong <[email-masked]>
Date: Wednesday, 10 July 2019 at 05:55
To: "[email-masked]" <[email-masked]>
Subject: [spring] Comments on <draft-ietf-spring-srv6-network-programming-01>