Subject: [spring] FW: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-04.txt

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 1 Jul 2019 12:24:59 +0000

Hi all,

We just submitted a new revision of draft-dong-spring-sr-for-enhanced-vpn. The major changes in this version are: 

1. Clarify that each virtual network can have customized network topology and may have dedicated network resources, so that both soft isolation and hard isolation can be covered.

2. Focus on the usage of SR-MPLS SID and SRv6 locator/SID as data plane identifiers of virtual network topology and resource. 

3. In section 5 "Procedures", polish the description about the mechanism of creating SR virtual networks, and clarify that enhanced VPNs can be mapped to the same or different SR virtual networks.

4. Section 6 “Benefits of the proposed mechanism” is simplified by focusing on the features of the proposed mechanism. 

5. Add new coauthors.

Your review and comments are welcome.

Best regards,
Jie (on behalf of co-authors)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, July 01, 2019 8:14 PM
To: Takuya Miyasaka <[email-masked]>; Zhenqiang Li <[email-masked]>; Fengwei Qin <[email-masked]>; Yongqing Zhu <[email-masked]>; Stewart Bryant <[email-masked]>; Dongjie (Jimmy) <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-04.txt

A new version of I-D, draft-dong-spring-sr-for-enhanced-vpn-04.txt
has been successfully submitted by Jie Dong and posted to the IETF repository.

Name:		draft-dong-spring-sr-for-enhanced-vpn
Revision:	04
Title:		Segment Routing for Enhanced VPN Service
Document date:	2019-07-01
Group:		Individual Submission
Pages:		19
URL:            https://www.ietf.org/internet-drafts/draft-dong-spring-sr-for-enhanced-vpn-04.txt
Status:         https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/
Htmlized:       https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-04
Htmlized:       https://datatracker.ietf.org/doc/html/draft-dong-spring-sr-for-enhanced-vpn
Diff:           https://www.ietf.org/rfcdiff?url2=draft-dong-spring-sr-for-enhanced-vpn-04

Abstract:
   Enhanced VPN (VPN+) is an enhancement to VPN technology to enable it
   to support the needs of new applications, particularly applications
   that are associated with 5G services.  These applications require
   better isolation from both control and data plane's perspective and
   have more stringent performance requirements than can be provided
   with overlay VPNs.  The characteristics of an enhanced VPN as
   perceived by its tenant needs to be comparable to those of a
   dedicated private network.  This requires tight integration between
   the overlay VPN and the underlay network topology and resources in a
   scalable manner.  An enhanced VPN may form the underpinning of 5G
   network slicing, but will also be of use in its own right.  This
   document describes the use of segment routing based mechanisms to
   provide the enhanced VPN service with required network topology and
   resources.  The overall mechanism of using segment routing to provide
   enhanced VPN service is also described.  The proposed mechanism is
   applicable to both SR with MPLS data plane and SR with IPv6 data
   plane (SRv6).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "qinfengwei" <[email-masked]>
Date: Wed, 3 Jul 2019 11:28:51 +0800

Hi all,
	5G is about to enter the commercial stage in China Mobile, its network need provide end-to-end network slicing. 5G mobile service is quite different from other services, which require hard slice and soft slice. For uRLLC, the hard isolation 
could be used to satisfy its high demand of bandwidth and delay. For other scenarios, the customized virtual network could be provided by the bearer network to meet the requirement of bandwidth, delay ,jitter, etc.
 SR is a technical direction of the bearer network. The draft could support the combination of hard and soft isolation, which is a good idea. The draft could be got more discussion and further progress. 
We hope WG could improve this draft ASAP so that it can be adopted in network in the near future.

Thanks & BR
Fengwei Qin

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Dongjie (Jimmy)
发送时间: 2019年7月1日 20:25
收件人: SPRING WG List
抄送: [email-masked]
主题: [spring] FW: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-04.txt

Hi all,

5. Add new coauthors.

Best regards,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, July 01, 2019 8:14 PM
To: Takuya Miyasaka <[email-masked]>; Zhenqiang Li <[email-masked]>; Fengwei Qin <[email-masked]>; Yongqing Zhu <[email-masked]>; Stewart Bryant <[email-masked]>; Dongjie (Jimmy) <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-04.txt

Abstract:

The IETF Secretariat

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: "Zhuyq" <[email-masked]>
Date: Fri, 5 Jul 2019 07:47:20 +0800

Hi all,
Network slicing is a key feature for 5G to enable diversified services using the same network infrastructure. In order to support end-to-end network slicing, it is necessary to consider how to provide network slicing in mobile transport network. As segment routing is one of the candidate technologies for 5G transport, it is useful to provide a SR based network slicing solution to meet the requirement on different levels of isolation and network customization. This document is a good starting point in this direction, and we appreciate more review and discussion to help moving this work forward.
Best regards,
Zhu Yongqing

-----邮件原件-----
发件人: spring <[email-masked]> 代表 Dongjie (Jimmy)
发送时间: 2019年7月1日 20:25
收件人: SPRING WG List <[email-masked]>
抄送: [email-masked]
主题: [spring] FW: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-04.txt

Hi all,

5. Add new coauthors.

Best regards,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 01, 2019 8:14 PM
To: Takuya Miyasaka <[email-masked]>; Zhenqiang Li <[email-masked]>; Fengwei Qin <[email-masked]>; Yongqing Zhu <[email-masked]>; Stewart Bryant <[email-masked]>; Dongjie (Jimmy) <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-04.txt

Abstract:

The IETF Secretariat