Subject: [spring] comments on draft-ali-6man-spring-srv6-oam-03

From: li zhenqiang <[email-masked]>
Date: Fri, 23 Aug 2019 10:25:24 +0000

Dear authors and all,

Zhenqiang Li from China Mobile. Please consider the following comments.

1. Section 4.1.2.1, bullet 4, When node N4 receives the packet.
I think it is better to change "The packet gets punted to the ICMPv6 process for processing" to "The packet gets time-stamped and punted to the ICMPv6 process for processing".

2. Section 4.1.2.2, the last bullet.
The sentence "The ICMPv6 process at node N4 checks if its local SID (B:2:C31) is locally programmed or not and responds to the ICMPv6 Echo Request" should be "The ICMPv6 process at node N4 checks if its local SID (B:4:C52) is locally programmed or not and responds to the ICMPv6 Echo Request".

Since Flags.O=1 is used in this case, N4 should execute the local SID B:4:C52 after the execution of the pseudo-code specified in section 3.1.1. What is the proper behavior of N4 here?  Generate an ICMP parameter problem message to the Source with Error code "SR Upper-layer Header Error" according to section 4.3.1.2 of draft-ietf-6man-segment-routing-header-22?

To align with the bullets listed in section 4.1.2.1, we'd better add one new bullet here with the text "If the target SID is not locally programmed, N4 responses with the ICMPv6 message (Type:"SRv6 OAM (TBA)", Code: "SID not locally implemented (TBA)"); otherwise a success is returned".

3. Section 4.2.2.1, the last bullet.
I think it is better to change "The packet gets punted to the traceroute process for processing" to "The packet gets time-stamped and punted to the traceroute process for processing"

To align with the bullets listed in section 4.1.2.1, we'd better add one new bullet here with the text "If the target SID B:4:C52 is locally programmed, node N4 responses with the ICMPv6 message (Type: Destination unreachable, Code: Port Unreachable). If the target SID B:4:C52 is not a local SID, node N4 silently drops the traceroute probe".

4. Section 4.2.2.2, the last bullet.
The sentence "The traceroute process at node N4 checks if its local SID (B:2:C31) is locally programmed" should be "The traceroute process at node N4 checks if its local SID (B:4:C52) is locally programmed".

Since Flags.O=1 is used in this case, N4 should execute the local SID B:4:C52 after the execution of the pseudo-code specified in section 3.1.1. What is the proper behavior of N4 here?  Generate an ICMP parameter problem message to the Source with Error code "SR Upper-layer Header Error" according to section 4.3.1.2 of draft-ietf-6man-segment-routing-header-22?

To align with the bullets listed in section 4.1.2.1, we'd better split this bullet into two.

5. Figure 5
The SL for the response from 2001:DB8:1:2:21:: should be 1. The SL for the response from 2001:DB8:3:4::41:: should be 0.

6. Section 6.2
Don't we need to define PSP and USP for END.OP and END.OTP?

My pleasure to work together to move this draft forward.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Fri, 23 Aug 2019 14:20:59 +0000

Hi Li,

Many thanks for your comments.

Adding 6man WG and acking, for now.
Please expect a follow-up email with detailed response.

Thanks

Regards … Zafar

From: li zhenqiang <[email-masked]>
Date: Friday, August 23, 2019 at 6:25 AM
To: draft-ali-6man-spring-srv6-oam <[email-masked]>, spring <[email-masked]>
Subject: comments on draft-ali-6man-spring-srv6-oam-03
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Friday, August 23, 2019 at 6:25 AM

Dear authors and all,

5. Figure 5

6. Section 6.2

Best Regards,
Zhenqiang Li