Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Tue, 15 Oct 2019 16:45:06 +0000

Ron,

That sentence is there on purpose. RFC8200:
   IPv6 nodes must accept and attempt to process extension headers in
   any order and occurring any number of times in the same packet

I will update that sentence in the next revision of the draft to make it more formal and include the normative reference:
“As per [RFC8200], multiple occurrences of the SRH might be present in the same IPv6 header.”

Cheers,
Pablo.

From: spring <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Date: Monday, 14 October 2019 at 20:28
To: SPRING WG List <[email-masked]>
Subject: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Authors,

In Section 2 of draft-ietf-spring-srv6-network-programming-04, you say:

“SRH: Segment Routing Header as defined in  [I-D.ietf-6man-segment-routing-header].  We assume that the SRH may be present multiple times inside each packet.”

Did you mean to remove the final sentence?

                                     Ron

Juniper Business Use Only

---

From: Ron Bonica <[email-masked]>
Date: Tue, 15 Oct 2019 23:42:42 +0000

Pablo,

I am sure that you have read RFC 8200 carefully enough to have noticed the following text:

"Each extension header should occur at most once, except for the Destination Options header, which should occur at most twice (once before a Routing header and once before the upper-layer header).

This rule addresses the number of extension headers of any given type that can appear in a single packet. A packet that contains one IP header and two routing headers would violate this rule.

You quote the following text, also from RFC 8200, omitting the final sentences:

"IPv6 nodes must accept and attempt to process extension headers in any order and occurring any number of times in the same packet, except for the Hop-by-Hop Options header, which is restricted to appear immediately after an IPv6 header only.  Nonetheless, it is strongly advised that sources of IPv6 packets adhere to the above recommended order until and unless subsequent specifications revise

that recommendation."

Is it your intent to ignore the strong advice of RFC 8200 without offering any justification?

                                                                                                 Ron

Juniper Business Use Only
From: Pablo Camarillo (pcamaril) <[email-masked]>
Sent: Tuesday, October 15, 2019 12:45 PM
To: Ron Bonica <[email-masked]>; SPRING WG List <[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Ron,

I will update that sentence in the next revision of the draft to make it more formal and include the normative reference:
"As per [RFC8200], multiple occurrences of the SRH might be present in the same IPv6 header."

Cheers,
Pablo.

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Date: Monday, 14 October 2019 at 20:28
To: SPRING WG List <[email-masked]<mailto:[email-masked]>>
Subject: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Authors,

"SRH: Segment Routing Header as defined in  [I-D.ietf-6man-segment-routing-header].  We assume that the SRH may be present multiple times inside each packet."

                                     Ron

---

From: li zhenqiang <[email-masked]>
Date: Thu, 17 Oct 2019 04:15:45 +0000

Hi Pablo,

I believe the sentence you quote is used to suggest the node be prepared to handle WRONG packet, not suggesting the node to generate WRONG packet.
Sorry I am not an English native speaker. I hope I am right.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]

From: Pablo Camarillo (pcamaril)<mailto:[email-masked]>
Date: 2019-10-16 00:45
To: Ron Bonica<mailto:rbonica=[email-masked]>; SPRING WG List<mailto:[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2
Ron,

Cheers,
Pablo.

Authors,

                                     Ron

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Thu, 17 Oct 2019 09:40:46 +0000

Ron,

The intent is to define SIDs and their processing as general as possible to accept whatever is received as per RFC8200. This is a reminder of that fact.

Cheers,
Pablo.

From: Ron Bonica <[email-masked]>
Date: Wednesday, 16 October 2019 at 01:43
To: "Pablo Camarillo (pcamaril)" <[email-masked]>, SPRING WG List <[email-masked]>
Subject: RE: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Pablo,

“Each extension header should occur at most once, except for the Destination Options header, which should occur at most twice (once before a Routing header and once before the upper-layer header).

“IPv6 nodes must accept and attempt to process extension headers in any order and occurring any number of times in the same packet, except for the Hop-by-Hop Options header, which is restricted to appear immediately after an IPv6 header only.  Nonetheless, it is strongly advised that sources of IPv6 packets adhere to the above recommended order until and unless subsequent specifications revise

that recommendation.”

                                                                                                 Ron

Ron,

Cheers,
Pablo.

Authors,

                                     Ron