Subject: [spring] https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04#page-24

From: Rajesh M <[email-masked]>
Date: Fri, 11 Oct 2019 01:46:26 +0000

Wanted to know the use case where we only POP the SRH ?

4.16.1<https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04#section-4.16.1>.  PSP: Penultimate Segment Pop of the SRH

   The SRH processing of the End, End.X and End.T behaviors are

   modified: after the instruction "S14.  Update IPv6 DA with Segment

   List[Segments Left]" is executed, the following instructions must be

   executed as well:

   S14.1.   If (updated SL == 0) {

   S14.2.      Pop the SRH

   S14.3.   }

Juniper Business Use Only

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 14 Oct 2019 00:47:20 -0400

Rajesh

I believe that is how it’s written but want to confirm that with SRv6 we added the PSP to mirror mpls and SR-MPLS PHP and added USP to mirror mpls and UHP penultimate and ultimate hop pop that occurs either the default behavior on the egress P or USP on the egress PE FEC destination.  

Thanks 

Gyan

Sent from my iPhone

> On Oct 10, 2019, at 9:46 PM, Rajesh M <mrajesh=[email-masked]> wrote:
> 
> 4.16.1.  PSP: Penultimate Segment Pop of the SRH
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 14 Oct 2019 01:08:01 -0400

In-line

Sent from my iPhone

> On Oct 14, 2019, at 12:47 AM, Gyan Mishra <[email-masked]> wrote:
> 
> Rajesh
> 

Just to add to what I am saying so the PSP and USP is very critical and is not just something that was added to mimic mpls but is absolutely necessary with SRv6 from a IPv6 data plane standpoint that the EH that was inserted in-flight on intermediate nodes in this case the ingress PE so that EH header must be removed before the packet exits the SRv6 domain.

So the SRv6 domain construct of doing the removal PSP or USP is fine within the SRv6 routing domain In a service provider network within their own domain but when going inter domain especially in the internet use case this becomes problematic as now the onus to remove the EH SRH Routing type 4 header is on the downstream service provider many AS hops away and how is that enforced that the EH will ever get removed.  More then likely it will not.

How do we get around that and does that put a monkey wrench in the ubiquitous use cases for SRv6 especially the internet when many domains are involved with separate administrative control.

---

From: li zhenqiang <[email-masked]>
Date: Tue, 15 Oct 2019 07:53:07 +0000

I'm also confused by the flavor part in srv6-network-programming draft.
As we have discussed, SRv6 is totally different from MPLS in mechanism. Similar ideas can not be borrowed from MPLS to SRv6 directly.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]

From: Gyan Mishra<mailto:[email-masked]>
Date: 2019-10-14 12:47
To: Rajesh M<mailto:mrajesh=[email-masked]>
CC: SPRING WG List<mailto:[email-masked]>; Srihari Sangli<mailto:[email-masked]>; Shraddha Hegde<mailto:[email-masked]>
Subject: Re: [spring] https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04#page-24
Rajesh

Thanks

Gyan

Sent from my iPhone

On Oct 10, 2019, at 9:46 PM, Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>> wrote:

   executed as well:

   S14.2.      Pop the SRH

   S14.3.   }

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: Rajesh M <[email-masked]>
Date: Thu, 17 Oct 2019 12:21:41 +0000

Authors of the draft could you please respond ?

Juniper Business Use Only
From: Rajesh M
Sent: Friday, October 11, 2019 7:16 AM
To: SPRING WG List <[email-masked]>
Cc: Srihari Sangli <[email-masked]>; Shraddha Hegde <[email-masked]>
Subject: https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04#page-24

   executed as well:

   S14.2.      Pop the SRH

   S14.3.   }

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Thu, 17 Oct 2019 16:08:47 +0000

Rajesh,

I have already replied two days ago to your email. Please see mail archive.

Cheers,
Pablo.

From: Rajesh M <[email-masked]>
Date: Thursday, 17 October 2019 at 14:22
To: SPRING WG List <[email-masked]>, "cf(mailer list)" <[email-masked]>, "Pablo Camarillo (pcamaril)" <[email-masked]>
Cc: Srihari Sangli <[email-masked]>, Shraddha Hegde <[email-masked]>, Ron Bonica <[email-masked]>
Subject: RE: https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04#page-24

   executed as well:

   S14.2.      Pop the SRH

   S14.3.   }

---

From: Rajesh M <[email-masked]>
Date: Fri, 18 Oct 2019 01:55:22 +0000

Thanks Pablo.
I have responded for that mail chain. Still not convinced about PSP 😊

Juniper Business Use Only
From: Pablo Camarillo (pcamaril) <[email-masked]>
Sent: Thursday, October 17, 2019 9:39 PM
To: Rajesh M <[email-masked]>; SPRING WG List <[email-masked]>; draft-ietf-spring-srv6-network-programming <[email-masked]>
Cc: Srihari Sangli <[email-masked]>; Shraddha Hegde <[email-masked]>; Ron Bonica <[email-masked]>
Subject: Re: https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04#page-24

Rajesh,

Cheers,
Pablo.

From: Rajesh M <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 17 October 2019 at 14:22
To: SPRING WG List <[email-masked]<mailto:[email-masked]>>, "cf(mailer list)" <[email-masked]<mailto:[email-masked]>>, "Pablo Camarillo (pcamaril)" <[email-masked]<mailto:[email-masked]>>
Cc: Srihari Sangli <[email-masked]<mailto:[email-masked]>>, Shraddha Hegde <[email-masked]<mailto:[email-masked]>>, Ron Bonica <[email-masked]<mailto:[email-masked]>>
Subject: RE: https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04#page-24

Juniper Business Use Only
From: Rajesh M
Sent: Friday, October 11, 2019 7:16 AM
To: SPRING WG List <[email-masked]<mailto:[email-masked]>>
Cc: Srihari Sangli <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Subject: https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04#page-24

4.16.1<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-04*section-4.16.1__;Iw!8WoA6RjC81c!X5Ns-I_b8TGCfTmF55bEZbVR5Tyd3otcmtlbk4lZbk7lKXIph94PICOa3aQq3Ym6$>.  PSP: Penultimate Segment Pop of the SRH

   executed as well:

   S14.2.      Pop the SRH

   S14.3.   }