Subject: [spring] 5.2. T.Encaps: Transit with encapsulation in an SRv6 Policy

From: Rajesh M <[email-masked]>
Date: Wed, 16 Oct 2019 05:24:29 +0000

here S1 must be End SID only, It cannot be End.X ?
since forward along the shortest path to S1.

5.2.  T.Encaps: Transit with encapsulation in an SRv6 Policy

1.   push an IPv6 header with its own SRH (S3, S2, S1; SL=2)
2.   set outer IPv6 SA = T and outer IPv6 DA = S1
3.   set outer payload length, traffic class and flow label    ;; Ref1,2
4.   update the Next-Header value                              ;; Ref1
5.   decrement inner Hop Limit or TTL                          ;; Ref1
6.   forward along the shortest path to S1

Juniper Business Use Only

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Thu, 17 Oct 2019 09:40:48 +0000

Hi Rajesh,

The segment S1 can be anything.
The T.Encaps behavior is executed by a transit node that is configured to steer traffic into an SR Policy. This transit node is an SR Headend.
The SR policy contains segments S1, S2 and S3 that are typically instantiated in other routers throughout the network.
The SR Headend resolves the first SID of the SR policy (S1) into one or more outgoing interface(s) and next-hop(s). [draft-ietf-spring-segment-routing-policy]

Upon steering a packet into such SR policy using T.Encaps, the processing at line 6 simply forwards the packet based on that resolution.

Cheers,
Pablo.

From: Rajesh M <[email-masked]>
Date: Wednesday, 16 October 2019 at 07:24
To: SPRING WG List <[email-masked]>, "cf(mailer list)" <[email-masked]>, "Pablo Camarillo (pcamaril)" <[email-masked]>
Subject: 5.2. T.Encaps: Transit with encapsulation in an SRv6 Policy