Subject: [spring] Single Packet Contains Two Routing Headers (was: draft-ietf-spring-srv6-network-programming-04: Section 2)

From: Ron Bonica <[email-masked]>
Date: Thu, 17 Oct 2019 16:02:18 +0000

Pablo,

The two excerpts from RFC 8200, quoted below, should be understood in the context of Postel's Rule. That is, "be conservative in what you send and tolerant in what you receive".

RFC 8200 says that a single packet should not include two Routing headers. So, in keeping with the first part of Postel's Rule, the IETF should never publish a specification that violates that rule, unless it updates or obsoletes RFC 8200.

RFC 8200 also says that if an implementation receives a packet that includes two Routing headers, it should attempt to process it. This is in keeping with the second part of Postel's Rule.

Your statement in draft-ietf-spring-srv6-network-programming goes well beyond the second part of Postel's rule. It doesn't say, "If a poorly behaved implementation sends you a packet that includes two Routing headers, attempt to process them". It says, "We assume that the SRH may be present multiple times inside each packet".

There is a big difference.

                                                                                      Ron

Juniper Business Use Only
From: Pablo Camarillo (pcamaril) <[email-masked]>
Sent: Thursday, October 17, 2019 5:41 AM
To: Ron Bonica <[email-masked]>; SPRING WG List <[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Ron,

The intent is to define SIDs and their processing as general as possible to accept whatever is received as per RFC8200. This is a reminder of that fact.

Cheers,
Pablo.

From: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 16 October 2019 at 01:43
To: "Pablo Camarillo (pcamaril)" <[email-masked]<mailto:[email-masked]>>, SPRING WG List <[email-masked]<mailto:[email-masked]>>
Subject: RE: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Pablo,

I am sure that you have read RFC 8200 carefully enough to have noticed the following text:

"Each extension header should occur at most once, except for the Destination Options header, which should occur at most twice (once before a Routing header and once before the upper-layer header).

This rule addresses the number of extension headers of any given type that can appear in a single packet. A packet that contains one IP header and two routing headers would violate this rule.

You quote the following text, also from RFC 8200, omitting the final sentences:

"IPv6 nodes must accept and attempt to process extension headers in any order and occurring any number of times in the same packet, except for the Hop-by-Hop Options header, which is restricted to appear immediately after an IPv6 header only.  Nonetheless, it is strongly advised that sources of IPv6 packets adhere to the above recommended order until and unless subsequent specifications revise

that recommendation."

Is it your intent to ignore the strong advice of RFC 8200 without offering any justification?

                                                                                                 Ron

Juniper Business Use Only
From: Pablo Camarillo (pcamaril) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, October 15, 2019 12:45 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; SPRING WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Ron,

That sentence is there on purpose. RFC8200:
   IPv6 nodes must accept and attempt to process extension headers in
   any order and occurring any number of times in the same packet

I will update that sentence in the next revision of the draft to make it more formal and include the normative reference:
"As per [RFC8200], multiple occurrences of the SRH might be present in the same IPv6 header."

Cheers,
Pablo.

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Date: Monday, 14 October 2019 at 20:28
To: SPRING WG List <[email-masked]<mailto:[email-masked]>>
Subject: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Authors,

In Section 2 of draft-ietf-spring-srv6-network-programming-04, you say:

"SRH: Segment Routing Header as defined in  [I-D.ietf-6man-segment-routing-header].  We assume that the SRH may be present multiple times inside each packet."

Did you mean to remove the final sentence?

                                     Ron

Juniper Business Use Only

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 17 Oct 2019 19:08:40 +0000

Hi all,
FWIW I concur with Ron.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: spring <[email-masked]> On Behalf Of Ron Bonica
Sent: Thursday, October 17, 2019 7:02 PM
To: Pablo Camarillo (pcamaril) <[email-masked]>; SPRING WG List <[email-masked]>; 6man <[email-masked]>
Subject: [spring] Single Packet Contains Two Routing Headers (was: draft-ietf-spring-srv6-network-programming-04: Section 2)

Pablo,

                                                                                      Ron

Ron,

Cheers,
Pablo.

Pablo,

that recommendation."

                                                                                                 Ron

Ron,

Cheers,
Pablo.

Authors,

                                     Ron

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________