Subject: [spring] FW: New Version Notification for draft-bonica-6man-crh-helper-opt-00.txt

From: Ron Bonica <[email-masked]>
Date: Thu, 31 Oct 2019 18:25:19 +0000

Please review this draft

Juniper Business Use Only

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Thursday, October 31, 2019 2:21 PM
To: Ron Bonica <[email-masked]>; Xing Li <[email-masked]>; Congxiao Bao <[email-masked]>; Eddie Ruan <[email-masked]>
Subject: New Version Notification for draft-bonica-6man-crh-helper-opt-00.txt

A new version of I-D, draft-bonica-6man-crh-helper-opt-00.txt
has been successfully submitted by Ron Bonica and posted to the IETF repository.

Name:		draft-bonica-6man-crh-helper-opt
Revision:	00
Title:		Compressed Routing Header (CRH) Helper Option
Document date:	2019-10-31
Group:		Individual Submission
Pages:		7
URL:            https://tools.ietf.org/html/draft-bonica-6man-crh-helper-opt-00

Abstract:
   This document defines the IPv6 CRH Helper option.  When an SRm6
   ingress node originates a packet, it can use the IPv6 CRH Helper
   option to provide SID Forwarding Information Base (SFIB) information
   to downstream nodes that do not maintain a complete SFIB.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 31 Oct 2019 20:36:40 +0100

Hi Ron,

If you are excluding the SFIBH length shouldn't the max legal value be 18
(16+1+1) and not 19 octets ?

Likewise I am a bit not clear about the min 2 octets ? Does this mean that
High SID index is optional as in that case one could indeed imagine just
Low SID index + 1 octet v6 prefix. If not I think it should be 3-18 not
2-19.

   o  SFIBH Length - (8-bits) Length of the SFIBH, in octets, *excluding
      SFIBH Length.*  Value MUST be greater than 2 and less than 19.

Thx,
R.

On Thu, Oct 31, 2019 at 7:25 PM Ron Bonica <rbonica=
[email-masked]> wrote:

> To: Ron Bonica <[email-masked]>; Xing Li <[email-masked]>;
> Congxiao Bao <[email-masked]>; Eddie Ruan <[email-masked]>
> URL:
> https://tools.ietf.org/html/draft-bonica-6man-crh-helper-opt-00
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>