Subject: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

From: Ron Bonica <[email-masked]>
Date: Mon, 14 Oct 2019 18:27:37 +0000

Authors,

In Section 2 of draft-ietf-spring-srv6-network-programming-04, you say:

"SRH: Segment Routing Header as defined in  [I-D.ietf-6man-segment-routing-header].  We assume that the SRH may be present multiple times inside each packet."

Did you mean to remove the final sentence?

                                     Ron

Juniper Business Use Only

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 14 Oct 2019 20:41:56 +0200

Hi Ron,

Packet may have many headers. Each header may contain an SRH. So if you
look at entire packet there can be multiple SRH instances there.

:)

Thx,
R.

On Mon, Oct 14, 2019 at 8:27 PM Ron Bonica <rbonica=
[email-masked]> wrote:

> “SRH: Segment Routing Header as defined in
> [I-D.ietf-6man-segment-routing-header].  We assume that the SRH may be
> present multiple times inside each packet.”
>
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Ron Bonica <[email-masked]>
Date: Mon, 14 Oct 2019 18:50:05 +0000

Robert,

In that is what you mean, you might want to do one of the following:

  *   Remove the sentence entirely
  *   Remove the ambiguity. One could interpret the sentence as an artifact of older draft versions in which it was OK for two SRH's to follow a single IPv6 header.

                                                 Ron

From: Robert Raszuk <[email-masked]>
Sent: Monday, October 14, 2019 2:42 PM
To: Ron Bonica <[email-masked]>
Cc: SPRING WG List <[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2

Hi Ron,

Packet may have many headers. Each header may contain an SRH. So if you look at entire packet there can be multiple SRH instances there.

:)

Thx,
R.

On Mon, Oct 14, 2019 at 8:27 PM Ron Bonica <rbonica=[email-masked]<mailto:[email-masked]>> wrote:
Authors,

                                     Ron

Juniper Business Use Only
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!8WoA6RjC81c!QMoHREC3wNJ2SvZyoTeYLe0kM1GCQ0nFZIR6j3PqB1hZ_CwbLztSCPdNI9Paq3ya$>

---

From: li zhenqiang <[email-masked]>
Date: Tue, 15 Oct 2019 06:44:34 +0000

Please state clearly and unambiguously in the doc since this is the base specification of SRv6.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]

From: Robert Raszuk<mailto:[email-masked]>
Date: 2019-10-15 02:41
To: Ron Bonica<mailto:rbonica=[email-masked]>
CC: SPRING WG List<mailto:[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section 2
Hi Ron,

:)

Thx,
R.

“SRH: Segment Routing Header as defined in  [I-D.ietf-6man-segment-routing-header].  We assume that the SRH may be present multiple times inside each packet.”

                                     Ron