Subject: [spring] draft-ietf-spring-srv6-network-programming-04: Section1

From: Ron Bonica <[email-masked]>
Date: Mon, 14 Oct 2019 18:25:43 +0000

Authors,

In Section 1, you say:

"The network programming consists in combining segment routing functions, both simple and complex, to achieve a networking  objective that goes beyond mere packet routing."

In your opinion, do any of the functions defined in this document go beyond mere packet routing? If so, which?

If not, can you give an example of a function that does go beyond mere packet routing?

                                                                                 Ron

Juniper Business Use Only

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 14 Oct 2019 20:40:33 +0200

>  can you give an example of a function that does go beyond mere packet
routing?

An instruction(s) which triggers explicit detection of probe packet and
adjusts the switching vector to special hardware to handle it

Examples: https://tools.ietf.org/html/draft-lapukhov-dataplane-probe-01

Thx,
R.

On Mon, Oct 14, 2019 at 8:26 PM Ron Bonica <rbonica=
[email-masked]> wrote:

> Authors,
>
>
>
> In Section 1, you say:
>
>
>
> “The network programming consists in combining segment routing functions,
> both simple and complex, to achieve a networking  objective that goes
> beyond mere packet routing.”
>
>
>
> In your opinion, do any of the functions defined in this document go
> beyond mere packet routing? If so, which?
>
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Ron Bonica <[email-masked]>
Date: Mon, 14 Oct 2019 18:54:43 +0000

Robert,

Reading the draft, I would hope that these "non-routing" functions had something to do with the IP layer (OAM, etc). It would be helpful if you could provide a few examples and maybe even references to other drafts.

That would allay fears that we were about to see an amazing layer violation.

                                                                     Ron

From: Robert Raszuk <[email-masked]>
Sent: Monday, October 14, 2019 2:41 PM
To: Ron Bonica <[email-masked]>
Cc: SPRING WG List <[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section1

>  can you give an example of a function that does go beyond mere packet routing?

An instruction(s) which triggers explicit detection of probe packet and adjusts the switching vector to special hardware to handle it

Examples: https://tools.ietf.org/html/draft-lapukhov-dataplane-probe-01<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-lapukhov-dataplane-probe-01__;!8WoA6RjC81c!RLBo_hyspstgm4WbFYdQCEjsDVz8qI2w71Phu9zXfJxB596vQm_KQvM1wAcnNnvk$>

Thx,
R.

On Mon, Oct 14, 2019 at 8:26 PM Ron Bonica <rbonica=[email-masked]<mailto:[email-masked]>> wrote:
Authors,

In Section 1, you say:

                                                                                 Ron

Juniper Business Use Only
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!8WoA6RjC81c!RLBo_hyspstgm4WbFYdQCEjsDVz8qI2w71Phu9zXfJxB596vQm_KQvM1wKl8maI0$>

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 14 Oct 2019 21:06:58 +0200

> That would allay fears that we were about to see an amazing layer
violation.

Well P4 is here and folks are getting smarter with their hardware
capabilities. My impression is that layer violation is already here - well
at least all tools to get there are shipping :)

On Mon, Oct 14, 2019 at 8:54 PM Ron Bonica <[email-masked]> wrote:

> Robert,
>
>
>
> Reading the draft, I would hope that these “non-routing” functions had
> something to do with the IP layer (OAM, etc). It would be helpful if you
> could provide a few examples and maybe even references to other drafts.
>
>
>
> *From:* Robert Raszuk <[email-masked]>
> *Sent:* Monday, October 14, 2019 2:41 PM
> *To:* Ron Bonica <[email-masked]>
> *Cc:* SPRING WG List <[email-masked]>
> *Subject:* Re: [spring] draft-ietf-spring-srv6-network-programming-04:
> Section1
>
>
>
>
>
> <https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-lapukhov-dataplane-probe-01__;!8WoA6RjC81c!RLBo_hyspstgm4WbFYdQCEjsDVz8qI2w71Phu9zXfJxB596vQm_KQvM1wAcnNnvk$>
>
>
>
>
> Thx,
> R.
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!8WoA6RjC81c!RLBo_hyspstgm4WbFYdQCEjsDVz8qI2w71Phu9zXfJxB596vQm_KQvM1wKl8maI0$>
>
>
>

---

From: Ron Bonica <[email-masked]>
Date: Mon, 14 Oct 2019 21:08:24 +0000

Robert,

A few words in the draft about the degree to which NP will respect layer boundaries might be helpful.

In IETF standards, it is always best to reveal at technology's goals early, often and completely. Ambiguity is rarely helpful.

                                                                                          Ron

Sent: Monday, October 14, 2019 3:07 PM

> That would allay fears that we were about to see an amazing layer violation.

Well P4 is here and folks are getting smarter with their hardware capabilities. My impression is that layer violation is already here - well at least all tools to get there are shipping :)

On Mon, Oct 14, 2019 at 8:54 PM Ron Bonica <[email-masked]<mailto:[email-masked]>> wrote:
Robert,

                                                                     Ron

From: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Sent: Monday, October 14, 2019 2:41 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Cc: SPRING WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-04: Section1

Thx,
R.

In Section 1, you say:

                                                                                 Ron