Subject: [spring] draft-ietf-spring-srv6-network-programming: Section 4.16

From: Ron Bonica <[email-masked]>
Date: Mon, 14 Oct 2019 18:42:16 +0000

Authors,

Lacking the B.INSERT and T.INSERT functions, can you describe a use-case for the PSP and USP flavors of the END, END.X and END.T functions?

                                              Ron

Juniper Business Use Only

---

From: li zhenqiang <[email-masked]>
Date: Tue, 15 Oct 2019 07:32:00 +0000

I suggest this section be removed from this version until the community reaches rough consensus.
Further, the example for PSP in the companion doc srv6-net-pgm-illustration is wrong. PSP is used for END.DT4 in the companion doc while flavors are only defined for END, END.X and END.T in srv6-network-programming.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]

From: Ron Bonica<mailto:rbonica=[email-masked]>
Date: 2019-10-15 02:42
To: SPRING WG List<mailto:[email-masked]>
Subject: [spring] draft-ietf-spring-srv6-network-programming: Section 4.16
Authors,

                                              Ron

---

From: "Wang, Weibin (NSB - CN/Shanghai)" <[email-masked]>
Date: Tue, 15 Oct 2019 08:34:39 +0000

I think PSP description in the draft is right, PSP action is determined and performed by END (.X/.T) SID, not by END.DT4; the PSP pseudocode is defined within END, not in END.DT4; that is not same with MPLS PHP action, the PHP is determined by last HOP signaling “implicit NULL 3”;

--------------------------------------
Cheer !

WANG Weibin

From: spring <[email-masked]> On Behalf Of li zhenqiang
Sent: 2019年10月15日 15:32
To: Ron Bonica <rbonica=[email-masked]>; [email-masked]
Cc: draft-ietf-spring-srv6-network-programming <[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming: Section 4.16

Best Regards,
Zhenqiang Li
________________________________
[email-masked]<mailto:[email-masked]>

From: Ron Bonica<mailto:rbonica=[email-masked]..org>
Date: 2019-10-15 02:42
To: SPRING WG List<mailto:[email-masked]>
Subject: [spring] draft-ietf-spring-srv6-network-programming: Section 4.16
Authors,

                                              Ron

---

From: Ron Bonica <[email-masked]>
Date: Tue, 15 Oct 2019 14:55:55 +0000

+1

Juniper Business Use Only
From: li zhenqiang <[email-masked]>
Sent: Tuesday, October 15, 2019 3:32 AM
To: Ron Bonica <[email-masked]>; [email-masked]
Cc: draft-ietf-spring-srv6-network-programming <[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming: Section 4.16

Best Regards,
Zhenqiang Li

                                              Ron

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Tue, 15 Oct 2019 16:45:30 +0000

Li,

I have replied the technical questions regarding PSP and USP in the email thread from one week ago.
You have not provided any technical concern.

> “Further, the example for PSP in the companion doc srv6-net-pgm-illustration is wrong. PSP is used for END.DT4 in the companion doc while flavors are only defined for END, END.X and END.T in srv6-network-programming.”

The illustration in section 2.8.1 is correct. Please re-read it. PSP is used at node 3 together with the End.X behavior.

Regards,
Pablo.

Replies from one week ago:
https://mailarchive.ietf.org/arch/msg/spring/V0ZpjVLSVZxHaBwecXFxqJjlg_c
https://mailarchive.ietf.org/arch/msg/spring/WrYzRZC0HKVgBYaYMCQVcTWrfak

From: li zhenqiang <[email-masked]>
Date: Tuesday, 15 October 2019 at 09:32
To: Ron Bonica <rbonica=[email-masked]>, "[email-masked]" <[email-masked]>
Cc: draft-ietf-spring-srv6-network-programming <[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming: Section 4.16
Resent from: <[email-masked]>
Resent to: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent date: Tuesday, 15 October 2019 at 09:32

Best Regards,
Zhenqiang Li

                                              Ron

---

From: li zhenqiang <[email-masked]>
Date: Thu, 17 Oct 2019 04:11:00 +0000

Hi Pablo,

I am still confused by the example in section 2.8.1. Node 3 is the destionation of SID B:3:C4::, why should it behave PSP for this SID? While for SID B:8:D100::, it is an END.DT4, the PSP behavior is not defined for this kind of SIDs. Node 3 should not behave PSP for SID B:8:D100::, neither.  Would you please explain node 3 is the penultimate segment hop of which node or which segment? Suppose the behavior is correct, may I know the benifit you gain in this example?

Many Thanks,
Zhenqiang Li

From: Pablo Camarillo (pcamaril)<mailto:[email-masked]>
Date: 2019-10-16 00:45
To: li zhenqiang<mailto:[email-masked]>; Ron Bonica<mailto:rbonica=[email-masked]>; [email-masked]<mailto:[email-masked]>
CC: draft-ietf-spring-srv6-network-programming<mailto:[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming: Section 4.16
Li,

Regards,
Pablo.

Best Regards,
Zhenqiang Li

                                              Ron