Subject: Re: [spring] New Version Notification for draft-matsushima-spring-srv6-deployment-status-02.txt

From: Satoru Matsushima <[email-masked]>
Date: Fri, 18 Oct 2019 11:27:13 +0900

Hi Cameron,

#get back SPRING list again since it is a use case under SR architecture.

> Its seems your scenario could be instructive for us , i think it is generally common to dual-stack the edge first, but LINE has a different path

AFAIK, the IP CLOS fabric in LINE DC also supported IPv4 while it is IPv6-only network which was used to connect the hypervisors with IPv4 addresses using RFC5549 based control-plane solution (i.e, v4 NLRI w/ v6 nhop).

It means that the LINE case is also an incremental SRv6 deployment onto existing IPv6 data-plane.

Cheers,
--satoru

> On Oct 18, 2019, at 11:20, Ca By <[email-masked]> wrote:
> 
> 
> Hirofumi,
> 
> Dropping SPRING since this is strictly an ipv6 question. 
> 
> Do you happen to have a deck about LINE supporting ipv6 on the internet? I notice api.line.me does not have aaaa record. And it is curious that you have the ability to deploy SRv6 internally but not dual-stack client internet services. 
> 
> Its seems your scenario could be instructive for us , i think it is generally common to dual-stack the edge first, but LINE has a different path
>  
> thanks,
> CB
> 
>> On Thu, Oct 17, 2019 at 6:29 PM Hirofumi Ichihara <[email-masked]> wrote:
>> Hi,
>> 
>> Let me introduce LINE's SRv6 DC use case as well. We have already deployed SRv6 network with our private cloud on production environment. Please have a look at this slide( https://speakerdeck.com/line_developers/line-data-center-networking-with-srv6 ) if you're interested in our use case. And also we're interested in other DC use cases and implementations.. Please let me know if you have such information.
>> 
>> Thanks,
>> Hirofumi
>> 
>> 
>> 2019年10月17日(木) 21:31 Lizhenbin <[email-masked]>:
>>> Hi Folks,
>>> We updated the SRv6 deployment draft as follows. There are two new deployments of SRv6 from China for reference: 
>>> China Unicom and CERNET2. In the past two years, China pushed the IPv6 deployment and almost all the IP networks 
>>> of operators achieve the goal "IPv6 Ready". This provide a strong base for SRv6 deployments which can help operators 
>>> provide new services based on IPv6 infrastructure. Moreover the easy incremental deployment advantage of SRv6 (refer 
>>> to https://tools.ietf.org/html/draft-xie-spring-srv6-network-migration-00 ) facilitates the SRv6 deployments in the existing 
>>> network. Besides the SRv6 deployments proposed in the draft, there will be more SRv6 for different application scenariosin 
>>> the near future. These SRv6 deployments  are also promoting the IPv6 deployment and more IPv6 traffic will be beared by 
>>> these networks.  
>>> 
>>> 
>>> 
>>> Best Regards,
>>> Robin
>>> 
>>> 
>>> 
>>> ________________________________________
>>> 发件人: [email-masked] [[email-masked]]
>>> 发送时间: 2019年10月15日 11:15
>>> 收件人: Zafar Ali; Clarence Filsfils; Lizhenbin; Satoru Matsushima
>>> 主题: New Version Notification for draft-matsushima-spring-srv6-deployment-status-02.txt
>>> 
>>> A new version of I-D, draft-matsushima-spring-srv6-deployment-status-02.txt
>>> has been successfully submitted by Zafar Ali and posted to the
>>> IETF repository.
>>> 
>>> Name:           draft-matsushima-spring-srv6-deployment-status
>>> Revision:       02
>>> Title:          SRv6 Implementation and Deployment Status
>>> Document date:  2019-10-14
>>> Group:          Individual Submission
>>> Pages:          19
>>> URL:            https://www.ietf.org/internet-drafts/draft-matsushima-spring-srv6-deployment-status-02.txt
>>> Status:         https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/
>>> Htmlized:       https://tools.ietf.org/html/draft-matsushima-spring-srv6-deployment-status-02
>>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-matsushima-spring-srv6-deployment-status
>>> Diff:           https://www.ietf.org/rfcdiff?url2=draft-matsushima-spring-srv6-deployment-status-02
>>> 
>>> Abstract:
>>>    This draft provides an overview of IPv6 Segment Routing (SRv6)
>>>    deployment status.  It lists various SRv6 features that have been
>>>    deployed in the production networks.  It also provides an overview of
>>>    SRv6 implementation and interoperability testing status.
>>> 
>>> 
>>> 
>>> 
>>> 
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>> 
>>> The IETF Secretariat
>>> --------------------------------------------------------------------
>>> IETF IPv6 working group mailing list
>>> [email-masked]
>>> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
>>> --------------------------------------------------------------------
>> --------------------------------------------------------------------
>> IETF IPv6 working group mailing list
>> [email-masked]
>> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
>> --------------------------------------------------------------------

---

From: Hirofumi Ichihara <[email-masked]>
Date: Fri, 18 Oct 2019 11:58:04 +0900

Hi Cameron,

I believe that we'll support IPv6 for our LINE service on the internet but
it's different from this use case like Satoru mentioned. In this case, we
focus on providing multi-tenant network for our users with SRv6.

Thanks,
Hirofumi

2019年10月18日(金) 11:27 Satoru Matsushima <[email-masked]>:

> Its seems your scenario could be instructive for us , i think it is
> generally common to dual-stack the edge first, but LINE has a different path
>
>
> AFAIK, the IP CLOS fabric in LINE DC also supported IPv4 while it is
> IPv6-only network which was used to connect the hypervisors with IPv4
> addresses using RFC5549 based control-plane solution (i.e, v4 NLRI w/ v6
> nhop).
>
> Do you happen to have a deck about LINE supporting ipv6 on the internet? I
> notice api.line.me does not have aaaa record. And it is curious that you
> have the ability to deploy SRv6 internally but not dual-stack client
> internet services.
>
> Its seems your scenario could be instructive for us , i think it is
> generally common to dual-stack the edge first, but LINE has a different path
>
> thanks,
> CB
>
>> Let me introduce LINE's SRv6 DC use case as well. We have already
>> deployed SRv6 network with our private cloud on production environment.
>> Please have a look at this slide(
>> https://speakerdeck.com/line_developers/line-data-center-networking-with-srv6 )
>> if you're interested in our use case. And also we're interested in other DC
>> use cases and implementations.. Please let me know if you have such
>> information.
>>
>> Thanks,
>> Hirofumi
>>
>>
>>> We updated the SRv6 deployment draft as follows. There are two new
>>> deployments of SRv6 from China for reference:
>>> China Unicom and CERNET2. In the past two years, China pushed the IPv6
>>> deployment and almost all the IP networks
>>> of operators achieve the goal "IPv6 Ready". This provide a strong base
>>> for SRv6 deployments which can help operators
>>> provide new services based on IPv6 infrastructure. Moreover the easy
>>> incremental deployment advantage of SRv6 (refer
>>> to
>>> https://tools.ietf.org/html/draft-xie-spring-srv6-network-migration-00
>>> ) facilitates the SRv6 deployments in the existing
>>> network. Besides the SRv6 deployments proposed in the draft, there will
>>> be more SRv6 for different application scenariosin
>>> the near future. These SRv6 deployments  are also promoting the IPv6
>>> deployment and more IPv6 traffic will be beared by
>>> these networks.
>>>
>>>
>>>
>>> Best Regards,
>>> Robin
>>>
>>>
>>>
>>> 主题: New Version Notification for
>>> draft-matsushima-spring-srv6-deployment-status-02.txt
>>>
>>> A new version of I-D,
>>> draft-matsushima-spring-srv6-deployment-status-02.txt
>>> URL:
>>> https://www.ietf.org/internet-drafts/draft-matsushima-spring-srv6-deployment-status-02.txt
>>> Status:
>>> https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/
>>> Htmlized:
>>> https://tools.ietf.org/html/draft-matsushima-spring-srv6-deployment-status-02
>>> Htmlized:
>>> https://datatracker.ietf.org/doc/html/draft-matsushima-spring-srv6-deployment-status
>>> Diff:
>>> https://www.ietf.org/rfcdiff?url2=draft-matsushima-spring-srv6-deployment-status-02
>>>
>>> Abstract: