Subject: [spring] Draft for Node protection of intermediate nodes in SR Paths

From: Shraddha Hegde <[email-masked]>
Date: Fri, 22 Nov 2019 03:38:15 +0000

WG,

This is the draft I pointed out that talks about solutions for providing node-protection.
It covers Anycast case as well as keeping forwarding plane longer.
https://tools.ietf.org/html/draft-hegde-spring-node-protection-for-sr-te-paths-05

Review and comments solicited.

Rgds
Shraddha

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 22 Nov 2019 10:22:34 +0100

Hi Shraddha,

I have one question to the document.

As you know the critical element for the effective protection of any scheme
is the failure detection. On that your draft seems to have just one little
paragraph:

   Note that R7 activates the node-protecting backup path when it
   detects that the link to R8 has failed.  R7 does not know that node
   R8 has actually failed.  However, the node-protecting backup path is
   computed assuming that the failure of the link to R8 implies that R8
   has failed.

Well IMO this is not enough. Specifically there can be a lot of types of
node failure when link is still up. Moreover there can be even running BFD
across the link just fine when say fabric failure occurs at R8.

While this is not solely issue with this draft, it is our common IETF
failure to provide correct means of detecting end to end path or fragments
of path failures (I am specifically not calling them segment here :).

For example I propose that to effectively detect R8 failure as node failure
which is the topic of your proposal a mechanism is clearly defined and
includes bi-dir data plane probes send between R7-R9, R3-R7, R4-R7, R4-R9,
R3-R9

Many thx,
Robert.

On Fri, Nov 22, 2019 at 4:38 AM Shraddha Hegde <shraddha=
[email-masked]> wrote:

> *https://tools.ietf.org/html/draft-hegde-spring-node-protection-for-sr-te-paths-05*
> <https://tools.ietf.org/html/draft-hegde-spring-node-protection-for-sr-te-paths-05>
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Sat, 23 Nov 2019 09:00:15 +0000

Shraddha, Robert and all,
Regarding Robert's question:
I wonder if multi-hop IP BFD session with addresses used as /32 (or /128) prefixes serving as Nose SIDs of R8 and R7 respectively could be used as such a trigger by R7? Such a session would not respond to link failures, and I find it problematic to imagine a scenario when it would be kept UP in the case of a real node failure.

Of course such a session would have to be slow enough not to react to link failures. But it still couks be much faster than IGP conversion IMHO.

My 2c,
Sasha

Such

Get Outlook for Android<https://aka.ms/ghei36>

________________________________
From: spring <[email-masked]> on behalf of Robert Raszuk <[email-masked]>
Sent: Friday, November 22, 2019, 11:22
To: Shraddha Hegde
Cc: [email-masked]; [email-masked]
Subject: Re: [spring] Draft for Node protection of intermediate nodes in SR Paths

Hi Shraddha,

As you know the critical element for the effective protection of any scheme is the failure detection. On that your draft seems to have just one little paragraph:

Well IMO this is not enough. Specifically there can be a lot of types of node failure when link is still up. Moreover there can be even running BFD across the link just fine when say fabric failure occurs at R8.

While this is not solely issue with this draft, it is our common IETF failure to provide correct means of detecting end to end path or fragments of path failures (I am specifically not calling them segment here :).

For example I propose that to effectively detect R8 failure as node failure which is the topic of your proposal a mechanism is clearly defined and includes bi-dir data plane probes send between R7-R9, R3-R7, R4-R7, R4-R9, R3-R9

Many thx,
Robert.

On Fri, Nov 22, 2019 at 4:38 AM Shraddha Hegde <shraddha=[email-masked]..org<mailto:[email-masked]>> wrote:
WG,

This is the draft I pointed out that talks about solutions for providing node-protection.
It covers Anycast case as well as keeping forwarding plane longer.
https://tools.ietf.org/html/draft-hegde-spring-node-protection-for-sr-te-paths-05<https://clicktime.symantec.com/375SW6TBGPi2mN7V9YeVWGg6H2?u=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-hegde-spring-node-protection-for-sr-te-paths-05>

Rgds
Shraddha

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg<https://clicktime.symantec.com/35M9j5zHTaSYRwVh5RP6xcB6H2?u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg>

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 23 Nov 2019 11:37:33 +0100

Hi Sasha,

On the surface your suggestion may look cool - but if you zoom in - I do
not think it will work in practice.

See - one of the biggest value of BFD is its offload to line card's
hardware. And in most cases it is ingress line card to the box. So if you
instruct such hardware to respond to SID address loopback you still did not
gain much in terms of detection router's fabric failures, remote LC failure
or control plane issues which could soon result in box failure. The
catalogue of router failures is of course much more colorful.

If you ask BFD to be responded by RP/RE it no longer has the BFD advantage.

IMHO the best way to detect node failure is actually to send the probes
*across* the node under test to its peers.

The way I would think of establishing such m-hop sessions would be fully
automated with one knob per IGP adj. ex: "bfd detect-node-failure [max N]"
where local BFD subsystem would create N sessions to IGP peers of the node
we are to protect. LSDB has those peers so no new protocol extension is
needed, perhaps even no new IETF draft is required :). N would be the limit
of such sessions in case the node under protection has say 10s of peers.
Default could be perhaps even 1.

Thx,
Robert.

On Sat, Nov 23, 2019 at 10:00 AM Alexander Vainshtein <
[email-masked]> wrote:

> I wonder if multi-hop IP BFD session with addresses used as /32 (or /128)
> prefixes serving as Nose SIDs of R8 and R7 respectively could be used as
> such a trigger by R7? Such a session would not respond to link failures,
> and I find it problematic to imagine a scenario when it would be kept UP in
> the case of a real node failure.
>
> Of course such a session would have to be slow enough not to react to link
> failures. But it still couks be much faster than IGP conversion IMHO.
>
> My 2c,
> Sasha
>
> Such
>
>
> Get Outlook for Android <https://aka.ms/ghei36>
>
> ------------------------------
> *From:* spring <[email-masked]> on behalf of Robert Raszuk <
> [email-masked]>
> *Sent:* Friday, November 22, 2019, 11:22
> *To:* Shraddha Hegde
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [spring] Draft for Node protection of intermediate nodes
> in SR Paths
>
> Hi Shraddha,
>
> As you know the critical element for the effective protection of any
> scheme is the failure detection. On that your draft seems to have just one
> little paragraph:
>
> For example I propose that to effectively detect R8 failure as node
> failure which is the topic of your proposal a mechanism is clearly defined
> and includes bi-dir data plane probes send between R7-R9, R3-R7, R4-R7,
> R4-R9, R3-R9
>
> Many thx,
> Robert.
>
>
> [email-masked]..org <[email-masked]>> wrote:
>
>> WG,
>>
>> <https://clicktime.symantec.com/375SW6TBGPi2mN7V9YeVWGg6H2?u=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-hegde-spring-node-protection-for-sr-te-paths-05>
>>
>> <https://clicktime.symantec.com/35M9j5zHTaSYRwVh5RP6xcB6H2?u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg>
>
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Sat, 23 Nov 2019 11:15:23 +0000

Robert,
Lots of thanks for a prompt response.

I respectfully disagree with your statement that BFD implementation  is usually offloaded to the HW of the ingress line card.  I do not think this can wor for MH BFD sessions because the ingress and egress line cards are not known in advance and change with the routing changes
A good  multi-hop BFD implementation should be ready to overcome this. There are many ways to achieve that. A naive implementation that runs in SW of the control card is also possible of course. And they would sensd and receive packets

My 2c.

________________________________
From: Robert Raszuk <[email-masked]>
Sent: Saturday, November 23, 2019, 12:37
To: Alexander Vainshtein; Shraddha Hegde
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [spring] Draft for Node protection of intermediate nodes in SR Paths

Hi Sasha,

On the surface your suggestion may look cool - but if you zoom in - I do not think it will work in practice.

See - one of the biggest value of BFD is its offload to line card's hardware. And in most cases it is ingress line card to the box. So if you instruct such hardware to respond to SID address loopback you still did not gain much in terms of detection router's fabric failures, remote LC failure or control plane issues which could soon result in box failure. The catalogue of router failures is of course much more colorful.

IMHO the best way to detect node failure is actually to send the probes *across* the node under test to its peers.

The way I would think of establishing such m-hop sessions would be fully automated with one knob per IGP adj. ex: "bfd detect-node-failure [max N]" where local BFD subsystem would create N sessions to IGP peers of the node we are to protect. LSDB has those peers so no new protocol extension is needed, perhaps even no new IETF draft is required :). N would be the limit of such sessions in case the node under protection has say 10s of peers. Default could be perhaps even 1.

Thx,
Robert.

On Sat, Nov 23, 2019 at 10:00 AM Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:
Shraddha, Robert and all,
Regarding Robert's question:
I wonder if multi-hop IP BFD session with addresses used as /32 (or /128) prefixes serving as Nose SIDs of R8 and R7 respectively could be used as such a trigger by R7? Such a session would not respond to link failures, and I find it problematic to imagine a scenario when it would be kept UP in the case of a real node failure.

My 2c,
Sasha

Such

Get Outlook for Android<https://clicktime.symantec.com/3CfVQPtBYBAPbHUSngEVNQD6H2?u=https%3A%2F%2Faka.ms%2Fghei36>

________________________________
From: spring <[email-masked]<mailto:[email-masked]>> on behalf of Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Sent: Friday, November 22, 2019, 11:22
To: Shraddha Hegde
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] Draft for Node protection of intermediate nodes in SR Paths

Hi Shraddha,

Many thx,
Robert.

Rgds
Shraddha

---

From: Alexander Vainshtein <[email-masked]>
Date: Sat, 23 Nov 2019 14:44:53 +0000

Robert,
On the second thought, for the purpose of this draft (i.e. in the scope of SR) it is possible to implement your suggestion by running S-BFD sessions between R7 (as the initiator) and each other adjacency of R8  (acting as Reflectors) of a SR policy with list of two SIDs:
- protected adjacency between R7 and R8
- Node SID of the specific "other" adjacency  of R8.

If all these sessions fail, R7 can reliably consider R8 as failed.

I am not sure this would be much better than multi-hop IP BFD, and it looks much more complicated to me.

What do you think?

________________________________
From: Alexander Vainshtein <[email-masked]>
Sent: Saturday, November 23, 2019, 13:15
To: Robert Raszuk; Shraddha Hegde
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [spring] Draft for Node protection of intermediate nodes in SR Paths

Robert,

My 2c.

Hi Sasha,

Thx,
Robert.

My 2c,
Sasha

Such

Hi Shraddha,

Many thx,
Robert.

Rgds
Shraddha

---

From: Alexander Vainshtein <[email-masked]>
Date: Sat, 23 Nov 2019 15:14:12 +0000

And coming back to the draft in question:
I think that it is about thecprotection action itself, anf this action may be triggered by different events.

This approach has been taken in the MPLS Egress Protection Framework<https://datatracker.ietf.org/doc/draft-ietf-mpls-egress-protection-framework/> draft (now in the RFC Editor queue).

Sent: Saturday, November 23, 2019, 16:44

Robert,

What do you think?

Robert,

My 2c.

Hi Sasha,

Thx,
Robert.

My 2c,
Sasha

Such

Hi Shraddha,

Many thx,
Robert.

Rgds
Shraddha