Subject: [spring] draft-ietf-spring-srv6-network-programming-05

From: Parag Kaneriya <[email-masked]>
Date: Wed, 20 Nov 2019 05:18:18 +0000

Hello,

For a Single SID:
Endpoint behavior having "End SID with flavors USP&USD"  how to support.
Among USP, USD which must be given priority while processing the packet ?

For both of them precondition is
If (Segments Left == 0) {

As per my understanding  setting  "Single SID" having USP and USD flavor is not appropriate.

Thanks,

Juniper Business Use Only

---

From: "Wang, Weibin (NSB - CN/Shanghai)" <[email-masked]>
Date: Wed, 20 Nov 2019 06:22:46 +0000

I also have the same doubt on it;
It May be:
If (SL==0) {
If (NH=SRH) {
then POP current SRH   /**USP**/
     }
Else (NH=41 || 4) {
Then do Decapsulation outer IPx header   /**USD**/
         }
--------------------------------------
Cheers !

WANG Weibin

From: spring <[email-masked]> On Behalf Of Parag Kaneriya
Sent: 2019年11月20日 13:18
To: SPRING WG List <[email-masked]>
Cc: Rajesh M <[email-masked]>; [email-masked]; [email-masked]
Subject: [spring] draft-ietf-spring-srv6-network-programming-05

Hello,

For a Single SID:

As per my understanding  setting  “Single SID” having USP and USD flavor is not appropriate.

Thanks,

---

From: Parag Kaneriya <[email-masked]>
Date: Wed, 20 Nov 2019 07:56:26 +0000

Wouldn’t pseudo code lead to same issue ?  As per me ,  NH would be pointing to SRH when DA is local address.  NH value may not reflect SRH header “next header”.

Regards
Parag

Juniper Business Use Only
From: spring <[email-masked]> On Behalf Of Wang, Weibin (NSB - CN/Shanghai)
Sent: Wednesday, November 20, 2019 2:23 PM
To: Parag Kaneriya <pkaneria=[email-masked]>; SPRING WG List <[email-masked]>
Cc: Rajesh M <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming-05

WANG Weibin

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Parag Kaneriya
Sent: 2019年11月20日 13:18
To: SPRING WG List <[email-masked]<mailto:[email-masked]>>
Cc: Rajesh M <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [spring] draft-ietf-spring-srv6-network-programming-05

Hello,

For a Single SID:

Thanks,

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Fri, 22 Nov 2019 08:45:00 +0000

Parag, Rajesh,

Thanks for your comments and we are happy to have the offline discussions with you on implementation details during this week. For the benefit of the WG, I would like to summarize as follows:

The USP and USD flavors are complementary to each other. They can be active together or individually for a given SID.

An implementation may optimise the packet processing by looking whether the conditions for the USD flavor are met, in which case it can proceed with USD processing, else trigger USP.

Thanks,
Pablo

From: Parag Kaneriya <[email-masked]>
Date: Wednesday, 20 November 2019 at 13:18
To: SPRING WG List <[email-masked]>
Cc: "Pablo Camarillo (pcamaril)" <[email-masked]>, "cf(mailer list)" <[email-masked]>, Rajesh M <[email-masked]>
Subject: draft-ietf-spring-srv6-network-programming-05

Hello,

For a Single SID:

Thanks,

---

From: Rajesh M <[email-masked]>
Date: Mon, 25 Nov 2019 04:15:25 +0000

Thanks Pablo.

"An implementation may optimise the packet processing by looking whether the conditions for the USD flavor are met, in which case it can proceed with USD processing, else trigger USP"

Please update the network programming draft for the same.

Juniper Business Use Only
From: Pablo Camarillo (pcamaril) <[email-masked]>
Sent: Friday, November 22, 2019 2:15 PM
To: Parag Kaneriya <[email-masked]>; SPRING WG List <[email-masked]>
Cc: cf(mailer list) <[email-masked]>; Rajesh M <[email-masked]>
Subject: Re: draft-ietf-spring-srv6-network-programming-05

Parag, Rajesh,

Thanks,
Pablo

From: Parag Kaneriya <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 20 November 2019 at 13:18
To: SPRING WG List <[email-masked]<mailto:[email-masked]>>
Cc: "Pablo Camarillo (pcamaril)" <[email-masked]<mailto:[email-masked]>>, "cf(mailer list)" <[email-masked]<mailto:[email-masked]>>, Rajesh M <[email-masked]<mailto:[email-masked]>>
Subject: draft-ietf-spring-srv6-network-programming-05

Hello,

For a Single SID:

Thanks,