Subject: [spring] Request for WG review and adoption of draft-li-spring-srv6-path-segment-04.txt

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 6 Nov 2019 13:38:09 +0000

Hi SPRING,

We just updated the draft-li-spring-srv6-path-segment, major updates:

* add text to clarify why do we need SRv6 Path Segment: 
   
   The segment list may not be a good key to identify an SRv6
   path, since the the length of segment list is flexible according to
   the number of SIDs.  Also, the length of SID list will be too long to
   be a key when it contains many SIDs.  For instance, if packet A uses
   the SRH with 3 SIDs while Packet B uses the SRH with 10 SIDs, the key
   to identify these two paths will be a 384-bits value and a 1280-bits
   value.  A fixed length Path ID at a fixed location will help in processing performance.

* move encoding part to draft-li-6man-srv6-path-segment-encap-01

Since the text of this document is stable and mature, we hope to have a WG review, and we request for WG adoption.
Any questions or comments are welcome!

Best regards,
Cheng

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, November 04, 2019 10:53 PM
To: Rakesh Gandhi <[email-masked]>; Lizhenbin <[email-masked]>; Weiqiang Cheng <[email-masked]>; Dhruv Dhody <[email-masked]>; Mach Chen <[email-masked]>; Dongjie (Jimmy) <[email-masked]>; Mach Chen <[email-masked]>; Chengli (Cheng Li) <[email-masked]>
Subject: New Version Notification for draft-li-spring-srv6-path-segment-04.txt

A new version of I-D, draft-li-spring-srv6-path-segment-04.txt
has been successfully submitted by Cheng Li and posted to the IETF repository.

Name:		draft-li-spring-srv6-path-segment
Revision:	04
Title:		Path Segment for SRv6 (Segment Routing in IPv6)
Document date:	2019-11-04
Group:		Individual Submission
Pages:		9
URL:            https://www.ietf.org/internet-drafts/draft-li-spring-srv6-path-segment-04.txt
Status:         https://datatracker.ietf.org/doc/draft-li-spring-srv6-path-segment/
Htmlized:       https://tools.ietf.org/html/draft-li-spring-srv6-path-segment-04
Htmlized:       https://datatracker.ietf.org/doc/html/draft-li-spring-srv6-path-segment
Diff:           https://www.ietf.org/rfcdiff?url2=draft-li-spring-srv6-path-segment-04

Abstract:
   Segment Routing (SR) allows for a flexible definition of end-to-end
   paths by encoding paths as sequences of sub-paths, called "segments".
   Segment routing architecture can be implemented over an MPLS data
   plane as well as an IPv6 data plane.

   Further, Path Segment has been defined in order to identify an SR
   path in SR-MPLS networks, and used for various use-cases such as end-
   to-end SR Path Protection and Performance Measurement (PM) of an SR
   path.  Similar to SR-MPLS, this document defines the Path Segment in
   SRv6 networks in order to identify an SRv6 path.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Tue, 12 Nov 2019 12:42:02 +0800

Hi Group,
>From carriers' point view, the application scenario for the Path Segment is
valid. It can provide some important functions as follows.
1. E2E performance monitoring. SID list information does not always include
all the information of the Path, for example the reduce mode. Even if the
SID list carries all the path information, it is too long in terms of
implementation.
2.Based on the path segment, we can provide such as bi-directional LSP
easily.

B.R.
Weiqiang Cheng

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Chengli (Cheng
Li)
Sent: Wednesday, November 06, 2019 9:38 PM
To: 'SPRING WG List' <[email-masked]>
Subject: [spring] Request for WG review and adoption of
draft-li-spring-srv6-path-segment-04.txt

Hi SPRING,

   
   value.  A fixed length Path ID at a fixed location will help in
processing performance.

Since the text of this document is stable and mature, we hope to have a WG
review, and we request for WG adoption.
Any questions or comments are welcome!

Best regards,
Cheng

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, November 04, 2019 10:53 PM
To: Rakesh Gandhi <[email-masked]>; Lizhenbin <[email-masked]>;
Weiqiang Cheng <[email-masked]>; Dhruv Dhody
<[email-masked]>; Mach Chen <[email-masked]>; Dongjie (Jimmy)
<[email-masked]>; Mach Chen <[email-masked]>; Chengli (Cheng Li)
<[email-masked]>
Subject: New Version Notification for
draft-li-spring-srv6-path-segment-04.txt

A new version of I-D, draft-li-spring-srv6-path-segment-04.txt
has been successfully submitted by Cheng Li and posted to the IETF
repository.

Name:		draft-li-spring-srv6-path-segment
Revision:	04
Title:		Path Segment for SRv6 (Segment Routing in IPv6)
Document date:	2019-11-04
Group:		Individual Submission
Pages:		9
URL:
https://www.ietf.org/internet-drafts/draft-li-spring-srv6-path-segment-04.tx
t
Status:
https://datatracker.ietf.org/doc/draft-li-spring-srv6-path-segment/
Htmlized:
https://tools.ietf.org/html/draft-li-spring-srv6-path-segment-04
Htmlized:
https://datatracker.ietf.org/doc/html/draft-li-spring-srv6-path-segment
Diff:
https://www.ietf.org/rfcdiff?url2=draft-li-spring-srv6-path-segment-04

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring