Subject: [spring] draft-ietf-spring-srv6-network-programming-05

From: Rajesh M <[email-masked]>
Date: Wed, 20 Nov 2019 04:41:26 +0000

How about adding PSD flavor (Penultimate Segment Decapsulation) ?

For TILFA some of the implementation might support Encapsulation Mode rather than insert mode.
In such cases PSD favor is of use, where at the Penultimate hop itself we remove both
Ipv6 header as well as SRH header added for TILFA purpose.

Juniper Business Use Only

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Fri, 22 Nov 2019 08:41:39 +0000

Rajesh,

Thanks for taking the time to discuss this requirement with the co-authors during this week. For the benefit of the WG, I would like to summarize as follows:

Your request for introducing PSD is actually asking for removing the outer IPv6 header encap before its destination and propagating the last segment from the outer header to the DA of the inner header. This is complex and goes against encap/tunnelling techniques.

Thanks,
Pablo

From: Rajesh M <[email-masked]>
Date: Wednesday, 20 November 2019 at 12:41
To: SPRING WG <[email-masked]>
Cc: "Pablo Camarillo (pcamaril)" <[email-masked]>, "cf(mailer list)" <[email-masked]>
Subject: draft-ietf-spring-srv6-network-programming-05