Subject: [spring] hop limit decrement on SRv6 proxies

From: Ryo Nakamura <[email-masked]>
Date: Sun, 3 Nov 2019 18:48:02 +0100

Dear authors of sr-service-programming daft,

Through an experiment of SRv6 service chaining, we found that there were variations on hop limit decrement behaviors of SRv6 proxies, as noted in Section 4.4 in draft-upa-srv6-service-chaining-exp. An implementation decreases hop limit of IPv6 headers when sending packets to IFACE-OUT, and another implementation does not decrease it on IFACE-OUT. Thus, hop limit values of packets varied depending on the proxy implementations.

These variations would complicate traceroute results, for instance. Thus, we suggest clarifying how to decrement hop limit in the sr-service-programming draft. Should one proxying decrement hop limit twice or once?

Regards,
Ryo Nakamura

---

From: "Francois Clad (fclad)" <[email-masked]>
Date: Tue, 5 Nov 2019 17:52:50 +0000

Dear Nakamura-san,

Many thanks for reviewing this draft and experimenting on SRv6 service chaining.

I understand that the current version of the draft is not very clear regarding IPv6 hop limit updates and will work towards improving this aspect in the next revision of the draft.

In the specific case of the SRv6 masquerading proxy (End.AM) that you mention in section 4.4 of draft-upa-srv6-service-chaining-exp, each traversal of the proxy is one IP hop. The proper behavior should thus be to decrement the hop limit each time the packet traverses the proxy.

Regards,
Francois

On 03/11/2019 18:48, "spring on behalf of Ryo Nakamura" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Regards,
    Ryo Nakamura
    _______________________________________________
    spring mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spring