Subject: [spring] SPRING SRv6 Deployment Status draft

From: David Melman <[email-masked]>
Date: Wed, 6 Nov 2019 09:19:45 +0000

Hi Zefar, Satoru.

Marvell's Prestera Falcon CX 8500 family of Ethernet switches supports SRv6 features, including processing of the SRH as described in [I-D.ietf-6man-segment-routing-header].

In the next draft of  https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/, please add to the section "Additional Routing platforms":

  *   Marvell
     *   Hardware implementation in the Prestera Falcon CX 8500 family of Ethernet switches

Thanks!
David Melman

---

From: 松嶋聡 <[email-masked]>
Date: Wed, 6 Nov 2019 02:53:36 -0800

Thanks David, that’s a good news !

Yes we’ll capture it in the next revision.

Best regards,

Sent from my iPhone

2019/11/06 18:19、David Melman <[email-masked]>のメール:

Hi Zefar, Satoru.

Marvell’s Prestera Falcon CX 8500 family of Ethernet switches supports SRv6
features, including processing of the SRH as described in
[I-D.ietf-6man-segment-routing-header].

In the next draft of
https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/,
please add to the section “Additional Routing platforms”:

   - Marvell
      - Hardware implementation in the Prestera Falcon CX 8500 family of
      Ethernet switches

Thanks!

David Melman

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Thu, 7 Nov 2019 02:28:29 +0000

Hi Satoru, Zafar,

We are announcing another deployment of SRv6. MTN has deployed SRv6, as described below.
Can you please also update the SRv6 deployment draft with the following details?

“
As part of the complete mobile IP network, Uganda MTN has deployed a SRv6 network that carries all services in its backbone.
The following SRv6 features have been deployed:
o A Segment Routing Header [I-D.ietf-6man-segment-routing-header<https://tools.ietf.org/html/draft-matsushima-spring-srv6-deployment-status-02#ref-I-D.ietf-6man-segment-routing-header>] based data plane.
o End, End.X, End.DT4, End.DX2, End.dt2u, End.dt2m functions as per [I-D.ietf-spring-srv6-network-programming].
o BGP VPN SRv6 extensions [I-D.dawra-bess-srv6-services<https://tools.ietf.org/html/draft-matsushima-spring-srv6-deployment-status-02#ref-I-D.dawra-bess-srv6-services>].
o Topology Independent (TI-LFA) Fast Reroute mechanisms leveraging SRv6 for the O(50msec)  protection against node and link, as described in [I-D.ietf-rtgwg-segment-routing-ti-lfa<https://tools.ietf.org/html/draft-matsushima-spring-srv6-deployment-status-02#ref-I-D.ietf-rtgwg-segment-routing-ti-lfa>].
o BGP Prefix Independent Convergence (PIC) core and edge [I-D.ietf-rtgwg-bgp-pic].
o Support for Ping and Traceroute as defined in [I-D.ietf-6man-spring-srv6-oam].
”

Best Regards,
Shuping

From: spring [mailto:[email-masked]] On Behalf Of 松嶋聡
Sent: Wednesday, November 06, 2019 6:54 PM
To: David Melman <[email-masked]>
Cc: [email-masked]; Zafar Ali (zali) <[email-masked]>
Subject: Re: [spring] SPRING SRv6 Deployment Status draft

Best regards,
Sent from my iPhone

2019/11/06 18:19、David Melman <[email-masked]<mailto:[email-masked]>>のメール:

Hi Zefar, Satoru.

Marvell’s Prestera Falcon CX 8500 family of Ethernet switches supports SRv6 features, including processing of the SRH as described in [I-D.ietf-6man-segment-routing-header].

In the next draft of  https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/, please add to the section “Additional Routing platforms”:

  *   Marvell

Thanks!
David Melman

---

From: Satoru Matsushima <[email-masked]>
Date: Thu, 7 Nov 2019 18:35:37 +0900

Thanks Shuping, good to hear that new deployment!

Yes, will capture it in the next revision too.

cheers,
--satoru

> On Nov 7, 2019, at 11:28, Pengshuping (Peng Shuping) <[email-masked]> wrote:
> 
> 
> Hi Satoru, Zafar,
>  
> o A Segment Routing Header [I-D.ietf-6man-segment-routing-header] based data plane.
> o BGP VPN SRv6 extensions [I-D.dawra-bess-srv6-services].
> o Topology Independent (TI-LFA) Fast Reroute mechanisms leveraging SRv6 for the O(50msec)  protection against node and link, as described in [I-D.ietf-rtgwg-segment-routing-ti-lfa].
> Marvell
> Hardware implementation in the Prestera Falcon CX 8500 family of Ethernet switches
>  
> Thanks!
> David Melman

---

From: Satoru Matsushima <[email-masked]>
Date: Mon, 18 Nov 2019 08:20:07 +0800

Hi David, Shuping,

As your inputs, Marvel and MTN cases have been captured in the SRv6 deployment status draft. Please check it out from the following i-d announce. 

Thank you for your contribution!

Best regards,
--satoru

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : SRv6 Implementation and Deployment Status
>        Authors         : Satoru Matsushima
>                          Clarence Filsfils
>                          Zafar Ali
>                          Zhenbin Li
>    Filename        : draft-matsushima-spring-srv6-deployment-status-03.txt
>    Pages           : 20
>    Date            : 2019-11-16
> 
> Abstract:
>   This draft provides an overview of IPv6 Segment Routing (SRv6)
>   deployment status.  It lists various SRv6 features that have been
>   deployed in the production networks.  It also provides an overview of
>   SRv6 implementation and interoperability testing status.
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-matsushima-spring-srv6-deployment-status-03
> https://datatracker.ietf.org/doc/html/draft-matsushima-spring-srv6-deployment-status-03
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-matsushima-spring-srv6-deployment-status-03
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

>> On Nov 7, 2019, at 17:35, Satoru Matsushima <[email-masked]> wrote: