Subject: [spring] FW: New Version Notification for draft-bonica-spring-sr-mapped-six-00.txt

From: Ron Bonica <[email-masked]>
Date: Tue, 19 Nov 2019 18:14:45 +0000

Juniper Business Use Only

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Tuesday, November 19, 2019 1:09 PM
To: Ron Bonica <[email-masked]>; Shraddha Hegde <[email-masked]>; Andrew Alston <[email-masked]>; Gang Chen <[email-masked]>; Joel Halpern <[email-masked]>; Andrew Alston <[email-masked]>; Luay Jalil <[email-masked]>; Yuji Kamite <[email-masked]>; Jen Linkova <[email-masked]>; Daniam Henriques <[email-masked]>
Subject: New Version Notification for draft-bonica-spring-sr-mapped-six-00.txt

A new version of I-D, draft-bonica-spring-sr-mapped-six-00.txt
has been successfully submitted by Ron Bonica and posted to the IETF repository.

Name:		draft-bonica-spring-sr-mapped-six
Revision:	00
Title:		Segment Routing Mapped To IPv6 (SRm6)
Document date:	2019-11-19
Group:		Individual Submission
Pages:		24
URL:            https://tools.ietf.org/html/draft-bonica-spring-sr-mapped-six-00

Abstract:
   This document describes Segment Routing mapped to IPv6 (SRm6).  SRm6
   is a Segment Routing (SR) solution that leverages IPv6.  It supports
   a wide variety of use-cases while remaining in strict compliance with
   IPv6 specifications.  SRm6 is optimized for ASIC-based forwarding
   devices that operate at high data rates.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 20 Nov 2019 15:30:37 +0100

Hi Ron,

I must first say that this is very cleanly written draft ... easy read !

But after reading it now I have one major question - what document/spec
function is this draft attempts to serve ?

Is it new SR Architecture ? Normative references still refers to RFC8402,
but its body is clearly not compliant with it.  Not sure if this is
omission or intentional.

It redefines fundamental RFC8402 definitions - for example it redefines
SRv6 prefix SID.

*3.1.3.  SRv6   When SR is used over the IPv6 data plane:   o  A Prefix-SID
is an IPv6 address.*

So please could you share what is the intended role of this draft ? At
this point I do not see that it is aiming to update RFC8402, but just
define a new set of encodings which contradict directly with it.

Many thx,
R.

On Tue, Nov 19, 2019 at 7:14 PM Ron Bonica <rbonica=
[email-masked]> wrote:

> To: Ron Bonica <[email-masked]>; Shraddha Hegde <[email-masked]>;
> Andrew Alston <[email-masked]>; Gang Chen <
> [email-masked]>; Joel Halpern <[email-masked]>; Andrew
> Alston <[email-masked]>; Luay Jalil <
> [email-masked]>; Yuji Kamite <[email-masked]>; Jen Linkova <
> [email-masked]>; Daniam Henriques <[email-masked]>
> URL:
> https://tools.ietf.org/html/draft-bonica-spring-sr-mapped-six-00
>
>
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Ron Bonica <[email-masked]>
Date: Sat, 23 Nov 2019 23:59:20 +0000

Robert,

Good to hear from you and thanks for the complement.

Your question goes to the heart of the SR and IPv6 debate and will require more than an email to answer. Standby for a document in the next few weeks.

                                                                         Ron

From: spring <[email-masked]> On Behalf Of Robert Raszuk
Sent: Wednesday, November 20, 2019 9:31 AM
To: Ron Bonica <rbonica=[email-masked]>
Cc: SPRING WG <[email-masked]>
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-sr-mapped-six-00.txt

Hi Ron,

But after reading it now I have one major question - what document/spec function is this draft attempts to serve ?

Is it new SR Architecture ? Normative references still refers to RFC8402, but its body is clearly not compliant with it.  Not sure if this is omission or intentional.

It redefines fundamental RFC8402 definitions - for example it redefines SRv6 prefix SID.

3.1.3.  SRv6
   When SR is used over the IPv6 data plane:
   o  A Prefix-SID is an IPv6 address.

So please could you share what is the intended role of this draft ? At this point I do not see that it is aiming to update RFC8402, but just define a new set of encodings which contradict directly with it.

Many thx,
R.

On Tue, Nov 19, 2019 at 7:14 PM Ron Bonica <rbonica=[email-masked]<mailto:[email-masked]>> wrote:

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, November 19, 2019 1:09 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; Andrew Alston <[email-masked]<mailto:[email-masked]>>; Gang Chen <[email-masked]<mailto:[email-masked]>>; Joel Halpern <[email-masked]<mailto:[email-masked]>>; Andrew Alston <[email-masked]<mailto:[email-masked]>>; Luay Jalil <[email-masked]<mailto:[email-masked]>>; Yuji Kamite <[email-masked]<mailto:[email-masked]>>; Jen Linkova <[email-masked]<mailto:[email-masked]>>; Daniam Henriques <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-bonica-spring-sr-mapped-six-00.txt

URL:            https://tools.ietf.org/html/draft-bonica-spring-sr-mapped-six-00<https://urldefense.com/v3/__https:/tools.ietf..org/html/draft-bonica-spring-sr-mapped-six-00__;!8WoA6RjC81c!W7gGBVD-zguqgZLZW2uxuDeKdGYsUfArP249qioRggS0G3cTwNzP5PlkgaTxZF_w$>

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!8WoA6RjC81c!W7gGBVD-zguqgZLZW2uxuDeKdGYsUfArP249qioRggS0G3cTwNzP5PlkgbRjvgCw$>.

The IETF Secretariat
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!8WoA6RjC81c!W7gGBVD-zguqgZLZW2uxuDeKdGYsUfArP249qioRggS0G3cTwNzP5PlkgVRm0Fb5$>

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 24 Nov 2019 01:29:07 +0100

Hi Ron,

I am not sure if there is any ongoing debate. To me this all boils down to
a very simple
few questions which can be summarized as below:

*Q1: Do we want to enable services (VPN, TE, SFC ....) over native single
unified *
*       IPv/v6 transport ?*

     If No - end of the debate - use currently shipping tools.
     If Yes - then

          *Q2 - Do we want to complicate networks with new mapping
schema (considering *
*                  we already have one shipping SR-MPLS over IPv4/v6) ?*

                If No - end of the debate - use SR-MPLS over IP or MPLS
over IP.
                If Yes - then

*                     Q3 - Are we open for combined control plane **solution
with fixed low overhead ? *

                          If Yes - Pls consider LISP
or draft-raszuk-teas-ip-te-np
                          If No - why ?

Best,
Robert.

On Sun, Nov 24, 2019 at 12:59 AM Ron Bonica <[email-masked]> wrote:

> Your question goes to the heart of the SR and IPv6 debate and will require
> more than an email to answer. Standby for a document in the next few weeks.
>
>
>
>
>                                                      Ron
>
>
>
>
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *Robert Raszuk
> *Sent:* Wednesday, November 20, 2019 9:31 AM
> *To:* Ron Bonica <rbonica=[email-masked]>
> *Cc:* SPRING WG <[email-masked]>
> *Subject:* Re: [spring] FW: New Version Notification for
> draft-bonica-spring-sr-mapped-six-00.txt
>
>
>
> Hi Ron,
>
>
>
> *3.1.3.  SRv6    When SR is used over the IPv6 data plane:    o  A
> Prefix-SID is an IPv6 address.*
>
>
>
> <https://urldefense.com/v3/__https:/tools.ietf..org/html/draft-bonica-spring-sr-mapped-six-00__;!8WoA6RjC81c!W7gGBVD-zguqgZLZW2uxuDeKdGYsUfArP249qioRggS0G3cTwNzP5PlkgaTxZF_w$>
>
>
>
> Abstract:
> tools.ietf.org
> <https://urldefense.com/v3/__http:/tools.ietf.org__;!8WoA6RjC81c!W7gGBVD-zguqgZLZW2uxuDeKdGYsUfArP249qioRggS0G3cTwNzP5PlkgbRjvgCw$>
> .
>
> The IETF Secretariat
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!8WoA6RjC81c!W7gGBVD-zguqgZLZW2uxuDeKdGYsUfArP249qioRggS0G3cTwNzP5PlkgVRm0Fb5$>
>
>
>