Subject: [spring] Update and request to adopt draft-dong-spring-sr-for-enhanced-vpn

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 16 Dec 2019 10:36:22 +0000

Dear WG, 

We just submitted a new revision of draft-dong-spring-sr-for-enhanced-vpn to solve the comments and suggestions received both during IETF106 and on the mail list.

The major changes are:

1. Following the chairs' suggestion, we reduced the description about network slicing and enhanced VPN service from the abstract, introduction and the following sections, so that it mainly focuses on the SR based data plane mechanism, use case and procedures. 

2. Solve the comments received from Sasha (thanks again).

3. Some editorial changes. 

After this update, this document describes a generic mechanism to enhance SR with resource awareness, and the major content of the document has been stable. Thus the co-authors believe it is ready for SPRING WG to adopt it, and would like to solicit to initiate the adoption poll on this document. Thanks. 

Best regards,
Jie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, December 16, 2019 5:13 PM
To: Takuya Miyasaka <[email-masked]>; Zhenqiang Li <[email-masked]>; Fengwei Qin <[email-masked]>; Stewart Bryant <[email-masked]>; Yongqing Zhu <[email-masked]>; Dongjie (Jimmy) <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-06.txt

A new version of I-D, draft-dong-spring-sr-for-enhanced-vpn-06.txt
has been successfully submitted by Jie Dong and posted to the IETF repository.

Name:		draft-dong-spring-sr-for-enhanced-vpn
Revision:	06
Title:		Segment Routing for Resource Partitioned Virtual Networks
Document date:	2019-12-16
Group:		Individual Submission
Pages:		18
URL:            https://www.ietf.org/internet-drafts/draft-dong-spring-sr-for-enhanced-vpn-06.txt
Status:         https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/
Htmlized:       https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-06
Htmlized:       https://datatracker.ietf.org/doc/html/draft-dong-spring-sr-for-enhanced-vpn
Diff:           https://www.ietf.org/rfcdiff?url2=draft-dong-spring-sr-for-enhanced-vpn-06

Abstract:
   This document describes the mechanism to associate Segment Routing
   Identifiers (SIDs) with network resource attributes.  The resource-
   aware SIDs retain their original functionality, with the additional
   semantics of identifying the set of network resources available for
   the packet processing action.  These SIDs can be used to build SID
   lists with reserved network resources, which can be used for many
   network scenarios.  One typical use case is to provide SR virtual
   networks with required network topology and resource attributes.  The
   proposed mechanism is applicable to both segment routing with MPLS
   data plane (SR-MPLS) and segment routing with IPv6 data plane (SRv6).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 20 Dec 2019 11:55:06 +0800

Dear All,

Resource awareness segment routing is essential for enhanced VPN.  This feature also enriches SPRING by taking the resource of each hop enroute into account when doing the source routing.
Hope all the comments and suggestions are incorporated in this version. As a co-author I believe it is ready for WG adoption call.

Best Regards,
Zhenqiang Li

[email-masked]
 
From: Dongjie (Jimmy)
Date: 2019-12-16 18:36
To: [email-masked]
CC: [email-masked]
Subject: [spring] Update and request to adopt draft-dong-spring-sr-for-enhanced-vpn
Dear WG, 

The major changes are:

 

Best regards,
Jie
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, December 16, 2019 5:13 PM
To: Takuya Miyasaka <[email-masked]>; Zhenqiang Li <[email-masked]>; Fengwei Qin <[email-masked]>; Stewart Bryant <[email-masked]>; Yongqing Zhu <[email-masked]>; Dongjie (Jimmy) <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-06.txt

 
Abstract:

 
The IETF Secretariat
 
_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring