Subject: [spring] SRv6 Network programming minor detail

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 8 Dec 2019 15:18:55 -0500

In reading section 3.1 on the SID format, I noticed a small inconsitency 
with a large impact.  My guess is that either I am misreading the text, 
or there is a typo.

The first part of the section talks about LOC:FUNCT and is clear that 
this uses all 128 bits of the IPv6 address.  I think I understand that.

Later in the section, in talking about arguments, it says 
"LOC:FUNCT:ARGS::".  Is the final :: intended?  That seems to require 
that the entire thing fit in the upper 64 bits of the IPv6 address. 
Which I believe is not intended.  I would have expected simply 
"LOC:FUNCT:ARGS".

Thank you,
Joel

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Mon, 9 Dec 2019 15:21:08 +0000

Joel,

You are right, the final :: are not needed and will be removed.

Cheers,
Pablo.

-----Original Message-----
From: spring <[email-masked]> on behalf of "Joel M. Halpern" <[email-masked]>
Date: Sunday, 8 December 2019 at 21:19
To: "[email-masked]" <[email-masked]>
Subject: [spring] SRv6 Network programming minor detail

    
    
    Thank you,
    Joel
    
    _______________________________________________
    spring mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spring