Subject: [spring] draft-ietf-spring-srv6-network-programming: Relative advantages of SRv6

From: Ron Bonica <[email-masked]>
Date: Mon, 30 Dec 2019 10:07:24 +0000

Pablo,

Would you consider adding a short section to the draft explaining the relative advantages of SRv6 over SR-MPLS? This section would explain why an network operator would deploy SRv6 instead of SR-MPLS.

                                                                                         Ron

Juniper Business Use Only

---

From: 程伟强 <[email-masked]>
Date: Mon, 30 Dec 2019 18:32:52 +0800 (CST)

Hi,I agree with Ron.

B.R.

Weiqiang Cheng

----邮件原文----发件人：Ron Bonica  <rbonica=[email-masked]>收件人：SPRING WG  <[email-masked]>抄　送: (无)发送时间：2019-12-30 18:07:24主题：[spring] draft-ietf-spring-srv6-network-programming: Relativeadvantages of SRv6

Pablo,

 

                                                                                         Ron

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 30 Dec 2019 12:15:42 +0100

Hi Ron,

How about instead of jumping into the middle of SR piece first focus on
more fundamental comparison of IP transport vs MPLS transport in a network ?

Do you still believe that the concept of domain wide flooding of host
routes and labels attached to it - be it /32 or /128 prefixes is a wise
thing ?

For years MPLS world struggled with it ... and it still hurts in many ways
today.

Instead of nicely summarized areas or regions where you advertise single
IGP summary out, when your SPF is very small (and its timers can be very
aggressive) you are flooding within or across continents all of the hosts
routes from 1000s of routers slowing the entire network down. That's just
sick network architecture to me. And the only reason for doing it ... Your
transport label is not summarizable !

For other hints pls take a look at RFC 4023 & RFC 7510 :).

Do you really see any value to copy text from those drafts into subject
document ? I do not.

Cheers,
R.

PS. Once we first agree on the proper network transport - only then there
is time to focus on service level discussions.

On Mon, Dec 30, 2019 at 11:07 AM Ron Bonica <rbonica=
[email-masked]> wrote:

> Pablo,
>
>
>
> Would you consider adding a short section to the draft explaining the
> relative advantages of SRv6 over SR-MPLS? This section would explain why an
> network operator would deploy SRv6 instead of SR-MPLS.
>
>
>
>
>                                                                                       Ron
>
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Ron Bonica <[email-masked]>
Date: Mon, 30 Dec 2019 12:19:01 +0000

Robert,

We should probably let the authors decide if that is part of the answer to my question.

                                                                             Ron

From: Robert Raszuk <[email-masked]>
Sent: Monday, December 30, 2019 6:16 AM
To: Ron Bonica <[email-masked]>
Cc: SPRING WG <[email-masked]>
Subject: Re: [spring] draft-ietf-spring-srv6-network-programming: Relative advantages of SRv6

Hi Ron,

How about instead of jumping into the middle of SR piece first focus on more fundamental comparison of IP transport vs MPLS transport in a network ?

Do you still believe that the concept of domain wide flooding of host routes and labels attached to it - be it /32 or /128 prefixes is a wise thing ?

For years MPLS world struggled with it .... and it still hurts in many ways today.

Instead of nicely summarized areas or regions where you advertise single IGP summary out, when your SPF is very small (and its timers can be very aggressive) you are flooding within or across continents all of the hosts routes from 1000s of routers slowing the entire network down. That's just sick network architecture to me. And the only reason for doing it ... Your transport label is not summarizable !

Do you really see any value to copy text from those drafts into subject document ? I do not.

Cheers,
R.

PS. Once we first agree on the proper network transport - only then there is time to focus on service level discussions.

On Mon, Dec 30, 2019 at 11:07 AM Ron Bonica <rbonica=[email-masked]<mailto:[email-masked]>> wrote:
Pablo,

                                                                                         Ron

Juniper Business Use Only
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!!NEt6yMaO-gk!RLEoWuvBeBb6us3jpbxeKxaVWdSUk1CFw-FbnocM8a7MPS0CYX1CMz5Ihz84l76N$>

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 30 Dec 2019 14:40:32 +0100

Ron,

I beg your pardon, but what are you trying to say?

Isn't this a WG document now and *any* WG member is fully entitled to
comment on any question asked or point being raised ? Leave alone formal
document contributor.

Are you saying that answers from those listed on top of the draft carries
more weight ? Is this some new IETF process you are trying to define here ?

Once document transitions to WG doc status authors who own src are
becoming just editors with the obligation to incorporate WG suggested
changes which got approved via rough consensus as judged by chairs. Are you
questioning that too ?

Thx,
R.

---

From: Ron Bonica <[email-masked]>
Date: Mon, 30 Dec 2019 16:35:20 +0000

Robert,

I just realized that you are a contributor. So, I will take that as an invitation to contribute my two cents.

Please stand by. It will take an hour or two to craft a well-considered response and it may not be ready before I shut down for the holiday.

                                                                                Happy New Year,
                                                                                   Ron

Sent: Monday, December 30, 2019 8:41 AM

Ron,

Isn't this a WG document now and *any* WG member is fully entitled to comment on any question asked or point being raised ? Leave alone formal document contributor.

Are you saying that answers from those listed on top of the draft carries more weight ? Is this some new IETF process you are trying to define here ?

Once document transitions to WG doc status authors who own src are becoming just editors with the obligation to incorporate WG suggested changes which got approved via rough consensus as judged by chairs. Are you questioning that too ?

Thx,
R.

On Mon, Dec 30, 2019 at 1:19 PM Ron Bonica <[email-masked]<mailto:[email-masked]>> wrote:
Robert,

                                                                             Ron