Subject: [spring] SPRING SRv6 Deployment Status draft

From: Tadas Planciunas <[email-masked]>
Date: Fri, 6 Dec 2019 09:07:23 +0200

Hi Zefar, Satoru,

In the next draft of
https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/,
we'd like to be added to the section “2.  Deployment Status” as we have
significant progress on our SRv6 deployment:

*NOIA Network (https://noia.network <https://noia.network>)*

NOIA Network is Internet Technology company creating a cutting-edge SRv6
stack implementation and backbone for managing private and distributed mesh
networks.

Our software deployment consists of Orchestration, Analytics, Agent,
Controller, Business Intelligence (AI) and several product Interfaces to
access the network.

Project whitepaper and tokenomics model can be found here:
https://noia.network/programmable-internet-whitepaper and
https://noia.network/tokenomics-whitepaper

NOIA Network have deployed a nationwide SRv6 network backbone. The SRv6
backbone is based on white box or cloud routers with FD.io VPP or Linux
srext module installed.

The following SRv6 features have been deployed:

   - A Segment Routing Header [I-D.ietf-6man-segment-routing-header] based
   data plane.
   - END , END.X, END.DT4, End.DT6 functions as per
   [I-D.filsfils-spring-srv6-network-programming].
   - iOAM Proof of Transit and Trace options as per
   [I-D.ietf-ippm-ioam-data].
   - BFD for Multihop Paths as per [I-D.ietf-bfd-multihop].
   - Topology Independent (TI-LFA) Fast Reroute mechanisms leveraging
   - SRv6 for the O(50msec) protection against node and link, as described
   in [I-D.ietf-rtgwg-segment-routing-ti-lfa].

Thank you.

-- 

Pagarbiai / Regards

IT Manager, Dev Lead @ NOIA Network

+370 614 68669

https://noia.network/

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Fri, 6 Dec 2019 19:16:20 +0000

Hi Tadas,

Many thanks for sharing the SRv6 deployment in a nationwide backbone network!

It will be our pleasure to include the text provided by you in the next revision of the SRv6 deployment draft.
We can publish it during the next week.

Have a great weekend!

Thanks

Regards … Zafar

From: Tadas Planciunas <[email-masked]>
Date: Friday, December 6, 2019 at 2:07 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Zafar Ali (zali)" <[email-masked]>
Cc: Jonas Simanavicius <[email-masked]>, "Pablo Camarillo (pcamaril)" <[email-masked]>
Subject: [spring] SPRING SRv6 Deployment Status draft

Hi Zefar, Satoru,

In the next draft of  https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/, we'd like to be added to the section “2.  Deployment Status” as we have significant progress on our SRv6 deployment:

NOIA Network (https://noia.network)

NOIA Network is Internet Technology company creating a cutting-edge SRv6 stack implementation and backbone for managing private and distributed mesh networks.

Our software deployment consists of Orchestration, Analytics, Agent, Controller, Business Intelligence (AI) and several product Interfaces to access the network.

Project whitepaper and tokenomics model can be found here: https://noia.network/programmable-internet-whitepaper and https://noia.network/tokenomics-whitepaper

NOIA Network have deployed a nationwide SRv6 network backbone. The SRv6 backbone is based on white box or cloud routers with FD.io VPP or Linux srext module installed.

  *   A Segment Routing Header [I-D.ietf-6man-segment-routing-header] based data plane.
  *   END , END.X, END.DT4, End.DT6 functions as per [I-D.filsfils-spring-srv6-network-programming].
  *   iOAM Proof of Transit and Trace options as per [I-D.ietf-ippm-ioam-data].
  *   BFD for Multihop Paths as per [I-D.ietf-bfd-multihop].
  *   Topology Independent (TI-LFA) Fast Reroute mechanisms leveraging
  *   SRv6 for the O(50msec) protection against node and link, as described in [I-D.ietf-rtgwg-segment-routing-ti-lfa].

Thank you.

---

From: Tadas Planciunas <[email-masked]>
Date: Fri, 6 Dec 2019 21:54:37 +0200

Thank you, you too!

On Fri, Dec 6, 2019, 21:16 Zafar Ali (zali) <[email-masked]> wrote:

> *From: *Tadas Planciunas <[email-masked]>
> *Date: *Friday, December 6, 2019 at 2:07 AM
> *To: *"[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>,
> "Zafar Ali (zali)" <[email-masked]>
> *Cc: *Jonas Simanavicius <[email-masked]>, "Pablo Camarillo
> (pcamaril)" <[email-masked]>
> *Subject: *[spring] SPRING SRv6 Deployment Status draft
>
>
>
> Hi Zefar, Satoru,
>
>
>
> In the next draft of
>    - A Segment Routing Header [I-D.ietf-6man-segment-routing-header]
>    based data plane.
>    - SRv6 for the O(50msec) protection against node and link, as
>    described in [I-D.ietf-rtgwg-segment-routing-ti-lfa].
>
>
> Thank you.
>
>
>
> --
>
> Pagarbiai / Regards
>

---

From: Sébastien Parisot <[email-masked]>
Date: Tue, 10 Dec 2019 10:33:53 +0100 (CET)

Hi Satoru, Zafar,

I would like to provide an update to SRv6 deployment in Iliad's nationwide network in Italy.

As of the end of 2019, the SRv6 network consists of:
- 1000 Cisco NCS 5500 routers
- 1800 Iliad's Nodeboxes
- The network services 4.5 million mobile subscribers (as of Q3 2019)
- The network is carrying 300 Gbps of commercial traffic at peak hours
- It is expected to grow to more than 4000 Nodeboxes in 2020.

The following SRv6 features have been deployed:
- A Segment Routing Header based data plane
- End (PSP), End.X (PSP), End.DT4, T.Encaps.Red, T.Insert.Red functions
- BGP VPN SRv6 extensions
- ISIS SRv6 extensions
- SRH-based Topology Independent (TI-LFA) Fast Reroute mechanisms
- Support for ping and traceroute

Can you please update the SRv6 deployment draft accordingly?

Thanks,
Sébastien

----- Mail original -----
> De: "Zafar Ali, zali" <[email-masked]>
> À: "Tadas Planciunas" <[email-masked]>, "SPRING WG List" <[email-masked]>, "松嶋聡"
> <[email-masked]>
> Cc: "Jonas Simanavicius" <[email-masked]>, "Pablo Camarillo, pcamaril" <[email-masked]>, "Zafar Ali, zali"
> <[email-masked]>
> Envoyé: Vendredi 6 Décembre 2019 20:16:20
> Objet: Re: [spring] SPRING SRv6 Deployment Status draft

> Hi Tadas ,
> To: "[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>, "Zafar Ali (zali)" <[email-masked]>
> In the next draft of [
> https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/
> |
> https://datatracker.ietf.org/doc/draft-matsushima-spring-srv6-deployment-status/
> ] , we'd like to be added to the section “2. Deployment Status” as we have
> NOIA Network ( [ https://noia.network/ | https://noia.network ] )
> 
> NOIA Network is Internet Technology company creating a cutting-edge SRv6 stack
> implementation and backbone for managing private and distributed mesh networks.
> 
> Our software deployment consists of Orchestration, Analytics, Agent, Controller,
> Business Intelligence (AI) and several product Interfaces to access the
> network.
> 
> Project whitepaper and tokenomics model can be found here: [
> https://noia.network/programmable-internet-whitepaper |
> https://noia.network/programmable-internet-whitepaper ] and [
> https://noia.network/tokenomics-whitepaper |
> https://noia.network/tokenomics-whitepaper ]
> 
> NOIA Network have deployed a nationwide SRv6 network backbone. The SRv6 backbone
> is based on white box or cloud routers with FD.io VPP or Linux srext module
> installed.
> 
>    * END , END.X, END.DT4, End.DT6 functions as per
> [ https://noia.network/ | https://noia.network/ ]

---

From: 松嶋聡 <[email-masked]>
Date: Wed, 11 Dec 2019 13:11:11 +0100

Hi Sebastien,

Thank you very much for your updates on Iliad in detail!

It shows that one vendor’s SRv6 implementation is interoperable with
your in-house SRv6 implementation, and the networks consist of those
routers are running very well.

I think the draft has this info should be a good reference for
operators who have been planning next-gen networks for them.

Yes, we’re happy to update the draft with it.

Cheers,
--satoru

>>> On Dec 10, 2019, at 18:34, Sébastien Parisot <[email-masked]> wrote:
>> Hi Satoru, Zafar,
>>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring