Subject: [spring] draft-ietf-spring-srv6-network-programming - Extraneous functions

From: Ron Bonica <[email-masked]>
Date: Thu, 12 Dec 2019 19:56:07 +0000

Folks,

Are there use cases for the following functions:

  *   0x001F - END with PSP, USP and USD
  *   0x0023 - END.X with PSP, USP and USD
  *   0x0027 - END.X with PSP, USP and USD

It seems that if the SRH was removed at the penultimate segment, there is little sense in removing it again at the ultimate segment.

                                                                                                                             Ron

Juniper Business Use Only

---

From: Ron Bonica <[email-masked]>
Date: Thu, 12 Dec 2019 20:28:25 +0000

Authors,

Looking more closely at the IANA registry, it seems that you have reserved 8 code points for each of the END, END.X and END.T functions. These 8 codepoints cover all permutations of PSP, USP, and USD.

However, the following permutations make little sense:

  *   <USD, PSP, USP> and <PSP, USP> because you can only pop the SRH once
  *   <USD and USP>, because it is identical to <USD>

Also, is there a use-case for USP, alone?

                                                                               Ron

Juniper Business Use Only
From: Ron Bonica
Sent: Thursday, December 12, 2019 2:56 PM
To: [email-masked]
Subject: draft-ietf-spring-srv6-network-programming - Extraneous functions

Folks,

                                                                                                                             Ron

---

From: "Wang, Weibin (NSB - CN/Shanghai)" <[email-masked]>
Date: Fri, 13 Dec 2019 00:06:06 +0000

Hi Ron,

I think the same SID，such as you mention, May be included in different SRH of different packets, so the same SID have different behavior in different packet whose SRH include it.

Cheers!

Wang Weibin

From: spring <[email-masked]> On Behalf Of Ron Bonica
Sent: 2019年12月13日 3:56
To: [email-masked]
Subject: [spring] draft-ietf-spring-srv6-network-programming - Extraneous functions

Folks,

  *   0x001F – END with PSP, USP and USD
  *   0x0023 – END.X with PSP, USP and USD
  *   0x0027 - END.X with PSP, USP and USD

                                                                                                                             Ron

---

From: "Wang, Weibin (NSB - CN/Shanghai)" <[email-masked]>
Date: Fri, 13 Dec 2019 14:20:53 +0000

Hi Authors:

I look at the following SIDs function again, and I indeed fail to find useful meaning of the combination of USP & USD, as well as {PSP & USP & USD}.
Given that there are no 2 or more successive SRH instances in one packet in this draft, So Regardless of which specific packet whose SRH instance include the same SID below in last location, the final behavior of these SIDs in different packet’s SRHs are always the same, either USP or USD, it is up to the execution order among the USD and USP, because these SIDs are executed in last node of segment list and their pre-condition is same, i.e “ if {segment left ==0}” in same location in Pseudocode module.
Do you give a use case to explain for them, for example, the one SID below of one SRH instance has behavior for USP, at the same time, the same SID of another SRH instance of another packet has behavior for USD.

0x001E |  End with USP&USD
0x0022 |  End.X with USP&USD
0x0026 |  End.T with USP&USD

Cheers!

Wang Weibin

From: Wang, Weibin (NSB - CN/Shanghai)
Sent: 2019年12月13日 8:06
To: 'Ron Bonica' <rbonica=[email-masked]>; [email-masked]
Subject: RE: draft-ietf-spring-srv6-network-programming - Extraneous functions

Hi Ron,

Cheers!

Wang Weibin

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Ron Bonica
Sent: 2019年12月13日 3:56
To: [email-masked]<mailto:[email-masked]>
Subject: [spring] draft-ietf-spring-srv6-network-programming - Extraneous functions

Folks,

                                                                                                                             Ron