Subject: [spring] SRv6's new deployment status information at OSS-fields.

From: Hiroki Shirokura <[email-masked]>
Date: Fri, 17 Jan 2020 19:04:03 +0900

Dear all SRv6-ers

I'm Hiorki working on developing SRv6 DCN and routing
software about SRv6.

I want to inform you a bit-news for SRv6 OpenSource implementation.
I contributed code to ExaBGP to support parsing and
advertising Prefix-SID for SRv6 L3VPN (especially type-4 and type-5)
and that was already merged and informed by ExaBGP community [1,2].
This is first-SRv6-BGP-cplane as OSS, isn't it ;)

And It's already reflected on segment-routing.net with
support by Ahmed. (thx Ahmed!!) [3]
**Can you reflect this deployment update to draft?**

- [1] https://twitter.com/exabgp/status/1216849537706446856
- [2] https://github.com/Exa-Networks/exabgp/releases/tag/4.2.0
- [3] https://www.segment-routing.net/open-software/exabgp/

Great thanks, I'm crazy happy to dive this fantastic community and
contribute SRv6. :)
[P.S. Just FYI]
Also I'm trying to contribute to another OSS (FRRouting and wireshark).
That is currently on review. If that will be completed, FRR will be
able to support BGP VPNv4 with SRv6 backend (Prefix-sid type-4,5
both is supported). And wireshark will be able to dissect
BGP-Prefix-SID path-attribute for SRv6-VPN (type-4,5).
If some updates occurred, I'll inform to here.
cheers
-- Hiroki / slankdev

---

From: Satoru Matsushima <[email-masked]>
Date: Sat, 18 Jan 2020 10:22:41 +0900

Thank you Hiroki, yes it’s a great news indeed!

I’d be happy to capture this (and your coming outcomes) in the next revision of srv6-deployment status draft.

Cheers,
--satoru

> On Jan 17, 2020, at 20:16, Hiroki Shirokura <[email-masked]> wrote:
> 
> 
> Dear all SRv6-ers
> Great thanks, I'm crazy happy to dive this fantastic community and contribute SRv6. :)
> 
> [P.S. Just FYI]
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring