Subject: [spring] Fwd: I-D Action: draft-zhou-idr-inter-domain-lcu-01.txt

From: Robert Raszuk <[email-masked]>
Date: Tue, 18 Feb 2020 10:45:59 +0100

Dear Authors of  "Inter-domain Network Slicing via BGP-LU" draft,

Can you kindly elaborate why your ultimate goal can not be
accomplished using SR-MPLS and flexible algorithm ?

Is having N solutions to the same problem a good thing ? See writing a
draft is easy, publishing it as RFC a bit harder but doable, but the real
challenge is to support it in all products as well as struggle with
interoperability issues between completely disjointed solutions.

As to your proposal why is this a standards track vs information ? AFAIK
you are not defining any BGP extension - just using add-paths and
community. How receiver interprets the community is a local matter.

Many thx,
R.

---------- Forwarded message ---------
From: <[email-masked]>
Date: Tue, Feb 18, 2020 at 10:35 AM
Subject: I-D Action: draft-zhou-idr-inter-domain-lcu-01.txt
To: <[email-masked]>

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

        Title           : Inter-domain Network Slicing via BGP-LU
        Authors         : Jin Zhou
                          Chunning Dai
                          Shaofu Peng
        Filename        : draft-zhou-idr-inter-domain-lcu-01.txt
        Pages           : 7
        Date            : 2020-02-18

Abstract:
   This document aims to solve inter-domain network slicing problems
   using existing technologies.  It attempts to establish multiple BGP-
   LU LSPs of different colors for a prefix to stitch multiple network
   segments.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-zhou-idr-inter-domain-lcu/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-zhou-idr-inter-domain-lcu-01
https://datatracker.ietf.org/doc/html/draft-zhou-idr-inter-domain-lcu-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-zhou-idr-inter-domain-lcu-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Thu, 20 Feb 2020 16:41:44 +0800 (CST)

Dear Robert,

Firstly, we strongly agree that the SR-MPLS & FA solution can achieve the ultimate goal. According to our understanding, for an E2E inter-domain SR policy, color is used to define the corresponding TE purpose. The controller can centrally calculate the E2E path that meets the TE purpose. Then for the segment list in each domain, FA can be used for stack depth optimization. In addition, the controller can also select inter-domain link resources according to the TE purpose. Note that, although FA uses distributed CSPF, the entire E2E SR policy is calculated centrally.

This draft discusses how to use BGP-LU to calculate an E2E inter-AS LU LSP in a distributed manner, which is different from the above scheme. The underlay path inside each domain (such as the SR-FA, SR-TE tunnel, SR policy in the domain) will be iterated based on the BGP-LU color plus next-hop.The link resources between the domains will also be selected based on the BGP-LU color. These are all done by the equipment itself.

We think that both solutions can coexist, each with its own application scenario. This draft is mainly used for seamless MPLS IPRAN networks configured with BGP-LU. Some services will be carried using E2E SR policy, but some other service will be carried using E2E BGP-LU LSP.

The existed BGP mechanism is enough to achieve the goal, and we don't think extra extensions are necessary.  Admittedly, as u said, it's really a local strategy. ASBR determines whether to advertise multipaths based on <prefix, color>, whether to generate label switching entries based on <prefix, color>, and whether to generate BGP-LSP entries based on <prefix, color>.  These local determinations have implemeted in our product. 

Thanks for your attention and advice. 

Jin

周瑾 Jin Zhou

技术预研工程师 Technology Pre-research Engineer
架构团队/有线规划部/有线产品经营部 Architecture Team/Wireline Product Planning Division

33/F, R&D Building, ZTE
Corporation Hi-tech Road South, 
Hi-tech
Industrial Park Nanshan District, Shenzhen, P..R.China, 518057 
T: +86 755 xxxxxxxx F:+86 755 xxxxxxxx 
M: +86 18575565135
E: [email-masked] 
www.zte.com.cn

原始邮件

发件人：[email-masked] <[email-masked]>
收件人：[email-masked] <[email-masked]>;
日 期 ：2020年02月19日 04:01
主 题 ：Idr Digest, Vol 190, Issue 14

Send Idr mailing list submissions to
    [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
    https://www.ietf.org/mailman/listinfo/idr
or, via email, send a message with subject or body 'help' to
    [email-masked]

You can reach the person managing the list at
    [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Idr digest..."

Today's Topics:

   1. Fwd: I-D Action: draft-zhou-idr-inter-domain-lcu-01.txt
      (Robert Raszuk)

----------------------------------------------------------------------

Message: 1
Date: Tue, 18 Feb 2020 10:45:59 +0100
From: Robert Raszuk <[email-masked]>
To: "idr@ietf. org" <[email-masked]>, SPRING WG <[email-masked]>
Subject: [Idr] Fwd: I-D Action: draft-zhou-idr-inter-domain-lcu-01.txt
Message-ID:
    <[email-masked]>
Content-Type: text/plain; charset="utf-8"

Many thx,
R.

---------- Forwarded message ---------
From: <[email-masked]>
Date: Tue, Feb 18, 2020 at 10:35 AM
Subject: I-D Action: draft-zhou-idr-inter-domain-lcu-01.txt
To: <[email-masked]>

Abstract:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/idr/attachments/20200218/3e0bdbe1/attachment.html>

------------------------------

Subject: Digest Footer

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

------------------------------

End of Idr Digest, Vol 190, Issue 14
************************************