Subject: [spring] I-D Action: draft-ietf-spring-sr-service-programming-02.txt

From: [email-masked]
Date: Mon, 09 Mar 2020 10:49:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Source Packet Routing in Networking WG of the IETF.

        Title           : Service Programming with Segment Routing
        Authors         : Francois Clad
                          Xiaohu Xu
                          Clarence Filsfils
                          Daniel Bernier
                          Cheng Li
                          Bruno Decraene
                          Shaowen Ma
                          Chaitanya Yadlapalli
                          Wim Henderickx
                          Stefano Salsano
	Filename        : draft-ietf-spring-sr-service-programming-02.txt
	Pages           : 39
	Date            : 2020-03-09

Abstract:
   This document defines data plane functionality required to implement
   service segments and achieve service programming in SR-enabled MPLS
   and IPv6 networks, as described in the Segment Routing architecture.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-spring-sr-service-programming/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-spring-sr-service-programming-02
https://datatracker.ietf.org/doc/html/draft-ietf-spring-sr-service-programming-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-sr-service-programming-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Francois Clad (fclad)" <[email-masked]>
Date: Mon, 9 Mar 2020 18:43:33 +0000

Dear all,

We have just updated the SR Service Programming draft with the following changes:
 - Aligned SRv6 pseudocodes for static, dynamic and masquerading proxies with draft-ietf-6man-segment-routing-header and draft-ietf-spring-srv6-network-programming
 - For consistency, aligned SR-MPLS pseudocodes to follow a similar model
 - Added missing pseudocode for the caching flavor of the masquerading proxy
 - Added code points in the IANA section for all flavors of the masquerading proxy (similar to what is done in draft-ietf-spring-srv6-network-programming)
 - Various editorial fixes (text clarification, removal of redundancies, terminology fixes,…)

Any feedback welcome.

Thanks,
Francois (on behalf of my co-authors)

On 09/03/2020 18:50, "spring on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    

    _______________________________________________
    spring mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spring