Subject: Re: [spring] draft-ali-spring-sr-traffic-accounting-04 reviewed

From: "Zafar Ali (zali)" <[email-masked]>
Date: Sun, 1 Mar 2020 14:43:42 +0000

Hi Thomas

Did you mean there is a need for IPFIX MPLS label type entry for Binding SID?
Can you please elaborate?

Thanks

Regards … Zafar

From: spring <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Sunday, March 1, 2020 at 9:31 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [spring] draft-ali-spring-sr-traffic-accounting-04 reviewed

Dear Zafar, Dear draft authors,

I reviewed draft-ali-spring-sr-traffic-accounting-04 and tested it in Swisscom's lab. Planning to deploy it in the production network in the coming months.

The draft is very straight forward and easy to read. I have only one small comment regarding section 7, IANA Considerations.

In IPFIX entity type 46 at IANA, the top label type (label source) is defined. In the following section the possible values are described:
https://www.iana.org/assignments/ipfix/ipfix.xhtml#ipfix-mpls-label-type

For Segment Routing an additional value needs to be defined and your draft seems to be the right place to cover that.

Hope that makes sense.

Best Wishes
Thomas Graf
____________________________________________________________________________
Network Engineer
Datacenter Functions
Telefon +41-58-223 84 01
Mobile   +41-79-728 80 12
[email-masked]<mailto:[email-masked]>
____________________________________________________________________________
Swisscom (Schweiz) AG
IT, Network & Infrastructure
Datacenter Functions
Binzring 17
8045 Zürich
www.swisscom.com
Postadresse:
Binzring 17
8045 Zürich

---

From: <[email-masked]>
Date: Sun, 1 Mar 2020 15:49:01 +0000

Hi Zafar,

Correct. For instance next free value 6 for SID at IPFIX entity 46.

We have seen vendor implementation marking 5 even though the label value is a SID, not coming from LDP. This due to the fact that there is no value assigned for SID yet.

Best Wishes
Thomas Graf

From: Zafar Ali (zali) <[email-masked]>
Sent: Sunday, March 1, 2020 3:44 PM
To: Graf Thomas, INI-NET-DCF <[email-masked]>; [email-masked]
Cc: [email-masked]; Zafar Ali (zali) <[email-masked]>
Subject: Re: [spring] draft-ali-spring-sr-traffic-accounting-04 reviewed

Hi Thomas

Thanks

Regards ... Zafar

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Sunday, March 1, 2020 at 9:31 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [spring] draft-ali-spring-sr-traffic-accounting-04 reviewed

In IPFIX entity type 46 at IANA, the top label type (label source) is defined. In the following section the possible values are described:
https://www.iana.org/assignments/ipfix/ipfix.xhtml#ipfix-mpls-label-type<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fipfix%2Fipfix.xhtml%23ipfix-mpls-label-type&data=02%7C01%7CThomas.Graf%40swisscom.com%7C77d5d2926dba439191fd08d7bdeefdaf%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637186706461423641&sdata=l2ZfUq0PHaTGFQCHwfsaFL7jKT0CGorn9QpBo4OKy1A%3D&reserved=0>

Hope that makes sense.

Best Wishes
Thomas Graf
____________________________________________________________________________
Network Engineer
Datacenter Functions
Telefon +41-58-223 84 01
Mobile   +41-79-728 80 12
[email-masked]<mailto:[email-masked]>
____________________________________________________________________________
Swisscom (Schweiz) AG
IT, Network & Infrastructure
Datacenter Functions
Binzring 17
8045 Zürich
www.swisscom.com<http://www.swisscom.com/>
Postadresse:
Binzring 17
8045 Zürich

---

From: <[email-masked]>
Date: Sun, 15 Mar 2020 15:41:26 +0000

Hi Ali,

I apologize for late reply. Sure. Makes perfectly sense. I created the following draft

https://www.ietf.org/id/draft-tgraf-ipfix-mpls-sr-label-type-00.txt

Could you please review it and feedback me. I will call for adoption at the OPSAWG working group if that makes sense to you. From my perspective, in the past, RFC's adding only additional operational related IPFIX information entities into the IANA registry were handled at OPSAWG.

Best Wishes
Thomas

From: Zafar Ali (zali) <[email-masked]>
Sent: Sunday, March 1, 2020 4:59 PM
To: Graf Thomas, INI-NET-DCF <[email-masked]>
Cc: Zafar Ali (zali) <[email-masked]>
Subject: Re: [spring] draft-ali-spring-sr-traffic-accounting-04 reviewed

Hi Thomas,

I agree with you.
I think draft-ali-spring-sr-traffic-accounting-04 is not the right place.

May be we can write a very small draft (in PCE WG)?

Thanks

Regards ... Zafar

From: <[email-masked]<mailto:[email-masked]>>
Date: Sunday, March 1, 2020 at 10:49 AM
To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: RE: [spring] draft-ali-spring-sr-traffic-accounting-04 reviewed

Hi Zafar,

Best Wishes
Thomas Graf

From: Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, March 1, 2020 3:44 PM
To: Graf Thomas, INI-NET-DCF <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] draft-ali-spring-sr-traffic-accounting-04 reviewed

Hi Thomas

Thanks

Regards ... Zafar

In IPFIX entity type 46 at IANA, the top label type (label source) is defined. In the following section the possible values are described:
https://www.iana.org/assignments/ipfix/ipfix.xhtml#ipfix-mpls-label-type<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fipfix%2Fipfix.xhtml%23ipfix-mpls-label-type&data=02%7C01%7CThomas.Graf%40swisscom.com%7C5f16412781aa47f3410e08d7bdf97398%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637186751391408992&sdata=bvJmdUxj%2B%2FVZ6%2BOZjuk1aIiuNT%2FQUI874WT7tYiRbH4%3D&reserved=0>

Hope that makes sense.

Best Wishes
Thomas Graf