Subject: [spring] FW: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-07.txt

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 10 Mar 2020 10:00:27 +0000

Hi all, 

We've submitted a new revision of draft-dong-spring-sr-for-enhanced-vpn. 

This version includes some editorial changes based on the previous -06 version, which have solved the comments received before and during IETF 106 meeting. 

The authors believe this document is ready for WG adoption, and thus solicit the WG to consider initiating the adoption poll on it. Thanks.

Best regards,
Jie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, March 9, 2020 4:33 PM
To: Takuya Miyasaka <[email-masked]>; Dongjie (Jimmy) <[email-masked]>; Stewart Bryant <[email-masked]>; Yongqing Zhu <[email-masked]>; Fengwei Qin <[email-masked]>; Zhenqiang Li <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-07.txt

A new version of I-D, draft-dong-spring-sr-for-enhanced-vpn-07.txt
has been successfully submitted by Jie Dong and posted to the IETF repository.

Name:		draft-dong-spring-sr-for-enhanced-vpn
Revision:	07
Title:		Segment Routing for Resource Guaranteed Virtual Networks
Document date:	2020-03-09
Group:		Individual Submission
Pages:		18
URL:            https://www.ietf.org/internet-drafts/draft-dong-spring-sr-for-enhanced-vpn-07.txt
Status:         https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/
Htmlized:       https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-07
Htmlized:       https://datatracker.ietf.org/doc/html/draft-dong-spring-sr-for-enhanced-vpn
Diff:           https://www.ietf.org/rfcdiff?url2=draft-dong-spring-sr-for-enhanced-vpn-07

Abstract:
   This document describes the mechanism to associate Segment Routing
   Identifiers (SIDs) with network resource attributes.  The resource-
   aware SIDs retain their original functionality, with the additional
   semantics of identifying the set of network resources available for
   the packet processing action.  These SIDs can be used to build SR
   paths with reserved network resources.  In addition, these SID can
   also be used to build SR based virtual networks, which provide the
   network topology and resource attributes required by particular
   services.  The proposed mechanism is applicable to both segment
   routing with MPLS data plane (SR-MPLS) and segment routing with IPv6
   data plane (SRv6).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Wed, 11 Mar 2020 12:07:49 +0800 (CST)

Hi Jie,

I don’t think it’s time to call for adoption. Teas Slice DT is still working on the definition and the framework of the transport slice，which has not been accepted by the teas working group. 

For the draft, I have some comments:

1.Compared with the ietf-teas-enhanced-vpn, It seems like that there is no more new technology. What's the meaning of this draft as standard track? 

2.Control plane extensions that you referred in this draft is ietf-dong-lsr-sr-enhanced-vpn, and ietf-dong-idr-bgpls-sr-enhanced-vpn, and we also have a series of control plane drafts: https://tools.ietf.org/html/draft-zch-lsr-isis-network-slicing-03, https://tools.ietf.org/html/draft-chen-idr-bgp-ls-transport-slice-00 , https://tools.ietf.org/html/draft-peng-pce-te-constraints-02 satisfying the same requirement. So Control plane extensions are still an open question, and needing further discussing. 

3. For slice resources, our draft: https://tools.ietf.org/html/draft-peng-teas-network-slicing-03  induced slice-id(AII) for slice resources management, and our solution can differentiate them (e.g. L2 link or L3 interface), how to compute SR-BE or SR-TE path according to AII combined with other criteria. This isnot very clear in your draft.

Regards,

Ran

原始邮件

发件人：Dongjie(Jimmy) <[email-masked]>
收件人：'SPRING WG List' <[email-masked]>;
抄送人：[email-masked] <[email-masked]>;
日 期 ：2020年03月10日 18:00
主 题 ：[spring] FW: New Version Notification fordraft-dong-spring-sr-for-enhanced-vpn-07.txt

Hi all, 

Best regards,
Jie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, March 9, 2020 4:33 PM
To: Takuya Miyasaka <[email-masked]>; Dongjie (Jimmy) <[email-masked]>; Stewart Bryant <[email-masked]>; Yongqing Zhu <[email-masked]>; Fengwei Qin <[email-masked]>; Zhenqiang Li <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-07.txt

Abstract:

The IETF Secretariat

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 11 Mar 2020 08:36:44 +0000

Hi Ran,

Thanks for your feedback. Please see my replies inline with [Jie]:

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 11, 2020 12:08 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re:[spring] FW: New Version Notification fordraft-dong-spring-sr-for-enhanced-vpn-07.txt

Hi Jie,

I don’t think it’s time to call for adoption. Teas Slice DT is still working on the definition and the framework of the transport slice，which has not been accepted by the teas working group.
[Jie] If you read the latest version or the previous (-06) version of this document, you would find that this draft defines a generic enhancement to SR data plane. Although network slicing is one of the target use cases, this document is relatively independent from the discussion and progress of the NS design team. Thus I don’t see a reason of not progressing this work in SPRING.

1.  Compared with the ietf-teas-enhanced-vpn, It seems like that there is no more new technology. What's the meaning of this draft as standard track?

[Jie] The proposed enhancement to SR data plane is clearly described in the draft. , in short it introduces new semantics to SR SIDs, so that the SIDs could be used to identify the set of resources used for packet processing.

2.  Control plane extensions that you referred in this draft is ietf-dong-lsr-sr-enhanced-vpn, and ietf-dong-idr-bgpls-sr-enhanced-vpn, and we also have a series of control plane drafts: https://tools.ietf.org/html/draft-zch-lsr-isis-network-slicing-03, https://tools.ietf.org/html/draft-chen-idr-bgp-ls-transport-slice-00 , https://tools.ietf.org/html/draft-peng-pce-te-constraints-02 satisfying the same requirement. So Control plane extensions are still an open question, and needing further discussing.

[Jie] Normally the SR data plane functions and procedures are defined in SPRING first, then the control plane extensions would be discussed and defined in relevant WGs to support the required SR data plane functions. Do you mean the control plane should be discussed first?

[Jie] Again, this document is not for network slicing only, while it seems the draft you mentioned is. Besides, the mechanisms and example of using the resource-aware SIDs for packet forwarding with SR based explicit path and loose path has been described in this document. Please refer to section 2 and section 4.2 for more information.

Best regards,

Jie

Regards,

Ran

原始邮件
发件人：Dongjie(Jimmy) <[email-masked]<mailto:[email-masked]>>
收件人：'SPRING WG List' <[email-masked]<mailto:[email-masked]>>;
抄送人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年03月10日 18:00
主 题 ：[spring] FW: New Version Notification fordraft-dong-spring-sr-for-enhanced-vpn-07.txt
Hi all,

Best regards,
Jie

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, March 9, 2020 4:33 PM
To: Takuya Miyasaka <[email-masked]<mailto:[email-masked]>>; Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>; Stewart Bryant <[email-masked]<mailto:[email-masked]>>; Yongqing Zhu <[email-masked]<mailto:[email-masked]>>; Fengwei Qin <[email-masked]<mailto:[email-masked]>>; Zhenqiang Li <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-07.txt

Abstract:

The IETF Secretariat

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: <[email-masked]>
Date: Fri, 13 Mar 2020 11:35:44 +0800 (CST)

Hi Jie,

Thanks for your reply,Please see my replies inline with [Ran]:

Regards,

Ran

原始邮件

发件人：Dongjie(Jimmy) <[email-masked]>
收件人：陈然00080434;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年03月11日 17:18
主 题 ：Re: [Teas] [spring] FW: New Version Notificationfordraft-dong-spring-sr-for-enhanced-vpn-07.txt

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

Hi Ran,

 

 

Hi Jie,

[Ran] 1. Control plane extensions that you referred in this draft are closely related to the network slicing, and on the other hand , It seems the application scenario of this draft is mainly network slicing .

          2. The current technology already  support the resource management, e.g. draft-ietf-lsr-flex-algo. 

[Jie] The proposed enhancement to SR data plane is clearly described  the draft. , in short it introduces new semantics to SR SIDs, so that the SIDs could be used to identify the set of resources used for packet .

[Ran] The current technology seems already  support this, e.g. draft-ietf-lsr-flex-algo  describe the SID be allocated per flex-algorithm and related metric information.

2. Control plane extensions that you referred in this draft is ietf-dong-lsr-sr-enhanced-vpn, and ietf-dong-idr-bgpls-sr-enhanced-vpn, and we also have a series of control plane drafts:https://tools.ietf.org/html/draft-zch-lsr-isis-network-slicing-03, https://tools.ietf.org/html/draft-chen-idr-bgp-ls-transport-slice-00 , https://tools.ietf.org/html/draft-peng-pce-te-constraints-02 satisfying the same requirement. So Control plane extensions are still an open question, and needing further discussing.

3. For slice resources, our draft:https://tools.ietf.org/html/draft-peng-teas-network-slicing-03  induced slice-id(AII) for slice resources management, and our solution can differentiate them (e.g. L2 link or L3 interface), how to compute SR-BE or SR-TE path according to AII combined with other criteria. This isnot very clear in your draft.

[Ran]Again,Control plane extensions that you referred in this draft are closely related to the network slicing, see the draft ietf-dong-lsr-sr-enhanced-vpn:

regards,

Ran

Best regards,

Jie

Regards,

Ran

原始邮件

日 期 ：2020年03月10日 18:00

Hi all, 

Best regards,
Jie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, March 9, 2020 4:33 PM
To: Takuya Miyasaka <[email-masked]>; Dongjie (Jimmy) <[email-masked]>; Stewart Bryant <[email-masked]>; Yongqing Zhu <[email-masked]>; Fengwei Qin <[email-masked]>; Zhenqiang Li <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-07.txt

Abstract:

The IETF Secretariat

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 26 Mar 2020 15:15:36 +0000

Hi Ran,

Sorry for the late response. Please see some replies inline with [Jie2].

[Jie2] IMO it is totally fine that the one use case of this document is network slicing, while this does not prevent it from being used in other scenarios. This is clearly stated in the draft.

[Jie2] Not sure how you reach that conclusion. As described in that draft, Flex-Algo is about distributed constraint path computation, I don’t find resource management mentioned in that document.

[Jie2]  While the resource semantic is not introduced in any other existing SR document.

2. Control plane extensions are still an open question, and needing further discussing.

[Jie2] The text you referred to was in a previous version. If you check the latest version, you will find the text and extensions generic and not coupled with network slicing.

Best regards,

Jie

regards,

Ran

Best regards,

Jie

Regards,

Ran

原始邮件

Best regards,
Jie

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, March 9, 2020 4:33 PM
To: Takuya Miyasaka <[email-masked]<mailto:[email-masked]>>; Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>; Stewart Bryant <[email-masked]<mailto:[email-masked]>>; Yongqing Zhu <[email-masked]<mailto:[email-masked]>>; Fengwei Qin <[email-masked]<mailto:[email-masked]>>; Zhenqiang Li <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-07.txt

Abstract:

The IETF Secretariat