Subject: [spring] Status of draft-ietf-spring-srv6-network-programming?

From: Fernando Gont <[email-masked]>
Date: Fri, 6 Mar 2020 06:25:35 -0300

Marting & Bruno,

May I ask what's the status of this I-D?  -

On one hand, both of you declared consensus to move it forward. On 
another hand, the authors keep making changes to address comments (good) 
so what the wg will ship will be different from what the document on 
which you claimed consensus. Besides, the datatracker lists the document 
as "in WGLC".

So:
What's the status of this document?
And.. are you planning to do a second WGLC?

Thanks,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: Fernando Gont <[email-masked]>
Date: Wed, 11 Mar 2020 01:05:41 -0300

Folks,

Ping?

---

From: <[email-masked]>
Date: Wed, 11 Mar 2020 18:12:31 +0000

Fernando,

> From: Fernando Gont [mailto:[email-masked]] 
> Sent: Wednesday, March 11, 2020 5:06 AM
> 
> Folks,
> 
> Ping?
> 
> 

The call for comments is closed and I believe people had ample time to review the document and make comments.
Till then, authors have been working on addressing the received comments, and updating the document. 
Some occasional new questions or points are been raised, but I don't see anything wrong with this. This may happen after the WGLC (e.g. during AD review, during IETF last call, during IESG review, and when the RFC is published via email or errata).
I'm in the process of writing the shepherd write up.

Reviewing all the diff on all versions of the document, I don't see large technical changes that would require a formal review of those changes though a second WG last call.  Except one change regarding the processing of the upper layer, that has recently been raised by Chris. Let's see the solution on this.
Other than that, the changes are:
- some editorial clarifications
- removal of OAM references & counters (Greg's comment)
- large editorial changes in the PSP section to provide more clarification and context and explicit the consequences. But with no change to the technical behavior.

Do you see a need for a formal review of some changes?

Thanks,
--Bruno

> > Thanks,

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 11 Mar 2020 14:32:49 -0400

Bruno, I can not speak for anyone else.  But I have made clear to the 
authors (on list) and the AD (off list) that the current revision of the 
document does not provide what I consider adequate explanation of the 
consequence of the PSP issues.

If progress is such an important concern, then put out NP without PSP, 
and issue a separate document with PSP.  The NP document (quite 
correctly) does not claim to be a complete compilation of all behaviors 
or all flavors.

 From other people's questions about the PSP processing, it seems that 
the text is still not clear about what SID has the PSP flavor (I think I 
know how that is supposed to work, but the degree of accidental 
misinterpretation suggests the document could be better.)

Yours,
Joel

On 3/11/2020 2:12 PM, [email-masked] wrote:
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Fernando Gont <[email-masked]>
Date: Wed, 11 Mar 2020 15:36:32 -0300

On 11/3/20 15:12, [email-masked] wrote:
[....]
> The call for comments is closed and I believe people had ample time to review the document and make comments.

Shouldn't the datatracker state be updated?

> Some occasional new questions or points are been raised, but I don't see anything wrong with this. This may happen after the WGLC (e.g. during AD review, during IETF last call, during IESG review,…

How come consensus was declared before there was agreement on the 
changes to address the received feedback?

e.g., what if the updates do not satisfy the folks providing comments 
during WGLC?

> Do you see a need for a formal review of some changes?

I do see a need for a second WGLC, because my understanding is that 
several comments from wg participants have not been addressed.

I'd rather have a second WGLC and have the wg ship a document that the 
wg largely feels comfortable with, as opposed to have wg participants 
rehash the same discussions during IETF LC because they were dismissed 
during WGLC.

Thanks,

---

From: Fernando Gont <[email-masked]>
Date: Wed, 11 Mar 2020 16:20:06 -0300

> misinterpretation suggests the document could be better.)

That's indeed my objection: claiming consensus before folks that raised 
issues confirm that they issues they raised have been addressed.

Thanks,