Subject: [spring] draft-ietf-spring-srv6-network-programming - references

From: <[email-masked]>
Date: Fri, 13 Mar 2020 16:27:09 +0000

Hi Pablo,

I have two comments regarding the References sections in the draft.

1) I think that below reference should be moved to the normative reference section

   [RFC6437]  Amante, S., Carpenter, B., Jiang, S., and J. Rajahalme,
              "IPv6 Flow Label Specification", RFC 6437,
              DOI 10.17487/RFC6437, November 2011,
              <https://www.rfc-editor.org/info/rfc6437>.

2) The reference used for the Ethernet frame is:
   [Ethernet]
              DigitalEquipment, Intel, and Xerox, "The Ethernet -- A
              Local Area Network: Data Link Layer and Physical Layer
              (Version 2.0)", November 1982.

What about using an IEEE specification instead? Using an IEEE specification would avoid a downward normative references.

Following the example of https://tools.ietf.org/html/rfc4448 I would propose the following, but that is really an open suggestion

   [802.3]      IEEE802.3-2005, ISO/IEC 8802-3: 2000 (E), "IEEE Standard
                for Information technology -- Telecommunications and
                information exchange between systems -- Local and
                metropolitan
                 area networks -- Specific requirements -- Part 3:
                Carrier Sense Multiple Access with Collision Detection
                (CSMA/CD) Access Method and Physical Layer
                Specifications", 2005.

Thanks,
Regards,
--Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Mon, 16 Mar 2020 10:15:32 +0000

Hi Bruno,

Thank you. Both proposed changes look good to me.
I will also update draft-ietf-6man-SRH... to RFC8754.

Cheers,
Pablo.

From: "[email-masked]" <[email-masked]>
Date: Friday, 13 March 2020 at 17:27
To: "Pablo Camarillo (pcamaril)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: draft-ietf-spring-srv6-network-programming - references

Hi Pablo,

Thanks,
Regards,
--Bruno

Thank you.