Subject: Re: [spring] SRV6 - SR-TE support & Flex Alg support ? and comparison and contrast of those two steering strategies

From: Peter Psenak <[email-masked]>
Date: Sun, 5 Apr 2020 18:09:44 +0200

Hi Gyan,

On 01/04/2020 03:43, Gyan Mishra wrote:
> Thank you both for your feedback.  That really helps a lot and clarifies.
> 
> So flex-algo can be used with SR-TE as part of the policy specifying a 
> delay metric and also be used as part of the IGP flex algo cSPF.

yes.

> 
> Their might be some slight nuances but overall as far as features for 
> both SR-MPLS & SRv6 the SR-TE policy would require binding SID and have 
> similarities with lose or strict with prefix-sid or ad-sid specified 
> correct and all same features and functionality. Correct?

yes.

> 
> Also for inter-as or inter-domain SR -  for both SR-MPLS or SRv6  the 
> SR-TE w/ binding sid could be used as well in place of traditional 
> BGP-LU for inter-as or csc.  Correct?

yes.

> 
> So operators have the option to stay with inter-as BGP-LU or go with 
> SR-TE which is more attractive and powerful with simplicity.

agree.

thanks,
Peter
> 
> Kind regards
> 
> Gyan
> 
> On Tue, Mar 31, 2020 at 5:15 AM Ketan Talaulikar (ketant) 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi Gyan,
> 
>     To add to what Peter has clarified, SR Policy architecture also
>     supports SRv6 (as you've pointed out in the references) - loose and
>     strict paths as well as steering for colored BGP routes.
> 
>     Thanks,
>     Ketan
> 
>     -----Original Message-----
>     From: spring <[email-masked]
>     <mailto:[email-masked]>> On Behalf Of Peter Psenak
>     Sent: 31 March 2020 13:42
>     To: Gyan Mishra <[email-masked]
>     <mailto:[email-masked]>>; SPRING WG <[email-masked]
>     <mailto:[email-masked]>>
>     Subject: Re: [spring] SRV6 - SR-TE support & Flex Alg support ? and
>     comparison and contrast of those two steering strategies
> 
>     Hi Gyan,
> 
>     let me comment on the flex-algo aspect. Please see inline:
> 
>     On 30/03/2020 23:50, Gyan Mishra wrote:
>      >
>      > Does SRv6 support SR-TE and flex Alg?
> 
>     yes, it does support both.
> 
>      >
>      >
>      > Since SRv6 supports native traffic steering with SRH with end prefix
>      > sid and end.x adjacency sid you can achieve the basic steering and
>      > ECMP capability with prefix sid lose or strict hop by hop with every
>      > node specified in SRH SL.
>      >
>      > I want to confirm that SRv6 fully supports all of the  SR-TE
>      > capabilities available with SR-MPLS with static lose or strict paths
>      > and coloring of vpn flows.
>      >
>      >  From the SR policy draft I did see that section 4 lists segment
>     types
>      > and does appear to support SRv6 sid.
>      >
>      >
>     https://tools.ietf.org/html/draft-ietf-spring-segment-routing-policy-0
>      > 6
>      >
>      >
>      >     4
>      >   
>       <https://tools.ietf.org/html/draft-ietf-spring-segment-routing-policy-06#section-4>.
>      >     Segment Types
>      >
>      >
>      >
>      >     A Segment-List is an ordered set of segments represented as
>     <S1, S2,
>      >     ... Sn> where S1 is the first segment.
>      >
>      >     Based on the desired dataplane, either the MPLS label stack
>     or the
>      >     SRv6 SRH is built from the Segment-List.  However, the
>     Segment-List
>      >     itself can be specified using different segment-descriptor
>     types and
>      >     the following are currently defined:
>      >
>      >
>      > Flex Alg - SRv6 support?
> 
>     yes.
> 
>      >
>      > Flex Alg is orthogonal to SR TE as it provides IGP extensions for
>      > constrained SPF versus traditional RSVP or SR-TE providing the
>      > extensions for cSPF - basically another method of steering which as
>      > well is very powerful tool for operators.
>      >
>      > It does appear SRv6 supports flex Alg draft below.
> 
>     yes.
> 
>      >
>      > https://tools.ietf.org/html/draft-ietf-lsr-flex-algo-06
>      >
>      > Abstract
>      >
>      > IGP protocols traditionally compute best paths over the network based
>      >     on the IGP metric assigned to the links.  Many network
>     deployments
>      >     use RSVP-TE based or Segment Routing based Traffic Engineering to
>      >     enforce traffic over a path that is computed using different
>     metrics
>      >     or constraints than the shortest IGP path.  This document
>     proposes a
>      >     solution that allows IGPs themselves to compute constraint based
>      >     paths over the network.  This document also specifies a way
>     of using
>      >     Segment Routing (SR) Prefix-SIDs and SRv6 locators to steer
>     packets
>      >     along the constraint-based paths.
>      >
>      >
>      >
>      > What are the benefits of using SR-TE over flex Alg and vice versa?
> 
>     you can think of them as different tools in your SR-TE tool set. You
>     pick them as you need them. They can be used independently in
>     parallel or can even be combined together to give you even more
>     flexibility.
> 
>     The principal difference is that SR-TE provisions point-to-point
>     path(s) between two end-points, while flex-algo provides any to any
>     paths between set of participating nodes.
> 
>      >
>      > Also can SR-TE use flex Alg steered paths as the dynamic cSPF paths?
> 
>     yes
> 
>      >
>      > Can SR-TE use and specify flex Alg to be used for traffic steering?
> 
>     yes
> 
>     thanks,
>     Peter
> 
>      >
>      >
>      > Kind regards
>      >
>      >
>      > Gyan
>      > Verizon
>      > Cell 301 502-1347
>      > --
>      >
>      > Gyan  Mishra
>      >
>      > Network Engineering & Technology
>      >
>      > Verizon
>      >
>      > Silver Spring, MD 20904
>      >
>      > Phone: 301 502-1347
>      >
>      > Email: [email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >
>      >
>      >
> 
>     _______________________________________________
>     spring mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/spring
> 
> 
> 
> -- 
> 
> Gyan  Mishra
> 
> Network Engineering & Technology
> 
> Verizon
> 
> Silver Spring, MD 20904
> 
> Phone: 301 502-1347
> 
> Email: [email-masked] <mailto:[email-masked]>
> 
> 
>

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 5 Apr 2020 13:04:23 -0400

Thank you

Gyan

On Sun, Apr 5, 2020 at 12:09 PM Peter Psenak <[email-masked]> wrote:

> >       <
> https://tools.ietf.org/html/draft-ietf-spring-segment-routing-policy-06#section-4
> >.
> >      >     Segment Types
> >      >
> >      >
> >      >

Gyan  Mishra

Verizon

Silver Spring, MD 20904

Phone: 301 502-1347