Subject: [spring] FW: New Version Notification for draft-bonica-spring-sr-mapped-six-01.txt

From: Ron Bonica <[email-masked]>
Date: Fri, 10 Apr 2020 15:05:22 +0000

Folks,

Please review and comment.

                         Ron

Juniper Business Use Only

> -----Original Message-----
> From: [email-masked] <[email-masked]>
> Sent: Friday, April 10, 2020 10:18 AM
> To: Luay Jalil <[email-masked]>; Gang Chen
> <[email-masked]>; [email-masked]
> <[email-masked]>; Jen Linkova <[email-masked]>;
> [email-masked]
> <[email-masked]>; Daniam Henriques
> <[email-masked]>; Ron Bonica
> <[email-masked]>; Yuji Kamite <[email-masked]>; Joel Halpern
> <[email-masked]>; Shraddha Hegde <[email-masked]>
> Subject: New Version Notification for draft-bonica-spring-sr-mapped-six-
> 01.txt
> 
> [External Email. Be cautious of content]
> 
> 
> A new version of I-D, draft-bonica-spring-sr-mapped-six-01.txt
> has been successfully submitted by Ron Bonica and posted to the IETF
> repository.
> 
> Name:           draft-bonica-spring-sr-mapped-six
> Revision:       01
> Title:          Segment Routing Mapped To IPv6 (SRm6)
> Document date:  2020-04-10
> Group:          Individual Submission
> Pages:          18
> URL:            https://urldefense.com/v3/__https://www.ietf.org/internet-
> drafts/draft-bonica-spring-sr-mapped-six-01.txt__;!!NEt6yMaO-
> gk!ReC5D9PqJg9VvhTCWgZN97t18LSeFN2lqDJE-
> 4sfI8tHuQzazw38mDU55l4XfCX4$
> Status:
>  https://datatracker.ietf.org/doc/draft-bonica-spring-sr-mapped-six
> Htmlized:       https://tools.ietf.org/html/draft-bonica-spring-sr-mapped-six-01
> Htmlized:  https://datatracker.ietf.org/doc/html/draft-bonica-spring-sr-mapped-six
> Diff: https://www.ietf.org/rfcdiff?url2=draft-bonica-spring-sr-mapped-six-01
> 
> Abstract:
>    This document describes Segment Routing Mapped to IPv6 (SRm6).  SRm6
>    is a Segment Routing (SR) solution that supports a wide variety of
>    use-cases while complying with IPv6 specifications.  SRm6 is
>    optimized for ASIC-based routers that operate at high data rates.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Melchior Aelmans <[email-masked]>
Date: Sun, 12 Apr 2020 09:58:35 +0200

Hi Ron, authors,

Are the "should" and "must" used in the following sentence meant as those
described in https://tools.ietf.org/html/rfc8174?

   To minimize packet length, network operators should use 16-bit SIDs
   whenever possible.  However, when more than 65,520 SIDs are required,
   network operators must use 32-bit SIDs.

In other words the  Requirements Language section is missing.

Cheers,
Melchior

On Fri, Apr 10, 2020 at 5:06 PM Ron Bonica <rbonica=
[email-masked]> wrote:

> > URL:
> https://urldefense.com/v3/__https://www.ietf.org/internet-
> > Htmlized:
> https://tools.ietf.org/html/draft-bonica-spring-sr-mapped-six-01
> > Htmlized:
> https://datatracker.ietf.org/doc/html/draft-bonica-spring-sr-mapped-six
> > Diff:
> https://www.ietf.org/rfcdiff?url2=draft-bonica-spring-sr-mapped-six-01
> >
> > Abstract:
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Ron Bonica <[email-masked]>
Date: Mon, 13 Apr 2020 14:55:18 +0000

Hi Melchior,

These words are intentionally lower-case and do not carry RFC 2119 or 8174 weight.

In fact, you won't see any RFC 2119 language, IANA requests or packet formats in the entire document. So, it could be INFORMATIONAL just as well as it could be STANDARDS TRACK.

                                                                         Ron

Juniper Business Use Only
From: Melchior Aelmans <[email-masked]>
Sent: Sunday, April 12, 2020 3:59 AM
To: Ron Bonica <[email-masked]>
Cc: [email-masked]
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-sr-mapped-six-01.txt

Hi Ron, authors,

Are the "should" and "must" used in the following sentence meant as those described in https://tools.ietf.org/html/rfc8174<https://urldefense.com/v3/__https:/tools.ietf.org/html/rfc8174__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiIoJGAK3$>?

Cheers,

Melchior

On Fri, Apr 10, 2020 at 5:06 PM Ron Bonica <rbonica=[email-masked]<mailto:[email-masked]>> wrote:
Folks,

                         Ron

> From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
> To: Luay Jalil <[email-masked]<mailto:[email-masked]>>; Gang Chen
> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> <[email-masked]<mailto:[email-masked]>>; Jen Linkova <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:[email-masked]>
> <[email-masked]<mailto:[email-masked]>>; Daniam Henriques
> <[email-masked]<mailto:[email-masked]>>; Ron Bonica
> <[email-masked]<mailto:[email-masked]>>; Yuji Kamite <[email-masked]<mailto:[email-masked]>>; Joel Halpern
> <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
> URL:            https://urldefense.com/v3/__https://www.ietf.org/internet-<https://urldefense.com/v3/__https:/www.ietf.org/internet->
>  https://datatracker.ietf.org/doc/draft-bonica-spring-sr-mapped-six<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-bonica-spring-sr-mapped-six__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiGjXv_EV$>
> Htmlized:       https://tools.ietf.org/html/draft-bonica-spring-sr-mapped-six-01<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-bonica-spring-sr-mapped-six-01__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiFLvKMZ3$>
> Htmlized:  https://datatracker.ietf.org/doc/html/draft-bonica-spring-sr-mapped-six<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-bonica-spring-sr-mapped-six__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiKF1Mz-Y$>
> Diff: https://www.ietf.org/rfcdiff?url2=draft-bonica-spring-sr-mapped-six-01<https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-bonica-spring-sr-mapped-six-01__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiLfD7Vb9$>
>
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiMG33FtH$>.
>
> The IETF Secretariat
>
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiBIJiR8N$>

---

From: Melchior Aelmans <[email-masked]>
Date: Tue, 14 Apr 2020 13:00:54 +0200

Ack, thanks Ron for clarifying!

Cheers,
Melchior

On Mon, Apr 13, 2020 at 4:55 PM Ron Bonica <[email-masked]> wrote:

> In fact, you won’t see any RFC 2119 language, IANA requests or packet
> formats in the entire document. So, it could be INFORMATIONAL just as well
> as it could be STANDARDS TRACK.
>
>
>
>
> Ron
>
>
>
>
>
>
>
> *From:* Melchior Aelmans <[email-masked]>
> *Sent:* Sunday, April 12, 2020 3:59 AM
> *To:* Ron Bonica <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [spring] FW: New Version Notification for
> draft-bonica-spring-sr-mapped-six-01.txt
>
>
>
> *[External Email. Be cautious of content]*
>
>
>
> Hi Ron, authors,
>
>
>
> described in https://tools.ietf.org/html/rfc8174
> <https://urldefense.com/v3/__https:/tools.ietf.org/html/rfc8174__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiIoJGAK3$>
> ?
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/internet->
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-bonica-spring-sr-mapped-six__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiGjXv_EV$>
> > Htmlized:
> <https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-bonica-spring-sr-mapped-six-01__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiFLvKMZ3$>
> > Htmlized:
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-bonica-spring-sr-mapped-six__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiKF1Mz-Y$>
> > Diff:
> <https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-bonica-spring-sr-mapped-six-01__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiLfD7Vb9$>
> >
> > Abstract:
> > until the htmlized version and diff are available at tools.ietf.org
> <https://urldefense.com/v3/__http:/tools.ietf.org__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiMG33FtH$>
> .
> >
> > The IETF Secretariat
> >
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!!NEt6yMaO-gk!Rgx7CYdsiICBAUWuI6Dy3xSPEH0YemhahBTgQ6NeA8DKEFRymprNFwmDiBIJiR8N$>
>
>