Subject: [spring] draft-ietf-lsr-isis-srv6-extensions

From: Parag Kaneriya <[email-masked]>
Date: Wed, 27 May 2020 12:22:40 +0000

Hello,

This is regarding the query for Locator TVL ,

As per the draft there is flags  D (L2-L1 leaking) and A (anycast ) defined.   Since there is space already exists for other flags , why can't  R flag is not defined in the main tlv.

Defining in main tlv when it had space, have some benefit as per me.

  1.  Many operator may opt to support main tlvs and may not support sub-sub-tvl.
  2.  Easy implantation and inter-op can  work with main tvl implementation itself.
I understand that rfc7794 can define extended prefix attribute tlv, for the same and   Locator tlv can sent with sub-sub-tlv define in rfc7794.

Regards
Parag

Juniper Business Use Only

---

From: Peter Psenak <[email-masked]>
Date: Fri, 29 May 2020 16:14:03 +0200

Parag,

On 27/05/2020 14:22, Parag Kaneriya wrote:
> As per the draft there is flags  D (L2-L1 leaking) and A (anycast ) 
> defined.   Since there is space already exists for other flags , why 
> can’t  R flag is not defined in the main tlv.

the A flag has been moved to Prefix Attribute Flags Sub-TLV.
R-flag is part of the Prefix Attribute Flags Sub-TLV as well.

Prefix Attribute Flags Sub-TLV can be advertised as a Sub-TLV inside the 
Locator TLV.

>  1. Many operator may opt to support main tlvs and may not support

I don't understand. Either you support a particular extension or not. 
You can not be selective based on what level of nesting is being used 
for it.

thanks,
Peter

> I understand that rfc7794 can define extended prefix attribute tlv, for 
> the same and   Locator tlv can sent with sub-sub-tlv define in rfc7794.
> 
> Regards
> 
> Parag
> 
>