Subject: Re: [spring] Long-standing practice of due-diligence is expected - Re: CRH is not needed - Re: How CRH support SFC/Segment Endpoint option?

From: 刘毅松 <[email-masked]>
Date: Sat, 30 May 2020 10:50:08 +0800

Hi Zafar

I totally agree with you. The CRH solution is more complicated but does not show any more genuine benefits. There is still no use-case document now to provide an understanding of the intended use of CRH.

Thanks

Yisong

发件人: spring <[email-masked]> 代表 Zafar Ali (zali)
发送时间: 2020年5月28日 03:19
收件人: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; Sander Steffann <[email-masked]>
抄送: [email-masked]; Mach Chen <[email-masked]>; Ron Bonica <[email-masked]>; 6man <[email-masked]>; Chengli (Cheng Li) <[email-masked]>; Zafar Ali (zali) <[email-masked]>
主题: [spring] Long-standing practice of due-diligence is expected - Re: CRH is not needed - Re: How CRH support SFC/Segment Endpoint option?

WH> My position remains that RFC8663 is a valid alternative and is available; I am against WG adoption of CRH.

The industry widely supports RFC8663. 

Instead of denying the evidence, could the CRH authors and proponents finally understand that people are not opposed to new ideas? 

People are reminding a long-standing practice of the IETF process. Before tackling a new piece of work, a working group must perform a due diligence on 

1.	whether this new work is redundant with respect to existing IETF protocols, 
2.	whether this new work would deliver genuine benefits and use-cases. 

It is factually and logically clear to the working-group that the currently submitted CRH documents.  

1.	fail to position CRH with respect to existing standard widely supported by the industry (e.g., RFC8663) 
2.	fail to isolate new benefit or use-case [1]

This positive collaborative feedback was already given in SPRING. 

The CRH authors may change this analysis. They need to document 1 and 2. 

Why did the CRH authors not leverage this guidance in SPRING WG?  

This was also the chair's guidance in Montreal [2] and Singapore [3] 

All the lengthy discussions and debates on the mailing list could be avoided if only the CRH authors would tackle 1 and 2. 

The CRH authors must tackle 1 and 2.  

*	This is the best way to justify a/the work from the IETF community and b/ the hardware and software investment from vendors. 
*	True benefits must be present to justify such a significant engineering investment (new data-pane, new control-plane). 

Thanks

Regards … Zafar 

[1]  <https://mailarchive.ietf.org/arch/msg/ipv6/W3gO-dni2tB4nG9e13QsJnjFgG8/> https://mailarchive.ietf.org/arch/msg/ipv6/W3gO-dni2tB4nG9e13QsJnjFgG8/

[2]  <https://etherpad.ietf.org:9009/p/notes-ietf-105-spring?useMonospaceFont=true> https://etherpad.ietf.org:9009/p/notes-ietf-105-spring?useMonospaceFont=true

[3]  <https://mailarchive.ietf.org/arch/msg/ipv6/aWkqPfpvDRyjrW8snR8TCohxcBg/> https://mailarchive.ietf.org/arch/msg/ipv6/aWkqPfpvDRyjrW8snR8TCohxcBg/

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Sat, 30 May 2020 16:06:51 +0000

Here is a very broad-reaching and large-scale use case – worldwide air and ground
transportation (planes, trains and automobiles):

https://datatracker.ietf.org/doc/draft-templin-intarea-6706bis/
https://datatracker.ietf.org/doc/draft-templin-6man-omni-interface/

Fred

From: ipv6 [mailto:[email-masked]] On Behalf Of ???
Sent: Friday, May 29, 2020 7:50 PM
To: 'Zafar Ali (zali)' <zali=[email-masked]>; 'Henderickx, Wim (Nokia - BE/Antwerp)' <[email-masked]>; 'Sander Steffann' <[email-masked]>
Cc: [email-masked]; '6man' <[email-masked]>
Subject: Re: [spring] Long-standing practice of due-diligence is expected - Re: CRH is not needed - Re: How CRH support SFC/Segment Endpoint option?

Hi Zafar

Thanks
Yisong
发件人: spring <[email-masked]<mailto:[email-masked]>> 代表 Zafar Ali (zali)
发送时间: 2020年5月28日 03:19
收件人: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>; Sander Steffann <[email-masked]<mailto:[email-masked]>>
抄送: [email-masked]<mailto:[email-masked]>; Mach Chen <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>; 6man <[email-masked]<mailto:[email-masked]>>; Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>; Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>
主题: [spring] Long-standing practice of due-diligence is expected - Re: CRH is not needed - Re: How CRH support SFC/Segment Endpoint option?

Thanks

Regards … Zafar

[1] https://mailarchive.ietf.org/arch/msg/ipv6/W3gO-dni2tB4nG9e13QsJnjFgG8/

[2] https://etherpad.ietf.org:9009/p/notes-ietf-105-spring?useMonospaceFont=true

[3] https://mailarchive.ietf.org/arch/msg/ipv6/aWkqPfpvDRyjrW8snR8TCohxcBg/