Subject: [spring] FW: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-08.txt

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 23 Jun 2020 03:17:22 +0000

Hi all, 

FYI we have uploaded a new revision of draft-dong-spring-sr-for-enhanced-vpn to resolve the comments received recently. Please take a look and let us know if your comments have been addressed. Thanks.

Best regards,
Jie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, June 22, 2020 5:22 PM
To: Dongjie (Jimmy) <[email-masked]>; Yongqing Zhu <[email-masked]>; Takuya Miyasaka <[email-masked]>; Fengwei Qin <[email-masked]>; Stewart Bryant <[email-masked]>; Zhenqiang Li <[email-masked]>
Subject: New Version Notification for draft-dong-spring-sr-for-enhanced-vpn-08.txt

A new version of I-D, draft-dong-spring-sr-for-enhanced-vpn-08.txt
has been successfully submitted by Jie Dong and posted to the IETF repository.

Name:		draft-dong-spring-sr-for-enhanced-vpn
Revision:	08
Title:		Segment Routing for Resource Guaranteed Virtual Networks
Document date:	2020-06-22
Group:		Individual Submission
Pages:		18
URL:            https://www.ietf.org/internet-drafts/draft-dong-spring-sr-for-enhanced-vpn-08.txt
Status:         https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/
Htmlized:       https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-08
Htmlized:       https://datatracker.ietf.org/doc/html/draft-dong-spring-sr-for-enhanced-vpn
Diff:           https://www.ietf.org/rfcdiff?url2=draft-dong-spring-sr-for-enhanced-vpn-08

Abstract:
   This document describes the mechanism to associate Segment Routing
   Identifiers (SIDs) with network resource attributes.  The resource-
   aware SIDs retain their original functionality, with the additional
   semantics of identifying the set of network resources available for
   the packet processing action.  These SIDs can be used to build SR
   paths with reserved network resources.  In addition, these SID can
   also be used to build SR based virtual networks, which provide the
   network topology and resource attributes required by particular
   services.  The proposed mechanism is applicable to both segment
   routing with MPLS data plane (SR-MPLS) and segment routing with IPv6
   data plane (SRv6).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 22 Jun 2020 23:44:05 -0400

Thank you for the work and improvements in thsi draft.

I have one thought, as an individual participant, with regard to one 
small part of this draft.  The bullet list in section 4 seems to 
duplicate / overlap with the work being done in the TEAS network slicing 
design team, which does not yet have working group rough consensus even 
for adoption.  It will be challenging for this work to carefully track 
that document.  Would it damage the overall message of this document if 
the 6 bullets were removed?

Thank you,
Joel

On 6/22/2020 11:17 PM, Dongjie (Jimmy) wrote:
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 23 Jun 2020 07:08:39 +0000

Hi Joel, 

Thanks for your reply and comment. 

The bullet list in section 4 was introduced before the TEAS NS design team, while I understand that it is related to the topic under discussion in the design team. Perhaps we could reduce such description in this document and leave the details for the design team. Does this solve your comment?

Best regards,
Jie

> From: Joel M. Halpern [mailto:[email-masked]]
> Sent: Tuesday, June 23, 2020 11:44 AM
> To: Dongjie (Jimmy) <[email-masked]>; 'SPRING WG' <[email-masked]>
> Subject: Re: [spring] FW: New Version Notification for
> draft-dong-spring-sr-for-enhanced-vpn-08.txt
> 
> I have one thought, as an individual participant, with regard to one small part
> of this draft.  The bullet list in section 4 seems to duplicate / overlap with
> the work being done in the TEAS network slicing design team, which does not
> yet have working group rough consensus even for adoption.  It will be
> challenging for this work to carefully track that document.  Would it damage
> the overall message of this document if the 6 bullets were removed?
> 
> Thank you,
> Joel
> 
> > FYI we have uploaded a new revision of
> draft-dong-spring-sr-for-enhanced-vpn to resolve the comments received
> recently. Please take a look and let us know if your comments have been
> addressed. Thanks.
> >
> > Best regards,
> > Jie
> >
> > To: Dongjie (Jimmy) <[email-masked]>; Yongqing Zhu
> > <[email-masked]>; Takuya Miyasaka <[email-masked]>;
> > Fengwei Qin <[email-masked]>; Stewart Bryant
> > <[email-masked]>; Zhenqiang Li <[email-masked]>
> > Subject: New Version Notification for
> > draft-dong-spring-sr-for-enhanced-vpn-08.txt
> >
> >
> > URL:
> https://www.ietf.org/internet-drafts/draft-dong-spring-sr-for-enhanced-vpn-
> 08.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/
> > Htmlized:
> https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-08
> > Htmlized:
> https://datatracker.ietf.org/doc/html/draft-dong-spring-sr-for-enhanced-vpn
> > Diff:
> https://www.ietf.org/rfcdiff?url2=draft-dong-spring-sr-for-enhanced-vpn-08
> >
> > Abstract:
> > Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >
> >

---

From: Joel Halpern Direct <[email-masked]>
Date: Tue, 23 Jun 2020 08:46:36 -0400

Thank you Jie.  Yes, I think it would help to do what you describe, 
reducing those discussions in this document.

Yours,
Joel