Subject: Re: [spring] WG Adoption Call fordraft-dong-spring-sr-for-enhanced-vpn

From: <[email-masked]>
Date: Thu, 16 Jul 2020 17:19:32 +0800 (CST)

Dear WG,

I don't support WG adoption.

It is not a new idea for each Virtual Network to have its own SIDs.

e.g. The earlist description of the SID be allocated per flex-algorithm and related metric

 information was in draft-hegdeppsenak-isis-sr-flex-algo-00(2017.7.17) (now is draft-ietf-isis-sr-flex-algo) . 

The earlist description of the SID be allocated per MT was in draft-filsfils-spring-segment-routing-04(2014.7.3)

(now is RFC8402 ), and draft-peng-lsr-network-slicing-00(2019.2.25) describe the

SID be allocated per AII(alias alice).  For slice resources, https://tools.ietf.org/html/draft-peng-teas-network-slicing-03  

induced slice-id(AII) for slice resources management, and can differentiate them (e.g. L2 link or L3 interface,

section 7 ), and how to compute SR-BE or SR-TE path according to AII combined with other criteria.

Regards,

Ran

-----Original Message-----From: spring <[email-masked]> On Behalf Of James GuichardSent: Wednesday, July 15, 2020 8:17 PMTo: [email-masked]: [email-masked]: [spring] WG Adoption Call for draft-dong-spring-sr-for-enhanced-vpnDear WG:  This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/ <https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/>  ending Wednesday 29th July 2020.    Please speak up if you support or oppose adopting this document into the WG. Please also provide comments/reasons for that support (or lack thereof). Silence will not be considered consent.  Thanks!  Jim, Joel & Bruno      _______________________________________________spring mailing [email-masked]

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 16 Jul 2020 11:50:04 +0000

Hi Ran,

Thanks for your comments. While I don’t quite get your point of objection.  Perhaps you have some misunderstanding about the relationship of the drafts mentioned.

RFC 8402 introduced the topology and service semantics of SR SID, this document proposed to add resource semantics to SIDs. Then MT or Flex-Algo are control plane mechanism for the distribution of topology-specific SIDs. The relationship with these documents are described in this draft.

My reading of draft-peng in LSR and TEAS is that they may provide an option of control plane extensions for the resource-aware SIDs defined in this document, which just proves that the enhancement in this document is in the right direction, and more work based on it could be done in relevant WGs.

Thus my suggestion would be to have the SR enhancement adopted in SPRING first, then more discussion about its control plane could happen in other WGs as the next step.

Hope this helps.

Best regards,
Jie

From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 16, 2020 5:20 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [spring] WG Adoption Call fordraft-dong-spring-sr-for-enhanced-vpn

Dear WG,

Regards,

Ran

-----Original Message-----
From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of James Guichard
Sent: Wednesday, July 15, 2020 8:17 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [spring] WG Adoption Call for draft-dong-spring-sr-for-enhanced-vpn

Dear WG:

This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/ <https://datatracker.ietf.org/doc/draft-dong-spring-sr-for-enhanced-vpn/>  ending Wednesday 29th July 2020.

Please speak up if you support or oppose adopting this document into the WG. Please also provide comments/reasons for that support (or lack thereof). Silence will not be considered consent.

Thanks!

Jim, Joel & Bruno

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>

---

From: <[email-masked]>
Date: Mon, 20 Jul 2020 17:11:07 +0800 (CST)

Hi Jie,

IMO, the essence of the problem is that an identifier should be introduced to manage and maintain virtual network resources,  not whether it is necessary to allocate resource related SIDs , because the current SR architecture already supports resource related SIDs allocation, there is no limit to that. For example, service SID (compuated resource related), Node/Adjacency SID(topological resource related), etc. Especially, SRv6 SID encourages programming anything. Can we say that these SIDs have no resource meaning?

Thus, draft-dong-spring-sr-for-enhanced-vpn does not introduce any new content on the existing SR architecture.

For identifier to manage and maintain virtual network resources, draft-peng-teas-network-slicing firstly to introduce a new identifier (AII) in the network to unifiedly identify the topology, computing and storage resource. Before that, other existing identities only focus on topology resources.

Just for topology related resource, Segment Routing with MTR/Flex-algo/AII all support the division of multiple topological resource, and already support allocatoin of SID per MT-ID/algorithm/AII. Especially for link resource, the bandwidth of the same link can be subdivided into multiple resources. 

If these subdivided resources exist in the form of sub-interface resources, L2-bundles(rfc8668) provides the method to assign adjacency-SID for members, In other words, the allocation of member adjacency SID has already been aware of these subdivided resources, each sub-interface has its own link attributes (bandwidth, delay, etc.). 

If there are no sub-interface, the link can also be shared by multiple virtual networks to allocate multiple adjacency SIDs. Under the existing SR architecture, draft-peng-teas-network-slicing and draft-peng-lsr-algorithm-related-adjacency-sid have already described the allocation of adjacency SID per AII and algorithm.

Obviously, the above SR with MTR/Flex-algo/AII are all complete solutions, including control plane extensions and forwarding mechanisms, and they need not make any changes to the SR architecture.

I wonder according to draft-dong-spring-sr-for-enhanced-vpn, what can we do under its guidance, or what we can't do without this draft? 

Regards,

Ran

原始邮件

发件人：Dongjie(Jimmy) <[email-masked]>
收件人：陈然00080434;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
抄送人：[email-masked] <[email-masked]>;
日 期 ：2020年07月16日 19:50
主 题 ：RE: [spring] WG Adoption Callfordraft-dong-spring-sr-for-enhanced-vpn

Hi Ran,

Thanks for your comments. While I don’t quite get your point of objection.  Perhaps you have some misunderstanding about the relationship of the
 drafts mentioned.

RFC 8402 introduced the topology and service semantics of SR SID, this document proposed to add resource semantics to SIDs. Then MT or Flex-Algo
 are control plane mechanism for the distribution of topology-specific SIDs. The relationship with these documents are described in this draft.

My reading of draft-peng in LSR and TEAS is that they may provide an option of control plane extensions for the resource-aware SIDs defined in this
 document, which just proves that the enhancement in this document is in the right direction, and more work based on it could be done in relevant WGs.

Thus my suggestion would be to have the SR enhancement adopted in SPRING first, then more discussion about its control plane could happen in other
 WGs as the next step.  

Hope this helps.

Best regards,

Jie

From: spring [mailto:[email-masked]]On Behalf Of [email-masked]

Dear WG,

SID be allocated per AII(alias alice).  For slice resources,https://tools.ietf.org/html/draft-peng-teas-network-slicing-03  

 

Regards,

Ran

-----Original Message-----
From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Wednesday, July 15, 2020 8:17 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-dong-spring-sr-for-enhanced-vpn

Dear WG:

Thanks!

Jim, Joel & Bruno

[email-masked]

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 21 Jul 2020 12:48:35 +0800

Hi Ran,
 
Thank you very much for your interests in and comments on this draft.

Yes, you are right that SR architecture supports resource related SIDs. So we can specify the resource related framework under SR architecture.  This is the main purpose of this doc. RFC8402 supports resource related SIDs, but doesn't  define them, which are defined in this doc.

However, I am afraid I can not agree with you that this doc is mainly to manage and maintain virtual network resources.  The concept and mechanism of resource-awareness SID is introduced in this doc to enrich the semantics of SR SID and to enhance the SR architecture. Thanks to its flexibility and extensibility.
Resource related SIDs introduced in this doc can be used to construct virtual networks, resource isolated pathes, dedicated queques in one node and so on, which depends on the application scenarios. 

Since this draft belongs to SPRING WG, IMO it is correct that it focuses the semantics and functions associated with SR SIDs. The identifier and mechanisms in control plane could be discussed in the corresponding protocol WGs as next step. Please pay attention to our related work in the protocol WGs and you are welcome to present your comments there. Thanks alot.
 
Best regards,
Zhenqiang Li

[email-masked]
 
From: [email-masked]
Date: 2020-07-20 17:11
To: [email-masked]
CC: james.n.guichard; spring; spring-chairs
Subject: Re: [spring]WG Adoption Callfordraft-dong-spring-sr-for-enhanced-vpn
Hi Jie,
IMO, the essence of the problem is that an identifier should be introduced to manage and maintain virtual network resources,  not whether it is necessary to allocate resource related SIDs , because the current SR architecture already supports resource related SIDs allocation, there is no limit to that. For example, service SID (compuated resource related), Node/Adjacency SID(topological resource related), etc. Especially, SRv6 SID encourages programming anything. Can we say that these SIDs have no resource meaning?
Thus, draft-dong-spring-sr-for-enhanced-vpn does not introduce any new content on the existing SR architecture.

Regards,
Ran

原始邮件

        

Hope this helps.
 
Best regards,
Jie

Dear WG,
 
Regards,
Ran

-----Original Message-----
From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Wednesday, July 15, 2020 8:17 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-dong-spring-sr-for-enhanced-vpn

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: <[email-masked]>
Date: Thu, 23 Jul 2020 09:25:26 +0800 (CST)

Hi zhenqiang,

Resource is a big, all encompassing concept. Similarly, service concept, application concept, intent concept, etc, you can find more. 

IMO, we can't ignore the fact that the current SR architecture already cover resource related SID allocation, but to surmise that it lacks resource meaning, then to submit an unnecessary and redundant framework. 

AFAIK, there have already been several documents that defined the allocation of SID for specific resouce, for example:

draft-ietf-lsr-flex-algo described topology related resource partition and algorithm based SID allocation, 

L2-bundles(rfc8668) described the allocation of member adjacency SIDs for subdivided link resources

draft-peng-teas-network-slicing described slice related resource partition and corresponding SID allocation.

All of these solutions follow the existing SR architecture. Thus it is not the truth that we all think that the existing SR architecture does not cover allocating resource-awareness SID and explicitly resource capability or semantic need to be defined.

I believe there will be more SR based solution in the future. For simplicity and refinement, we can not paint the lily to change the existing architecture at will, ignoring the fact that it can work and perfect support for every solutions. Otherwise, for some purpose, someone can also persist that the SR architecture lacks service meanning, application meaning, intent meanning, etc, then more and more unnecessary X-awareness framework appear. 

So let us focus on specific solutions, i.e, just like what is done in flex-algo or other documents, detailed control extension and forwarding mechanism for virtual network (yes ,you can say this doc is not only for virtual network, but this is exactly what makes me confused. It is not clear for other purpose) . A new X-awareness framework is really unnecessary, except for standard strategy.

Regards,

PSF

原始邮件

发件人：[email-masked] <[email-masked]>
收件人：陈然00080434;Dongjie (Jimmy) <[email-masked]>;
抄送人：James Guichard <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年07月21日 12:48
主 题 ：Re: [spring] WG AdoptionCallfordraft-dong-spring-sr-for-enhanced-vpn

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

Hi Ran,

Since this draft belongs to SPRING WG, IMO it is correct that it focuses the semantics and functions associated with SR SIDs. The identifier and mechanisms in control plane could be discussed in the corresponding protocol WGs as next step. Please pay attention to our related work in the protocol WGs and you are welcome to present your comments there... Thanks alot.

Best regards,

Zhenqiang Li

--------------------------------------------------------------------------------

[email-masked]

Hi Jie,

Regards,

Ran

Hi Ran,

 

RFC 8402 introduced the topology and service semantics of SR SID, this document proposed to add resource semantics to SIDs. Then MT or Flex-Algo
 are control plane mechanism for the distribution of topology-specific SIDs... The relationship with these documents are described in this draft.

 

 

Hope this helps.

Best regards,

Jie

 

Dear WG,

The earlist description of the SID be allocated per MT was in draft-filsfils-spring-segment-routing-04(2014.7...3)

 

Regards,

Ran

-----Original Message-----
From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Wednesday, July 15, 2020 8:17 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-dong-spring-sr-for-enhanced-vpn

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "qinfengwei" <[email-masked]>
Date: Thu, 23 Jul 2020 11:40:28 +0800

Hi Shaofu,

The resource in this document refers to the data plane resource used for packet processing. This aligns with the resource reservation concept in TEAS. This has been clarified in the draft. 

With SR architecture, SIDs can be used to represent any instructions, thus using SID to identify a set of network resource complies with the SR architecture. However, the segments as defined in RFC 8402 and other documents before this draft did not cover this useful semantic. Thus IMO this needs to be specified explicitly under the SR architecture first, so that further work based on resource-aware SIDs can be done in relevant WGs. 

 

Thanks,

Fengwei Qin

发件人: spring [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2020年7月23日 09:25
收件人: [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
主题: Re: [spring] WG AdoptionCallfordraft-dong-spring-sr-for-enhanced-vpn

Hi zhenqiang,

Regards,

PSF

原始邮件

日 期 ：2020年07月21日 12:48

Hi Ran,

Best regards,

Zhenqiang Li

  _____  

[email-masked]

Date: 2020-07-20 17:11

To: [email-masked] <mailto:[email-masked]> 

CC: james.n.guichard <mailto:[email-masked]> ; spring <mailto:[email-masked]> ; spring-chairs <mailto:[email-masked]> 

Hi Jie,

Regards,

Ran

日 期 ：2020年07月16日 19:50

Hi Ran,

RFC 8402 introduced the topology and service semantics of SR SID, this document proposed to add resource semantics to SIDs. Then MT or Flex-Algo are control plane mechanism for the distribution of topology-specific SIDs... The relationship with these documents are described in this draft.

Hope this helps.

Best regards,

Jie

Dear WG,

SID be allocated per AII(alias alice).  For slice resources, <https://tools.ietf.org/html/draft-peng-teas-network-slicing-03> https://tools.ietf.org/html/draft-peng-teas-network-slicing-03  

Regards,

Ran

-----Original Message-----
From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Wednesday, July 15, 2020 8:17 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-dong-spring-sr-for-enhanced-vpn

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: <[email-masked]>
Date: Fri, 24 Jul 2020 15:24:09 +0800 (CST)

Hi fengwei,

Please see inline with [PSF]

Regards,

PSF

Hi Shaofu,

 

 

 [PSF] I don’t know if this is the view of you or that of most people. I provided the concerns in last mail that there are already resource related SIDs allocation. You can question that the existing mechanism of resource related SID allocation maybe not enough, and need complement more scenarios and solutions. That is OK. But even there are only 10% scenarios that the existing mechanism of resource related SID allocation can cover, and 90% scenarios need to be improved by you, you can't change the fact that resource semantic already exists. Otherwise, it is hard to explain why an SR-TE path with specific resource reserved and specific resource related SIDs can be created to replace a traditional RSVP-TE LSP, without the guidance of this document.

Thus, what is missing is not this resource-awareness concept, but more mechanisms to address more scenarios. AFAIK, The existing mechanism mainly focuses on coarse-grained resource partition, if you can further introduce mechanisms to describe how to do fine-grained resource partitioning, for example, let the queue policy within the node be more than a local matter, etc, that would be very comforting, and I think that would be dry goods.

 

Thanks,

Fengwei Qin

 

Hi zhenqiang,

Regards,

PSF

 

原始邮件

日 期 ：2020年07月21日 12:48

Hi Ran,

 

 

 

 

Best regards,

Zhenqiang Li

[email-masked]

Date: 2020-07-20 17:11

To: [email-masked]

Hi Jie,

 

 

Regards,

Ran

日 期 ：2020年07月16日 19:50

Hi Ran,

 

        

 

 

Hope this helps.

Best regards,

Jie

 

Dear WG,

 

Regards,

Ran

-----Original Message-----
From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Wednesday, July 15, 2020 8:17 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-dong-spring-sr-for-enhanced-vpn

Dear WG:

Thanks!

Jim, Joel & Bruno