Subject: [spring] Conclusion of WG adoption call for draft-dong-spring-sr-for-enhanced-vpn

From: James Guichard <[email-masked]>
Date: Wed, 29 Jul 2020 15:31:41 +0000

Dear SPRING WG:

This email concludes the WG adoption call for draft-dong-spring-sr-for-enhanced-vpn.

The chairs noted that although the document received a lot of support, evaluation of consensus to adopt should primarily be driven by substantive comments (technical or otherwise) of which there were several on differing parts of the document.

The text of the current document covers two main parts that may be categorized into standards track and informational track.

The first part is related to the association of resources to Segment Routing Identifiers (SIDs) that:

  *   is specifically referenced in the SPRING charter for mapping segments to forwarding behaviors
  *   received strong support, including from technical reviewers
  *   is the main goal of the draft, stating nearly the full draft abstract:

   " This document describes the mechanism to associate network resource attributes to Segment Routing Identifiers (SIDs).  Such SIDs are referred to as resource-aware SIDs in this document.  The resource-aware SIDs retain their original forwarding semantics, but with the additional semantics to identify the set of network resources available for the packet processing action.  The resource-aware SIDs can therefore be used to build SR paths with a set of reserved network resources."

While this part of the specification still requires some work in order to specify resource-aware semantics for all or a subset of existing SIDs, the chairs feel that consensus to adopt this part of the document was reached and that this should form the basis of a standards track document. Therefore, authors can you please publish a WG document covering only this first part; the document should:

  *   avoid the use of VPN related terms in the filename, title, abstract, page headers etc.
  *   only cover the normative specification of "resource-aware SIDs"
  *   have a filename that reflects the core idea of "resource-aware SIDs" and start with draft-ietf-spring... (suggestion draft-ietf-spring-resource-aware-segments-00)

In addition, please indicate on the mailing list whether you are aware of any undisclosed relevant IPR.

Macroscopically, the above will involve removing sections 4 and 5 of the current document, and maybe the penultimate sentence in the abstract. In addition, the current section 3 (control plane) will need to be significantly re-scoped although this may happen as part of the normal WG document process. In the future, it will also need to precisely define the new information/parameters that would need to be advertised in the control plane; only leaving the encoding to the corresponding protocol specific documents. Now would be better, but it may be done in the future given the agreement on the scope of this document.

The second part is related to the building of virtual networks (e.g. VPN, VPN+, VNT, enhanced VPN...). This part is not primarily an extension to segment/SID, and seems less mature, informational in nature, and one way of building an end-to-end service using a set of building blocks, while other methods are possible and may be equally valid. Therefore, this part may be described in an informational document independent from the standards track document. Depending on the direction that authors choose to follow, this subject may have adherence with the BESS and TEAS WGs, which would need to be considered. Alternatively, the document could follow the direction of an applicability statement or recipe on how to provide, in an SR network, dedicated resources for some services (e.g .VPN, IP TV replication service...).

Authors, you are encouraged to publish a second informational document (individual-ID) covering the non-resource-aware-SIDs parts (with pointers to the standard track document used as a building block) and then have the WG review and then reevaluate that part of the adoption call.

Thanks,

Jim, Joel, & Bruno

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 31 Jul 2020 16:04:37 +0000

Hi Chairs,

Thanks a lot for your guidance in moving forward with this document. We have submitted the first part as standard track, and will continue to work on the rest as informational.

And I am unaware of any undisclosed relevant IPR.

Best regards,
Jie

From: spring [mailto:[email-masked]] On Behalf Of James Guichard
Sent: Wednesday, July 29, 2020 11:32 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] Conclusion of WG adoption call for draft-dong-spring-sr-for-enhanced-vpn

Dear SPRING WG:

Thanks,

Jim, Joel, & Bruno