Subject: Re: [spring] [Lsr] clarification of END Point behavior in draft-ietf-spring-srv6-network-programming

From: Parag Kaneriya <[email-masked]>
Date: Mon, 6 Jul 2020 09:16:35 +0000

Hello,

I am going through recent draft https://tools.ietf.org/pdf/draft-ietf-spring-srv6-network-programming-16.pdf

Changes are follow ,

4.1. End: Endpoint

S01. When an SRH is processed {
S02. If (Segments Left == 0) {
S03. Proceed to process the next header in the packet, whose type is identified by the Next Header field in the routing header.
S04. }
S05. If (IPv6 Hop Limit <= 1) {
S06. Send an ICMP Time Exceeded message to the Source Address, Code 0 (Hop limit exceeded in transit), Interrupt packet processing and discard
     the packet.
S07. }

With these change, I have below few question

  1.  Can END SID can be last SID of the SID list ?   earlier draft (not sure which version), it was explicitly mentioned that last SID can't be END sid ( Most basic flavors ).
  2.  IF yes then When/Who will remove the SRH header when last sid is END SID in the sid list.

Regards
Parag

Juniper Business Use Only

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Tue, 7 Jul 2020 17:40:10 +0000

Hi Parag,

Yes, it can be the last SID. When SL=0 you ignore the SRH and process the next header in the header chain. Upper-layer header processing is defined in 4.1.1.
If you would like to remove the SRH with the End behavior you can use PSP, USP or USD flavors to do so.

Regards,
Pablo.

From: spring <[email-masked]> On Behalf Of Parag Kaneriya
Sent: lunes, 6 de julio de 2020 11:17
To: [email-masked]; SPRING WG <[email-masked]>
Subject: Re: [spring] [Lsr] clarification of END Point behavior in draft-ietf-spring-srv6-network-programming

Hello,

Changes are follow ,

4.1. End: Endpoint

Regards
Parag