Subject: Re: [spring] WG LC https://datatracker.ietf.org/doc/draft-ietf-spring-sr-yang/

From: Dhruv Dhody <[email-masked]>
Date: Wed, 8 Jul 2020 12:04:59 +0530

Hi WG,

I guess it is still 7th in some part of the earth and hoping I am not
too late :)

I find it weird that the SRv6 Yang
[https://tools.ietf.org/html/draft-raza-spring-srv6-yang-05] does not
use/augment ietf-segment-routing or ietf-segment-routing-common. A
sync up between these modules will be useful to understand the overall
design! A section describing this would also be quite useful.

Few comments -

- Avoid references in Abstract, See
https://tools.ietf.org/html/rfc7322#section-4.3

   Similarly, the Abstract should be complete in itself.  It will appear
   in isolation in publication announcements and in the online index of
   RFCs.  Therefore, the Abstract must not contain citations.

   You could replace those with straight textual mentions of the documents.

   Also, the use of SHOULD in the abstract does not seem right.
- Section 4, you say -

   The sr-mpls configuration is split in global configuration and
   interface configuration.

   But there is no interface configuration mentioned.

   s/lcoal/local/

- Section 5.1.1.1,  you should remove this -

   This section is a first proposal on how to use S-bit in Adj-SID to
   create bundles.  Authors would like to trigger discussion based on
   this first proposal.

   Please also add references for S-bit and B-Flag etc

- Section 8

   - The yang model lacks a "reference" statement when importing
external modules or designing key concepts. They are useful while
reviewing.
   - Can we rename ipv4-sid and ipv6-sid to ipv4-prefix-sid and
ipv6-prefix-sid respectively?
   - It could be useful to add a description of why ERLD is read-only
in the YANG.
   - Why is the grouping srgb defined in ietf-segment-routing-common,
but the feature protocol-srgb is in ietf-segment-routing-mpls?
   - Can the ISIS YANG typedef be used instead of redefining the
system-id in SR yang.
   - In the grouping sr-controlplane, is it not better to have a
reference to the policy rather than a string?

      +--rw segment-routing
      |  +--rw enabled?    boolean
      |  +--rw bindings
      |     +--rw advertise
      |     |  +--rw policies*   string
      |     +--rw receive?     boolean

   - Target is defined as a string in the yang. You do say that they
are IPv4/IPv6 prefix in the context of the I-D. I want to confirm that
the string is the right choice in such a case.

- Section 11, ietf-segment-routing-mpls is missing from IANA section

Thanks!
Dhruv

On Tue, Jun 23, 2020 at 11:29 PM James Guichard
<[email-masked]> wrote:
>
> Dear SPRING WG:
>
>
>
> This email starts a two week WG LC for https://datatracker.ietf.org/doc/draft-ietf-spring-sr-yang/.
>
>
>
> Substantive comments should be directed to the mailing list no later than July 7th. Editorial suggestions can be sent to the authors.
>
>
>
> Thanks!
>
>
>
> Jim, Joel & Bruno
>
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Yingzhen Qu <[email-masked]>
Date: Fri, 10 Jul 2020 06:49:58 +0000

Hi Dhruv,

Thank you for your review and comments.

You're correct that SRv6 YANG should be augmenting segment-routing like sr-mpls. This was the agreement between SRv6 and SR-MPLS YANG authors.  Hopefully SRv6 YANG authors will update so in the next revision.

I've uploaded version -17 to address your comments. Detailed answers please see inline with [YQ].

Thanks,
Yingzhen

Other detailed comments please see answer inline.

On 7/7/20, 11:40 PM, "spring on behalf of Dhruv Dhody" <[email-masked] on behalf of [email-masked]> wrote:

    Hi WG,

    [https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-raza-spring-srv6-yang-05&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Caf6a379099eb41ab642d08d82309bfec%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637297872081216770&amp;sdata=1fiXJq6aFeKyAVgFN7gSlHRdqINQgoKfCcyIzp5AWe4%3D&amp;reserved=0] does not
    
    Few comments -
    
    - Avoid references in Abstract, See
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc7322%23section-4.3&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Caf6a379099eb41ab642d08d82309bfec%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637297872081226764&amp;sdata=jD%2FCEGQKug86nyaE1bx2N4i5x4l0gkdy3XNvZ4oD3lI%3D&amp;reserved=0

    

[YQ]: fixed abstract.

    - Section 4, you say -

    
       s/lcoal/local/

    
 [YQ]: fixed
   
    - Section 8
    
[YQ]: added references

       - Can we rename ipv4-sid and ipv6-sid to ipv4-prefix-sid and
    ipv6-prefix-sid respectively?
[YQ]: not sure whether there are other modules using these groupings. Will check to make sure not breaking other YANG modules importing it.

[YQ]: ERLD?

       - Why is the grouping srgb defined in ietf-segment-routing-common,
    but the feature protocol-srgb is in ietf-segment-routing-mpls?
[YQ]: ietf-segment-routing-common is also used by other modules, while protocol-srgb is specific to sr-mpls.

       - Can the ISIS YANG typedef be used instead of redefining the
    system-id in SR yang.
[YQ]: ISIS-SR YANG will be importing both SR-MPLS and ISIS YANG, so the typedef from ISIS YANG can't be reused since it will cause circular reference.

          +--rw segment-routing
          |  +--rw enabled?    boolean
          |  +--rw bindings
          |     +--rw advertise
          |     +--rw receive?     Boolean

[YQ]: Do you mean the policy in mapping server? Which is a string.
    
 [YQ]: this is intended.
   
   [YQ]: fixed
 
    Thanks!
    Dhruv

    On Tue, Jun 23, 2020 at 11:29 PM James Guichard
    <[email-masked]> wrote:
    >
    > Dear SPRING WG:
    >
    >
    >
    > This email starts a two week WG LC for https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-spring-sr-yang%2F&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Caf6a379099eb41ab642d08d82309bfec%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637297872081226764&amp;sdata=kyQNCDzQZFMpA6ypqu%2Bfg8X6vH4iZPDSqrpHrUNiELU%3D&amp;reserved=0.
    >
    >
    >
    > https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Caf6a379099eb41ab642d08d82309bfec%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637297872081226764&amp;sdata=I0BaAyU%2BI9uvcRW8Suj4%2BN7XPsd%2FbupIkAeg%2F6QknyA%3D&amp;reserved=0
    
    _______________________________________________
    spring mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Caf6a379099eb41ab642d08d82309bfec%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637297872081226764&amp;sdata=I0BaAyU%2BI9uvcRW8Suj4%2BN7XPsd%2FbupIkAeg%2F6QknyA%3D&amp;reserved=0

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 10 Jul 2020 13:25:02 +0530

Hi Yingzhen,

Thanks for your reply, snipping to the open items -

> You're correct that SRv6 YANG should be augmenting segment-routing like sr-mpls. This was the agreement between SRv6 and SR-MPLS YANG authors.  Hopefully SRv6 YANG authors will update so in the nex…

I would also encourage you to consider adding some high-level text
describing the relationship between the 3 modules defined in this I-D
and your guidance for SRv6-Yang. A figure could also be quite useful.

> [YQ]: not sure whether there are other modules using these groupings. Will check to make sure not breaking other YANG modules importing it.

I looked in the IGP SR Yang I-Ds as well as searched in the
https://www.yangcatalog.org/ and found nothing.
More importantly, it is normal for other YANG modules to be updated in
such a case.

>        - It could be useful to add a description of why ERLD is read-only

Entropy capable Readable Label Depth - the node-capabilities, and
entropy-readable-label-depth below marked as "ro"

   module: ietf-segment-routing-mpls
     augment /rt:routing/sr:segment-routing:
       +--rw sr-mpls
          +--ro node-capabilities
          |  +--ro entropy-readable-label-depth?   uint8
          +--rw msd {max-sid-depth}?

> [YQ]: ISIS-SR YANG will be importing both SR-MPLS and ISIS YANG, so the typedef from ISIS YANG can't be reused since it will cause circular reference.

That is not true! Notice the arrows in  - https://sketchboard.me/NCeua6qrZBzV
Also, I made the change in my local copy, and all 3 yang models compile cleanly!

> [YQ]: Do you mean the policy in mapping server? Which is a string.

Yes, I assume this policy is the same as -
/rt:routing/sr:segment-routing:/sr-mpls/bindings/mapping-server/policy/name
and thus wondering why not a leafref? If this policy is different
please add more text explaining it.

>     the string is the right choice in such a case.

Please consider adding some descriptive text around this.

Thanks!
Dhruv