Subject: [spring] WG Adoption Call for draft-raza-spring-srv6-yang

From: James Guichard <[email-masked]>
Date: Mon, 13 Jul 2020 21:52:19 +0000

Dear WG:

This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-raza-spring-srv6-yang/ ending Monday 27th July 2020.

Please speak up if you support or oppose adopting this document into the WG. Please also provide comments/reasons for that support (or lack thereof). Silence will not be considered consent.

Thanks!

Jim, Joel & Bruno

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Tue, 14 Jul 2020 04:09:21 +0000

Hi All,

I support the adoption of this document by the WG. The Yang model for SRv6 is something that the WG needs to work on as a deliverable alongside all the ongoing SRv6 work. The proposal in the draft aligns with the draft-ietf-spring-srv6-network-programming and thus provides a good base for the WG.

Thanks,
Ketan

From: spring <[email-masked]> On Behalf Of James Guichard
Sent: 14 July 2020 03:22
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-srv6-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Tue, 14 Jul 2020 16:59:47 +0000

I support the adoption of this draft. It aligns with the SR Policy Architecture and is a crucial component for config driven SR Policy.

Thanks,
Mike.

From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Monday, July 13, 2020 5:52 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-srv6-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Majumdar, Kausik" <[email-masked]>
Date: Tue, 14 Jul 2020 18:12:09 +0000

Support the WG adoption on the SRv6 Yang draft. This is an important draft for the SRv6 service Yang draft to move forward.

Regards,
Kausik

From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Monday, July 13, 2020 2:52 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-srv6-yang

Dear WG: This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-raza-spring-srv6-yang/ ending Monday 27th July 2020. Please speak up if you support or oppose adopting t
External ([email-masked]<mailto:[email-masked]>)
Report This Email<https://shared.outlook.inky.com/report?id=Y29tbXNjb3BlL2thdXNpay5tYWp1bWRhckBjb21tc2NvcGUuY29tLzBhM2UwZDRiNDU4MGNlYzY5NjlkOGE1ZmNlNTU5NDY2LzE1OTQ2NzcxNTUuOTE=#key=b09deda205566219576e9fc2eb77a58a>  FAQ<https://www.inky.com/banner-faq/>  Protection by INKY<https://www.inky.com>

Dear WG:

This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-raza-spring-srv6-yang/<https://secure-web.cisco.com/1iBGFeR2YYpQUyKBw-J3iAY4clPzIxH_4bkP-lGk3iiY6DS3UlYReZ6wasaPw4sfgUksgrezABqBApTJSFvOJ15pIOQeZY0cgSE6DUBKLXlZrnzQi9EeyquoMMIcfsYIrIGvfEquXLxpRPJb9Mg24ubH33wbFhpAXtvB8CLZURBcNpVdhcE9Sr42rgrWtMUy0tiYuE8_6_DNJnbLp-QvWQSfMcKNh7ExwXXklzR5zX9v8wM7QyFa6ibxHHnPXdMcWGA0MM8DNwg_8GyWbHrx3af76zZzrzFgj60dY_m363lmzy7eLVogrFaGzbrm4eiMFQnlPs0Nfl65AtPcPmJfIzw/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-raza-spring-srv6-yang%2F> ending Monday 27th July 2020.

Thanks!

Jim, Joel & Bruno

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 15 Jul 2020 02:06:29 +0000

Hi SPRING,

Yes I support the document.
YANG model is an important work for SRv6, and the YANG model has reached the consensus among vendors and operators, so I support the adoption.

Respect,
C.L

From: spring [mailto:[email-masked]] On Behalf Of James Guichard
Sent: Tuesday, July 14, 2020 5:52 AM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-srv6-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Huzhibo <[email-masked]>
Date: Wed, 15 Jul 2020 02:24:32 +0000

Hi spring:

      Support as a co-author. I think it's ready to move forward.

Thanks
Zhibo

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 15 Jul 2020 07:14:00 +0000

Hi WG,

I support the adoption of this document.

Best regards,
Jie

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Zhuangshunwan <[email-masked]>
Date: Wed, 15 Jul 2020 12:13:46 +0000

Hi All,

I support the WG adoption of this important Base Yang model.

Thanks,
Shunwan

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Lizhenbin <[email-masked]>
Date: Wed, 15 Jul 2020 13:26:07 +0000

Hi All,

I support the adoption of the draft. There has been multiple implementations of SRv6. The YANG model will facilitate the interworking for the configuration.

Best Regards,

Zhenbin (Robin)

________________________________
发件人: spring [[email-masked]] 代表 James Guichard [[email-masked]]
发送时间: 2020年7月14日 5:52
收件人: [email-masked]
抄送: [email-masked]
主题: [spring] WG Adoption Call for draft-raza-spring-srv6-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 15 Jul 2020 21:43:37 +0800

I support the adoption since this doc is an integral member of the SRv6 standard family.

Best Regards,
Zhenqiang Li

[email-masked]
 
From: James Guichard
Date: 2020-07-14 05:52
To: [email-masked]
CC: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-srv6-yang
Dear WG:

 
Thanks!
 
Jim, Joel & Bruno

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 15 Jul 2020 14:41:21 +0000

I support the adoption.

Linda Dunbar

________________________________
发件人: spring [[email-masked]] 代表 James Guichard [[email-masked]]
发送时间: 2020年7月14日 5:52
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: [spring] WG Adoption Call for draft-raza-spring-srv6-yang
Dear WG:

This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-raza-spring-srv6-yang/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-raza-spring-srv6-yang%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C606c2ad2a1a1434f020a08d828c2aaa7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637304163851692570&sdata=y4z9LYWiFK2IvimuuPfMruCbj1bc8ieMAqNJamehnAo%3D&reserved=0> ending Monday 27th July 2020.

Thanks!

Jim, Joel & Bruno

---

From: "Xiejingrong (Jingrong)" <[email-masked]>
Date: Wed, 15 Jul 2020 15:06:07 +0000

Basic building block of SRv6 technology for inter-op between routers and NMS.
I do support the adoption.

Thanks
Jingrong Xie

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 15 Jul 2020 11:32:35 -0400

I support critical WG adoption of Yang models for SRv6.

Gyan

On Tue, Jul 14, 2020 at 10:06 PM Chengli (Cheng Li) <[email-masked]> wrote:

> YANG model is an important work for SRv6, and the YANG model has reached
> the consensus among vendors and operators, so I support the adoption.
>
>
>
> Respect,
>
> C.L
>
>
>
>
>
> *From:* spring [mailto:[email-masked]] *On Behalf Of *James
> Guichard
> *Sent:* Tuesday, July 14, 2020 5:52 AM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* [spring] WG Adoption Call for draft-raza-spring-srv6-yang
>
>
>
> Dear WG:
>
>
>
> This email begins a 2 week WG adoption call for
> https://datatracker.ietf.org/doc/draft-raza-spring-srv6-yang/ ending
> Monday 27th July 2020.
>
>
>
> Please speak up if you support or oppose adopting this document into the
> WG. Please also provide comments/reasons for that support (or lack
> thereof). Silence will not be considered consent.
>
>
>
> Thanks!
>
>
>
> Jim, Joel & Bruno
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Mach Chen <[email-masked]>
Date: Thu, 16 Jul 2020 01:39:54 +0000

Hi,

I have read the draft, it's an important building block of SRv6, support the adoption.

Best regards,
Mach

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Rakesh Gandhi <[email-masked]>
Date: Tue, 21 Jul 2020 12:16:01 -0400

Hi WG,
I support the WG adoption of this important work for SRv6.

Thanks,
Rakesh

>
>
> *From:* spring <[email-masked]> *On Behalf Of *James Guichard
> *Sent:* 14 July 2020 03:22
> *To:* [email-masked]

---

From: Xufeng Liu <[email-masked]>
Date: Tue, 21 Jul 2020 14:57:56 -0400

Support as a co-author.
Thanks,
- Xufeng

---

From: Dhruv Dhody <[email-masked]>
Date: Sat, 25 Jul 2020 22:51:47 +0530

Hi WG,

I support the adoption of this work and I have thoughts on how to
improve the document -

Some questions/comments -
- Can the title of the I-D be improved?
- Why do you have the config and the state trees separately in Figures
1 and 2? That's out of fashion with NMDA!
- I hope this model is applicable for both the headend router as well
as for the controller. If yes, we should highlight that as well as
make sure the YANG model takes care of this. For example, counters,
forwarding, etc
- The node-capabilities are marked as read-only, but an operator may
want to disable or enable these right?

Suggestions for improving YANG -
- Update copyright year
- path-attrs-cmn is described as "Path properties -common for v4/v6",
in that case, is this the right yang model for it? and should it be in
the generic SR model instead?
- Typedef for algorithm could be useful, it is unit32 here but uint8
in draft-ietf-spring-sr-yang
- What is the purpose of the empty containers end, end_psp, end_usp,
end_psp_usp, end_usd, end_psp_usd, end_usp_usd, end_psp_usp_usd? Are
they placeholders for something?
- Run this "pyang -f yang --keep-comments --yang-line-length 69
<FILE>" to help you with formatting the yang model.

Thanks!
Dhruv

---

From: Jeff Tantsura <[email-masked]>
Date: Sat, 25 Jul 2020 10:27:18 -0700

Very much with Dhruv here.
While the work is important and should be progressing, overall quality could be significantly improved.
Please use draft-ietf-spring-sr-yang as the example.

Regards,
Jeff

> On Jul 25, 2020, at 10:22, Dhruv Dhody <[email-masked]> wrote:
> 
> Hi WG,
>

---

From: Yingzhen Qu <[email-masked]>
Date: Sat, 25 Jul 2020 23:52:36 +0000

Hi,

I agree with Dhruv's comments that there should not be separate configuration and state trees. 

Also "grouping" is overly used in the model, and I'd suggest the authors remove some groups when updating the draft.

Thanks,
Yingzhen

On 7/25/20, 10:23 AM, "spring on behalf of Dhruv Dhody" <[email-masked] on behalf of [email-masked]> wrote:

    Hi WG,

    
    
    Thanks!
    Dhruv
    
    On Tue, Jul 14, 2020 at 3:22 AM James Guichard
    <[email-masked]> wrote:
    >
    > Dear WG:
    >
    >
    >
    > This email begins a 2 week WG adoption call for https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-raza-spring-srv6-yang%2F&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7C0b316d999f4f41b2edb008d830bf6a89%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637312945993728664&amp;sdata=TgKml9vtVT8T4Gak6DUmVaNJ14BAF7cyfccIv4oqm1o%3D&amp;reserved=0 ending Monday 27th July 2020.
    >
    >
    >
    > https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7C0b316d999f4f41b2edb008d830bf6a89%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637312945993728664&amp;sdata=nKQLkDrLqa%2FkXT6WDFdXJKAf%2FSuaay1paSp6VHfScPg%3D&amp;reserved=0
    
    _______________________________________________
    spring mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7C0b316d999f4f41b2edb008d830bf6a89%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637312945993728664&amp;sdata=nKQLkDrLqa%2FkXT6WDFdXJKAf%2FSuaay1paSp6VHfScPg%3D&amp;reserved=0

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Mon, 27 Jul 2020 23:20:56 +0000

Thanks Dhruv, Jeff, and Yingzhen for your comments.

The next rev of the model will take care of NMDA style as well as simplify the grouping.

On 2020-07-25, 7:53 PM, "spring on behalf of Yingzhen Qu" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    Thanks,
    Yingzhen

        Hi WG,

        Thanks!
        Dhruv

---

From: James Guichard <[email-masked]>
Date: Tue, 28 Jul 2020 10:42:47 +0000

Dear WG:

The 2-week adoption call for draft-raza-spring-srv6-yang has now closed. There is strong support for adoption of this document into the WG and therefore authors please publish a new version as draft-ietf-spring-srv6-yang-00. The chairs note that several comments were received during the adoption call to help improve the structure and quality of the document; authors please work with the people that provided these comments to incorporate them as appropriate into the document.

Authors, please indicate on the mailing list whether you are aware of any undisclosed relevant IPR.

Thanks!

Jim, Joel & Bruno

From: James Guichard
Sent: Monday, July 13, 2020 5:52 PM
To: [email-masked]
Cc: [email-masked]
Subject: WG Adoption Call for draft-raza-spring-srv6-yang

Dear WG:

Thanks!

Jim, Joel & Bruno