Subject: [spring] IPv6+??

From: Andrew Alston <[email-masked]>
Date: Fri, 3 Jul 2020 17:31:54 +0000

Hi All,

I came across this website: https://www.ipv6plus.net/

Now, I wish to clarify a few things.

  1.  This website seems to imply – strong – that Srv6 is not infact IPv6 – but rather IPv6+ - is this the position of the member of this working group or is this simply someones bizarre idea?
  2.  This site seems heavily related to the new ip stuff that was presented to the ITU – does anyone here know if there is any actual relation between this and that crowd?

Thanks

Andrew

---

From: Lizhenbin <[email-masked]>
Date: Sat, 4 Jul 2020 08:08:05 +0000

Hi Andrew,

Thanks for your paying attention to the website. Please refer to my clarification.

a. SRv6 is the technology based on IPv6. In the past 20+ years IPv6 has being deployed. One of the most important drives is the address space. The development of 5G and cloud proposes the new chances for the development and deployment of IPv6. Depending on the native IP reacheability and providing rich attributes based on the IPv6 extension headers, IPv6 can provide flexible connectivity to satisfy the requirements of 5G and cloud. SRv6 is the typical representative solutions. This makes this round of IPv6-based innovations and deployments shows the new characteristics of the times to some extent. Then IPv6+ concept is proposed.  It means the solutions is based on IPv6 and used for the scenarios of 5G and cloud.

b. IPv6+  has nothing with the New IP. It is apparent that the solutions proposed in the IPv6+ are based on the IPv6 and all the standardization work is being done in IETF and has nothing with ITU-T.

I am not sure if it is appropriate to discuss this work in the mailing list of SPRING WG.  More questions and comments can be sent to [email-masked]<mailto:[email-masked]>.

Best Regards,

Robin

________________________________
发件人: spring [[email-masked]] 代表 Andrew Alston [[email-masked]]
发送时间: 2020年7月4日 1:31
收件人: [email-masked]
主题: [spring] IPv6+??

Hi All,

[Robin

  1.  This site seems heavily related to the new ip stuff that was presented to the ITU – does anyone here know if there is any actual relation between this and that crowd?

Thanks

Andrew

---

From: Mark Smith <[email-masked]>
Date: Sat, 4 Jul 2020 20:39:43 +1000

Where are the IPv6+ Internet Drafts?

On Sat, 4 Jul 2020, 18:08 Lizhenbin, <[email-masked]> wrote:

> a. SRv6 is the technology based on IPv6. In the past 20+ years IPv6 has
> being deployed. One of the most important drives is the address space. The
> development of 5G and cloud proposes the new chances for the development
> and deployment of IPv6. Depending on the native IP reacheability and
> providing rich attributes based on the IPv6 extension headers, IPv6 can
> provide flexible connectivity to satisfy the requirements of 5G and cloud.
> SRv6 is the typical representative solutions. This makes this round of
> IPv6-based innovations and deployments shows the new characteristics of the
> times to some extent. Then IPv6+ concept is proposed.  It means the
> solutions is based on IPv6 and used for the scenarios of 5G and cloud.
>
>
> b. IPv6+  has nothing with the New IP. It is apparent that the solutions
> proposed in the IPv6+ are based on the IPv6 and all the standardization
> work is being done in IETF and has nothing with ITU-T.
>
>
>
> I am not sure if it is appropriate to discuss this work in the mailing
> list of SPRING WG.  More questions and comments can be sent to
> [email-masked].
>
>
>
>
>
> Best Regards,
>
> Robin
>
>
>
>
>
>
> ------------------------------
> *发件人:* spring [[email-masked]] 代表 Andrew Alston [
> [email-masked]]
> *发送时间:* 2020年7月4日 1:31
> *收件人:* [email-masked]
> *主题:* [spring] IPv6+??
>
> Hi All,
>
>
>
>    1. This website seems to imply – strong – that Srv6 is not infact IPv6
>    – but rather IPv6+ - is this the position of the member of this working
>    group or is this simply someones bizarre idea?
>
> [Robin
>
>    1. This site seems heavily related to the new ip stuff that was
>    presented to the ITU – does anyone here know if there is any actual
>    relation between this and that crowd?
>
>
>
> Thanks
>
>
>
> Andrew
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Sat, 4 Jul 2020 10:51:39 +0000

Where are the requirements.. I mean actual ones..

Thanks,
              Jim Uttaro

From: spring <[email-masked]> On Behalf Of Mark Smith
Sent: Saturday, July 04, 2020 6:40 AM
To: Lizhenbin <[email-masked]>
Cc: SPRING WG <[email-masked]>; Andrew Alston <[email-masked]>
Subject: Re: [spring] 答复: IPv6+??

On Sat, 4 Jul 2020, 18:08 Lizhenbin, <[email-masked]<mailto:[email-masked]>> wrote:

Hi Andrew,

Best Regards,

Robin

________________________________
发件人: spring [[email-masked]<mailto:[email-masked]>] 代表 Andrew Alston [[email-masked]<mailto:[email-masked]>]
发送时间: 2020年7月4日 1:31
收件人: [email-masked]<mailto:[email-masked]>
主题: [spring] IPv6+??
Hi All,

I came across this website: https://www.ipv6plus.net/<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ipv6plus.net_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=xY6EacJ5lx2Wdodq3HVdOJnLu47yv-NeOtF_pims9wo&s=MRwEZihBF6LGmyvanssazkk5goh92USabH9rzxSuIcg&e=>

[Robin

Thanks

Andrew

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_spring&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=xY6EacJ5lx2Wdodq3HVdOJnLu47yv-NeOtF_pims9wo&s=b-d6W4ys7Vc5jHULav7uoajVG1yo_F5vTpaluGS1eIw&e=>

---

From: James Guichard <[email-masked]>
Date: Sat, 4 Jul 2020 11:51:04 +0000

Folks:

As one of the SPRING chairs I would like to point out that this website is not sanctioned by, or have anything to do with SPRING, and therefore we should not use the mailing list for any discussion about it; as pointed out below there is an email address provided for questions so please use that.

Thanks!

Jim

From: spring <[email-masked]> On Behalf Of UTTARO, JAMES
Sent: Saturday, July 04, 2020 6:52 AM
To: Mark Smith <[email-masked]>; Lizhenbin <[email-masked]>
Cc: SPRING WG <[email-masked]>; Andrew Alston <[email-masked]>
Subject: Re: [spring] 答复: IPv6+??

Thanks,
              Jim Uttaro

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Mark Smith
Sent: Saturday, July 04, 2020 6:40 AM
To: Lizhenbin <[email-masked]<mailto:[email-masked]>>
Cc: SPRING WG <[email-masked]<mailto:[email-masked]>>; Andrew Alston <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] 答复: IPv6+??

Hi Andrew,

Best Regards,

Robin

I came across this website: https://www.ipv6plus.net/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__www.ipv6plus.net_%26d%3DDwMFaQ%26c%3DLFYZ-o9_HUMeMTSQicvjIg%26r%3Ds7ZzB4JbPv3nYuoSx5Gy8Q%26m%3DxY6EacJ5lx2Wdodq3HVdOJnLu47yv-NeOtF_pims9wo%26s%3DMRwEZihBF6LGmyvanssazkk5goh92USabH9rzxSuIcg%26e%3D&data=02%7C01%7Cjames.n.guichard%40futurewei.com%7C09aaf448e0dc4f9a74b008d820084c4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637294567316076979&sdata=3%2B1WoB9DoVG1z4JTFCjoVlSLKxXabockUalTp9Qq0LE%3D&reserved=0>

[Robin

Thanks

Andrew

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__www.ietf.org_mailman_listinfo_spring%26d%3DDwMFaQ%26c%3DLFYZ-o9_HUMeMTSQicvjIg%26r%3Ds7ZzB4JbPv3nYuoSx5Gy8Q%26m%3DxY6EacJ5lx2Wdodq3HVdOJnLu47yv-NeOtF_pims9wo%26s%3Db-d6W4ys7Vc5jHULav7uoajVG1yo_F5vTpaluGS1eIw%26e%3D&data=02%7C01%7Cjames.n.guichard%40futurewei.com%7C09aaf448e0dc4f9a74b008d820084c4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637294567316076979&sdata=tznPj8R1L2pct3vCbidzV6Opkoe7CcyWTKnuVhHLaHU%3D&reserved=0>

---

From: Lizhenbin <[email-masked]>
Date: Sat, 4 Jul 2020 11:57:38 +0000

Hi Mark,

I explained that there are group solutions for IPv6+ instead of that IPv6+ is a single technology.

There are the internet drafts for these solutions which are also proposed in the IPv6+ website.

You can learn more through visiting the website.

It is also always complained that the IETF work on a specific solution is distributed in multiple

working groups and it is hard to understand the whole picture.  I have ever proposed the following

draft and wish it could be helpful to understand the possible work distributed in multiple IETF areas.

https://tools.ietf.org/html/draft-li-cross-ietf-area-work-00

You can see that the work in IPv6+ is another try to cope with the issue.

Best Regards,

Robin

________________________________
发件人: Mark Smith [[email-masked]]
发送时间: 2020年7月4日 18:39
收件人: Lizhenbin
抄送: Andrew Alston; SPRING WG
主题: Re: [spring] 答复: IPv6+??

Hi Andrew,

Best Regards,

Robin

Hi All,

[Robin

Thanks

Andrew

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 4 Jul 2020 14:04:27 +0200

All,

It looks to me that "IPv6+" is just a marketing name to sell a bunch of new
IPv6 based services and has nothing to do with SPRING nor for that matter
with IETF.

As such unless anyone has copyrights on that specific ASCII string any
vendor can use it as it seems fit their marketing strategy.

Likewise others could still use other similar technology marketing or
product names "IPv6^6", "IPv6NG", "IPv6@5G" etc ...

Cheers,
R.

On Sat, Jul 4, 2020 at 12:40 PM Mark Smith <[email-masked]> wrote:

>>    1. This website seems to imply – strong – that Srv6 is not infact
>>    IPv6 – but rather IPv6+ - is this the position of the member of this
>>    working group or is this simply someones bizarre idea?
>>
>> [Robin
>>

---

From: Lizhenbin <[email-masked]>
Date: Sat, 4 Jul 2020 12:09:22 +0000

Hi Jim,

I respect the comment from the chair. I propose the following draft (because it is SRv6 work) for your reference on the requirements.

https://tools.ietf.org/html/draft-tian-spring-srv6-deployment-consideration-01

L

Later there may be more information when update.

Best Regards,
Robin

________________________________
发件人: UTTARO, JAMES [[email-masked]]
发送时间: 2020年7月4日 18:51
收件人: Mark Smith; Lizhenbin
抄送: SPRING WG; Andrew Alston
主题: RE: [spring] 答复: IPv6+??

Thanks,
              Jim Uttaro

Hi Andrew,

Best Regards,

Robin

[Robin

Thanks

Andrew

---

From: Mark Smith <[email-masked]>
Date: Sun, 5 Jul 2020 11:15:31 +1000

On Sat, 4 Jul 2020, 22:04 Robert Raszuk, <[email-masked]> wrote:

> All,
>
> It looks to me that "IPv6+" is just a marketing name to sell a bunch of
> new IPv6 based services and has nothing to do with SPRING nor for that
> matter with IETF.
>

The name implies it is a major development effort to extend IPv6, and that
implies IETF affiliation.

Heard about SPRING++ project yet?

Think about what you would assume and how you might act regarding your
SPRING deployment plans if you'd just heard about it now.

> product names "IPv6^6", "IPv6NG", "IPv6@5G" etc ...

Of those, only 'IPv6@5G' doesn't imply extending IPv6.

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Mon, 6 Jul 2020 17:05:40 +0000

Robin,

              The draft calls out the benefits of SRV6 vs SR/MPLS as the authors see it.  That is fine and is a data point for those considering SRV6 instead of SR/MPLS.  So I guess I am confused as to what we are talking about. If IPV6+ is different and new I would suggest crafting a requirements document similar to what we did for EVPN. See attached..

https://datatracker.ietf.org/doc/rfc7209/

Thanks,
              Jim Uttaro

From: Lizhenbin <[email-masked]>
Sent: Saturday, July 04, 2020 8:09 AM
To: UTTARO, JAMES <[email-masked]>; Mark Smith <[email-masked]>
Cc: SPRING WG <[email-masked]>; Andrew Alston <[email-masked]>
Subject: 答复: [spring] 答复: IPv6+??

Hi Jim,

https://tools.ietf.org/html/draft-tian-spring-srv6-deployment-consideration-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dtian-2Dspring-2Dsrv6-2Ddeployment-2Dconsideration-2D01&d=DwMFbw&c=LFYZ-o9_HUMeMTSQicvjIg&r=3qhKphE8RnwJQ6u8MrAGeA&m=rZlTYAgCetZk13lEzdKbOH06XI9eujWc1XLPq7DNHOM&s=P4NZY3pETadVCQ71xsC7CXEj6vr9ewpJkd1HWuhPFD8&e=>

L

Best Regards,
Robin

Thanks,
              Jim Uttaro

Hi Andrew,

Best Regards,

Robin

[Robin

Thanks

Andrew