Subject: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

From: James Guichard <[email-masked]>
Date: Mon, 13 Jul 2020 15:37:55 +0000

Dear WG:

This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-raza-spring-sr-policy-yang/ ending Monday 27th July 2020.

Please speak up if you support or oppose adopting this document into the WG. Please also provide comments/reasons for that support (or lack thereof). Silence will not be considered consent.

Thanks!

Jim, Joel & Bruno

---

From: "Stone, Andrew (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 13 Jul 2020 19:10:28 +0000

Hello authors. I have some observations/questions:

  1.  Dynamic Candidate path has constraints but no optimization-metric that I can see: i.e find shortest path by TE METRIC, Latency etc. Any plans to add?

  1.  Bandwidth demand appear to be missing. For example, requested would be useful for dynamic candidate path. Any plans to add (bandwidth attributes in general)?

  1.  I’m not sure if this was discussed, but has there been any thoughts around the ability to define constraints per-pre-defined-SID list in a dynamic case? One could almost think of this as being an “Explicit Candidate Path with Dynamic Segment lists” (not actually suggesting that name, just an example)
While ideally TE goals would be expressed as an optimization on the candidate path and the number of SID lists can be determined automatically, some TE rules might not be easy to describe and may be more appropriately defined on individual SID lists.  As a simple example, imagine if one wanted to create a candidate path, and specify TE rules per SID list such as send 50% traffic via red plane, 50% traffic via blue plane.
SR Policy color=100, endpoint 10.0.0.1
  candidate path 1, preference 100
      weight 1 SID list 1 < --- objective latency, include red
      weight 1 SID list 2 < --- objective latency, include blue

Thanks in advance,
Andrew

From: spring <[email-masked]> on behalf of James Guichard <[email-masked]>
Date: Monday, July 13, 2020 at 11:38 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Tue, 14 Jul 2020 04:05:00 +0000

Hi All,

I support the WG adoption of this important Yang model for SR Policy. It is one of the WG milestones and therefore something that the WG has already resolved to work upon. The proposal in the draft itself is well advanced and provides a very good version for the WG to accomplish this work item.

Thanks,
Ketan

From: spring <[email-masked]> On Behalf Of James Guichard
Sent: 13 July 2020 21:08
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Majumdar, Kausik" <[email-masked]>
Date: Tue, 14 Jul 2020 06:18:17 +0000

This is an important draft to define the SR Policy Yang definition. Support the WG adoption.

Thanks,
Kausik

From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Monday, July 13, 2020 8:38 AM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear WG: This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-raza-spring-sr-policy-yang/ ending Monday 27th July 2020. Please speak up if you support or oppose adopt
External ([email-masked]<mailto:[email-masked]>)
Report This Email<https://shared.outlook.inky.com/report?id=Y29tbXNjb3BlL2thdXNpay5tYWp1bWRhckBjb21tc2NvcGUuY29tL2ZkMjQ2OGU2YzliMDNjZjYyZDVjMGI1NGEzYjFjYTExLzE1OTQ2NTQ2OTEuNjQ=#key=f99a0d797cf1cde804e597d30dd2c7e4>  FAQ<https://www.inky.com/banner-faq/>  Protection by INKY<https://www.inky.com>

Dear WG:

This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-raza-spring-sr-policy-yang/<https://secure-web.cisco.com/1L4dUcZOQ2KsJyB6zXTfObfeBBtXJncOjR_HPhRa_Y2HROZ7B6pfxZqUBZ44HTqKDVrZDfjG1JFU3uHFCy3qkj95A2u5zr_bezUToj10_gj9BWjAa2KIe4SoAtwaVNwlfX0rciLxS3pW3FZOKULIXE36sK9ypPmmEzV7Zx0BVqXSzzI99zSmZEcwugUOJfgE9S5sjOxQz3aeRXK4a-HnBeuFkPBvFkMviiOstz3DvaCN-8xgWcbx_IeA_KhFB-rLJaA6O68MqaajESQRuz1DI7HDgeNzjSqfzx86yuzQKAoCv96nBDvy1VyDvGtJfXEQp91FxtW3WZR5pkNJKeGg_fA/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-raza-spring-sr-policy-yang%2F> ending Monday 27th July 2020.

Thanks!

Jim, Joel & Bruno

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Tue, 14 Jul 2020 17:07:13 +0000

I support the adoption of this draft. It aligns with the SR Policy Architecture and is a crucial component for config driven SR Policy.

Thanks,
Mike.

From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Monday, July 13, 2020 11:38 AM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Lizhenbin <[email-masked]>
Date: Wed, 15 Jul 2020 02:28:15 +0000

Hi All,

I support the WG adoption of the draft. SR Policy is an important feature and there are multiple implementations. The adoption of the YANG models will be helpful for the interworking.

Best Regards,

Zhenbin (Robin)

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Wed, 15 Jul 2020 06:38:12 +0000

I support the adoption of this draft.

Rgds,
-
Kamran

Date: Monday, July 13, 2020 at 11:39 AM

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Huzhibo <[email-masked]>
Date: Wed, 15 Jul 2020 06:45:31 +0000

support the adoption.

Thanks
Zhibo

From: spring [mailto:[email-masked]] On Behalf Of James Guichard
Sent: Monday, July 13, 2020 11:38 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 15 Jul 2020 07:13:09 +0000

Hi WG,

Best regards,
Jie

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Jaganbabu Rajamanickam (jrajaman)" <[email-masked]>
Date: Wed, 15 Jul 2020 11:36:54 +0000

Hello Jim, Joel & Bruno,
   I would strongly support WG adoption of the SRV6 base draft, as all the other SRv6 drafts will depends on this.

Thanx,
Jags

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Zhuangshunwan <[email-masked]>
Date: Wed, 15 Jul 2020 12:10:49 +0000

Hi All,

I support the WG adoption of this important Yang model as a co-author.  I believe it's in a good shape and ready to move forward.

Thanks,
Shunwan

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Voyer, Daniel" <[email-masked]>
Date: Wed, 15 Jul 2020 13:22:06 +0000

Hi WG,

I support, as a co-author, the adoption of this draft.

dan

Subject: [EXT][spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 15 Jul 2020 21:39:15 +0800

What do you mean by the SRV6 base draft? 

Regards,
Zhenqiang Li

[email-masked]
 
From: Jaganbabu Rajamanickam \(jrajaman\)
Date: 2020-07-15 19:36
To: James Guichard; [email-masked]
CC: [email-masked]
Subject: Re: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang
Hello Jim, Joel & Bruno,
   I would strongly support WG adoption of the SRV6 base draft, as all the other SRv6 drafts will depends on this.
 
Thanx,
Jags

Dear WG:

 
Thanks!
 
Jim, Joel & Bruno

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 15 Jul 2020 21:45:14 +0800

I support the adoption since this doc is an integral member of the SR standard family.

Best Regards,
Zhenqiang Li

[email-masked]
 
From: James Guichard
Date: 2020-07-13 23:37
To: [email-masked]

 
Thanks!
 
Jim, Joel & Bruno

---

From: "Xiejingrong (Jingrong)" <[email-masked]>
Date: Wed, 15 Jul 2020 15:07:21 +0000

Basic building block of SR technology for inter-op between routers and NMS.
I do support the adoption.

Thanks
Jingrong Xie

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Muhammad Durrani <[email-masked]>
Date: Wed, 15 Jul 2020 16:37:12 +0000

Hello chair,

Supporting adoption of this draft into the WG .. My organization is actively working on MPLS/TE to SR migration and eagerly waiting to see progress in this area for network provisioning automation.

Regards,
Muhammad

From: Kamran Raza (skraza) <[email-masked]>
Sent: Tuesday, July 14, 2020 11:36 PM
To: Kamran Raza (skraza) <[email-masked]>; Robert Sawaya (rsawaya) <[email-masked]>; [email-masked]; [email-masked]; Muhammad Durrani <[email-masked]>; [email-masked]; [email-masked]
Subject: [EXTERNAL] FW: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear [co-] authors.

Please respond to SPRING mailer for the adoption call.
Also, it will help if you get few more colleagues of yours to support as well.

Thx
--
Kamran

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of James Guichard <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 13, 2020 at 11:39 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [spring] WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear WG:

This email begins a 2 week WG adoption call for https://datatracker.ietf.org/doc/draft-raza-spring-sr-policy-yang/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-raza-spring-sr-policy-yang/__;!!PcPv50trKLWG!gCQXjB6Ns6VWCh_DD2J0ND7e3KmTk9qYXap--jV1-sGUB_vcC-1QuuoW-fA4fMIS$> ending Monday 27th July 2020.

Thanks!

Jim, Joel & Bruno

[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>;

---

From: Mach Chen <[email-masked]>
Date: Thu, 16 Jul 2020 01:40:24 +0000

Hi,

I have read the draft, it's an important building block of SRv6, support the adoption.

Best regards,
Mach

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Gaurav Dawra <[email-masked]>
Date: Thu, 16 Jul 2020 06:51:22 -0700

Support

Sent from my iPhone

> On Jul 13, 2020, at 8:38 AM, James Guichard <[email-masked]> wrote:
> 
> 
> Dear WG:
>  
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Sun, 19 Jul 2020 23:28:56 +0000

Dear chairs and the WG,

I read the document; it provides a very good base for the WG to work on and finish one of its milestones.
I support the adoption of this draft.

Thanks

Regards … Zafar

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Tue, 21 Jul 2020 08:59:46 -0500

I strongly support adoption of this draft -- it is an integral part of the
SR Policy toolkit.

-Pavan (as a co-author)

On Mon, Jul 13, 2020 at 10:38 AM James Guichard <
[email-masked]> wrote:

> Dear WG:
>
>
>
> This email begins a 2 week WG adoption call for
> https://datatracker.ietf.org/doc/draft-raza-spring-sr-policy-yang/ ending
> Monday 27th July 2020.
>
>
>
> Please speak up if you support or oppose adopting this document into the
> WG. Please also provide comments/reasons for that support (or lack
> thereof). Silence will not be considered consent.
>
>
>
> Thanks!
>
>
>
> Jim, Joel & Bruno
>
>
>
>
>
>

---

From: Ian Duncan <[email-masked]>
Date: Tue, 21 Jul 2020 11:52:42 -0400

Hello -

I support WG adoption. Look forward to our productive discussions on
refining the model.

Best .. Ian

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 21 Jul 2020 18:02:45 +0200

Support.

Thx,
R.

---

From: Rakesh Gandhi <[email-masked]>
Date: Tue, 21 Jul 2020 12:06:26 -0400

Hi WG,
Support the WG adoption of this important work for SR Policy.

Thanks,
Rakesh

---

From: "Francois Clad (fclad)" <[email-masked]>
Date: Tue, 21 Jul 2020 16:18:15 +0000

Hi,

The definition of a YANG data model for the SR policy architecture is an important work item for this WG.

Thanks,
Francois

Date: Monday 13 July 2020 at 17:38

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Xufeng Liu <[email-masked]>
Date: Tue, 21 Jul 2020 14:39:37 -0400

Support.

Thanks,
- Xufeng

On Tue, Jul 21, 2020 at 12:18 PM Francois Clad (fclad) <fclad=
[email-masked]> wrote:

> *From: *spring <[email-masked]> on behalf of James Guichard <
> [email-masked]>
> *Date: *Monday 13 July 2020 at 17:38
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *[spring] WG Adoption Call for draft-raza-spring-sr-policy-yang
>
>
>
> Dear WG:
>
>
>

---

From: Dhruv Dhody <[email-masked]>
Date: Sat, 25 Jul 2020 22:48:35 +0530

Hi WG,

I support the adoption of this work and I have thoughts on how to
improve the document -

Some questions/comments -

- Why do you have the config and the state trees separately in Figures
2 and 3? That's out of fashion with NMDA!
- I hope this model is applicable for both the headend router as well
as for the controller. If yes, we should highlight that as well as
make sure the YANG model takes care of this. For example, counters,
path-forwarding_state, etc
- I found the top-level container "traffic-engineering" on top as out
of place when the rest of the SR-Policy work does not use it.
- Regarding segment types, I have a few thoughts -
  * I-D.ietf-spring-segment-routing-policy uses Type A,B,C,...,
whereas you use Type 1,2,3..
  * Should we use identity here instead of enum, to allow for future
segment types to be defined?
 - Please describe the use of group-id and subgroup-id for
disjointness, this was not clear from yang or the text
 - The constraints currently defined are quite minimal, is there any
reason for that? I feel more constraint and optimization criteria
should be supported.
 - How do we relate the information in forwarding-paths to the
candidate path? Also, where would the inactive candidate paths
received from BGP/PCEP stored in this model (assumption that
forwarding-paths are active only)? Maybe segment-lists for dynamic
paths should be added as well?

Suggestions for improving YANG -
- Add references such as during import and important leaves.
- Use generic-path-disjointness in ietf-te-types instead of defining a
new identity for path-disjointness
- Use of identity for protocol-origin-type (instead of enum) to allow
other protocols to be added easily
- Use of labels as a key in a label stack is incorrect (see grouping
mpls-label-stack), as you could have the same label repeated in the
stack.
- sid-algorithm, color, and name should have its own typedef
- Run "pyang -f yang --keep-comments --yang-line-length 69 <FILE>" to
help with formatting.

Thanks!
Dhruv

---

From: "Richard Vallee (rvallee)" <[email-masked]>
Date: Mon, 27 Jul 2020 11:39:06 +0000

Hello everyone,

I support the WG adoption of this important work for SR Policy.

Thanks
Richard

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: Sonal Agarwal <[email-masked]>
Date: Mon, 27 Jul 2020 09:35:08 -0700

Hi WG,

I support adoption of this draft.

Regards,
Sonal.

> On Jul 14, 2020, at 11:38 PM, Kamran Raza (skraza) <skraza=[email-masked]> wrote:
> 
>

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Mon, 27 Jul 2020 23:17:33 +0000

Thanks Dhuruv for your support and useful review/comments. 
We will discuss within authors and incorporate comments accordingly.

On 2020-07-25, 1:20 PM, "spring on behalf of Dhruv Dhody" <[email-masked] on behalf of [email-masked]> wrote:

    Hi WG,

    Thanks!
    Dhruv

---

From: James Guichard <[email-masked]>
Date: Tue, 28 Jul 2020 10:33:34 +0000

Dear WG:

The 2-week adoption call for draft-raza-spring-sr-policy-yang has now closed. There is strong support for adoption of this document into the WG and therefore authors please publish a new version as draft-ietf-spring-sr-policy-yang-00. The chairs note that several comments were received during the adoption call and we expect to see those resolved as part of the WG process; authors please work with the people that commented to resolve any open issues and/or comments.

Authors, please indicate on the mailing list whether you are aware of any undisclosed relevant IPR.

Thanks!

Jim, Joel & Bruno

From: James Guichard
Sent: Monday, July 13, 2020 11:38 AM
To: [email-masked]
Cc: [email-masked]
Subject: WG Adoption Call for draft-raza-spring-sr-policy-yang

Dear WG:

Thanks!

Jim, Joel & Bruno