Subject: [spring] https://tools.ietf.org/html/draft-ietf-lsr-flex-algo-08 (OSPFv2 flex algo)

From: Rajesh M <[email-masked]>
Date: Fri, 7 Aug 2020 04:03:34 +0000

Note : Discussion is not about FAPM.

For flex algorithm (example take it as 128) OSPF Prefix (For summary/external prefixes),  how to get the prefix cost ? there is no prefix cost field in OSPFv2 Extended Prefix TLV.
Currently only way I can see is prefix needs to be advertised in flex algo zero(as summary or external prefixes in legacy ospf) as well as in flex algo 128 (OSPFv2 Extended Prefix TLV)

Thanks
Rajesh

Juniper Business Use Only

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 14 Aug 2020 13:33:16 +0000

Hi Rajesh,

The prefix reachability is always signalled via the OSPFv2 Type 3/5/7 LSAs - this is required for Algo 0 and 1 but also for Flex Algo for basic reachability. These LSAs carry/include the IGP metric in them. The OSPFv2 Extended Prefix TLV is used to carry the Prefix SIDs - both algo 0 and Flex Algos. The FAPM in the OSPFv2 Extended Prefix TLV enables the prefix metric specific to the FA to be also signalled with using FAD with M flag.

I am not sure if I understood your question correctly and if not please elaborate.

Thanks,
Ketan

From: Rajesh M <[email-masked]>
Sent: 07 August 2020 09:34
To: Peter Psenak (ppsenak) <[email-masked]>; Shraddha Hegde <[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; Gulko, Arkadiy (Refinitiv) <[email-masked]>
Cc: SPRING WG <[email-masked]>
Subject: https://tools.ietf.org/html/draft-ietf-lsr-flex-algo-08 (OSPFv2 flex algo)

Thanks
Rajesh