Subject: [spring] WG Adoption Call for https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-11

From: James Guichard <[email-masked]>
Date: Thu, 22 Oct 2020 12:51:37 +0000

Dear WG:

This message starts a 3 week WG adoption call for document https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-11 ending November 12th 2020. Please note that this document has several changes from v-10 that were requested by the SPRING and IPPM chairs. For this reason, the chairs have extended the adoption call for an additional week to allow the WG enough time to review these changes before deciding on WG adoption.

Some background:

Several review comments were received previously for document https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10. The SPRING and IPPM chairs considered those comments, and upon review of this version of the document, determined the following:

  *   The SPRING document should describe only the procedures relevant to SPRING with pointers to non-SPRING document/s that define any extensions. Several extensions including Control Code Field Extension for TWAMP Light Messages, Loss Measurement Query Message Extensions, and Loss Measurement Response Message Extensions were included in https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10 and should be removed from the SPRING document.
  *   The TWAMP extensions included in https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10 should be described in a new document published in the IPPM WG.

These conclusions were discussed with the authors of  https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10 the result of which is the publication of the following two documents:

  *   https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-11. The subject of this WG adoption call.
  *   https://tools.ietf.org/html/draft-gandhi-ippm-twamp-srpm-00. This document will be progressed (if determined by the WG) within the IPPM WG.

After review of the SPRING document please indicate support (or not) for WG adoption to the mailing list. Please also provide comments/reasons for that support (or lack thereof) as silence will not be considered as consent.

Finally, the chairs would like to thank the authors for their efforts in this matter.

Thanks!

Jim, Bruno, & Joel

---

From: Mach Chen <[email-masked]>
Date: Wed, 28 Oct 2020 01:55:13 +0000

Support the adoption (as co-author).

Best regards,
Mach

From: spring [mailto:[email-masked]] On Behalf Of James Guichard
Sent: Thursday, October 22, 2020 8:52 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [spring] WG Adoption Call for https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-11

Dear WG:

Some background:

Thanks!

Jim, Bruno, & Joel

---

From: Stefano Salsano <[email-masked]>
Date: Wed, 28 Oct 2020 03:26:06 +0100

I support the adoption of this document

FYI, we've used a previous version of this document and we've done an 
implementation and setup a testbed, please see results described in:

P. Loreti et. al. “SRv6-PM: Performance Monitoring of SRv6 Networks with 
a Cloud-Native Architecture”, submitted to IEEE TNSM, special issue on 
“Advanced Management of Softwarized Networks” (minor revision submitted)
https://arxiv.org/pdf/2007.08633.pdf

P. Loreti et. al. “Implementation of Accurate Per-Flow Packet Loss 
Monitoring in Segment Routing over IPv6 Networks”,
IEEE International Conference on High Performance Switching and Routing, 
(HPSR 2020), 11-14 May 2020, Virtual Conference
https://arxiv.org/pdf/2004.11414.pdf

Stefano

Il 2020-10-22 14:51, James Guichard ha scritto:
> Dear WG:
> 
> This message starts a 3 week WG adoption call for document 
> https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-11 ending 
> November 12^th 2020. Please note that this document has several changes 
> from v-10 that were requested by the SPRING and IPPM chairs. For this 
> reason, the chairs have extended the adoption call for an additional 
> week to allow the WG enough time to review these changes before deciding 
> on WG adoption.
> 
> Some background:
> 
> Several review comments were received previously for document 
> https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10. The 
> SPRING and IPPM chairs considered those comments, and upon review of 
> this version of the document, determined the following:
> 
>   * The SPRING document should describe only the procedures relevant to
>     SPRING with pointers to non-SPRING document/s that define any
>     extensions. Several extensions including***Control Code Field
>     Extension for TWAMP Light Messages*, *Loss Measurement Query Message
>     Extensions*, and *Loss Measurement Response Message Extensions *were
>     included
>     inhttps://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10 and
>     should be removed from the SPRING document.
>   * The TWAMP extensions included in
>     https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10 should
>     be described in a new document published in the IPPM WG. 
> 
> These conclusions were discussed with the authors of 
> https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10 the result 
> of which is the publication of the following two documents:
> 
>   * https://tools.ietf.org/html/draft-gandhi-ippm-twamp-srpm-00. This
>     document will be progressed (if determined by the WG) within the
>     IPPM WG.
> 
> After review of the SPRING document please indicate support (or not) for 
> WG adoption to the mailing list. Please also provide comments/reasons 
> for that support (or lack thereof) as silence will not be considered as 
> consent.
> 
> **//
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
> 

-- 
*******************************************************************
Stefano Salsano
Professore Associato
Dipartimento Ingegneria Elettronica
Universita' di Roma Tor Vergata
Viale Politecnico, 1 - 00133 Roma - ITALY

http://netgroup.uniroma2.it/Stefano_Salsano/

E-mail  : [email-masked]
Cell.   : +39 320 4307310
Office  : (Tel.) +39 06 72597770 (Fax.) +39 06 72597435
*******************************************************************

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 27 Oct 2020 19:43:41 -0700

Yes/support 

Regards,
Jeff

> On Oct 27, 2020, at 19:26, Stefano Salsano <[email-masked]> wrote:
> 
> FYI, we've used a previous version of this document and we've done an implementation and setup a testbed, please see results described in:
> 
> P. Loreti et. al. “SRv6-PM: Performance Monitoring of SRv6 Networks with a Cloud-Native Architecture”, submitted to IEEE TNSM, special issue on “Advanced Management of Softwarized Networks” (minor revision submitted)
> P. Loreti et. al. “Implementation of Accurate Per-Flow Packet Loss Monitoring in Segment Routing over IPv6 Networks”,
> IEEE International Conference on High Performance Switching and Routing, (HPSR 2020), 11-14 May 2020, Virtual Conference
>> This message starts a 3 week WG adoption call for document https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-11 ending November 12^th 2020. Please note that this document has several changes from v-10 that were requested by the SPRING and IPPM chairs. For this reason, the chairs have extended the adoption call for an additional week to allow the WG enough time to review these changes before deciding on WG adoption.
>> Some background:
>>    be described in a new document published in the IPPM WG. These conclusions were discussed with the authors of https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10 the result of which is the publication of the following two documents:

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 28 Oct 2020 02:55:51 -0400

I support WG adoption of this document.

Regards

Gyan

On Tue, Oct 27, 2020 at 10:44 PM Jeff Tantsura <[email-masked]>
wrote:

> reason, the chairs have extended the adoption call for an additional week
> to allow the WG enough time to review these changes before deciding on WG
> adoption.
> >> Some background:
> https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10. The SPRING
> and IPPM chairs considered those comments, and upon review of this version
> of the document, determined the following:
> >>    be described in a new document published in the IPPM WG. These
> conclusions were discussed with the authors of
> >> After review of the SPRING document please indicate support (or not)
> for WG adoption to the mailing list. Please also provide comments/reasons
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Thu, 29 Oct 2020 22:04:25 +0000

Support.

Regards,
Jakob.

From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Thursday, October 22, 2020 5:52 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [spring] WG Adoption Call for https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-11

Dear WG:

Some background:

Thanks!

Jim, Bruno, & Joel

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 30 Oct 2020 02:01:53 +0000

Hi WG,

Support. However, there are some encoding format changes among versions, hope the encoding format can be stable in the following revision ASAP.

Many thanks for the authors' contribution!

Thanks,
Cheng

Dear WG:

Some background:

Thanks!

Jim, Bruno, & Joel

---

From: Loa Andersson <[email-masked]>
Date: Fri, 30 Oct 2020 12:30:06 +0800

Working Group,

I support adopting this document.

However I have one question; if it leads to (very small) changes in the 
document, this can be done after the adoption.

I'm looking at

    HMAC-SHA: Consists of two parts
    HMAC: Hashed Message Authentication Code (expanded in the document).
    SHA: Secure Hash Algorithm (not expanded, but on the other hand it an
         well-known abbreviation)

When we combine two abbreviations what rules apply, is it enough that 
eachpart is expanded "somewhere" even if the parts are found at 
different places. Or does the rule "expand at first occurrence apply?

I guess that in part this depends on whether we view HMAC-SHA as one 
unit or two separate parts? And how familiar we believe our readers are 
with the abbreviations.

I don't have a strong opinion on this, but would suggest that we place
HMAC-SHA in the "Abbreviations" in section 2.2 and expamnd it fully.

On 30/10/2020 10:01, Chengli (Cheng Li) wrote:
> Hi WG,
> 
> Support. However, there are some encoding format changes among versions, 
> hope the encoding format can be stable in the following revision ASAP.
> 
> Many thanks for the authors’ contribution!
> 
> Thanks,
> 
> Cheng
> 
> *From:* spring [mailto:[email-masked]] *On Behalf Of *James 
> Guichard
> *Sent:* Thursday, October 22, 2020 8:52 PM
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* [spring] WG Adoption Call for 
> https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-11
> 
> Dear WG:
> 
>     extensions. Several extensions including*Control Code Field
>     included in
>     https://tools.ietf.org/html/draft-gandhi-spring-twamp-srpm-10 and
> //

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 30 Oct 2020 12:43:46 +0000

Hi Loa, 

In most cases, I believe that if the component acronyms are either well-known or expanded, there is no requirement to expand the hyphenated combination acronym. 

Thanks,
Acee

On 10/30/20, 12:32 AM, "spring on behalf of Loa Andersson" <[email-masked] on behalf of [email-masked]> wrote:

    Working Group,

    I'm looking at

    --