Subject: [spring] Fw:New Version Notification for draft-srcompdt-spring-compression-requirement-01.txt

From: "苏远超(以泰)" <[email-masked]>
Date: Thu, 19 Nov 2020 18:20:54 +0800

Hi Dear Spring WG,
   This is Yuanchao Su, network architect lead of Alibaba Cloud. We support the requirements in Appendix A should be part of the draft in the next version.
   Alibaba have been working on SRv6 & uSID for a while, we require all SR-related technology to be standard complied from day 1, as we believe this is the right way to avoid inter-operatability issues and accelerate deployment.
   From a cloud provider point of view, an open & strong eco-system is very very key. After several years development, SRv6's ecosystem is ramping up. We do consider SID compression solution should base on current SRv6 ecosytem but not build from scratch.
   Thanks.

           Yuanchao Su
           Alibaba Cloud

From: 程伟强
Date: 2020-11-15 23:27
To: spring
CC: srcomp;  [email-masked]
Subject: [spring] Fw:New Version Notification for draft-srcompdt-spring-compression-requirement-01.txt
Hi Group,
SR compression design team have submitted a new version of compression requirement draft.
Main changes as follows: 
- added 3 items about scalibility with agreement within the design team 
- added an appendix including 3 items without without unanimous consensus within the design team
- some minor text issue fixed
Please review it and let us know your comments.

BTW: We will have 1-hour session for the design team topic on Friday and welcome to join us.

B.R.
Weiqiang on behalf of design team

----邮件原文----
 发件人：internet-drafts <[email-masked]>
 收件人：Weiqiang Cheng <[email-masked]>,Sander Steffann <[email-masked]>,SJM Steffann <[email-masked]>
 抄　送: (无)
 发送时间：2020-11-15 22:58:57
 主题：New Version Notification for draft-srcompdt-spring-compression-requirement-01.txt

 A new version of I-D, draft-srcompdt-spring-compression-requirement-01.txt
 has been successfully submitted by Weiqiang Cheng and posted to the
 IETF repository.

 Name: draft-srcompdt-spring-compression-requirement
 Revision: 01
 Title: Compressed SRv6 SID List Requirements
 Document date: 2020-11-13
 Group: Individual Submission
 Pages: 13
 URL: https://www.ietf.org/archive/id/draft-srcompdt-spring-compression-requirement-01.txt
 Status: https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement/
 Htmlized: https://datatracker.ietf.org/doc/html/draft-srcompdt-spring-compression-requirement
 Htmlized: https://tools.ietf.org/html/draft-srcompdt-spring-compression-requirement-01
 Diff: https://www.ietf.org/rfcdiff?url2=draft-srcompdt-spring-compression-requirement-01

 Abstract:
  This document specifies requirements for solutions to compress SRv6
  SID lists.

 Please note that it may take a couple of minutes from the time of submission
 until the htmlized version and diff are available at tools.ietf.org.

 The IETF Secretariat

 Subject：New Version Notification for draft-srcompdt-spring-compression-requirement-01.txt

 A new version of I-D, draft-srcompdt-spring-compression-requirement-01.txt
 has been successfully submitted by Weiqiang Cheng and posted to the
 IETF repository.

 Name: draft-srcompdt-spring-compression-requirement
 Revision: 01
 Title: Compressed SRv6 SID List Requirements
 Document date: 2020-11-13
 Group: Individual Submission
 Pages: 13
 URL: https://www.ietf.org/archive/id/draft-srcompdt-spring-compression-requirement-01.txt
 Status: https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement/
 Htmlized: https://datatracker.ietf.org/doc/html/draft-srcompdt-spring-compression-requirement
 Htmlized: https://tools.ietf.org/html/draft-srcompdt-spring-compression-requirement-01
 Diff: https://www.ietf.org/rfcdiff?url2=draft-srcompdt-spring-compression-requirement-01

 Abstract:
  This document specifies requirements for solutions to compress SRv6
  SID lists.

 Please note that it may take a couple of minutes from the time of submission
 until the htmlized version and diff are available at tools.ietf.org.

 The IETF Secretariat

 如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] ,you can unsubscribe from this mail. We will immediately remove your information from send catalogue of our.

---

From: Gaurav Dawra <[email-masked]>
Date: Thu, 19 Nov 2020 21:48:51 -0800

+1 - I agree with Dirk and others.

The industry has been working on SRv6 for multiple years with technology being quite mature.

The requirements listed in the appendix are fully justified from a technical and deployment point of view.

I support the requirements based on the SRv6 control plane and data plane existing standards and works well with or without compression.

Gaurav

> On Nov 19, 2020, at 7:47 AM, Dirk Steinberg <[email-masked]> wrote:
> 
> Hello SPRING WG,
> 
> I have read the SRComp design team requirements draft 
> and would like to comment.
> 
> I truly believe that a SID compression scheme MUST integrate into the 
> existing SRv6 framework. Otherwise it does not make much sense, 
> or said another way, it will not be a SID compression scheme for SRv6 
> at all but another animal altogether.
> 
> SID compression should be used where the use case justifies it, i.e.
> strict path TE inside a given domain. Inter-Domain usage of SRv6,
> especially end systems in data centers, may have different requirements
> and thus decide to use uncompressed SRv6 SIDs. It is important that
> a SID list that describes a service that spans across multiple domains
> be able to contain both compressed and uncompressed SIDs. 
> Consequently, the same CP needs to support both compressed and 
> uncompressed SIDs.
> 
> I am currently working on an architecture based on SRv6 for different 
> domains within a carrier network. These domains have different 
> requirements and also different hardware capabilities that may lead 
> to different designs for each subnetwork. But all these domains/
> subnetworks must be able to interoperate seamlessly based on SRv6
> standards, regardless of whether SID compression is used or not.
> 
> Therefore I strongly agree that Appendix A should be part of the draft.
> 
> I would also like to suggest another requirement:
> IMHO the single biggest advantage that SRv6 has compared to 
> MPLS is aggregation (route summarization), something that is
> absolutely not possible with MPLS labels (SIDs).
> Aggregation (CIDR) is the very technology that has enabled the Internet 
> to scale and to become the worldwide internetwork that it is today. 
> In retrospect I believe the omission of aggregation has been the 
> biggest design mistake in MPLS -- but back then there were a lot 
> of other factors and the idea to use a very short tag for forwarding. 
> After all Tag Switching and MPLS were inspired from ATM 
> and within this context aggregation made no sense.
> 
> Consequently I propose to add to the draft the requirement that the
> SID compression scheme MUST be compatible with aggregation,
> i.e. it must be possible to express the reachability of a given set of
> SIDs (maybe in some domain or data center) using a summary prefix.
> 
> Thanks and Cheers
> Dirk
> 
> 
> 
> 
> 
> 
> On Thu, Nov 19, 2020 at 3:21 PM Ahmed Bashand <[email-masked]> wrote:
>> I also agree that the requirements in Appendix A should be part of the draft. Having of existing standard as a basis greatly simplifies the development and deployment of any compression scheme 
>> 
>> 
>> 
>> Thanks
>> 
>> 
>> Ahmed
>> 
>> 
>> 
>> 
>> 
>> On 11/19/20 12:58 AM, Ran Pang(联通集团中国联通研究院-本部) wrote:
>>> Hi Weiqiang and WG, 
>>>     I read the draft and agree with the requirements specified in it.I think the requirements in Appendix A should be part of the draft in the next version.
>>>     China Unicom is working on a network evolution plan for SRv6 now,  and we have done some field trials based on SRv6. In order to maintain the continuity of  the functionality, we suggest the solution based on the SRv6 standards.
>>> 
>>> Best regards,
>>> Pang Ran
>>>  
>>> From: 程伟强
>>> Date: 2020-11-15 23:27
>>> To: spring
>>> _______________________________________________
>>> spring mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/spring
>> _______________________________________________
>> spring mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/spring
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring