Subject: Re: [spring] [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 13 Nov 2020 11:12:19 +0000

Hi Giuseppe,

First of all, thanks for making the updates to the document to clarify the objective and applicability of IFIT and this draft extensions specifically to the SR Policy signalled by BGP. A good part of the puzzle is at least clearer to me now.

Sec 3 says (and I am trying to paraphrase here - so please correct me), that these IFIT attributes (new TLVs) are signalled via BGP along with the SR Policy Candidate Path to "enable IOAM and Alternate Marking" mechanisms for that SR Policy. This way all traffic steered over that SR Policy with have the IOAM and Alt Marking headers inserted on them.

Is there a Spring WG document that describes the implications of actually how this would get applied to the SR Policy forwarding planes (SR-MPLS and SRv6) and what types of Steering would be possible to be used for such SR Policies (ref https://tools.ietf.org/html/draft-ietf-spring-segment-routing-policy-09#section-8). ? E.g. if a packet is arriving at the headend with a stack of labels and gets steered via BSID into such an SR Policy where "IFIT is applied", how does that work?

Sec 6 (SR Policy operations with IFIT Attributes) says the following:

The validation of the individual fields of the IFIT
   Attributes sub-TLVs are handled by the SRPM (SR Policy Module).

However, I am still missing a document that describes how these are actually "handled" by the SRPM?

I understand that there is a similar draft in PCE WG as well, but it is also missing this information.

My concern is that we have documents for the protocol signaling mechanisms for IFIT but I am not able to locate a document that describes how exactly this information is going to get used/applied by SRPM.

Please do point/clarify if I am missing something here.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Giuseppe Fioccola
Sent: 02 November 2020 22:28
To: Susan Hares <[email-masked]>; [email-masked]
Subject: Re: [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

Dear Susan, All,
I'm not aware of any IPR related to this draft. I also support its adoption as coauthor.

Best Regards,

Giuseppe

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, November 2, 2020 6:57 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

This begins a 2 week WG adoption call for draft-qin-idr-sr-policy-ifit-04.txt (11/2/2020 to 11/16/2020).

The draft can be accessed at:
https://datatracker.ietf.org/doc/draft-zhu-idr-bgp-ls-path-mtu/

The authors should provide IPR statements by 11/5/2020 so the IDR WG can consider the IPR status in their
decision.

This draft adds the IFIT sub-TLV to the BGP Tunnel Encaps attribute for the SR policy tunnel type. This sub-TLV is only valid for SR Policy tunnel types.  Within the IFIT  sub-TLV value field, 5 sub-TLVs may be included (4 for IOAM and 1 for Enhanced Alternate Marking).

The IDR co-chairs thank the authors for their patience.  The WG adoption call for this draft has been delayed by the process of switching shepherds for BGP Tunnel Encaps draft.  Many BESS and IDR drafts currently refer to the BGP tunnel encapsulation drafts.

In your review of this draft, please differentiate between the following:

  *   Support/rejection of In-situ Flow Telemetry (IFIT) as a IP routing technology,
  *   Support/rejection of alternate marking as a IP routing technology,
  *   Support/rejection of adding new sub-TLVS for SR Policy tunnel type of BGP Tunnel Encap Attribute, and
  *   Specific issues with the descriptions of these features in the draft.

Cheers, Susan Hares

---

From: Giuseppe Fioccola <[email-masked]>
Date: Mon, 16 Nov 2020 07:11:32 +0000

Hi Ketan,
Thanks a lot for your revision.
My answers inline tagged as [GF]

Regards,

Giuseppe

From: Ketan Talaulikar (ketant) [mailto:[email-masked]]
Sent: Friday, November 13, 2020 12:12 PM
To: Giuseppe Fioccola <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

Hi Giuseppe,

[GF]: Yes, this is correct.

[GF]: Good point, in the next revision we can add some considerations on the Steering into an SR Policy. This can be useful also for the data plane drafts. Regarding SRv6, the relevant documents are already adopted: draft-ietf-ippm-ioam-ipv6-options for IOAM and draft-ietf-6man-ipv6-alt-mark for AltMark. These Options are defined for IPv6 and can be used with any Routing Header (including SRH). For SR-MPLS the relevant documents (e.g. draft-gandhi-spring-ioam-sr-mpls) are still individual.

[GF]: draft-ietf-idr-segment-routing-te-policy also mentions some high-level functionality of SRPM. I think we need to include more details in draft-qin-idr-sr-policy-ifit in order to describe the functionalities that are specific for IFIT (IOAM and AltMark).

[GF]: I can address this comment in both drafts.

[GF]: Some details about the SRPM operation for IFIT could be added in this draft.

Thanks,
Ketan

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Giuseppe Fioccola
Sent: 02 November 2020 22:28
To: Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

Dear Susan, All,

Best Regards,

Giuseppe

Cheers, Susan Hares

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 16 Nov 2020 07:39:09 +0000

Hi Giuseppe,

Thanks for your response. Perhaps my point was not clear and so let me please clarify.

I am seeing the IFIT signalling related drafts for BGP and PCEP (it was also there in LSR?) in their individual protocol working groups. While what these protocols are doing is only "carrying" (in case of BGP somewhat opaquely) the information and conveying it to the SR Policy Module (SRPM). The following may clarify the picture better : https://tools.ietf.org/html/draft-filsfils-spring-sr-policy-considerations-06#section-2

The key part of how this is handled by the SRPM, the related procedures and setup in the forwarding plane along with their applicability and any other considerations should be (IMHO) done in a Spring document. This is my suggestion and request to the authors - not to add all of this into an IDR document since that is not where you will find the right expertise to review these aspects.

Without that, it might seem like an uncoordinated protocol development effort for those of us who are not intimately aware of all the IFIT internals/details.

Rest, I will leave it up to the chairs of the WGs involved.

Thanks,
Ketan

From: Giuseppe Fioccola <[email-masked]>
Sent: 16 November 2020 12:42
To: Ketan Talaulikar (ketant) <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

Hi Ketan,

Regards,

Giuseppe

From: Ketan Talaulikar (ketant) [mailto:[email-masked]]
Sent: Friday, November 13, 2020 12:12 PM
To: Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

Hi Giuseppe,

Thanks,
Ketan

Dear Susan, All,

Best Regards,

Giuseppe

Cheers, Susan Hares

---

From: Giuseppe Fioccola <[email-masked]>
Date: Mon, 16 Nov 2020 08:43:25 +0000

Hi Ketan,
As discussed at the IDR session, I see your point.
draft-qin-idr-sr-policy-ifit is one building block of the SR Policy Architecture and a new SPRING document that describes the SRPM operations and procedures for IFIT (IOAM and AltMark) would be the best choice. Considering your contributions on related documents, we could also cooperate on that.
So, I agree, there is no need to add this into draft-qin-idr-sr-policy-ifit so far.

Regards,

Giuseppe

From: Ketan Talaulikar (ketant) [mailto:[email-masked]]
Sent: Monday, November 16, 2020 8:39 AM
To: Giuseppe Fioccola <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

Hi Giuseppe,

Thanks,
Ketan

From: Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>>
Sent: 16 November 2020 12:42
To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Idr] IPR Call and WG Adoption for draft-qin-idr-sr-policy-ifit-04.txt (11/1/2020 to 11/16/2020)

Hi Ketan,

Regards,

Giuseppe

Hi Giuseppe,

Thanks,
Ketan

Dear Susan, All,

Best Regards,

Giuseppe

Cheers, Susan Hares