Subject: [spring] Regd reserving block of colors values (draft-ietf-spring-segment-routing-policy)

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 11 Dec 2020 16:15:16 +0000

Hello All,

We had the discussion, both on the list before the IETF 109 as well as during the WG session at IETF 109, regarding some sort of an allocation or reservation of a block/range of color values on the routers. This range may be for either local use on the routers (i.e. not used for steering) or may be dedicated for a controller to use (e.g. for SR Policies initiated/signalled via controllers). There were different opinions expressed on this matter.

Today the draft-ietf-spring-segment-routing-policy does not contain any text on this aspect. It is left to the deployment design to manage the color space as required.

This email is to continue this discussion so we can arrive at a consensus on this topic.

Would appreciate feedback/inputs from the WG so we can address this open comment and progress this important draft towards WGLC.

Thanks,
Ketan

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 12 Dec 2020 16:51:18 -0500

Hi Ketan

In the draft the SR policy defined on a headend source SR node
(color,endpoint) tuple, the 32 bit color which defines the steering based
on the AD protocol source origin PCEP, BGP, CLI.

So the 32 bit color field could be numeric or ASCII field and is locally
significant and seems to be no different that the name or numeric value
that specifies a RSVP TE explicit path ID which is up to the operators to
define based on their design.

To me this should be left to local use by operators implementation of the
design.

Kind Regards

Gyan

On Fri, Dec 11, 2020 at 11:15 AM Ketan Talaulikar (ketant) <ketant=
[email-masked]> wrote:

> Hello All,
>
> We had the discussion, both on the list before the IETF 109 as well as
> during the WG session at IETF 109, regarding some sort of an allocation or
> reservation of a block/range of color values on the routers. This range may
> be for either

local use on the routers (i.e. not used for steering) or may be dedicated
> for a controller to use (e.g. for SR Policies initiated/signalled via
> controllers). There were different opinions expressed on this matter.
>
> Today the draft-ietf-spring-segment-routing-policy does not contain any
> text on this aspect. It is left to the deployment design to manage the
> color space as required.
>
> Would appreciate feedback/inputs from the WG so we can address this open
> comment and progress this important draft towards WGLC.
>
> Thanks,
> Ketan
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD