Subject: [Srcomp] REQ-7-28-LOSSLESS-COMPRESSION-00

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Tue, 28 Jul 2020 14:12:15 +0000

Short Name: The compression should be lossless, meaning the compressed SID List should have the same info.

Description: The information of the compressed SID list MUST be consistent with the original SID List. The information MUST NOT be lost in compression. For example, a strict path TE SID List CAN NOT be compressed to a loose path TE SID list, and the compressed SID List MUST carry the same information.

Rationale: The compression is aiming to reduce the overhead of the packet, and it should not change the forwarding path.

Metric: if the solution is lossless, then it is compliant, otherwise, not.

Chen

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 29 Jul 2020 20:14:30 +0000

Hi Cheng, I'm trying to understand what lossless means here and I think I get it but want to make sure.

Given the Rationale, I think "lossless" means a proposed solution always visits the segments in the computed path/segment list and does not drop any segments from the path a packet would take.
I.e. it doesn't try to remove segments resulting in a different path than a non-compressed SRv6 solution.

Correct?

Thanks
  Darren
________________________________
From: Srcomp <[email-masked]> on behalf of Chengli (Cheng Li) <[email-masked]>
Sent: Tuesday, July 28, 2020 10:12 AM
To: [email-masked] <[email-masked]>
Subject: [Srcomp] REQ-7-28-LOSSLESS-COMPRESSION-00

Chen

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Thu, 30 Jul 2020 02:24:33 +0000

Hi Darren, Correct!

Cheng

From: Darren Dukes (ddukes) [mailto:[email-masked]]
Sent: Thursday, July 30, 2020 4:15 AM
To: Chengli (Cheng Li) <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] REQ-7-28-LOSSLESS-COMPRESSION-00

Correct?

Thanks
  Darren
________________________________
From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 28, 2020 10:12 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [Srcomp] REQ-7-28-LOSSLESS-COMPRESSION-00

Chen