Subject: Re: [Srcomp] REQ-7-27-COMPRESS-01

From: Sander Steffann <[email-masked]>
Date: Tue, 28 Jul 2020 21:27:32 +0200

Hi Darren,

> On 28-07-2020 06:00, Darren Dukes (ddukes) wrote:
> COMPRESS, Encapsulation Compression
> 
> Description:
> A solution to compress SR for the IPv6 data plane MUST support efficient
> SRv6 encapsulating header compression.

The same goes for this requirement. You cannot assume that the design is
based on SRv6 headers. That is kind of the whole point of this design team…

Cheers,
Sander

---

From: Ron Bonica <[email-masked]>
Date: Tue, 28 Jul 2020 22:07:18 +0000

Darren, Sander,

We may be able to find mutual ground on this requirement.

In this requirement, I think that you (Darren) meant to say,

- The compression factor needs to be measurable.
- The compression factor needs to be good enough.

However, developing a metric by which compression can be measured isn't so easy as it looks. RFCs 8402, 7855 and the network programming draft may not help much.

Let's exchange a few emails to develop a metric.

                                                             Ron

Juniper Business Use Only

-----Original Message-----
From: Srcomp <[email-masked]> On Behalf Of Sander Steffann
Sent: Tuesday, July 28, 2020 3:28 PM
To: [email-masked]
Subject: Re: [Srcomp] REQ-7-27-COMPRESS-01

[External Email. Be cautious of content]

Hi Darren,

> SRv6 encapsulating header compression.

The same goes for this requirement. You cannot assume that the design is based on SRv6 headers. That is kind of the whole point of this design team…

Cheers,
Sander

--
Srcomp mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/srcomp__;!!NEt6yMaO-gk!VzPKUiL-VxNgDK4q6_-DUeQN-X7dbjyRJisk662UeK86xtPrgGUquqp8MuaMpsHJ$

---

From: Sander Steffann <[email-masked]>
Date: Wed, 29 Jul 2020 00:08:28 +0200

Hi Ron,

> Let's exchange a few emails to develop a metric.

Good plan :)

/happy chair
Sander

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 29 Jul 2020 01:41:37 +0000

Hi Sander, unfortunately, you have misunderstood this requirement.  I'll try to clarify.
- We are trying to define requirements and analyze proposals to compress SR for the IPv6 data plane.
  - You surely agree with this.
- Page 6 of RFC8402 defines "SRv6: the instantiation of SR on the IPv6 data plane."

The requirement simply says that a proposal MUST compress the thing that we agreed to compress.

I hope this helps you understand the requirement, perhaps you can provide additional comments or suggestions.

Thanks
  Darren

________________________________
From: Srcomp <[email-masked]> on behalf of Sander Steffann <[email-masked]>
Sent: Tuesday, July 28, 2020 3:27 PM
To: [email-masked] <[email-masked]>
Subject: Re: [Srcomp] REQ-7-27-COMPRESS-01

Hi Darren,

Cheers,
Sander

--
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

---

From: Sander Steffann <[email-masked]>
Date: Wed, 29 Jul 2020 06:21:17 +0200

Hi Darren,

> - We are trying to define requirements and analyze proposals to compress SR for the IPv6 data plane.  

That I totally agree with.

> The requirement simply says that a proposal MUST compress the thing that we agreed to compress.

But here you assume agreement on that SRv6 is the only instantiation of SR on the IPv6 data plane.

I'm totally fine with a requirement and metric that says that a proposal MUST result in smaller packets than RFC8402 for the same functionality. So I think your metric is fine, but the assumption that a proposal is based on SRv6/SRH is not.

I see Ron has already volunteered to work with you on rewording the requirement, so I'm sure something can be worked out.

Cheers!
Sander