Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

From: Ron Bonica <[email-masked]>
Date: Tue, 28 Jul 2020 21:28:58 +0000

Wim,

When you say the solution complies with 7855, which of the following do you mean:

  *   That it does not uses the SRH in a way that violates 7855
  *   That it must use the SRH

I assume that you mean the former and not the latter. Do I have that right?

                                                                 Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Monday, July 27, 2020 12:32 PM
To: [email-masked]
Subject: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

[External Email. Be cautious of content]

Short Name: SPRING FRAMEWORK

Description: Compliance to RFC 7855

Rationale: Having a solution that complies to RFC7855, would allow for a natural evolution in the SPRING WG, and interoperability for customers who deployed SR already

Metric: Compliance to RFC7855

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wed, 29 Jul 2020 03:54:27 +0000

What I mean is that if we find a solution that in compatible with RFC 7855 it allows for backward compatibility. I don’t want to dictate how to do that. I believe there is benefits in a solution or solutions that allow for that.
Does that make sense?

From: Ron Bonica <[email-masked]>
Date: Tuesday, 28 July 2020 at 23:29
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                 Ron

---

From: Ron Bonica <[email-masked]>
Date: Wed, 29 Jul 2020 19:23:13 +0000

Wim,

Yes, I think that I understand what you are saying. The solution is not required to use the SRH. But if it does use the SRH, it must be backwards compatible with RFC 7855.

                                                                                   Ron

Juniper Business Use Only
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Sent: Tuesday, July 28, 2020 11:54 PM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: REQ-7-27-SPRING-FRAMEWORK-00

What I mean is that if we find a solution that in compatible with RFC 7855 it allows for backward compatibility. I don't want to dictate how to do that. I believe there is benefits in a solution or solutions that allow for that.
Does that make sense?

From: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 28 July 2020 at 23:29
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                 Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Monday, July 27, 2020 12:32 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 30 Jul 2020 04:12:59 +0000

Lets put it differently, people have deployed SRv6 today. I believe there is a req, which ensure these people can migrate seamlessly to a compressed solution otherwise they have to redo things. I believe SRH is used in some of these deployments, so there should be a requirement that if we find a solution that is compatible with that a number of people will benefit from this.
We could even go a step further and say if we find a solution that is compatible with network programming draft people benefit from this and hence this is a requirement.

From: Ron Bonica <[email-masked]>
Date: Wednesday, 29 July 2020 at 21:23
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                                   Ron

Wim,

                                                                 Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 30 Jul 2020 15:20:52 +0000

Hi Wim,

Can I factor the following assertions from your message?

  1.  If the solution includes the SRH, it must not violate RFC 7855.
  2.  Whether or not the solution uses the SRH, there must be a way for existing SRv6 deployments that use the SRH to migrate to it.
  3.  The solution must use the SRH.

I think that 1) and 2) are valid requirements. 3) is not.

Do you agree?

                                        Ron

Sent: Thursday, July 30, 2020 12:13 AM

Wim,

                                                                                   Ron

Juniper Business Use Only
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 28, 2020 11:54 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                 Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 30 Jul 2020 19:02:22 +0000

Would we not say the solution must interwork with a SR deployment that uses SRv6 with SRH ?

From: Ron Bonica <[email-masked]>
Date: Thursday, 30 July 2020 at 17:20
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-00

Hi Wim,

Do you agree?

                                        Ron

Wim,

                                                                                   Ron

Wim,

                                                                 Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 30 Jul 2020 19:41:31 +0000

Wim,

First, we have to make a distinction between co-existence and interworking.

Assume that two tunnels connect Node A to Node B. One tunnel uses SRv6 with an RFC 8577 style SRH. The other tunnel uses Compression Mechanism X. In this case we can say that Compression Mechanism X can co-exist with the SRv6 SRH.

Now assume that a single tunnel connects Node A to Node B. Node A sends SRv6 packets that have an RFC 8577 style SRH. Node B receives packets in which the SRH has been replaced by Compression Mechanism X. Some intermediate node did the translation. We call this interworking.

Co-existence is clearly a requirement. Without co-existence, migration is impossible.

While I am a big fan of interworking, I am not sure that it is a requirement. Can you convince me that it is?

                                                                                                                Ron

Sent: Thursday, July 30, 2020 3:02 PM

Hi Wim,

Do you agree?

                                        Ron

Wim,

                                                                                   Ron

Wim,

                                                                 Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 30 Jul 2020 19:43:56 +0000

An interworking solution is the least desired since it add cost and bottlenecks.
So let’s call it native interworking w/o a GW.

From: Ron Bonica <[email-masked]>
Date: Thursday, 30 July 2020 at 21:41
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                                                                Ron

Hi Wim,

Do you agree?

                                        Ron

Wim,

                                                                                   Ron

Wim,

                                                                 Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 30 Jul 2020 19:46:11 +0000

What is interworking w/o a gateway?

Sent: Thursday, July 30, 2020 3:44 PM

An interworking solution is the least desired since it add cost and bottlenecks.
So let's call it native interworking w/o a GW.

Wim,

                                                                                                                Ron

Hi Wim,

Do you agree?

                                        Ron

Wim,

                                                                                   Ron

Wim,

                                                                 Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 30 Jul 2020 19:49:50 +0000

It means that there is no element that translates one protocol stack to another to make the 2 talk to each other.

From: Ron Bonica <[email-masked]>
Date: Thursday, 30 July 2020 at 21:46
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                                                                Ron

Hi Wim,

Do you agree?

                                        Ron

Wim,

                                                                                   Ron

Wim,

                                                                 Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 30 Jul 2020 19:51:51 +0000

Does that mean that every node must support both SRv6 SRH and the chosen compression mechanism?

                                                                  Ron

Sent: Thursday, July 30, 2020 3:50 PM

Wim,

                                                                                                                Ron

Hi Wim,

Do you agree?

                                        Ron

Wim,

                                                                                   Ron

Wim,

                                                                 Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 30 Jul 2020 19:55:06 +0000

And they can ideally seamlessly migrate, this is for migration the most ideal solution which lowest cost impact.

From: Ron Bonica <[email-masked]>
Date: Thursday, 30 July 2020 at 21:51
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-00

                                                                  Ron

Wim,

                                                                                                                Ron

Hi Wim,

Do you agree?

                                        Ron

Wim,

                                                                                   Ron

Wim,

                                                                 Ron

---

From: Sander Steffann <[email-masked]>
Date: Thu, 30 Jul 2020 21:57:54 +0200

Hi Wim,

> It means that there is no element that translates one protocol stack to> another to make the 2 talk to each other.
I think there are two ways two different protocol stacks can do that
(not saying that there are going to be two protocol stacks, but if there
are…):

1) Specify that devices implementing the new protocol MUST also
implement the other protocol and MUST be able to seamlessly send a
packet onward using either the new or the old protocol, depending on the
next hop. And this must be done without loss of information.

or

2) Specify that the new protocol MUST use a wire format that is
compatible with the existing protocol in such a way that it will not
confuse devices that only know about the old protocol and not the new
protocol.

Which way are you thinking?

Cheers,
Sander

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 30 Jul 2020 20:06:21 +0000

This is not just a data plane issue but also control plane and addressing and the instruction sweat. So say e.g that you have adopted SRv6 which is the real use case we have at play. If we find a solution that complies with this framework -> data plane/control-plane/addressing/etc we will do a big favor to the people who have adopted SRv6.

So for me the requirement is really about the fact that if we have a solution that make this migration seamless we do a major favor to operators that have gone down this path.

Look at ipv4 and ipv6 the fact that they are incompatible in all aspects has costed he industry a fortune.

On 30/07/2020, 21:57, "Sander Steffann" <[email-masked]> wrote:

    Hi Wim,

    or

    Cheers,
    Sander

---

From: Ron Bonica <[email-masked]>
Date: Thu, 30 Jul 2020 20:41:46 +0000

Wim,

I think that co-existence offers a safer migration strategy than interworking. The following paragraphs describe migration with co-existence. Can you describe migration with interworking?

                                                                            Ron

Migration with co-existence
======================= 
Pre-migration: The network contains many SRv6/SRH tunnels. Production traffic traverses these tunnels.

Migration Phase 1: Build out new tunnels that use the new compression mechanism. These tunnels co-exist with the SRv6/SRH tunnels. The risk associated with this phase is low because the SRv6/SRH tunnels are not touched and production traffic continues to traverse the SRv6/SRH tunnels.

Migration Phase 2: Run some test traffic through the new tunnels. Test connectivity and performance. The risk associated with this phase is low because the SRv6/SRH tunnels are not touched and production traffic continues to traverse the SRv6/SRH tunnels.

Migration Phase 3: Slowly shift traffic from the SRv6 / SRH tunnels to the new tunnels.

Migration Phase 4: Decommission the SRv6 / SRH tunnels.

-----Original Message-----
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]> 
Sent: Thursday, July 30, 2020 4:06 PM
To: Sander Steffann <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

    Hi Wim,

    or

    Cheers,
    Sander

---

From: Ron Bonica <[email-masked]>
Date: Thu, 30 Jul 2020 23:01:36 +0000

Wim,

Having take a walk around the block, it occurred to me that we may be using different words to talk about the same thing.

In my example, below, I talk about two sets of tunnels. One uses SRv6/SRH and the other uses something else (e.g., a different routing header type). They co-exist.

Are you thinking that the two tunnels are actually one tunnel? That some packets in the tunnel have an SRH and list segments another way (e.g., with a different routing header type)?

If so, we are using different words to describe the same thing.

                                                                 Ron

-----Original Message-----
From: Ron Bonica 
Sent: Thursday, July 30, 2020 4:42 PM
To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; Sander Steffann <[email-masked]>; [email-masked]
Subject: RE: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                            Ron

-----Original Message-----
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]> 
Sent: Thursday, July 30, 2020 4:06 PM
To: Sander Steffann <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

    Hi Wim,

    or

    Cheers,
    Sander

---

From: <[email-masked]>
Date: Fri, 31 Jul 2020 11:02:04 +0800 (CST)

Hi Ron,

In addition to migration case, whether there is necessary to consider the case that an E2E SR path may across multiple domains and each domain has different encapsulation style ?

Regards,

PSF

原始邮件

发件人：RonBonica <rbonica=[email-masked]>
收件人：Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>;SanderSteffann <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年07月31日 04:42
主 题 ：Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                            Ron

-----Original Message-----
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]> 
Sent: Thursday, July 30, 2020 4:06 PM
To: Sander Steffann <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

    Hi Wim,

    or

    Cheers,
    Sander

-- 
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 31 Jul 2020 04:15:54 +0000

I think the best way to describe it is the solution should be compatible with:
draft-ietf-spring-srv6-network-programming-16
This is the framework SRv6 uses.

On 31/07/2020, 01:01, "Ron Bonica" <[email-masked]> wrote:

    Wim,

                                                                     Ron

    -----Original Message-----
    From: Ron Bonica 
    Sent: Thursday, July 30, 2020 4:42 PM
    To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; Sander Steffann <[email-masked]>; [email-masked]
    Subject: RE: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

    Wim,

                                                                                Ron

    -----Original Message-----
    From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]> 
    Sent: Thursday, July 30, 2020 4:06 PM
    To: Sander Steffann <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
    Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

        Hi Wim,

        or

        Cheers,
        Sander

---

From: Ron Bonica <[email-masked]>
Date: Fri, 31 Jul 2020 14:34:33 +0000

Wim,

I suspect that this requirement has morphed as we discussed it. Could you post a version 01?

                                                                 Ron

-----Original Message-----
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]> 
Sent: Friday, July 31, 2020 12:16 AM
To: Ron Bonica <[email-masked]>; Sander Steffann <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

    Wim,

                                                                     Ron

    -----Original Message-----
    From: Ron Bonica
    Sent: Thursday, July 30, 2020 4:42 PM
    To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; Sander Steffann <[email-masked]>; [email-masked]
    Subject: RE: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

    Wim,

                                                                                Ron

    -----Original Message-----
    From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
    Sent: Thursday, July 30, 2020 4:06 PM
    To: Sander Steffann <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
    Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

        Hi Wim,

        or

        Cheers,
        Sander

---

From: Ron Bonica <[email-masked]>
Date: Fri, 31 Jul 2020 16:17:37 +0000

Peng,

I agree that interworking across SR domain boundaries is a requirement. We should probably write that up as a separate requirement.

Since it was your idea, would you like to submit the requirement?

                                                                                        Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, July 30, 2020 11:02 PM
To: rbonica=[email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

Hi Ron,

Regards,

PSF

原始邮件
发件人：RonBonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
收件人：Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>;SanderSteffann <[email-masked]<mailto:[email-masked]>>;[email-masked] <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年07月31日 04:42
主 题 ：Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00
Wim,

                                                                            Ron

-----Original Message-----
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, July 30, 2020 4:06 PM
To: Sander Steffann <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

On 30/07/2020, 21:57, "Sander Steffann" <[email-masked]<mailto:[email-masked]>> wrote:

    Hi Wim,

    or

    Cheers,
    Sander

--
Srcomp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/srcomp

---

From: <[email-masked]>
Date: Sat, 1 Aug 2020 11:14:07 +0800 (CST)

Hi Ron,

I just submit it, please check.

Regards,

PSF

原始邮件

发件人：RonBonica <[email-masked]>
收件人：彭少富10053815;rbonica=[email-masked] <rbonica=[email-masked]>;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年08月01日 00:17
主 题 ：RE: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

Peng,

 

 

                                                                                        Ron

 

From: Srcomp <[email-masked]> On Behalf [email-masked]

 

Hi Ron,

Regards,

PSF

原始邮件

收件人：Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>;SanderSteffann
 <[email-masked]>;[email-masked] <[email-masked]>;

日期：2020年07月31日
 04:42

主题：Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

Wim,

                                                                            Ron

-----Original Message-----
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]> 
Sent: Thursday, July 30, 2020 4:06 PM
To: Sander Steffann <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

    Hi Wim,

    or

    Cheers,
    Sander

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Sat, 1 Aug 2020 04:44:54 +0000

done

On 31/07/2020, 16:34, "Ron Bonica" <[email-masked]> wrote:

    Wim,

                                                                     Ron

    -----Original Message-----
    From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]> 
    Sent: Friday, July 31, 2020 12:16 AM
    To: Ron Bonica <[email-masked]>; Sander Steffann <[email-masked]>; [email-masked]
    Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

        Wim,

                                                                         Ron

        -----Original Message-----
        From: Ron Bonica
        Sent: Thursday, July 30, 2020 4:42 PM
        To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; Sander Steffann <[email-masked]>; [email-masked]
        Subject: RE: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

        Wim,

                                                                                    Ron

        -----Original Message-----
        From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
        Sent: Thursday, July 30, 2020 4:06 PM
        To: Sander Steffann <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
        Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-00

            Hi Wim,

            or

            Cheers,
            Sander