Subject: [Srcomp] REQ-7-28-FLEX-ADDRESS-PLANNING-00

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Tue, 28 Jul 2020 13:47:25 +0000

Short Name: Flexible IPv6 address Planning

Description: The compression mechanism MUST support flexible IPv6 address planning, and MUST NOT require for specific address type and address value. Also, It MUST support to be deployed by using GLA, ULA and other unicast address types.

Rationale: The address planning of the network is vary based on the address schema of the operator, so the solution MUST support flexible address planning. Operators need to deploy the solution based on their own addresses planning.

Metric: if the solution only works when using a specific address type, or some specific address value, that is not compliant. If it require one or some specific prefixes, that is not compliant.

Cheng

---

From: Ron Bonica <[email-masked]>
Date: Wed, 29 Jul 2020 18:59:19 +0000

Cheng Li,

I strongly support this requirement. In fact, I would like to add two metrics.

Assume that two companies run SRv6 networks. One company draws it locators from the prefix 2001:db8::/48, while the other draws its locators from the prefix 2001:db8:FFFF:FF00::/56. At some point, the companies want to merge their networks into a single SRv6 domain.

Metric 1: The merger must not require renumbering of either network. The compression mechanism must continue to work, even though locators have different lengths.

Metric 2: The merger must not require renumbering of either network. Compression efficiency must not be effected by the merger.

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Chengli (Cheng Li)
Sent: Tuesday, July 28, 2020 9:47 AM
To: [email-masked]
Subject: [Srcomp] REQ-7-28-FLEX-ADDRESS-PLANNING-00

[External Email. Be cautious of content]

Cheng

---

From: <[email-masked]>
Date: Thu, 30 Jul 2020 10:42:42 +0800 (CST)

Hi Ron,

Whether there should be a prerequisite, that there is no overlap in address assignments between the two companies before merging ?

For example, company-1 has not used 2001:db8:FFFF:FF00::1/128 that may also be used by company-2.

Regards,

PSF

原始邮件

发件人：RonBonica <rbonica=[email-masked]>
收件人：Chengli (Cheng Li) <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年07月30日 02:59
主 题 ：Re: [Srcomp] REQ-7-28-FLEX-ADDRESS-PLANNING-00

-- 
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

Cheng Li,

 

Assume that two companies run SRv6 networks. One company draws it locators from the prefix 2001:db8::/48, while the other draws its locators from the prefix 2001:db8:FFFF:FF00::/56. At some point, the companies want to merge their networks
 into a single SRv6 domain.

 

 

 

From: Srcomp <[email-masked]> On Behalf OfChengli (Cheng Li)
Sent: Tuesday, July 28, 2020 9:47 AM
To: [email-masked]
Subject: [Srcomp] REQ-7-28-FLEX-ADDRESS-PLANNING-00

 

 

Description: The compression mechanism MUST support flexible IPv6 address planning, and MUST NOT require for specific address type and address value. Also, It MUST support to be deployed by using
 GLA, ULA and other unicast address types.

Rationale: The address planning of the network is vary based on the address schema of the operator, so the solution MUST support flexible address planning. Operators need to deploy the solution based
 on their own addresses planning.

 

Cheng

---

From: Ron Bonica <[email-masked]>
Date: Thu, 30 Jul 2020 18:43:40 +0000

Hello Peng,

I assume that there is no overlap before merging the SR domains, but maybe we should say that explicitly.

The point is that renumbering should not be required to make the compression mechanism work, even though one network uses /48 locators and the other uses /56 locators.

                                                                                                         Ron

Juniper Business Use Only
From: [email-masked] <[email-masked]>
Sent: Wednesday, July 29, 2020 10:43 PM
To: Ron Bonica <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re:[Srcomp] REQ-7-28-FLEX-ADDRESS-PLANNING-00

Hi Ron,

Regards,

PSF

原始邮件
发件人：RonBonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
收件人：Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>;[email-masked] <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年07月30日 02:59
主 题 ：Re: [Srcomp] REQ-7-28-FLEX-ADDRESS-PLANNING-00
--
Srcomp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/srcomp
Cheng Li,

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf OfChengli (Cheng Li)
Sent: Tuesday, July 28, 2020 9:47 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] REQ-7-28-FLEX-ADDRESS-PLANNING-00

Cheng