Subject: [Srcomp] REQ-8-20-IPv6-to-CompSRv6-00

From: <[email-masked]>
Date: Thu, 20 Aug 2020 15:31:47 +0800 (CST)

Short Name: Migration from IPv6-only to Compression based SRv6.

Description: The compression mechanism must support upgrade the existing IPv6-only node to the compression based SRv6 node directly.

Rational: The future network will use IPv6 single stack, and some current network that deployed IPv6-only mainly used for Internet services will be enhanced to carry more services with specific SLA. When upgrading the existing IPv6-only node to the compression based SRv6 node, it must not withdraw the existing IPv6 address planning, and not cause interoperability problem with legacy IPv6-only devices both for control plane and data plane, to minimize the impaction on the existing service. A compressed SR path traversing both IPv6-only nodes and compression based SRv6 nodes must be supported.

Metric: The compression mechanism must not cause interoperability problem with legacy SRv6 devices.  

Category: Migration

---

From: Ron Bonica <[email-masked]>
Date: Thu, 20 Aug 2020 16:53:04 +0000

Peng,

In the metric, did you mean to say:

  *   The compression mechanism must not cause interoperability problem with legacy *SRv6* devices

or

  *   The compression mechanism must not cause interoperability problem with legacy *IPv6* devices

                                                                                                       Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, August 20, 2020 3:32 AM
To: [email-masked]
Subject: [Srcomp] REQ-8-20-IPv6-to-CompSRv6-00

[External Email. Be cautious of content]

Category: Migration

---

From: <[email-masked]>
Date: Fri, 21 Aug 2020 09:47:12 +0800 (CST)

Oh, I made a mistake. It is:

The compression mechanism must not cause interoperability problem with legacy *IPv6* devices

原始邮件

发件人：RonBonica <rbonica=[email-masked]>
收件人：彭少富10053815;[email-masked] <[email-masked]>;
日 期 ：2020年08月21日 00:53
主 题 ：Re: [Srcomp] REQ-8-20-IPv6-to-CompSRv6-00

-- 
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

Peng,

 

The compression mechanism must not cause interoperability problem with legacy *SRv6* devices

or

The compression mechanism must not cause interoperability problem with legacy *IPv6* devices

                                                                                                       Ron

 

From: Srcomp <[email-masked]> On Behalf [email-masked]
Sent: Thursday, August 20, 2020 3:32 AM
To: [email-masked]
Subject: [Srcomp] REQ-8-20-IPv6-to-CompSRv6-00

 

Rational: The future network will use IPv6 single stack, and some current network that deployed IPv6-only mainly used for Internet services will be enhanced to carry more services with specific SLA. When upgrading the existing IPv6-only node to the compression
 based SRv6 node, it must not withdraw the existing IPv6 address planning, and not cause interoperability problem with legacy IPv6-only devices both for control plane and data plane, to minimize the impaction on the existing service. A compressed SR path traversing
 both IPv6-only nodes and compression based SRv6 nodes must be supported.

Category: Migration