Subject: [Srcomp] REQ-7-24-ipv6-based-01

From: Ron Bonica <[email-masked]>
Date: Mon, 10 Aug 2020 15:04:16 +0000

Short Name: IPv6 Based.

Description: The compression mechanism must be IPv6-based. The SR ingress node encapsulates its payload (e.g., Ethernet, IP, TCP) in an IPv6 header. The compression mechanism is either:

- Encoded in the IPv6 header
- Encoded in an IPv6 extension header that follows the IPv6 header.
- Encode in both.

The IPv6 header persists until it is removed by either by the SR egress node or a penultimate node.  Once the IPv6 header is completely processed and removed, it cannot be re-added.

Rational: The SR ingress node calculates routing and non-routing information regarding the SR path. Non-routing information includes:

-              DSCP bits
-              Flow label
-              Fragmentation information
-              Authentication information
-              Destination Options

The SR ingress node encodes routing and non-routing information in the IPv6 header and its extensions. If the IPv6 header were removed along the SR path, non-routing information would be lost.

Also, transit nodes may update the ECN bits in the IPv6 header. If the IPv6 header were removed, the ECN bits would be lost.

Metric: Non-routing information (e.g., DSCP, ECN, Destination Options) must be delivered from the source node to the destination node. It must not be delivered to an upper-layer protocol for the purposes of including it in a new IPv6 header, as is the case in RFC 8663.

Category: Functional

Juniper Business Use Only

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Wed, 12 Aug 2020 22:13:34 +0800

Hi Ron,

Could I replace the REQ-7-24-ipv6-based-01 with this directly in the excel
table?

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Ron Bonica
发送时间: 2020年8月10日 23:04
收件人: [email-masked]
主题: [Srcomp] REQ-7-24-ipv6-based-01

Short Name: IPv6 Based.

Description: The compression mechanism must be IPv6-based. The SR ingress
node encapsulates its payload (e.g.., Ethernet, IP, TCP) in an IPv6 header.
The compression mechanism is either:

- Encode in both.

The IPv6 header persists until it is removed by either by the SR egress node
or a penultimate node.  Once the IPv6 header is completely processed and
removed, it cannot be re-added.

Rational: The SR ingress node calculates routing and non-routing information
regarding the SR path. Non-routing information includes:

-              DSCP bits

-              Flow label

-              Destination Options

The SR ingress node encodes routing and non-routing information in the IPv6
header and its extensions. If the IPv6 header were removed along the SR
path, non-routing information would be lost.

Also, transit nodes may update the ECN bits in the IPv6 header. If the IPv6
header were removed, the ECN bits would be lost.

Metric: Non-routing information (e.g., DSCP, ECN, Destination Options) must
be delivered from the source node to the destination node. It must not be
delivered to an upper-layer protocol for the purposes of including it in a
new IPv6 header, as is the case in RFC 8663.

Category: Functional

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Wed, 12 Aug 2020 22:15:05 +0800

Sorry.

Could I replace the REQ-7-24-ipv6-based-00 with REQ-7-24-ipv6-based-01
directly in the excel table?

B.R.

Weiqiang Cheng

发件人: Weiqiang Cheng [mailto:[email-masked]] 
发送时间: 2020年8月12日 22:14
收件人: 'Ron Bonica'; [email-masked]'
主题: 答复: [Srcomp] REQ-7-24-ipv6-based-01

Hi Ron,

B.R.

Weiqiang Cheng

Short Name: IPv6 Based.

- Encode in both.

-              DSCP bits

-              Flow label

-              Destination Options

Category: Functional

---

From: Ron Bonica <[email-masked]>
Date: Wed, 12 Aug 2020 15:42:19 +0000

Yes, please do

Juniper Business Use Only
From: Weiqiang Cheng <[email-masked]>
Sent: Wednesday, August 12, 2020 10:14 AM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: 答复: [Srcomp] REQ-7-24-ipv6-based-01

[External Email. Be cautious of content]

Hi Ron,
Could I replace the REQ-7-24-ipv6-based-01 with this directly in the excel table?

B.R.
Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Ron Bonica
发送时间: 2020年8月10日 23:04
收件人: [email-masked]<mailto:[email-masked]>
主题: [Srcomp] REQ-7-24-ipv6-based-01

Short Name: IPv6 Based.

Description: The compression mechanism must be IPv6-based. The SR ingress node encapsulates its payload (e.g.., Ethernet, IP, TCP) in an IPv6 header. The compression mechanism is either:

-              DSCP bits
-              Flow label

Category: Functional

---

From: Ron Bonica <[email-masked]>
Date: Wed, 12 Aug 2020 15:42:35 +0000

Yes, please do

Juniper Business Use Only
From: Weiqiang Cheng <[email-masked]>
Sent: Wednesday, August 12, 2020 10:15 AM
To: 'Weiqiang Cheng' <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: 答复: [Srcomp] REQ-7-24-ipv6-based-01

Sorry.
Could I replace the REQ-7-24-ipv6-based-00 with REQ-7-24-ipv6-based-01 directly in the excel table?

B.R.
Weiqiang Cheng

Hi Ron,

B.R.
Weiqiang Cheng

Short Name: IPv6 Based.

-              DSCP bits
-              Flow label

Category: Functional