Subject: [Srcomp] Requirement Category Proposal

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wed, 5 Aug 2020 14:53:17 +0000

Here is a proposal for the list of categories that could be used:

  *   Functional requirements
  *   Convergence requirements
  *   Scalability requirements
  *   Security Requirements
  *   Efficiency/performance Requirements -> could be split maybe
  *   Migration Requirements

If you have other suggestions, open for any changes.

---

From: Ron Bonica <[email-masked]>
Date: Wed, 5 Aug 2020 16:48:01 +0000

Wim,

Could we add a category that addresses operational considerations (e.g., debuggability)?

Also, could you provide a sentence describing each category?

                                            Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Wednesday, August 5, 2020 10:53 AM
To: [email-masked]
Subject: [Srcomp] Requirement Category Proposal

[External Email. Be cautious of content]

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 6 Aug 2020 04:08:55 +0000

Ron. The debuggability would be in an operational requirement category maybe

  *
  *   Functional requirements: requirements that handle the base operation of SPRING, like adj-sid, prefix-sid handling
  *   Convergence requirements: requirements related to resilience, like FRR, the mechanisms related to link/node protection
  *   Scalability requirements: requirement related to scaling; the amount of link/nodes the solution can address, how many services the solution support
  *   Security Requirements: requirement related to security; security implications
  *   Efficiency/performance Requirements -> could be split maybe; requirements related to overhead of the solution and the data-plane operation (like lookup/packet manipulation operation)
  *   Migration Requirements: requirements related to the impact to migrate to such solution
  *   Operational requirements: requirements related to debugging, troubleshooting, visibility of the solution

From: Ron Bonica <[email-masked]>
Date: Wednesday, 5 August 2020 at 18:48
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Requirement Category Proposal

Wim,

                                            Ron

---

From: Ron Bonica <[email-masked]>
Date: Fri, 7 Aug 2020 19:48:03 +0000

Hi Wim,

These seem like very important distinctions. In fact, a requirements metric should reflect its category. The following are examples:

  *   The metric for a functional requirement should be of the form, "The compression mechanism should do something".
  *   The metric for a scaling requirement should be of the form, "The compression mechanism should support N objects".

I will look at the requirements that I have submitted an try to stylize their metrics in this way.

                                                                                            Ron

Juniper Business Use Only
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Sent: Thursday, August 6, 2020 12:09 AM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: Requirement Category Proposal

  *

From: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 5 August 2020 at 18:48
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Requirement Category Proposal

Wim,

                                            Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Wednesday, August 5, 2020 10:53 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] Requirement Category Proposal

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Sat, 8 Aug 2020 05:25:36 +0000

We can see if we map them to the categories how this fits., so lets try to use this and see if this sticks.

From: Ron Bonica <[email-masked]>
Date: Friday, 7 August 2020 at 21:48
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Requirement Category Proposal

Hi Wim,

  *   The metric for a functional requirement should be of the form, “The compression mechanism should do something”.
  *   The metric for a scaling requirement should be of the form, “The compression mechanism should support N objects”.

                                                                                            Ron

  *

Wim,

                                            Ron