Subject: Re: [Srcomp] REQ-7-27-SVC-SCALE-00

From: Ron Bonica <[email-masked]>
Date: Mon, 10 Aug 2020 15:12:35 +0000

Folks,

Do we have general consensus that we want the compression mechanism to replace the EVPN VXLAN header? If so, the VNI in the VXLAN header is 24-bits long. So, the Service Scale requirement should be 2**24 (i.e., 16.7 million).

                                                                                                                             Ron

Juniper Business Use Only
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Sent: Tuesday, July 28, 2020 4:41 PM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: REQ-7-27-SVC-SCALE-00

[External Email. Be cautious of content]

I said more then >16bit and 1Million was something I know someone deployed. So I would say lets list what we have as a customer requirement somehow

From: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 28 July 2020 at 21:07
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: REQ-7-27-SVC-SCALE-00

Wim,

Two to the sixteenth power is only 65k. If you want to support 1 million services, you need 20 bits, not 16.

The EVPN VNI is 24-bits long. Given that EVPN is a fastest growing VPN service, I suggest that we may actually need 24 bits.

                                                                                                               Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Monday, July 27, 2020 12:17 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Srcomp] REQ-7-27-SVC-SCALE-00

[External Email. Be cautious of content]

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, 27 July 2020 at 18:07
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: REQ-7-27-SVC-SCALE-00

Short Name: Service scale

Description: The compression mechanism must support > 1Million services (>16bit)

Rationale: Some network operators deploy networks which requires > 500K services.

Metric: The compression mechanism allows to work in an environment that support this scalability.

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 11 Aug 2020 05:19:34 +0000

I don’t know only use case which comes to 16M so far, I know 1 deployment which is getting close to 1M, this is why I suggested at least 20 bit. If we know deployments that need this scale would be good to know, but if you have local significant usage this would be 20 bit * # devices. So network wide this is massive.

From: Ron Bonica <[email-masked]>
Date: Monday, 10 August 2020 at 17:12
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SVC-SCALE-00

Folks,

                                                                                                                             Ron

Wim,

                                                                                                               Ron

---

From: Ron Bonica <[email-masked]>
Date: Tue, 11 Aug 2020 14:04:10 +0000

Wim,

I don't know of any deployments that scale larger than 1 million. However, if we want to replace VXLAN, we need to be as capable as VXLAN.

                                                                             Ron

Sent: Tuesday, August 11, 2020 1:20 AM

I don't know only use case which comes to 16M so far, I know 1 deployment which is getting close to 1M, this is why I suggested at least 20 bit. If we know deployments that need this scale would be good to know, but if you have local significant usage this would be 20 bit * # devices. So network wide this is massive.

Folks,

                                                                                                                             Ron

Juniper Business Use Only
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 28, 2020 4:41 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: REQ-7-27-SVC-SCALE-00

Wim,

                                                                                                               Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wed, 12 Aug 2020 04:02:59 +0000

See if we believe 24 bit is needed let’s do it, but I didn’t want to over specify. Also if we do local significant assignment we have a massive scale even with 20 bit.
If we all believe 24 bit is the way to go I will update the requirement.

From: Ron Bonica <[email-masked]>
Date: Tuesday, 11 August 2020 at 16:04
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SVC-SCALE-00

Wim,

I don’t know of any deployments that scale larger than 1 million. However, if we want to replace VXLAN, we need to be as capable as VXLAN.

                                                                             Ron

Folks,

                                                                                                                             Ron

Wim,

                                                                                                               Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 12 Aug 2020 12:50:40 +0000

Hi Wim and Ron, I'm a bit concerned that over-specification of scale requirements goes beyond SR compression and into general requirements for an SR instantiation and the myriad services it supports.

Darren
________________________________
From: Srcomp <[email-masked]> on behalf of Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Sent: Wednesday, August 12, 2020 12:02 AM
To: Ron Bonica <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Srcomp] REQ-7-27-SVC-SCALE-00

Wim,

                                                                             Ron

Folks,

                                                                                                                             Ron

Wim,

                                                                                                               Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 13 Aug 2020 14:14:21 +0000

Darren,

If all of the proposed compression mechanism maintained a strict separation between traffic engineering and services, I would agree with you. But they don't.

                                                      Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <[email-masked]>
Sent: Wednesday, August 12, 2020 8:51 AM
To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: REQ-7-27-SVC-SCALE-00

Darren
________________________________
From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, August 12, 2020 12:02 AM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Srcomp] REQ-7-27-SVC-SCALE-00

See if we believe 24 bit is needed let's do it, but I didn't want to over specify. Also if we do local significant assignment we have a massive scale even with 20 bit.

Wim,

                                                                             Ron

Folks,

                                                                                                                             Ron

Wim,

                                                                                                               Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 13 Aug 2020 18:59:24 +0000

Why don’t we create 2 requirements.
1 with 20 bit for local significant allocation and a 2nd for 24 bit with global allocation.

I believe we should decouple ourselves in req. from the way solutions are proposed.

From: Ron Bonica <[email-masked]>
Date: Thursday, 13 August 2020 at 16:14
To: Darren Dukes <[email-masked]>, "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SVC-SCALE-00

Darren,

If all of the proposed compression mechanism maintained a strict separation between traffic engineering and services, I would agree with you. But they don’t.

                                                      Ron

Darren

Wim,

                                                                             Ron

Folks,

                                                                                                                             Ron

Wim,

                                                                                                               Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 13 Aug 2020 19:35:00 +0000

Wim,

Is that for service instructions only? If so, I think that this is a good idea.

                                                             Ron

Juniper Business Use Only
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Sent: Thursday, August 13, 2020 2:59 PM
To: Ron Bonica <[email-masked]>; Darren Dukes (ddukes) <[email-masked]>; [email-masked]
Subject: Re: REQ-7-27-SVC-SCALE-00

Why don't we create 2 requirements.
1 with 20 bit for local significant allocation and a 2nd for 24 bit with global allocation.

From: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 13 August 2020 at 16:14
To: Darren Dukes <[email-masked]<mailto:[email-masked]>>, "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: REQ-7-27-SVC-SCALE-00

Darren,

                                                      Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, August 12, 2020 8:51 AM
To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: REQ-7-27-SVC-SCALE-00

Darren

Wim,

                                                                             Ron

Folks,

                                                                                                                             Ron

Wim,

                                                                                                               Ron

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 14 Aug 2020 11:07:12 +0800

Hi，all
Since I joined the maillist late and missed the early discussion of the requirements, I add several additional requirements to the datasheet sent by Weiqiang. Pls be kindely requested to check them.

Thanks
Chongfeng

From: Henderickx, Wim (Nokia - BE/Antwerp)
Date: 2020-08-14 02:59
To: Ron Bonica; Darren Dukes (ddukes); [email-masked]
Subject: Re: [Srcomp] REQ-7-27-SVC-SCALE-00
Why don’t we create 2 requirements.
1 with 20 bit for local significant allocation and a 2nd for 24 bit with global allocation.

 
Darren,

                                                      Ron

 

Darren

 
 
Wim,

                                                                             Ron

 

 
Folks,

                                                                                                                             Ron

 

 
 
Wim,

 
                                                                                                               Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Monday, July 27, 2020 12:17 PM
To: [email-masked]
Subject: Re: [Srcomp] REQ-7-27-SVC-SCALE-00

 
From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Monday, 27 July 2020 at 18:07
To: "[email-masked]" <[email-masked]>
Subject: REQ-7-27-SVC-SCALE-00

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 14 Aug 2020 04:17:30 +0000

Chongfeng, I believe it is better to send them in the email since we can discuss them one by one. You should have seen some examples I just send this morning on scale.

From: Srcomp <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Friday, 14 August 2020 at 05:07
To: "[email-masked]" <[email-masked]>, 'Weiqiang Cheng' <[email-masked]>
Subject: [Srcomp] Additional requirements

Hi，all

Thanks
Chongfeng

From: Henderickx, Wim (Nokia - BE/Antwerp)<mailto:[email-masked]>
Date: 2020-08-14 02:59
To: Ron Bonica<mailto:[email-masked]>; Darren Dukes (ddukes)<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Srcomp] REQ-7-27-SVC-SCALE-00
Why don’t we create 2 requirements.
1 with 20 bit for local significant allocation and a 2nd for 24 bit with global allocation.

Darren,

                                                      Ron

[External Email.. Be cautious of content]

Darren

Wim,

                                                                             Ron

Folks,

                                                                                                                             Ron

From: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 28 July 2020 at 21:07
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>, "srcomp@ietf..org<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: REQ-7-27-SVC-SCALE-00

Wim,

                                                                                                               Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 14 Aug 2020 04:22:40 +0000

Yes it would be for the service function.

From: Ron Bonica <[email-masked]>
Date: Thursday, 13 August 2020 at 21:35
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, Darren Dukes <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SVC-SCALE-00

Wim,

                                                             Ron

Darren,

                                                      Ron

Darren

Wim,

                                                                             Ron

Folks,

                                                                                                                             Ron

Wim,

                                                                                                               Ron

---

From: Ron Bonica <[email-masked]>
Date: Sat, 15 Aug 2020 14:21:57 +0000

Wim,

In that case, I agree. We should have two separate requirements.

                               Ron

Sent: Friday, August 14, 2020 12:23 AM

From: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 13 August 2020 at 21:35
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>, Darren Dukes <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: REQ-7-27-SVC-SCALE-00

Wim,

                                                             Ron

To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Darren,

                                                      Ron

Darren

Wim,

                                                                             Ron

Folks,

                                                                                                                             Ron

Wim,

                                                                                                               Ron