Subject: [Srcomp] REQ-8-17-FWD-EFFICIENCY

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 17 Aug 2020 18:43:18 +0000

FWD-Efficiency: Forwarding Efficiency

Description: The compression solution SHOULD minimize the number of required hardware resources accessed to process a segment.

Rationale: Efficiency in bits on the wire and processing efficiency are both important.  Optimizing one at the expense of the other may lead to issues in implementations.

Metric: The data plane efficiency metric (D) records the data plane forwarding efficiency of the proposed solution.  Two separate metrics are used:

   o  D.PRS(segment list): worst-case number of headers parsed during
      processing of the segment list.

   o  D.LKU(segment list): worst-case number of FIB lookups during
      processing of the segment list.

A proposal that minimizes each of these metrics would meet this requirement

Darren

---

From: Ron Bonica <[email-masked]>
Date: Mon, 17 Aug 2020 20:05:50 +0000

Darren,

Are D.PRS and D.IKU metrics that an operator actually cares about?

I think that an operators' only concern is whether a compression mechanism can be implemented to forward at line speed at a reasonable space/power/cost budget.

                                                                                          Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Monday, August 17, 2020 2:43 PM
To: [email-masked]
Subject: [Srcomp] REQ-8-17-FWD-EFFICIENCY

[External Email. Be cautious of content]

Darren

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 17 Aug 2020 20:30:44 +0000

Yes this is important to operators.

If their deployed hardware cannot implement a compression scheme at the scale and linerate of the deployed non-compressed solution it will cost them money in services or truck rolls.

Darren

________________________________
From: Ron Bonica <rbonica=[email-masked]>
Sent: Monday, August 17, 2020 4:05:50 PM
To: Darren Dukes (ddukes) <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: REQ-8-17-FWD-EFFICIENCY

Darren,

I think that an operators’ only concern is whether a compression mechanism can be implemented to forward at line speed at a reasonable space/power/cost budget.

                                                                                          Ron

Darren

---

From: Ron Bonica <[email-masked]>
Date: Mon, 17 Aug 2020 21:23:51 +0000

Darren,

Are we writing requirements to compensate for the limitations of a particular hardware platform?

                                                                                       Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Monday, August 17, 2020 4:31 PM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: REQ-8-17-FWD-EFFICIENCY

Darren

________________________________
From: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Monday, August 17, 2020 4:05:50 PM
To: Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: RE: REQ-8-17-FWD-EFFICIENCY

Darren,

                                                                                          Ron

From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Darren Dukes (ddukes)
Sent: Monday, August 17, 2020 2:43 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] REQ-8-17-FWD-EFFICIENCY

Darren

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Tue, 18 Aug 2020 00:21:35 +0000

No.

________________________________
From: Ron Bonica <rbonica=[email-masked]>
Sent: Monday, August 17, 2020 5:24 PM
To: Darren Dukes (ddukes); [email-masked]
Subject: RE: REQ-8-17-FWD-EFFICIENCY

Darren,

                                                                                       Ron

Darren

Darren,

                                                                                          Ron

Darren

---

From: Ron Bonica <[email-masked]>
Date: Tue, 18 Aug 2020 01:27:46 +0000

Are you assuming that all operators have a large installed base that cannot parse multiple extension headers and do an extra lookup while maintaining acceptable performance?

                                                                                                                                   Ron

Sent: Monday, August 17, 2020 8:22 PM

No.

To: Darren Dukes (ddukes); [email-masked]<mailto:[email-masked]>

Darren,

                                                                                       Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Sent: Monday, August 17, 2020 4:31 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: REQ-8-17-FWD-EFFICIENCY

Darren

Darren,

                                                                                          Ron

Darren

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Tue, 18 Aug 2020 03:33:09 +0000

No Ron. I’m assuming nothing.

In engineering, everything is a trade off.

If I’m looking to choose a video compression encoder to deploy in my video streaming service to reduce bit rates, my biggest two requirements are likely:
1- compression ratio
2- performance

I may have other requirements, but I certainly want to know how a proposal meets these first.

The same applies to the SR compression design team requirements.

When SPRING uses these requirements to choose a compression proposal for SR they will certainly want to choose one that balances compression and performance. There may be other requirements to weigh, but it’s crucial to know how a proposal meets these.

Darren

Sent: Monday, August 17, 2020 9:28 PM

                                                                                                                                   Ron

No.

Darren,

                                                                                       Ron

Darren

Darren,

                                                                                          Ron

Darren