Subject: Re: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-01

From: Ron Bonica <[email-masked]>
Date: Mon, 3 Aug 2020 14:44:15 +0000

Wim,

We may want to make the metrics a little more specific. May I suggest:

  *   The compression mechanism MUST support the following SID types (A, B, C)
  *   The compression mechanism MAY support the following SID types (X, Y, Z)
  *   If the compression mechanism uses any of the encodings defined in RFC 7855 or the network programming draft, they must be backwards compatible with legacy implementations. However, the compression mechanism is not required to use any of the encodings defined in RFC 7855 or the network programming draft.

                                                                                                         Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Saturday, August 1, 2020 12:45 AM
To: [email-masked]
Subject: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-01

[External Email. Be cautious of content]

Short Name: SPRING FRAMEWORK

Description: The compression solution must be compliant to RFC 7855 and https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-16

Rationale: Having a solution that complies to RFC7855/NPG, would allow for a natural evolution in the SPRING WG, and interoperability for customers who deployed SR already

Metric: Compliance to RFC7855 and https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-16

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 4 Aug 2020 03:58:16 +0000

Ron, I don’t believe your suggestion are metrics, but rather ways to achieve it.
The metric can be impact on control plane, data plane and addressing to achieve this interoperability.

From: Ron Bonica <[email-masked]>
Date: Monday, 3 August 2020 at 16:44
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-01

Wim,

                                                                                                         Ron

---

From: Ron Bonica <[email-masked]>
Date: Tue, 4 Aug 2020 15:12:40 +0000

Can you state the metric that you have in mind?

                                  Ron

Juniper Business Use Only
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Sent: Monday, August 3, 2020 11:58 PM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: REQ-7-27-SPRING-FRAMEWORK-01

Ron, I don't believe your suggestion are metrics, but rather ways to achieve it.
The metric can be impact on control plane, data plane and addressing to achieve this interoperability.

From: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Date: Monday, 3 August 2020 at 16:44
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-01

Wim,

                                                                                                         Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Saturday, August 1, 2020 12:45 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] REQ-7-27-SPRING-FRAMEWORK-01

Description: The compression solution must be compliant to RFC 7855 and https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-16<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-16__;!!NEt6yMaO-gk!VJ3OZLtYdWK_l8KxGPIM0o60zhIpoYAx3DwJLjs3gIyIH8-Y_Fk7RacckPjCT8_5$>

Metric: Compliance to RFC7855 and https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-16<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-16__;!!NEt6yMaO-gk!VJ3OZLtYdWK_l8KxGPIM0o60zhIpoYAx3DwJLjs3gIyIH8-Y_Fk7RacckPjCT8_5$>

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wed, 19 Aug 2020 04:27:54 +0000

Sorry seems to have lost track of this one. I would say the following.

Metric:

  *   Impact on data-plane operation (if the HW would operate in a different way compared to the original operation)
  *   Impact on control-plane. (if the control plane needs to be updated to support the new compression mechanism)
  *   Impact on framework/addressing/ec (if the framework need addressing changes, etc)

The more impact you have the worse the score is. Does this make sense?

From: Ron Bonica <[email-masked]>
Date: Tuesday, 4 August 2020 at 17:12
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-01

                                  Ron

Wim,

                                                                                                         Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 20 Aug 2020 16:58:08 +0000

Wim,

I am not sure that this is a valid requirement. For example, assume the following:

  *   Compression mechanism A has little impact on the data plane/control plane/framework/addressing
  *   Compression mechanism B greatly simplifies the data plane/control plane/framework/addressing

It seems that Compression mechanism B should be preferred.

                                                                          Ron

Sent: Wednesday, August 19, 2020 12:28 AM

Metric:

                                  Ron

Juniper Business Use Only
From: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>
Sent: Monday, August 3, 2020 11:58 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: REQ-7-27-SPRING-FRAMEWORK-01

Wim,

                                                                                                         Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 20 Aug 2020 17:45:03 +0000

There are other requirements which focus on efficiency this req. focusses on the complexities from migrating to an existing SRv6 deployment to the compressed solutions.
As such I believe this is a valid requirement

From: Ron Bonica <[email-masked]>
Date: Thursday, 20 August 2020 at 18:58
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-01

Wim,

                                                                          Ron

Metric:

                                  Ron

Wim,

                                                                                                         Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 20 Aug 2020 17:54:59 +0000

Wim,

How does this requirement benefit operators who have not deployed classic SRv6?

So long as migration requirements are fulfilled, how does it benefit operators who have deployed SRv6?

                                                                                        Ron

Sent: Thursday, August 20, 2020 1:45 PM

Wim,

                                                                          Ron

Metric:

                                  Ron

Wim,

                                                                                                         Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 20 Aug 2020 18:03:06 +0000

It is not relevant to those who have not deployed SRv6, but for the once that did it helps them to minimize the impact.
So this is why this is relevant.

From: Ron Bonica <[email-masked]>
Date: Thursday, 20 August 2020 at 19:55
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-01

Wim,

                                                                                        Ron

Wim,

                                                                          Ron

Metric:

                                  Ron

Wim,

                                                                                                         Ron

---

From: Ron Bonica <[email-masked]>
Date: Thu, 20 Aug 2020 19:21:26 +0000

Wim,

So long as the classic mechanism and the compressed mechanism can interoperate, or at least co-exist, why would a network operator care how different they were?

                                             Ron

Sent: Thursday, August 20, 2020 2:03 PM

Wim,

                                                                                        Ron

Wim,

                                                                          Ron

Metric:

                                  Ron

Wim,

                                                                                                         Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 21 Aug 2020 03:49:19 +0000

Operators will care: if you have to change the addressing, control plane, etc with one option versus not havng to do anything on that front,  there is aa clear benefit of one mechanism to another. This is what we are talking about.

From: Ron Bonica <[email-masked]>
Date: Thursday, 20 August 2020 at 21:21
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-01

Wim,

                                             Ron

Wim,

                                                                                        Ron

Wim,

                                                                          Ron

Metric:

                                  Ron

Wim,

                                                                                                         Ron

---

From: Ron Bonica <[email-masked]>
Date: Fri, 21 Aug 2020 16:27:25 +0000

Wim,

I agree that operators will care if you have to change the addressing plan. No routing mechanism should dictate an addressing plan. I think we have that in another requirement.

However, if the compression mechanism actually simplifies the control plane, that would probably be a net positive.

                                                           Ron

Sent: Thursday, August 20, 2020 11:49 PM

Wim,

                                             Ron

Wim,

                                                                                        Ron

Wim,

                                                                          Ron

Metric:

                                  Ron

Wim,

                                                                                                         Ron

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 21 Aug 2020 18:31:10 +0000

Ron, the requirement is the following.

Hypothetical scenario
Assume you have 2 solution that comply to all other requirements
If solution 1 requires a number of changes to get deployed vs another that doesn’t it is clear that people will select the one that doesn’t. this is what we want to spell out here.

From: Ron Bonica <[email-masked]>
Date: Friday, 21 August 2020 at 18:27
To: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: REQ-7-27-SPRING-FRAMEWORK-01

Wim,

                                                           Ron

Wim,

                                             Ron

Wim,

                                                                                        Ron

Wim,

                                                                          Ron

Metric:

                                  Ron

Wim,

                                                                                                         Ron