Subject: [Srcomp] 2020-08-12 Minutes for DT meeting-draft

From: "Weiqiang Cheng" <[email-masked]>
Date: Wed, 12 Aug 2020 22:13:34 +0800

Hi team,

Today’s minutes is as follows. Any comments let me know.

Srcomp meeting

2020-08-12 13:00 UTC

Status: draft

Attendees:

- Cheng Weiqiang of China Mobile [present]

- Ron Bonica of Juniper [present]

- Darren Dukes of Cisco [present]

- Cheng Li of Huawei [present]

- Peng Shaofu of ZTE and [present]

- Wim Henderickx of Nokia [present]

- Chongfeng Xie of China Telecom [present]

====topic1=====

We will try to use the following requirement Category Proposal：

*	Functional requirements: requirements that handle the base operation
of SPRING, like adj-sid, prefix-sid handling
*	Convergence requirements: requirements related to resilience, like
FRR, the mechanisms related to link/node protection
*	Scalability requirements: requirement related to scaling; the amount
of link/nodes the solution can address, how many services the solution
support
*	Security Requirements: requirement related to security; security
implications
*	Efficiency/performance Requirements -> could be split maybe;
requirements related to overhead of the solution and the data-plane
operation (like lookup/packet manipulation operation)
*	Migration Requirements: requirements related to the impact to
migrate to such solution
*	Operational requirements: requirements related to debugging,
troubleshooting, visibility of the solution

====topic2=====

We labeled the requirement items according to the category as enclosed file.

====Actions====

1. Weiqiang will update the table and create sheets based on the categories
instead of owners

2. Next week, let's check whether the existing items in the same category
are duplicated or can be merged.

Weiqiang Cheng

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 12 Aug 2020 22:30:12 +0800

OK, thanks for sending the spreadsheet and minutes.

Chongfeng

发件人： Weiqiang Cheng
发送时间： 2020-08-12 22:13
收件人： [email-masked]
主题： [Srcomp] 2020-08-12 Minutes for DT meeting-draft
Hi team,
Today’s minutes is as follows. Any comments let me know.
 
Srcomp meeting
2020-08-12 13:00 UTC
 
Status: draft
 
Attendees:
 
====topic1=====
We will try to use the following requirement Category Proposal：
Functional requirements: requirements that handle the base operation of SPRING, like adj-sid, prefix-sid handling
Convergence requirements: requirements related to resilience, like FRR, the mechanisms related to link/node protection
Scalability requirements: requirement related to scaling; the amount of link/nodes the solution can address, how many services the solution support
Security Requirements: requirement related to security; security implications
Efficiency/performance Requirements -> could be split maybe; requirements related to overhead of the solution and the data-plane operation (like lookup/packet manipulation operation)
Migration Requirements: requirements related to the impact to migrate to such solution
Operational requirements: requirements related to debugging, troubleshooting, visibility of the solution
 
====topic2=====
 
====Actions====
1. Weiqiang will update the table and create sheets based on the categories instead of owners
2. Next week, let's check whether the existing items in the same category are duplicated or can be merged.

Weiqiang Cheng

---

From: "[email-masked]" <[email-masked]>
Date: Sun, 16 Aug 2020 13:20:26 +0800

Hi，all,
Regarding to the proessing of the requirments, I have the following comments.
Generally, for a gvien technique, the requirements should originate from its ultimate user, and the requirements should be straightforward  and effective to guidance upcoming technqique design, and they should be very helpful to resolve the controversy among people. The main users of Compressed SRv6 are network operators and its customers, so the requirements extracted from DT's discussion should start from the perspective of operators and theirs customers. Although some points raised are helpful for Compressed SRv6 design, for instance, complianceto RFC XXX,  they should not be considered to be primary requirments, they can be considered as some kind of design principles.  The stage of requiment analysis is very important, but that does not mean the longer of the requirement list, the better, we should extract from the requirement list and focus on some Killer requirements ultimately.

Best regards
Chongfeng

发件人： Weiqiang Cheng
发送时间： 2020-08-12 22:13
收件人： [email-masked]
 
Srcomp meeting
2020-08-12 13:00 UTC
 
Status: draft
 
Attendees:
 
====topic1=====
 
====topic2=====
 
====Actions====

Weiqiang Cheng

---

From: Ron Bonica <[email-masked]>
Date: Mon, 17 Aug 2020 15:23:31 +0000

Chongfeng,

You raise a very important issue. I think that there are three types of functional requirements. Each can be recognized by its metric.

The first and most valid type of functional requirement has a metric of the form:

  *   The compression mechanism must do X
  *   The compression mechanism must do Y
  *   The compression mechanism must do Z

Where Y, Y and Z are useful network functions, as you describe.

The second type of functional requirement is also valid and has a metric of the form:

  *   The compression mechanism must not violate any existing BCP or Standards track RFC.

Normally, it wouldn’t even be necessary to state such a requirement. But if we don’t impose such a requirement, the IESG will.

The third type of requirement is invalid, and has a metric of the form:

  *   The compression mechanism must use the protocol machinery described in document X, where document X is not RFC 8200.

This type of requirement mandates a solution.

                                                                                                      Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of [email-masked]
Sent: Sunday, August 16, 2020 1:20 AM
To: 'Weiqiang Cheng' <[email-masked]>; srcomp <[email-masked]>
Subject: Re: [Srcomp] 2020-08-12 Minutes for DT meeting-draft

[External Email. Be cautious of content]

Hi，all,

Best regards
Chongfeng

发件人： Weiqiang Cheng<mailto:[email-masked]>
发送时间： 2020-08-12 22:13
收件人： [email-masked]<mailto:[email-masked]>
主题： [Srcomp] 2020-08-12 Minutes for DT meeting-draft

Hi team,

Srcomp meeting

2020-08-12 13:00 UTC

Status: draft

Attendees:

====topic1=====

  *   Functional requirements: requirements that handle the base operation of SPRING, like adj-sid, prefix-sid handling
  *   Convergence requirements: requirements related to resilience, like FRR, the mechanisms related to link/node protection
  *   Scalability requirements: requirement related to scaling; the amount of link/nodes the solution can address, how many services the solution support
  *   Security Requirements: requirement related to security; security implications
  *   Efficiency/performance Requirements -> could be split maybe; requirements related to overhead of the solution and the data-plane operation (like lookup/packet manipulation operation)
  *   Migration Requirements: requirements related to the impact to migrate to such solution
  *   Operational requirements: requirements related to debugging, troubleshooting, visibility of the solution

====topic2=====

====Actions====

Weiqiang Cheng

---

From: "Xie Chongfeng" <[email-masked]>
Date: Tue, 18 Aug 2020 19:52:28 +0800

Hi，Ron,
The classification scheme you proposed is clear,  personally I think it will be very useful for the organization of the requirment document.
Best regards
Chongfeng 

[email-masked]
 
From: Ron Bonica
Date: 2020-08-17 23:23
To: [email-masked]; 'Weiqiang Cheng'; srcomp
Subject: Re: [Srcomp] 2020-08-12 Minutes for DT meeting-draft
Chongfeng,

 
The compression mechanism must do X
The compression mechanism must do Y
The compression mechanism must do Z

 
The compression mechanism must not violate any existing BCP or Standards track RFC.

 
The compression mechanism must use the protocol machinery described in document X, where document X is not RFC 8200.

                                                                                                      Ron

 
 
Hi，all,
 
Best regards
Chongfeng
 
发件人： Weiqiang Cheng
发送时间： 2020-08-12 22:13
收件人： [email-masked]
 
Srcomp meeting
2020-08-12 13:00 UTC
 
Status: draft
 
Attendees:
 
====topic1=====
 
====topic2=====
 
====Actions====

Weiqiang Cheng