Subject: Re: [Srcomp] Comments on REQ-8-17-FWD-EFFICIENCY

From: <[email-masked]>
Date: Fri, 2 Oct 2020 10:59:16 +0800 (CST)

Hi Darren, Ron,

Can we add the following text in the document:

Different architectures of a forwarding engines may require produce different performance metrics to characterize this requirement.

Regards,

PSF

原始邮件

发件人：DarrenDukes(ddukes)
收件人：Ron Bonica;srcomp;
日 期 ：2020年09月30日 11:37
主 题 ：Re: [Srcomp] Comments on REQ-8-17-FWD-EFFICIENCY

-- 
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

Hi Ron, I don't see why you would propose the inclusion of the existing metrics be dependent on adding additional metrics...

However, if I generalize your proposed metric it comes out to:

- At a segment endpoint a packet is received 

- if It is destined to a local SID

  - For each header/extension header processed 

     Count the number of read and write operations to process
 the header

Any source routing solution requires a segment endpoint node to perform:

- some number of lookups to identify the segment,

- some number of headers to be parsed,

- an IPv6 header Destination Address rewrite.

I don't see how you can quantify read and write operations during header processing.  

Simply counting the headers processed should be sufficient as an approximation of the forwarding efficiency and your proposed metrics.

Darren

--------------------------------------------------------------------------------

From: Ron Bonica <rbonica=[email-masked]>
Sent: Monday, September 28, 2020 3:03 PM
To: Darren Dukes (ddukes) <[email-masked]>; srcomp <[email-masked]>
Subject: RE: Comments on REQ-8-17-FWD-EFFICIENCY 

Folks,

If we retain these metrics, we should also include:

P.BSF – The number of bit shifts required

P.EX0 – Number of fields in the routing header that must be examined when Segment Left is equal to 0

P.EX1 – Number of fields in the routing header that must be examined when Segment Left is greater than 1

                                                                          Ron

 

Juniper Business Use Only

From: Darren Dukes (ddukes) <ddukes=[email-masked]> 
Sent: Monday, September 28, 2020 2:37 AM
To: Ron Bonica <[email-masked]>; srcomp <[email-masked]>
Subject: Re: Comments on REQ-8-17-FWD-EFFICIENCY

[External Email. Be cautious of content]

Hi Ron, the metrics in this requirement are indeed valid, as lookups and header parsing can directly translate to impacts on pps, power, heat, cost.  These are things that operators tell me they care about and that
 we should analyze. 

Let's change the rationale to reflect this.

Rationale: Performing multiple lookups per packet can impede the forwarding rate and functionality of many ASICS.

Parsing multiple headers per packet to perform those lookups can impede the forwarding rate and functionality of many ASICs.

These may translate to reduced pps or increased costs for operators.

During the analysis of each proposal, it can be determined just how many lookups would be required and their type, but this is analysis work for the analysis phase of this team's output.  

Darren 

--------------------------------------------------------------------------------

From: Srcomp <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: Wednesday, September 23, 2020 3:06 PM
To: srcomp <[email-masked]>
Subject: [Srcomp] Comments on REQ-8-17-FWD-EFFICIENCY 

Folks,

The metrics associate with REQ-8-17-FWD-EFFICIENCY are invalid. Currently, the metrics are:

D.PRS(segment list): worst-case number of headers parsed during processing of the segment list.

D.LKU(segment list): worst-case number of FIB lookups during processing of the segment list.

D.PRS assumes that parsing a second extension header is expensive on all ASICs. While it may be expensive on some ASIC’s it is extremely inexpensive on others. Retaining this metric doesn’t optimize the solution for operators. It merely creates an advantage
 for the ASIC that can’t parse additional extension headers efficiently.

D.LKU assumes that it is possible to determine how many lookups a particular compression mechanism requires. It ignores the fact that the FIB can be optimized to reduce the number of lookups. Furthermore, it fails to make a distinction between longest match
 lookups and index lookups.

Finally, this requirement should be stated from the network operators perspective, not the ASIC developer’s. The network operator doesn’t care how many headers were parsed or how many lookups were execute. It cares about:

How many packet per second the ASIC can process

How much power the ASIC consumes

How much heat the ASIC generates

How much the ASIC costs

Unless we can develop better metric for this requirement, we should drop it.

                                                                                           Ron

 

 

Juniper Business Use Only

---

From: Ron Bonica <[email-masked]>
Date: Fri, 2 Oct 2020 16:26:34 +0000

We should add this!

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, October 1, 2020 10:59 PM
To: ddukes=[email-masked]
Cc: rbonica=[email-masked]; [email-masked]
Subject: Re: [Srcomp] Comments on REQ-8-17-FWD-EFFICIENCY

Hi Darren, Ron,

Regards,

PSF

原始邮件
发件人：DarrenDukes(ddukes)
收件人：Ron Bonica;srcomp;
日 期 ：2020年09月30日 11:37
主 题 ：Re: [Srcomp] Comments on REQ-8-17-FWD-EFFICIENCY
--
Srcomp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/srcomp
Hi Ron, I don't see why you would propose the inclusion of the existing metrics be dependent on adding additional metrics...

     Count the number of read and write operations to process the header

Darren

________________________________
From: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Monday, September 28, 2020 3:03 PM
To: Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>>; srcomp <[email-masked]<mailto:[email-masked]>>
Subject: RE: Comments on REQ-8-17-FWD-EFFICIENCY

Folks,

  *   P.BSF – The number of bit shifts required
  *   P.EX0 – Number of fields in the routing header that must be examined when Segment Left is equal to 0
  *   P.EX1 – Number of fields in the routing header that must be examined when Segment Left is greater than 1

                                                                          Ron

From: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Sent: Monday, September 28, 2020 2:37 AM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; srcomp <[email-masked]<mailto:[email-masked]>>
Subject: Re: Comments on REQ-8-17-FWD-EFFICIENCY

Hi Ron, the metrics in this requirement are indeed valid, as lookups and header parsing can directly translate to impacts on pps, power, heat, cost.  These are things that operators tell me they care about and that we should analyze.

Darren

________________________________

From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Wednesday, September 23, 2020 3:06 PM
To: srcomp <[email-masked]<mailto:[email-masked]>>
Subject: [Srcomp] Comments on REQ-8-17-FWD-EFFICIENCY

Folks,

  *   D.PRS(segment list): worst-case number of headers parsed during processing of the segment list.
  *   D.LKU(segment list): worst-case number of FIB lookups during processing of the segment list.

D.PRS assumes that parsing a second extension header is expensive on all ASICs. While it may be expensive on some ASIC’s it is extremely inexpensive on others. Retaining this metric doesn’t optimize the solution for operators. It merely creates an advantage for the ASIC that can’t parse additional extension headers efficiently.

D.LKU assumes that it is possible to determine how many lookups a particular compression mechanism requires. It ignores the fact that the FIB can be optimized to reduce the number of lookups. Furthermore, it fails to make a distinction between longest match lookups and index lookups.

  *   How many packet per second the ASIC can process
  *   How much power the ASIC consumes
  *   How much heat the ASIC generates
  *   How much the ASIC costs

                                                                                           Ron