Subject: Re: [Srcomp] 4.1.5. Heterogeneous SID lists

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 30 Oct 2020 05:34:41 +0000

I would echo the same as in my previous mail. Having this as a should is ok, but requirements are requirements and we are tasked to list them. I believe this is a valid requirement in the functional category

From: Srcomp <[email-masked]> on behalf of "Darren Dukes (ddukes)" <ddukes=[email-masked]>
Date: Friday, 30 October 2020 at 04:31
To: "[email-masked]" <[email-masked]>
Subject: Re: [Srcomp] 4.1.5. Heterogeneous SID lists

Team, this is obviously a functional requirement. Without it, operators are entirely unable to build SID lists with compressed and non-compressed SRv6 SIDs.  That may be a tradeoff SPRING is willing to make but we certainly must make this a SHOULD.  Besides the obvious cases we've discussed in our meetings, just this week there is a use case discussed on the 6man alias that requires compressed and non-compressed segments in a single segment list.

I hope other team members can register their analysis on this thread.

Darren
________________________________
From: Srcomp <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: Thursday, October 29, 2020 12:40 PM
To: [email-masked] <[email-masked]>
Subject: [Srcomp] 4.1.5. Heterogeneous SID lists

Folks,

I strongly object to the inclusion of “4.1.5. Heterogeneous SID lists” in the document. It is an architectural requirement, which is beyond the scope of this document and out of charter for the design team.

                                                      Ron

Juniper Business Use Only

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 30 Oct 2020 12:47:45 +0000

Agree with Wim, I think we have discussed already in weekly meeting. Using SHOULD is fine here.

I can understand Ron’s objection if we use MUST here, but right now, I do not understand.

Respect,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Nokia - BE/Antwerp)
Sent: Friday, October 30, 2020 1:35 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]>; [email-masked]
Subject: Re: [Srcomp] 4.1.5. Heterogeneous SID lists

From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of "Darren Dukes (ddukes)" <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Date: Friday, 30 October 2020 at 04:31
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Srcomp] 4.1.5. Heterogeneous SID lists

Darren
________________________________
From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Thursday, October 29, 2020 12:40 PM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [Srcomp] 4.1.5. Heterogeneous SID lists

Folks,

                                                      Ron