Subject: [Srcomp] 4.1.2. SRv6 Functionality

From: Ron Bonica <[email-masked]>
Date: Thu, 29 Oct 2020 16:48:42 +0000

Folks,

The following changes should be made to 4.1.2. SRv6 Functionality:

Description:

OLD>
A solution to compress an SRv6 SID list MUST support the functionality of SRv6. This requirement and set of metrics, is meant to assess whether a proposal that is not fully SRv6 based, as evaluated in section 4.1.1, provides equivalent functionality to SRv6. Such a proposal may utilize different control plane and/or data planes.
<OLD

NEW>
A solution to compress an SRv6 SID list MUST support the functionality of SRv6. Such a proposal may utilize different control plane and/or data planes.
<NEW

Rationale:

OLD>
Operators require SRv6 functionality. Evaluating the extent to which a proposal supports SRv6 functionality is important for operators and implementors to understand the impact on network operations.
<OLD

NEW>
Operators require SRv6 functionality.
<NEW

Metrics:

  *   Replace F.PING with F.OAM: Support a mechanism to determine the health of a SID.
  *   Remove F.TOT

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 30 Oct 2020 03:58:41 +0000

Team, not stating that “This requirement and set of metrics, is meant to assess whether a proposal that is not fully SRv6 based...” misses the reason for this requirement.  Solutions proposing alternate CP and DP must support this functionality at least.

The removal of ping to verify a SID is also not a good idea.  This is IPv6, we should be using basic IPv6 tools to verify the implementation of segments and identify when that is not possible in proposals.

I hope others can register their thoughts on this.

Darren

________________________________
From: Srcomp <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: Thursday, October 29, 2020 12:48 PM
To: [email-masked] <[email-masked]>
Subject: [Srcomp] 4.1.2. SRv6 Functionality

Folks,

Description:

OLD>

<OLD

NEW>

<NEW

Rationale:

OLD>

<OLD

NEW>

<NEW

Metrics: