Subject: Re: [Srcomp] Review REQ-8-01-INTERWORKING-DOMAINS-00

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 12 Oct 2020 12:26:45 +0000

Here is a proposal for this combination.

  *   REQ-8-20-IPv6-to-CompSRv6-00: Migration from IPv6 or SR MPLS to the compressed solution is deployment and not a topic for this section.  It should be covered in section 4.
  *   For REQ-8-01-INTERWORKING-DOMAINS-00, REQ-8-20-SRv6-to-CompSRv6-00, and REQ-8-26-SPRING-SRV6-MIGRATION-01, these could be covered by the following single requirement...
     *   Description: The compression solution MUST support deployment in existing SRv6 networks.
     *   Rationale: SRv6 is supported by multiple products and deployed in multiple networks today.  A compression solution that interoperates well with SRv6, as deployed, will reduce the overhead and simplify operations. For Network operators who would migrate to compressed SRv6, the move is expected to gradually occur over a period time, as they upgrade networks, domains, device families and software instances.
     *   Metric: A compliant compression solution provides the following
        *   Supports simultaneous deployment at a node with current SRv6 SIDs.
        *   Supports simultaneous deployment at a node with current SRv6 control plane.
        *   Supports simultaneous operation of current SRv6 paths with compressed paths.
        *   Supports paths consisting of compressed and non-compressed segments.
        *   Supports the behaviors in draft-ietf-spring-network-programming.
        *   Does not require removal of existing IPv6 planning.

Darren
________________________________
From: Darren Dukes (ddukes) <[email-masked]>
Sent: Wednesday, September 30, 2020 1:56 AM
To: srcomp <[email-masked]>
Subject: Re: Review REQ-8-01-INTERWORKING-DOMAINS-00

I think we may need to combine the following requirements into one or more new requirements that do not overlap and describe the requirements to transition from an SRv6 solution to a compression proposal.
SRv6-to-CompSRv6
HET-SID-LIST
INTERWORKING-DOMAINS
SPRING-SRV6-MIGRATION

Anything not related to that transition can be proposed in section 4 of the document.

Let's discuss in the call.

Darren
________________________________
From: Srcomp <[email-masked]> on behalf of Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Wednesday, September 30, 2020 1:37 AM
To: srcomp <[email-masked]>
Subject: [Srcomp] Review REQ-8-01-INTERWORKING-DOMAINS-00

This requirement covers two different scenarios:
1 - transition to the compression solution from SRv6
2 - migration to the compression solution from IPv6/MPLS/anything else.

I think the transition requirement is captured in HET-SID-LIST and can be duplicated to that

The migration requirement should be split out and moved to section 4 since it is common to any SR instantiation for IPv6.

Darren

---

From: 程伟强 <[email-masked]>
Date: Mon, 12 Oct 2020 20:39:14 +0800 (CST)

Looks good!---------
Best Regards,
Weiqiang

---邮件原文---

发件人："Darren Dukes \\(ddukes\\)" <ddukes=[email-masked]>

收件人：srcomp <[email-masked]>

抄送：(无)

发送时间：2020-10-12 20:27:46

主题：Re: [Srcomp] Review REQ-8-01-INTERWORKING-DOMAINS-00

 
 REQ-8-20-IPv6-to-CompSRv6-00: Migration from IPv6 or SR MPLS to the compressed solution is deployment and not a topic for this section.  It should be covered in section 4. For REQ-8-01-INTERWORKING-DOMAINS-00, REQ-8-20-SRv6-to-CompSRv6-00, and REQ-8-26-SPRING-SRV6-MIGRATION-01, these could be covered by the following single requirement...  Description: The compression solution MUST support deployment in existing SRv6 networks. Rationale: SRv6 is supported by multiple products and deployed in multiple networks today.  A compression solution that interoperates well with SRv6, as deployed, will reduce the overhead and simplify operations. For Network operators who would migrate to compressed SRv6, the move is expected to gradually occur over a period time, as they upgrade networks, domains, device families and software instances. Metric: A compliant compression solution provides the following  Supports simultaneous deployment at a node with current SRv6 SIDs. Supports simultaneous deployment at a node with current SRv6 control plane. Supports simultaneous operation of current SRv6 paths with compressed paths. Supports paths consisting of compressed and non-compressed segments. Supports the behaviors in draft-ietf-spring-network-programming. Does not require removal of existing IPv6 planning.  
 
 Darren

--------------------------------------------------------------------------------
 
From: Darren Dukes (ddukes) <[email-masked]> Sent: Wednesday, September 30, 2020 1:56 AM To: srcomp <[email-masked]> Subject: Re: Review REQ-8-01-INTERWORKING-DOMAINS-00  

 SRv6-to-CompSRv6 
 
 HET-SID-LIST 
 
 INTERWORKING-DOMAINS 
 
 SPRING-SRV6-MIGRATION 

 

 Darren

--------------------------------------------------------------------------------
 
From: Srcomp <[email-masked]> on behalf of Darren Dukes (ddukes) <ddukes=[email-masked]> Sent: Wednesday, September 30, 2020 1:37 AM To: srcomp <[email-masked]> Subject: [Srcomp] Review REQ-8-01-INTERWORKING-DOMAINS-00  

 

 

 Darren