Subject: [Srcomp] Update for REQ-8-26-HET-SID-LIST

From: Ron Bonica <[email-masked]>
Date: Tue, 13 Oct 2020 16:21:41 +0000

Further REQ-8-26-HET-SID-LIST word-smithing happened and the result was:

Description: The compression solution MAY support a combination of compressed and non-compressed segments in a single path.

Rationale: SRv6 is deployed today.  This requirement benefits networks that have deployed SRv6 before the compression mechanism was available and offers those networks improved compression on selected paths.  It does not benefit networks that will deploy SRv6 after the compression mechanism becomes widely available.

A network that has deployed SRv6 can achieve improved compression on select paths using a compressed segment without migrating all SRv6 nodes to the compression mechanism.

Metric: A compliant compression solution:

  *   Can process classic SRv6 SIDs (128 bits representing Locator, Function and Arguments) in the IPv6 Destination Address field

NOTE: I have intentionally omitted SRH processing from the metrics. Processing Classic SIDs gets you much more function at much less cost.

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 14 Oct 2020 07:12:42 +0000

Team, while looking at the other requirements in this section I believe this is a SHOULD, not a MAY... perhaps the other requirements for compression and fwd/state efficiency are really MUST.

Below is a proposal reflecting SHOULD, and cleaning up Rationale (it was a bit repetitive) while adding the important segment list/path text to metrics.  Changes in bold for your consideration, let's see if we can close this via email.

Description: The compression solution SHOULD support a combination of compressed and non-compressed segments in a single path.

Rationale: SRv6 is deployed today, in those networks support of paths with compressed and non-compressed segments improves compression without migrating all SRv6 nodes to the compression solution.  A network deployed with only the compression solution may not realize any advantage.

  *   Can support classic 128bit SRv6 SIDs in the IPv6 Destination Address field
  *   Can support segment lists (i.e., paths) with both compressed and 128bit SRv6 SIDs.

Darren

________________________________
From: Srcomp <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: Tuesday, October 13, 2020 12:21 PM
To: [email-masked] <[email-masked]>
Subject: [Srcomp] Update for REQ-8-26-HET-SID-LIST