Subject: [Srcomp] review of 00-07

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 11 Nov 2020 06:49:27 +0000

I have a few minor issues we could address in 01 or wait until 02.

- Section title capitalization nit
First word capitalized or every word? RFC8402 capitalizes every word, we should stick with that style.

-1 Introduction nit
The latter part of the introduction no longer flows well. we could change it...
<OLD>
It is a goal of the design team to identify the solutions to SR over IPv6 SID list compression.

In each category, the requirements are described under several sub-categories including

   o  Efficiency and performance

   o  Functional requirements

   o  Operational requirements

   o  Scalability requirements

   o  Convergence requirements

   o  Security requirements

For each requirement, a description, rationale and metrics are described.

The design team will produce a separate document to analyze the proposals.
</OLD>
<NEW>
It is a goal of the design team to identify the requirements for proposals to SR over IPv6 SID list compression.

For each requirement, a description, rationale, and metrics are defined.

The design team will produce a separate document to analyze the proposals.
<NEW>

- 2.1 Requirements Language nit
Should we delete this section?  Does it belong in an informational draft?  I didn't think so but requirements drafts don't seem to be consistent.
Should we change SHOULD/MUST/MAY to should/must/may?

- 2.2 Terminology section should include a definition of Metric, some metrics are measurements, some are binary yes/no
<NEW>
Metric: measurement of aspects of a compression proposal to determine the extent to which it meets a requirement.  It may or may not provide a binary determination.
</NEW>

- 3.1.1 SRv6 Encapsulation Header
We should include this in terminology 2.2:
<NEW>
SRv6 Encapsulation Header: The IPv6 header, and any extension headers preceding a payload, used to implement a Base SRv6 or compression proposal.
</NEW>

- We use compression solution, compression method, compression mechanism, compression proposal interchangeably.
We should choose one if possible, how about compression proposal?

- 3.1.2 we don't mention where parsing starts
<OLD>
D.PRS(segment list): number of headers parsed during processing of the segment list.
</OLD>
<NEW>
D.PRS(segment list): number of headers parsed during processing of the segment list, starting from and including the IPv6 header.
</NEW>

- 3.1.3 s/statestored/state stored/

- 4.2.1 "in the same way" was not clear, perhaps "with the same path" is better.
<OLD>
A compressed solution needs to support the objectives in the same way
</OLD>
<NEW>
A compression proposal needs to support the objectives with the same path.
</NEW>

- 5.1 missing a word...
<OLD>
Does not require removal of existing IPv6 planning
</OLD>
<NEW>
Does not require removal of existing IPv6 address planning
</NEW>

- appendix s/128bit/128-bit/

Darren

---

From: Ron Bonica <[email-masked]>
Date: Wed, 11 Nov 2020 18:23:02 +0000

Darren,

These look ok. Although:

  *   I am not sure that we need to define the word "metric". Most people know what it means
  *   I am not sure that we need to worry about style issues at all. If this document ever makes it to the RFC editor, they will enforce style requirements.

                                                               Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Wednesday, November 11, 2020 1:49 AM
To: [email-masked]
Subject: [Srcomp] review of 00-07

[External Email. Be cautious of content]

-1 Introduction nit

   o  Security requirements

- 5.1 missing a word...
<OLD>

Darren

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Thu, 12 Nov 2020 18:20:37 +0800

I am Ok with those change.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Darren Dukes (ddukes)
发送时间: 2020年11月11日 14:49
收件人: [email-masked]
主题: [Srcomp] review of 00-07

First word capitalized or every word? RFC8402 capitalizes every word, we
should stick with that style.

-1 Introduction nit

The latter part of the introduction no longer flows well. we could change
it...

<OLD>

It is a goal of the design team to identify the solutions to SR over IPv6
SID list compression. 

In each category, the requirements are described under several
sub-categories including

   o  Security requirements

</OLD>

<NEW>

It is a goal of the design team to identify the requirements for proposals
to SR over IPv6 SID list compression. 

<NEW>

Should we delete this section?  Does it belong in an informational draft?  I
didn't think so but requirements drafts don't seem to be consistent.

- 2.2 Terminology section should include a definition of Metric, some
metrics are measurements, some are binary yes/no

<NEW>

Metric: measurement of aspects of a compression proposal to determine the
extent to which it meets a requirement.  It may or may not provide a binary
determination.

</NEW>

<NEW>

SRv6 Encapsulation Header: The IPv6 header, and any extension headers
preceding a payload, used to implement a Base SRv6 or compression proposal.

</NEW>

- We use compression solution, compression method, compression mechanism,
compression proposal interchangeably.  

<OLD>

D.PRS(segment list): number of headers parsed during processing of the
segment list. 

</OLD>

<NEW>

D.PRS(segment list): number of headers parsed during processing of the
segment list, starting from and including the IPv6 header.

</NEW>

- 4.2.1 "in the same way" was not clear, perhaps "with the same path" is
better.

<OLD>

</OLD>

<NEW>

</NEW>

- 5.1 missing a word...

<OLD>

</OLD>

<NEW>

</NEW>

Darren

---

From: "Xie Chongfeng" <[email-masked]>
Date: Thu, 12 Nov 2020 21:27:17 +0800

I agree with these changes .

Best regards
Chongfeng

[email-masked]
 
发件人： Weiqiang Cheng
发送时间： 2020-11-12 18:20
收件人： 'Darren Dukes \(ddukes\)'; [email-masked]
主题： [Srcomp]答复: review of 00-07
I am Ok with those change.
 
B.R.
Weiqiang Cheng

 
 
-1 Introduction nit

 

 
 
   o  Security requirements

</OLD>
<NEW>

<NEW>

 

 

- 5.1 missing a word...
<OLD>

Darren

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 12 Nov 2020 13:28:43 +0000

OK, that's 4 ack's I'll go ahead with the changes and send an updated version.

Darren
________________________________
From: Weiqiang Cheng <[email-masked]>
Sent: Thursday, November 12, 2020 5:20 AM
To: Darren Dukes (ddukes) <[email-masked]>; [email-masked] <[email-masked]>
Subject: 答复: [Srcomp] review of 00-07

B.R.

Weiqiang Cheng

-1 Introduction nit

<OLD>

   o  Security requirements

</OLD>

<NEW>

<NEW>

<NEW>

</NEW>

<NEW>

</NEW>

<OLD>

</OLD>

<NEW>

</NEW>

<OLD>

</OLD>

<NEW>

</NEW>

- 5.1 missing a word...

<OLD>

</OLD>

<NEW>

</NEW>

Darren

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 12 Nov 2020 22:16:18 +0000

Here is the latest draft with these changes integrated along with diffs.

I did not include metric in terminology re Ron's comment.  We can add that later if needed.

Darren

________________________________
From: Srcomp <[email-masked]> on behalf of Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Wednesday, November 11, 2020 1:49 AM
To: [email-masked] <[email-masked]>
Subject: [Srcomp] review of 00-07

-1 Introduction nit

   o  Security requirements

- 5.1 missing a word...
<OLD>

Darren

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Fri, 13 Nov 2020 15:51:45 +0800

Thanks a lot to Darren for preparing the draft.

I read over the draft and it is OK for me.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Darren Dukes (ddukes)
发送时间: 2020年11月13日 06:16
收件人: Darren Dukes (ddukes); [email-masked]
主题: Re: [Srcomp] review of 00-07

I did not include metric in terminology re Ron's comment.  We can add that
later if needed.

Darren

  _____  

From: Srcomp <[email-masked]> on behalf of Darren Dukes (ddukes)
<ddukes=[email-masked]>
Sent: Wednesday, November 11, 2020 1:49 AM
To: [email-masked] <[email-masked]>
Subject: [Srcomp] review of 00-07 

-1 Introduction nit

<OLD>

   o  Security requirements

</OLD>

<NEW>

<NEW>

<NEW>

</NEW>

<NEW>

</NEW>

<OLD>

</OLD>

<NEW>

</NEW>

<OLD>

</OLD>

<NEW>

</NEW>

- 5.1 missing a word...

<OLD>

</OLD>

<NEW>

</NEW>

Darren