Subject: [Srcomp] SRCOMP Status Slides proposal for IETF109

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 16 Nov 2020 11:36:19 +0800

Hi team,

I prepared some slides to report the status and plan.

Please review and comment it. 

I will prepare another slides to introduce requirement draft, and I will
send it to team soon.

B.R.

Weiqiang Cheng

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Mon, 16 Nov 2020 03:52:02 +0000

Hi Weiqiang,

It looks good to me.

One comment:

*       Meetings
*        e-meetings
*       Weekly meeting
*        F2F meetings
*       During IETF meeting

I think we have twice meetings per week. Also, F2F meeting will be impossible this time, LOL.

Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Weiqiang Cheng
Sent: Monday, November 16, 2020 11:36 AM
To: 'srcomp' <[email-masked]>
Subject: [Srcomp] SRCOMP Status Slides proposal for IETF109

Hi team,
I prepared some slides to report the status and plan.
Please review and comment it.
I will prepare another slides to introduce requirement draft, and I will send it to team soon.

B.R.
Weiqiang Cheng

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 16 Nov 2020 12:34:13 +0800

Hi team,

Requirement draft Slides proposal for IETF109 is enclosed.

B.R.

Weiqiang Cheng

---

From: 程伟强 <[email-masked]>
Date: Mon, 16 Nov 2020 12:41:10 +0800 (CST)

Hi Cheng,

Thanks for your comments.

We will go back to weekly meeting after IETF109 and we hope to have F2F meeting soon, so I would like to change it as: 

•        e-meetings 

•       Twice meeting per week /Weekly meeting 

•        F2F meetings

•       During IETF meeting

B.R.

Weiqiang Cheng

----邮件原文----发件人："Chengli (Cheng Li)" <[email-masked]>收件人：Weiqiang Cheng  <[email-masked]>,srcomp <[email-masked]>抄　送: (无)发送时间：2020-11-16 11:52:02主题：Re: [Srcomp] SRCOMP Status Slides proposal for IETF109

Hi Weiqiang,

It looks good to me.

One comment:

•       Meetings

•        e-meetings 

•       Weekly meeting

•        F2F meetings

•       During IETF meeting

 

Cheng

 

From: Srcomp [mailto:[email-masked]] On Behalf Of Weiqiang Cheng Sent: Monday, November 16, 2020 11:36 AM To: 39srcomp39 <[email-masked]> Subject: [Srcomp] SRCOMP Status Slides proposal for IETF109

Hi team,

 

B.R.

Weiqiang Cheng

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Mon, 16 Nov 2020 06:06:38 +0000

Hi Weiqiang,

Most of the content LGTM.

I added some notes in the slide, please review it. Also, I made some adjustments of the format of several slides, like font, size, please review it as well.

Manty thanks for your work.
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Weiqiang Cheng
Sent: Monday, November 16, 2020 12:34 PM
To: 'srcomp' <[email-masked]>
Subject: [Srcomp] Requirement draft Slides proposal for IETF109

Hi team,

B.R.
Weiqiang Cheng

---

From: Ron Bonica <[email-masked]>
Date: Mon, 16 Nov 2020 07:08:42 +0000

These look good

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Weiqiang Cheng
Sent: Sunday, November 15, 2020 10:36 PM
To: 'srcomp' <[email-masked]>
Subject: [Srcomp] SRCOMP Status Slides proposal for IETF109

[External Email. Be cautious of content]

Hi team,

B.R.
Weiqiang Cheng

---

From: Ron Bonica <[email-masked]>
Date: Mon, 16 Nov 2020 07:36:12 +0000

Weiqiang,

Slide 6: This slide suggest that the charter of this WG:

  *   Is to find a way to compress the SID list in the SRH
  *   Does not allow any solution that includes a routing type other than the SRH

I don't think that this was your intent. Please clarify  or remove the slide.

Slide 17: The figure is misleading. As I read this requirement, there is only one domain. Within that domain, there are two sets of routers. These are:

  *   Routers that support Classic SRv6
  *   Routers that support the compression mechanism

These sets can be:

  *   Non-overlapping
  *   Partially overlapping
  *   Completely overlapping

Regardless of overlap, Classic SRv6 should work on nodes that support Classic SRv6. The compression mechanism should work on nodes that support the compression mechanism.

                                                               Ron

Sent: Sunday, November 15, 2020 11:34 PM

Hi team,

B.R.
Weiqiang Cheng

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 16 Nov 2020 23:13:08 +0800

Hi,

According to Ron and other member’s comments, I’ve modified the slides as
enclosed file.

Let me know your comments.

If no other comments, I will send it to secretary soon.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Ron Bonica
发送时间: 2020年11月16日 15:36
收件人: Weiqiang Cheng; 'srcomp'
主题: Re: [Srcomp] Requirement draft Slides proposal for IETF109

Weiqiang,

*	Is to find a way to compress the SID list in the SRH
*	Does not allow any solution that includes a routing type other than
the SRH

I don’t think that this was your intent. Please clarify  or remove the
slide.

Slide 17: The figure is misleading. As I read this requirement, there is
only one domain. Within that domain, there are two sets of routers. These
are:

These sets can be:

*	Non-overlapping
*	Partially overlapping
*	Completely overlapping

Regardless of overlap, Classic SRv6 should work on nodes that support
Classic SRv6. The compression mechanism should work on nodes that support
the compression mechanism. 

                                                               Ron

Hi team,

B.R.

Weiqiang Cheng

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 16 Nov 2020 23:13:47 +0800

Thanks Cheng.

发件人: Srcomp [mailto:[email-masked]] 代表 Chengli (Cheng Li)
发送时间: 2020年11月16日 14:07
收件人: Weiqiang Cheng; 'srcomp'
主题: Re: [Srcomp] Requirement draft Slides proposal for IETF109

Hi Weiqiang,

I added some notes in the slide, please review it. Also, I made some
adjustments of the format of several slides, like font, size, please review
it as well.

Cheng

 

Hi team,

B.R.

Weiqiang Cheng

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 16 Nov 2020 19:26:43 +0000

I am ok with the slides

From: Srcomp <[email-masked]> on behalf of Weiqiang Cheng <[email-masked]>
Date: Monday, 16 November 2020 at 16:13
To: 'Ron Bonica' <rbonica=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Srcomp] 答复: Requirement draft Slides proposal for IETF109

Hi,
According to Ron and other member’s comments, I’ve modified the slides as enclosed file.
Let me know your comments.

B.R.
Weiqiang Cheng

Weiqiang,

I don’t think that this was your intent. Please clarify  or remove the slide.

These sets can be:

  *   Non-overlapping
  *   Partially overlapping
  *   Completely overlapping

                                                               Ron

Hi team,

B.R.
Weiqiang Cheng

---

From: Ron Bonica <[email-masked]>
Date: Mon, 16 Nov 2020 23:25:23 +0000

Weiqiang,

I have modified the diagram in Slide 15 so that it depicts SRv6 base coexistence and not heterogenous SID lists.

                                                     Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Weiqiang Cheng
Sent: Monday, November 16, 2020 10:13 AM
To: 'Ron Bonica' <rbonica=[email-masked]>; 'srcomp' <[email-masked]>
Subject: [Srcomp] 答复: Requirement draft Slides proposal for IETF109

Hi,

B.R.
Weiqiang Cheng

Weiqiang,

These sets can be:

  *   Non-overlapping
  *   Partially overlapping
  *   Completely overlapping

                                                               Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Weiqiang Cheng
Sent: Sunday, November 15, 2020 11:34 PM
To: 'srcomp' <[email-masked]<mailto:[email-masked]>>
Subject: [Srcomp] Requirement draft Slides proposal for IETF109

Hi team,

B.R.
Weiqiang Cheng

---

From: 程伟强 <[email-masked]>
Date: Tue, 17 Nov 2020 09:58:34 +0800 (CST)

Hi Ron,

Thanks a lot.

It looks much better.

B.R.

Weiqiang Cheng

----邮件原文----发件人：Ron Bonica  <[email-masked]>收件人：Weiqiang Cheng  <[email-masked]>,Ron Bonica <rbonica=[email-masked]>,srcomp <[email-masked]>抄　送: (无)发送时间：2020-11-17 07:25:23主题：RE: [Srcomp] 答复:  Requirement draft Slides proposal for IETF109

Weiqiang,

 

                                                     Ron

 

From: Srcomp <[email-masked]> On Behalf Of Weiqiang Cheng Sent: Monday, November 16, 2020 10:13 AM To: 39Ron Bonica39 <rbonica=[email-masked]> 39srcomp39 <[email-masked]> Subject: [Srcomp] 答复: Requirement draft Slides proposal for IETF109

 

Hi,

 

 

B.R.

Weiqiang Cheng

发件人: Srcomp  [mailto:[email-masked]] 代表 Ron Bonica 发送时间: 2020年11月16日 15:36 收件人: Weiqiang Cheng 39srcomp39 主题: Re: [Srcomp] Requirement draft Slides proposal for IETF109

Weiqiang,

 

Is to find a way to compress the SID list in the SRH

Does not allow any solution that includes a routing type other than the SRH

 

 

Routers that support Classic SRv6

Routers that support the compression mechanism

These sets can be:

Non-overlapping

Partially overlapping

Completely overlapping

 

                                                               Ron

 

From: Srcomp <[email-masked]> On Behalf Of Weiqiang Cheng Sent: Sunday, November 15, 2020 11:34 PM To: 39srcomp39 <[email-masked]> Subject: [Srcomp] Requirement draft Slides proposal for IETF109

 

Hi team,

 

B.R.

Weiqiang Cheng