Subject: Re: [Srcomp] REQ-11-30-Addressing-plan/ Just pick it from 4.2.1. REQ-7-28-FLEX-ADDRESS-PLANNING-00

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 2 Dec 2020 08:05:37 +0000

Hi Ron,

I think we do lose this REQ.

Also, this requirement has been discussed and get consensus long time ago. I paste the text recorded in draft-srcompdt-spring-compression-requirement-00(using within design team before posting to the IETF)

4.2.  Operational Requirements

4.2.1.  REQ-7-28-FLEX-ADDRESS-PLANNING-00

   o  Description: The compression mechanism MUST support flexible IPv6
      address planning, and MUST NOT require for specific address type
      and address value.  Also, It MUST support to be deployed by using
      GLA, ULA and other unicast address types.

   o  Rational: The address planning of the network is vary based on the
      address schema of the operator, so the solution MUST support
      flexible address planning.  Operators need to deploy the solution
      based on their own addresses planning.

   o  Metric: if the solution only works when using a specific address
      type, or some specific address value, that is not compliant.  If
      it require one or some specific prefixes, that is not compliant.

I will tend to agree with this requirement, since it is the consensus and it will save our time to review new text.

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Tuesday, December 1, 2020 1:50 AM
To: srcomp <[email-masked]>
Subject: [Srcomp] REQ-11-30-Addressing-plan

Folks,

We seem to have lost a requirement concerning addressing plans. So, I introduce the following:

Description: The compression proposal MUST reduce the size of the SRv6 encapsulation header regardless of the addressing plan that the network operators use to number SIDs.

Rationale: Network operators will deploy the compression mechanism in brownfield networks that have already adapted an addressing plan. It may be impractical for these operators to renumber SIDs in order to obtain compression.

Metrics: The metrics in Section 3.1.1 of this document should represent multiple use-cases. In some uses cases, SIDs are drawn from diverse prefixes (e.g., two different ULAs that have only the first ten bits in common).

                                                                                                                                                                         Ron

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 2 Dec 2020 12:48:46 +0000

Hi Cheng, I recall we minuted some proposed text for this item on 10-21.

Darren

________________________________
From: Srcomp <[email-masked]> on behalf of Chengli (Cheng Li) <[email-masked]>
Sent: Wednesday, December 2, 2020 3:05 AM
To: Ron Bonica <rbonica=[email-masked]>; srcomp <[email-masked]>
Subject: Re: [Srcomp] REQ-11-30-Addressing-plan/ Just pick it from 4.2.1. REQ-7-28-FLEX-ADDRESS-PLANNING-00

Hi Ron,

Thanks,

Cheng

Folks,

                                                                                                                                                                         Ron

---

From: Ron Bonica <[email-masked]>
Date: Wed, 2 Dec 2020 14:14:33 +0000

Folks,

If we have already agreed on this requirement, let's add it to the document.

However, I would like to make one change. In the metrics section. Change the word "works" to "provides adequate compression".

                                                                                               Ron

Juniper Business Use Only
From: Chengli (Cheng Li) <[email-masked]>
Sent: Wednesday, December 2, 2020 3:06 AM
To: Ron Bonica <[email-masked]>; srcomp <[email-masked]>
Subject: RE: REQ-11-30-Addressing-plan/ Just pick it from 4.2.1. REQ-7-28-FLEX-ADDRESS-PLANNING-00

[External Email. Be cautious of content]

Hi Ron,

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Tuesday, December 1, 2020 1:50 AM
To: srcomp <[email-masked]<mailto:[email-masked]>>
Subject: [Srcomp] REQ-11-30-Addressing-plan

Folks,

                                                                                                                                                                         Ron

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Thu, 3 Dec 2020 01:47:06 +0000

LGTM

Cheng

From: Ron Bonica [mailto:[email-masked]]
Sent: Wednesday, December 2, 2020 10:15 PM
To: Chengli (Cheng Li) <[email-masked]>; srcomp <[email-masked]>
Subject: RE: REQ-11-30-Addressing-plan/ Just pick it from 4.2.1. REQ-7-28-FLEX-ADDRESS-PLANNING-00

Folks,

                                                                                               Ron

Juniper Business Use Only
From: Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, December 2, 2020 3:06 AM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; srcomp <[email-masked]<mailto:[email-masked]>>
Subject: RE: REQ-11-30-Addressing-plan/ Just pick it from 4.2.1. REQ-7-28-FLEX-ADDRESS-PLANNING-00

Hi Ron,

Thanks,
Cheng

Folks,

                                                                                                                                                                         Ron