Subject: [Srcomp] Discussion on Flex address planning.

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Thu, 10 Dec 2020 07:17:10 +0000

Hi team,

As we discussed yesterday, I post the discussion of flexible address planning requirement here for further discussion.

"
Description: The compression mechanism MUST support flexible IPv6 address planning, and MUST NOT rely on specific address type and address value. Also, It MUST support deployment by using GUA from different address blocks.

Rationale: The address planning of the network may vary based on the addressing scheme of the operator, so the solution MUST support a flexible addressing scheme.  Operators need to deploy the solution based on their own address planning.

Metric: A solution requiring a specific addressing scheme may not be compliant
"

Regarding the Metric, we have two options:

A: A solution requiring a specific addressing scheme may not be compliant

B: A solution requiring a specific addressing scheme for good compression may not be compliant.

Ron, Cheng, Weiqiang think the Option B and Option A are both OK, and Ron prefers to Option B. PSF thinks Option A and Option B are the same.

Darren do not like Option B. Cause he thinks, option B may be interpreted as: A solution requiring any addressing scheme for good compression may not be compliant.

The above text is the status of the last meeting yesterday. Comments are welcome.

============================================================================

Personally, I think the Option B CAN NOT be interpreted as A solution requiring any addressing scheme for good compression may not be compliant.
Because we should face the fact that we have addressing schemes in the real networks, though they are vary, but we do require addressing scheme. So "requiring any addressing scheme" won't be satisfied.

Also, using a chaos addresses allocation is not reasonable for the real deployment. Like in SRv6, it requires an addressing scheme for basic functionality.  It requires SRv6 SIDs within the SR domain are assigned from a block of addresses (RFC8754).
I think this is a very reasonable requirement and precondition.

We may add some text in description or rationale?

Cheng

---

From: Ron Bonica <[email-masked]>
Date: Thu, 10 Dec 2020 15:00:25 +0000

Cheng Li,

Ron is not OK with option A.

The difference between Option A and Option B is:

  *   Option A allows solutions that work, but do not provide good compression, unless a specific address scheme is deployed.
  *   Option B does not allow solutions that work, but do not provide good compression, unless a specific address scheme is deployed.

So, Option A offers no benefit to operators that don't used the specific addressing scheme.

                                                                        Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Chengli (Cheng Li)
Sent: Thursday, December 10, 2020 2:17 AM
To: [email-masked]
Subject: [Srcomp] Discussion on Flex address planning.

[External Email. Be cautious of content]

Hi team,

"

Cheng