Subject: [Srcomp] Draft Minutes Jan 20 2021

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 21 Jan 2021 02:05:48 +0000

Attendees: Weiqiang, PSF, Cheng Li, Wim, Darren, Ron, Chongfeng

Minutes

  *   Add members to requirements author list in the order they appear in contributor list.
     *   Analysis doc will be same
  *   Added Compression Levels text to next revision (Add “able to support” to text)
  *   Security requirement
     *   Delete “Security Requirements” from Backlog they are already handled in the draft.
  *   Operational requirements
     *   Not discussed, need closure
  *   Resurrecting BCP or PS statement (previously posted) with this proposed text:
     *   Description: The compression mechanism SHOULD not violate any proposed standard or BCP. If it does violate any PS or BCP it MUST update the related document.
     *   Rationale: Violation of existing standards makes the internet more fragile.
     *   Metric: A solution that does not violate PS or BCP, or updates PS or BCP satisfies this requirement.
     *   ACTION: Finalize text on the mailing list and conclude next week.
  *   Candidate proposals
     *   ACTION: Team to send proposals to srcomp – include the drafts or RFCs for analysis.
     *

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 21 Jan 2021 20:59:50 +0800

I diagree that the author list of analysis doc will be the same with the requirement doc.

Chongfeng 

[email-masked]
 
From: Darren Dukes \(ddukes\)
Date: 2021-01-21 10:05
To: [email-masked]
Subject: [Srcomp] Draft Minutes Jan 20 2021
Attendees: Weiqiang, PSF, Cheng Li, Wim, Darren, Ron, Chongfeng
 
Minutes
Add members to requirements author list in the order they appear in contributor list.
Analysis doc will be same
Added Compression Levels text to next revision (Add “able to support” to text)
Security requirement
Delete “Security Requirements” from Backlog they are already handled in the draft.
Operational requirements
Not discussed, need closure
Resurrecting BCP or PS statement (previously posted) with this proposed text:
Description: The compression mechanism SHOULD not violate any proposed standard or BCP. If it does violate any PS or BCP it MUST update the related document.
Rationale: Violation of existing standards makes the internet more fragile.
Metric: A solution that does not violate PS or BCP, or updates PS or BCP satisfies this requirement.
ACTION: Finalize text on the mailing list and conclude next week.
Candidate proposals
ACTION: Team to send proposals to srcomp – include the drafts or RFCs for analysis.

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 22 Jan 2021 03:21:04 +0000

Oh I just noticed the minutes.

As we discussed, it may be better to finish the requirement document before getting started to analysis document, I think it is the same to the authorships.
It may be inappropriate to assign the authors before writing a draft.

Regarding the requirements drafts, I agree with the existing order. Regarding the analysis document, it may be good to list the order based on their contributions.

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, January 21, 2021 9:00 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]>; srcomp <[email-masked]>
Subject: Re: [Srcomp] Draft Minutes Jan 20 2021

Chongfeng
________________________________
[email-masked]<mailto:[email-masked]>

From: Darren Dukes \(ddukes\)<mailto:ddukes=[email-masked]>
Date: 2021-01-21 10:05
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] Draft Minutes Jan 20 2021
Attendees: Weiqiang, PSF, Cheng Li, Wim, Darren, Ron, Chongfeng

Minutes

  *   Candidate proposals

---

From: Ron Bonica <[email-masked]>
Date: Fri, 22 Jan 2021 15:55:54 +0000

Folks,

It is essential that we adopt a requirement stating that the compression mechanism does not violate any existing PS or BCP document. Otherwise, there will be no consideration of PS/BCP compliance in the analysis document.

Please keep in mind that this requirement applies equally to all proposals.

                                                                                   Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Wednesday, January 20, 2021 9:06 PM
To: [email-masked]
Subject: [Srcomp] Draft Minutes Jan 20 2021

[External Email. Be cautious of content]

Minutes

  *   Added Compression Levels text to next revision (Add "able to support" to text)
  *   Security requirement

     *   Delete "Security Requirements" from Backlog they are already handled in the draft.

  *   Candidate proposals

     *   ACTION: Team to send proposals to srcomp - include the drafts or RFCs for analysis.
     *

---

From: Ron Bonica <[email-masked]>
Date: Fri, 22 Jan 2021 16:11:32 +0000

Folks,

I think that we agreed that our calls would be dedicated (100%) to the requirements document until it is done. However, we may exchange emails regarding the analysis document before the requirements document is complete.

Does this work for everyone?

Personally, I will take some time for a close reading of the seven solution documents. Since many of us are co-authors of those drafts, I expect to see some clarifying questions on those drafts.

                                                                       Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Chengli (Cheng Li)
Sent: Thursday, January 21, 2021 10:21 PM
To: [email-masked]; Darren Dukes (ddukes) <ddukes=[email-masked]>; srcomp <[email-masked]>
Subject: Re: [Srcomp] Draft Minutes Jan 20 2021

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, January 21, 2021 9:00 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>; srcomp <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Srcomp] Draft Minutes Jan 20 2021

Chongfeng

Minutes

  *   Candidate proposals

---

From: 程伟强 <[email-masked]>
Date: Sun, 24 Jan 2021 22:54:39 +0800 (CST)

Hi Ron,

I think we39ve started the discussion regarding the analysis document through emails. Let39s go on.

The inputs from you, Jim and Cheng Li are very useful.

First step, let39s generate a list of candidate proposals within the design team.

Then, we can read over those proposals and have more discussions.

Cheng Li gave a summary of the list. What is your comments?

B.R.
Weiqiang Cheng

----邮件原文----发件人：Ron Bonica  <rbonica=[email-masked]>收件人："Chengli (Cheng Li)" <[email-masked]>,"[email-masked]" <[email-masked]>,"Darren Dukes (ddukes)" <ddukes=[email-masked]>,srcomp  <[email-masked]>抄　送: (无)发送时间：2021-01-23 00:11:32主题：Re: [Srcomp] Draft Minutes Jan 20 2021

Folks,

 

 

 

                                                                       Ron

 

From: Srcomp <[email-masked]> On Behalf Of Chengli (Cheng Li) Sent: Thursday, January 21, 2021 10:21 PM To: [email-masked] Darren Dukes (ddukes) <ddukes=[email-masked]> srcomp <[email-masked]> Subject: Re: [Srcomp] Draft Minutes Jan 20 2021

 

 

 

 

Thanks,

Cheng

 

From: Srcomp [mailto:[email-masked]] On Behalf Of [email-masked] Sent: Thursday, January 21, 2021 9:00 PM To: Darren Dukes (ddukes) <ddukes=[email-masked]> srcomp <[email-masked]> Subject: Re: [Srcomp] Draft Minutes Jan 20 2021

 

 

Chongfeng 

--------------------------------------------------------------------------------

[email-masked]

Date: 2021-01-21 10:05

To: [email-masked]

 

Minutes

Security requirement

Operational requirements

Candidate proposals

---

From: Ron Bonica <[email-masked]>
Date: Mon, 25 Jan 2021 15:03:36 +0000

Folks,

Let’s spend the next two weeks as follows:

  *   Calls are 100% dedicated to the requirements document
  *   Each of us performs a detailed reading of all 7 documents and discuss them on the SRCOMP mailing list
  *   Weiqiang sends mail to the SPRING mailing list asking if there are any proposals other than the ones that we know about.

                                                         Ron

Juniper Business Use Only
From: 程伟强 <[email-masked]>
Sent: Sunday, January 24, 2021 9:55 AM
To: srcomp <[email-masked]>; Ron Bonica <[email-masked]>
Subject: Re:Re: [Srcomp] Draft Minutes Jan 20 2021

Hi Ron,

I think we've started the discussion regarding the analysis document through emails. Let's go on.

First step, let's generate a list of candidate proposals within the design team.
Then, we can read over those proposals and have more discussions.

B.R.
Weiqiang Cheng

----邮件原文----
发件人：Ron Bonica  <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
收件人："Chengli (Cheng Li)" <[email-masked]<mailto:[email-masked]>>,"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,"Darren Dukes (ddukes)" <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>,srcomp  <[email-masked]<mailto:[email-masked]>>
抄　送: (无)
发送时间：2021-01-23 00:11:32
主题：Re: [Srcomp] Draft Minutes Jan 20 2021

Folks,

                                                                       Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Chengli (Cheng Li)
Sent: Thursday, January 21, 2021 10:21 PM
To: [email-masked]<mailto:[email-masked]>; Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>; srcomp <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Srcomp] Draft Minutes Jan 20 2021

Thanks,
Cheng

Chongfeng

Minutes

  *   Candidate proposals

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Tue, 26 Jan 2021 14:40:04 +0800

Yes, Let’s go forward.

发件人: Srcomp [mailto:[email-masked]] 代表 Ron Bonica
发送时间: 2021年1月25日 23:04
收件人: 程伟强; srcomp
主题: Re: [Srcomp] Draft Minutes Jan 20 2021

Folks,

                                                         Ron

Hi Ron,

B.R.

Weiqiang Cheng

----邮件原文----
发件人：Ron Bonica  <rbonica=[email-masked]>
收件人："Chengli (Cheng Li)" <[email-masked]>,"[email-masked]" <[email-masked]>,"Darren Dukes (ddukes)" <ddukes=[email-masked]>,srcomp  <[email-masked]>
抄　送: (无)
发送时间：2021-01-23 00:11:32
主题：Re: [Srcomp] Draft Minutes Jan 20 2021

Folks,

                                                                       Ron

Thanks,

Cheng

 

Chongfeng 

  _____  

[email-masked]

From: Darren  <mailto:ddukes=[email-masked]>  Dukes \(ddukes\)

Date: 2021-01-21 10:05

To: [email-masked]

Minutes

*	Candidate proposals

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Tue, 26 Jan 2021 21:41:08 +0000

Hi Chongfeng, I think we may have discussed listing analysis draft authors alphabetically in the last call.  If that’s preferable, lets raise and close it in the next one.

On 2021-01-21, 8:00 AM, "Srcomp" <[email-masked]> wrote:

Chongfeng

Minutes
·     Add members to requirements author list in the order they appear in contributor list.
o  Analysis doc will be same
·     Added Compression Levels text to next revision (Add “able to support” to text)
·     Security requirement
o  Delete “Security Requirements” from Backlog they are already handled in the draft.
·     Operational requirements
o  Not discussed, need closure
·     Resurrecting BCP or PS statement (previously posted) with this proposed text:
o  Description: The compression mechanism SHOULD not violate any proposed standard or BCP. If it does violate any PS or BCP it MUST update the related document.
o  Rationale: Violation of existing standards makes the internet more fragile.
o  Metric: A solution that does not violate PS or BCP, or updates PS or BCP satisfies this requirement.
o  ACTION: Finalize text on the mailing list and conclude next week.
·     Candidate proposals
o  ACTION: Team to send proposals to srcomp – include the drafts or RFCs for analysis.
o

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 27 Jan 2021 10:29:45 +0800

Hi, Darren,

Yes， I agree that author list in the analysis draft takes the alphabetical order,  in addtion, it is better to mention this in the text of the draft.

Thank you 

Chongfeng

[email-masked]
 
From: Darren Dukes (ddukes)
Date: 2021-01-27 05:41
To: [email-masked]; Darren Dukes (ddukes); srcomp
Subject: Re: [Srcomp] Draft Minutes Jan 20 2021
Hi Chongfeng, I think we may have discussed listing analysis draft authors alphabetically in the last call.  If that’s preferable, lets raise and close it in the next one. 

 
Chongfeng 

[email-masked]

Minutes

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Wed, 27 Jan 2021 11:03:16 +0800

Good Idea, Let's follow the good practice of IETF and use the first alphabetical order of Surname. 

The order will be:

Ron Bonica

Weiqiang Cheng 

Darren Dukes

Wim Henderickx

Cheng Li

Peng Shaofu 

Chongfeng Xie

We've wasted some time on this and it's had some impact on team spirit.

I would like to close the topic and let’s focus on the discussion.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年1月27日 10:30
收件人: Darren Dukes (ddukes); Darren Dukes (ddukes); srcomp
主题: Re: [Srcomp] Draft Minutes Jan 20 2021

Hi, Darren,

Thank you 

Chongfeng

  _____  

[email-masked]

From: Darren Dukes (ddukes) <mailto:[email-masked]> 

Date: 2021-01-27 05:41

To: [email-masked]; Darren Dukes (ddukes) <mailto:ddukes=[email-masked]> ; srcomp <mailto:[email-masked]> 

 

Chongfeng 

  _____  

[email-masked]

From:  <mailto:ddukes=[email-masked]> Darren Dukes \(ddukes\)

Date: 2021-01-21 10:05

To:  <mailto:[email-masked]> [email-masked]

Minutes

·     Security requirement

·     Candidate proposals

o

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 27 Jan 2021 03:16:17 +0000

It looks good to me, let’s nail it down in tonight’ meeting.

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Weiqiang Cheng
Sent: Wednesday, January 27, 2021 11:03 AM
To: [email-masked]; 'Darren Dukes (ddukes)' <[email-masked]>; 'Darren Dukes (ddukes)' <ddukes=[email-masked]>; 'srcomp' <[email-masked]>
Subject: Re: [Srcomp] Draft Minutes Jan 20 2021

The order will be:

Ron Bonica
Weiqiang Cheng
Darren Dukes
Wim Henderickx
Cheng Li
Peng Shaofu
Chongfeng Xie

B.R.
Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2021年1月27日 10:30
收件人: Darren Dukes (ddukes); Darren Dukes (ddukes); srcomp
主题: Re: [Srcomp] Draft Minutes Jan 20 2021

Hi, Darren,

Thank you

Chongfeng

From: Darren Dukes (ddukes)<mailto:[email-masked]>
Date: 2021-01-27 05:41
To: [email-masked]<mailto:[email-masked]>; Darren Dukes (ddukes)<mailto:ddukes=[email-masked]>; srcomp<mailto:[email-masked]>
Subject: Re: [Srcomp] Draft Minutes Jan 20 2021
Hi Chongfeng, I think we may have discussed listing analysis draft authors alphabetically in the last call.  If that’s preferable, lets raise and close it in the next one.

On 2021-01-21, 8:00 AM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Chongfeng

Minutes
•     Add members to requirements author list in the order they appear in contributor list.
o  Analysis doc will be same
•     Added Compression Levels text to next revision (Add “able to support” to text)
•     Security requirement
o  Delete “Security Requirements” from Backlog they are already handled in the draft.
•     Operational requirements
o  Not discussed, need closure
•     Resurrecting BCP or PS statement (previously posted) with this proposed text:
o  Description: The compression mechanism SHOULD not violate any proposed standard or BCP. If it does violate any PS or BCP it MUST update the related document.
o  Rationale: Violation of existing standards makes the internet more fragile.
o  Metric: A solution that does not violate PS or BCP, or updates PS or BCP satisfies this requirement.
o  ACTION: Finalize text on the mailing list and conclude next week.
•     Candidate proposals
o  ACTION: Team to send proposals to srcomp – include the drafts or RFCs for analysis.
o