Subject: [Srcomp] Compression proposals

From: Ron Bonica <[email-masked]>
Date: Wed, 20 Jan 2021 16:03:15 +0000

Folks,

The following are a few compression proposals:

  *   draft-decraene-spring-srv6-vlsid
  *   draft-bonica-6man-comp-rtg-hdr
  *   draft-mirsky-6man-unified-id-sr

-          draft-filsfils-spring-net-pgm-extension-srv6-usid

Can anybody think of any others.

                                              Ron

Juniper Business Use Only

---

From: James Guichard <[email-masked]>
Date: Wed, 20 Jan 2021 18:24:56 +0000

Hi Ron,

There are several.

https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-for-cmpr-02.txt
https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-np-02.txt
https://www.ietf.org/archive/id/draft-filsfilscheng-spring-srv6-srh-comp-sl-enc-02.txt

Jim
From: Srcomp <[email-masked]> On Behalf Of Ron Bonica
Sent: Wednesday, January 20, 2021 10:03 AM
To: [email-masked]
Subject: [Srcomp] Compression proposals

Folks,

  *   draft-decraene-spring-srv6-vlsid
  *   draft-bonica-6man-comp-rtg-hdr
  *   draft-mirsky-6man-unified-id-sr
  *   draft-filsfils-spring-net-pgm-extension-srv6-usid

                                              Ron

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 22 Jan 2021 03:33:18 +0000

Hi Jim,

Many thanks for your information! However, the second draft defines the architecture of G-SRv6, while the first draft defines the G-SRv6 for compression as we can see it from the name of the drafts. Therefore, they are a single solution.

Also, the third draft describes three types of solutions including G-SRv6, Micro SID and combination. Therefore, they are mainly two proposals in the links you proposed: G-SRv6 and Micro Segment.

In summary, we already have multiple proposals as listed below:

*         G-SRv6 (One option in native SRv6 compression)

*         Micro SID(One option in native SRv6 compression)

  *   V-SID(draft-decraene-spring-srv6-vlsid)

*         CRH(draft-bonica-6man-comp-rtg-hdr)

  *   U-SID (draft-mirsky-6man-unified-id-sr)

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of James Guichard
Sent: Thursday, January 21, 2021 2:25 AM
To: Ron Bonica <rbonica=[email-masked]>; [email-masked]
Subject: Re: [Srcomp] Compression proposals

Hi Ron,

There are several.

Jim
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Ron Bonica
Sent: Wednesday, January 20, 2021 10:03 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] Compression proposals

Folks,

-          draft-decraene-spring-srv6-vlsid
-          draft-bonica-6man-comp-rtg-hdr
-          draft-mirsky-6man-unified-id-sr
-          draft-filsfils-spring-net-pgm-extension-srv6-usid

                                              Ron

---

From: Ron Bonica <[email-masked]>
Date: Fri, 22 Jan 2021 16:18:00 +0000

Folks,

We need to establish a list of Internet Drafts that must:

  *   Be studied by each of us before the analysis phase begins
  *   Appear in the normative references section of the analysis document

Do we think that all seven of the drafts mentioned in this thread belong to that list? Are there others?

                                                                             Ron

Juniper Business Use Only
From: Chengli (Cheng Li) <[email-masked]>
Sent: Thursday, January 21, 2021 10:33 PM
To: James Guichard <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: RE: Compression proposals

[External Email. Be cautious of content]

Hi Jim,

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of James Guichard
Sent: Thursday, January 21, 2021 2:25 AM
To: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Srcomp] Compression proposals

Hi Ron,

There are several.

https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-for-cmpr-02.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-for-cmpr-02.txt__;!!NEt6yMaO-gk!WWyQHxRvcuxNBlb5sZkNLLJJbE5QsZlWKSe9WxwTrUXSFy9yLDstcIcq5prEWyE6$>
https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-np-02.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-np-02.txt__;!!NEt6yMaO-gk!WWyQHxRvcuxNBlb5sZkNLLJJbE5QsZlWKSe9WxwTrUXSFy9yLDstcIcq5iA_OIGu$>
https://www.ietf.org/archive/id/draft-filsfilscheng-spring-srv6-srh-comp-sl-enc-02.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-filsfilscheng-spring-srv6-srh-comp-sl-enc-02.txt__;!!NEt6yMaO-gk!WWyQHxRvcuxNBlb5sZkNLLJJbE5QsZlWKSe9WxwTrUXSFy9yLDstcIcq5gN-qLBf$>

Jim

Folks,

                                              Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 25 Jan 2021 18:03:59 +0000

Here is my summary of drafts for reading and analysis:

draft-filsfilscheng-spring-srv6-srh-comp-sl-enc

  *   Documents SRv6 SID behaviors to support  compression, combining SIDs from:
     *   draft-filsfils-spring-net-pgm-extension-srv6-usid (SRv6 uSID)
     *   draft-cl-spring-generalized-srv6-np (SRv6 GSID)

draft-decraene-spring-srv6-vlsid

  *   Documents a new or modified routing header for compression and how to build SRv6 SIDs

draft-bonica-6man-comp-rtg-hdr

  *   Documents new routing headers and a label map to IPv6 address and behavior

draft-mirsky-6man-unified-id-sr

  *   Documents a new or modified routing header with variable length segments and a label map to IPv6 address and behavior

RFC8663

  *   Documents SR MPLS over IP(v6), a label mapped to IPv6 address and behavior.

Darren

On 2021-01-21, 10:33 PM, "Srcomp" <[email-masked]> wrote:

Hi Jim,

·         G-SRv6 (One option in native SRv6 compression)

·         Micro SID(One option in native SRv6 compression)
·         V-SID(draft-decraene-spring-srv6-vlsid)

·         CRH(draft-bonica-6man-comp-rtg-hdr)
·         U-SID (draft-mirsky-6man-unified-id-sr)

Thanks,
Cheng

Hi Ron,

There are several.

Jim

Folks,

                                              Ron

---

From: Ron Bonica <[email-masked]>
Date: Mon, 25 Jan 2021 19:11:13 +0000

Folks,

Is RFC 8663 really a compression proposal? It requires all of the segment endpoints to be MPLS aware?

                                                                                      Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Monday, January 25, 2021 1:04 PM
To: Chengli (Cheng Li) <[email-masked]>; James Guichard <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: Compression proposals

RFC8663

Darren

On 2021-01-21, 10:33 PM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jim,

Thanks,
Cheng

Hi Ron,

There are several.

https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-for-cmpr-02.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-for-cmpr-02.txt__;!!NEt6yMaO-gk!XQz6gvaf5fLsl1-HAyZF3mOPOTl2UN_a4ydV2oh6O6xNGbyyMoRZd0ULCD4E2xnW$>
https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-np-02.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-np-02.txt__;!!NEt6yMaO-gk!XQz6gvaf5fLsl1-HAyZF3mOPOTl2UN_a4ydV2oh6O6xNGbyyMoRZd0ULCEP-jEq5$>
https://www.ietf.org/archive/id/draft-filsfilscheng-spring-srv6-srh-comp-sl-enc-02.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-filsfilscheng-spring-srv6-srh-comp-sl-enc-02.txt__;!!NEt6yMaO-gk!XQz6gvaf5fLsl1-HAyZF3mOPOTl2UN_a4ydV2oh6O6xNGbyyMoRZd0ULCEVZ0xVo$>

Jim

Folks,

                                              Ron

---

From: Ron Bonica <[email-masked]>
Date: Mon, 25 Jan 2021 19:15:15 +0000

Folks,

This reminds me. What happened to REQ-7-24-ipv6-based? Was that dropped unintentionally?

                                                             Ron

Juniper Business Use Only
From: Ron Bonica
Sent: Monday, January 25, 2021 2:11 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]>; Chengli (Cheng Li) <[email-masked]>; James Guichard <[email-masked]>; [email-masked]
Subject: RE: Compression proposals

Folks,

                                                                                      Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Sent: Monday, January 25, 2021 1:04 PM
To: Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>; James Guichard <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: Compression proposals

RFC8663

Darren

Hi Jim,

Thanks,
Cheng

Hi Ron,

There are several.

Jim

Folks,

                                              Ron

---

From: Ron Bonica <[email-masked]>
Date: Mon, 25 Jan 2021 19:19:26 +0000

Folks,

The last mention of it is in an excel spread sheet attached to the 8-19 minutes. We appear to have approved it.

                                                   Ron

Sent: Monday, January 25, 2021 2:15 PM

Folks,

                                                             Ron

Juniper Business Use Only
From: Ron Bonica
Sent: Monday, January 25, 2021 2:11 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>; Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>; James Guichard <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Compression proposals

Folks,

                                                                                      Ron

RFC8663

Darren

Hi Jim,

Thanks,
Cheng

Hi Ron,

There are several.

Jim

Folks,

                                              Ron

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Tue, 26 Jan 2021 14:44:55 +0800

Good summary.

I also have concerns on RFC8663.  It was not designed for compression.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Darren Dukes (ddukes)
发送时间: 2021年1月26日 02:04
收件人: Chengli (Cheng Li); James Guichard; Ron Bonica; [email-masked]
主题: Re: [Srcomp] Compression proposals

・         Documents SRv6 SID behaviors to support  compression, combining
SIDs from:

o    draft-filsfils-spring-net-pgm-extension-srv6-usid (SRv6 uSID)

o    draft-cl-spring-generalized-srv6-np (SRv6 GSID)

・         Documents a new or modified routing header for compression and
how to build SRv6 SIDs

・         Documents new routing headers and a label map to IPv6 address and
behavior 

・         Documents a new or modified routing header with variable length
segments and a label map to IPv6 address and behavior

RFC8663

・         Documents SR MPLS over IP(v6), a label mapped to IPv6 address and
behavior.

Darren

Hi Jim,

Many thanks for your information! However, the second draft defines the
architecture of G-SRv6, while the first draft defines the G-SRv6 for
compression as we can see it from the name of the drafts. Therefore, they
are a single solution.

Also, the third draft describes three types of solutions including G-SRv6,
Micro SID and combination. Therefore, they are mainly two proposals in the
links you proposed: G-SRv6 and Micro Segment.

・         G-SRv6 (One option in native SRv6 compression)

・         Micro SID(One option in native SRv6 compression)

・         V-SID(draft-decraene-spring-srv6-vlsid)

・         CRH(draft-bonica-6man-comp-rtg-hdr)

・         U-SID (draft-mirsky-6man-unified-id-sr)

Thanks,

Cheng

Hi Ron,

There are several.

https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-for-cmpr-02
.txt

https://www.ietf.org/archive/id/draft-filsfilscheng-spring-srv6-srh-comp-sl-
enc-02.txt

Jim

Folks,

                                              Ron

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Tue, 26 Jan 2021 16:47:19 +0800

Hi Ron,

When we discuss the priority of the items at early of last September, we set
the item and some other security items as lower priority. 

I think we can go through it in our meetings.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Ron Bonica
发送时间: 2021年1月26日 03:19
收件人: Ron Bonica; Darren Dukes (ddukes); Chengli (Cheng Li); James
Guichard; [email-masked]
主题: Re: [Srcomp] Compression proposals

Folks,

The last mention of it is in an excel spread sheet attached to the 8-19
minutes. We appear to have approved it.

                                                   Ron

From: Srcomp <[email-masked]> On Behalf Of Ron Bonica
Sent: Monday, January 25, 2021 2:15 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]>; Chengli
(Cheng Li) <[email-masked]>; James Guichard
<[email-masked]>; [email-masked]
Subject: Re: [Srcomp] Compression proposals

Folks,

This reminds me. What happened to REQ-7-24-ipv6-based? Was that dropped
unintentionally?

                                                             Ron

From: Ron Bonica 
Sent: Monday, January 25, 2021 2:11 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]>; Chengli
(Cheng Li) <[email-masked]>; James Guichard
<[email-masked]>; [email-masked]
Subject: RE: Compression proposals

Folks,

Is RFC 8663 really a compression proposal? It requires all of the segment
endpoints to be MPLS aware?

Ron

From: Darren Dukes (ddukes) <ddukes=[email-masked]> 
Sent: Monday, January 25, 2021 1:04 PM
To: Chengli (Cheng Li) <[email-masked]>; James Guichard
<[email-masked]>; Ron Bonica <[email-masked]>;
[email-masked]
Subject: Re: Compression proposals

RFC8663

Darren

Hi Jim,

Thanks,

Cheng

Hi Ron,

There are several.

https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-for-cmpr-02
.txt
<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-cl-spring-
generalized-srv6-for-cmpr-02.txt__;!!NEt6yMaO-gk!XQz6gvaf5fLsl1-HAyZF3mOPOTl
2UN_a4ydV2oh6O6xNGbyyMoRZd0ULCD4E2xnW$> 

https://www.ietf.org/archive/id/draft-cl-spring-generalized-srv6-np-02.txt
<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-cl-spring-
generalized-srv6-np-02.txt__;!!NEt6yMaO-gk!XQz6gvaf5fLsl1-HAyZF3mOPOTl2UN_a4
ydV2oh6O6xNGbyyMoRZd0ULCEP-jEq5$> 

https://www.ietf.org/archive/id/draft-filsfilscheng-spring-srv6-srh-comp-sl-
enc-02.txt
<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-filsfilsch
eng-spring-srv6-srh-comp-sl-enc-02.txt__;!!NEt6yMaO-gk!XQz6gvaf5fLsl1-HAyZF3
mOPOTl2UN_a4ydV2oh6O6xNGbyyMoRZd0ULCEVZ0xVo$> 

Jim

Folks,

                                              Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Tue, 26 Jan 2021 12:19:40 +0000

Hi Ron, we could ask that question of any mapping based proposal. Is it really a compression proposal?
It requires all of the segment endpoints to be “some label-lookup technology” aware.

 rfc8663 has its limitations, but it could be analyzed for completeness, given its already an rfc.

Darren.

On 2021-01-25, 2:11 PM, "Ron Bonica" <rbonica=[email-masked]> wrote:

Folks,

                                                                                      Ron

draft-filsfilscheng-spring-srv6-srh-comp-sl-enc
-          Documents SRv6 SID behaviors to support  compression, combining SIDs from:
o   draft-filsfils-spring-net-pgm-extension-srv6-usid (SRv6 uSID)
o   draft-cl-spring-generalized-srv6-np (SRv6 GSID)

draft-decraene-spring-srv6-vlsid
-          Documents a new or modified routing header for compression and how to build SRv6 SIDs

draft-bonica-6man-comp-rtg-hdr
-          Documents new routing headers and a label map to IPv6 address and behavior

draft-mirsky-6man-unified-id-sr
-          Documents a new or modified routing header with variable length segments and a label map to IPv6 address and behavior

RFC8663
-          Documents SR MPLS over IP(v6), a label mapped to IPv6 address and behavior.

Darren

Hi Jim,

Thanks,
Cheng

Hi Ron,

There are several.

Jim

Folks,

                                              Ron

---

From: Ron Bonica <[email-masked]>
Date: Tue, 26 Jan 2021 15:29:33 +0000

Darren,

RFC 8663 is the only proposal that requires all segment endpoints to be SR-MPLS aware. It isn't an SRv6 compression proposal. It is SR-MPLS tunneled over IPv6.

                                                                                                           Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Tuesday, January 26, 2021 7:20 AM
To: Ron Bonica <rbonica=[email-masked]>; Chengli (Cheng Li) <[email-masked]>; James Guichard <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] Compression proposals

Hi Ron, we could ask that question of any mapping based proposal. Is it really a compression proposal?
It requires all of the segment endpoints to be "some label-lookup technology" aware.

Darren.

On 2021-01-25, 2:11 PM, "Ron Bonica" <rbonica=[email-masked]<mailto:rbonica=[email-masked]>> wrote:

Folks,

                                                                                      Ron

draft-filsfilscheng-spring-srv6-srh-comp-sl-enc
1.       Documents SRv6 SID behaviors to support  compression, combining SIDs from:
1.       draft-filsfils-spring-net-pgm-extension-srv6-usid (SRv6 uSID)
2.       draft-cl-spring-generalized-srv6-np (SRv6 GSID)

draft-decraene-spring-srv6-vlsid
2.       Documents a new or modified routing header for compression and how to build SRv6 SIDs

draft-bonica-6man-comp-rtg-hdr
3.       Documents new routing headers and a label map to IPv6 address and behavior

draft-mirsky-6man-unified-id-sr
4.       Documents a new or modified routing header with variable length segments and a label map to IPv6 address and behavior

RFC8663
5.       Documents SR MPLS over IP(v6), a label mapped to IPv6 address and behavior.

Darren

Hi Jim,

1.       G-SRv6 (One option in native SRv6 compression)

2.       Micro SID(One option in native SRv6 compression)
3.       V-SID(draft-decraene-spring-srv6-vlsid)

4.       CRH(draft-bonica-6man-comp-rtg-hdr)
5.       U-SID (draft-mirsky-6man-unified-id-sr)

Thanks,
Cheng

Hi Ron,

There are several.

Jim

Folks,

6.       draft-decraene-spring-srv6-vlsid
7.       draft-bonica-6man-comp-rtg-hdr
8.       draft-mirsky-6man-unified-id-sr
9.       draft-filsfils-spring-net-pgm-extension-srv6-usid

                                              Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Tue, 26 Jan 2021 18:13:28 +0000

What’s the difference between looking up an MPLS label in a UDP header vs looking up “New Label Type” in a routing header?  They both result in a behavior and IP address, they both require each segment endpoint to implement the label lookup.

I’m asking, because from a data plane point of view I can’t point to a significant difference.  Perhaps you can?

Thanks!
  Darren

On 2021-01-26, 10:29 AM, "Ron Bonica" <rbonica=[email-masked]> wrote:

Darren,

RFC 8663 is the only proposal that requires all segment endpoints to be SR-MPLS aware. It isn’t an SRv6 compression proposal. It is SR-MPLS tunneled over IPv6.

                                                                                                           Ron

Darren.

Folks,

                                                                                      Ron

RFC8663

Darren

Hi Jim,

Thanks,
Cheng

Hi Ron,

There are several.

Jim

Folks,

                                              Ron

---

From: Ron Bonica <[email-masked]>
Date: Tue, 26 Jan 2021 19:29:49 +0000

One is SR-MPLS. The other isn't.

                                   Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <[email-masked]>
Sent: Tuesday, January 26, 2021 1:13 PM
To: Ron Bonica <rbonica=[email-masked]>; Ron Bonica <[email-masked]>; Chengli (Cheng Li) <[email-masked]>; James Guichard <[email-masked]>; [email-masked]
Subject: Re: Compression proposals

What's the difference between looking up an MPLS label in a UDP header vs looking up "New Label Type" in a routing header?  They both result in a behavior and IP address, they both require each segment endpoint to implement the label lookup.

I'm asking, because from a data plane point of view I can't point to a significant difference.  Perhaps you can?

Thanks!
  Darren

On 2021-01-26, 10:29 AM, "Ron Bonica" <rbonica=[email-masked]<mailto:rbonica=[email-masked]>> wrote:

Darren,

                                                                                                           Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Darren Dukes (ddukes)
Sent: Tuesday, January 26, 2021 7:20 AM
To: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>; Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>; James Guichard <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Srcomp] Compression proposals

Darren.

Folks,

                                                                                      Ron

RFC8663

Darren

Hi Jim,

Thanks,
Cheng

Hi Ron,

There are several.

Jim

Folks,

                                              Ron