Subject: Re: [Srcomp] revision 03 candidate 01

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Sun, 3 Jan 2021 20:21:41 +0000

Hi Ron and team, the clarifying text for 4.2.1 is below:

Description: A solution to compress an SRv6 SID list MUST support the functionality of SRv6.
<OLD>This requirement and set of metrics is meant</OLD>
<NEW>While this requirement and set of metrics are applicable to all proposals, it is important</NEW>
to assess whether a proposal that is not fully SRv6 based, as evaluated in section "SRv6 Based", provides equivalent functionality to SRv6. Such a proposal may utilize different control planes and or data planes.

Attached is the updated draft (revision 03-02), and diff.  It includes a change to section 4.3.1 that was proposed by Greg Mirsky, and reviewed by the team, but omitted in revision 03-01.

If acceptable, I'll push the final XML to git (revision 03) for Weiqiang to submit.

Darren

________________________________
From: Ron Bonica <rbonica=[email-masked]>
Sent: Wednesday, December 23, 2020 11:28 AM
To: Darren Dukes (ddukes) <[email-masked]>; Darren Dukes (ddukes) <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: revision 03 candidate 01

Darren,

As written, the second and third sentences in the description of Requirement 4.2.1 suggest that the requirement applies only to “non-srv6 solutions”. Please fix this either by:

  *   Removing those sentence
  *   Proposing clarifying text.

                                    Ron

Juniper Business Use Only

From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Tuesday, December 22, 2020 10:18 PM
To: Ron Bonica <[email-masked]>; Darren Dukes (ddukes) <[email-masked]>; [email-masked]
Subject: Re: revision 03 candidate 01

[External Email. Be cautious of content]

Hi Ron, please see inline [dd].

________________________________

From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Wednesday, December 16, 2020 12:34 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Srcomp] revision 03 candidate 01

Folks,

Two quick comments.

First, the filename is invalid. It should end in -03, not 01-03.

[dd] Correct however, I've numbered the draft 03-01 and the next update will be 03-02. When there are no further updates, I'll change it to -03 and Weiqiang will submit it.

Second, in Section 4.2.1 you say:

Description: A solution to compress an SRv6 SID list MUST support the functionality of SRv6.  This requirement and set of metrics is meant to assess whether a proposal that is not fully SRv6 based, as  evaluated in section "SRv6 Based", provides equivalent functionality  to SRv6.  Such a proposal may utilize different control planes and or data planes.

Doesn’t this requirement apply equally to SRv6 and non-SRv6 based solutions? If so, the problem can be fixed by removing the second and third sentences.

[dd] The requirement applies to all proposals. The second sentence describes the key reason for this requirement and metrics.

Sorry for not catching this earlier today.

                                                                                 Ron

Juniper Business Use Only

From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Darren Dukes (ddukes)
Sent: Wednesday, December 16, 2020 9:04 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] revision 03 candidate 01

[External Email. Be cautious of content]

For internal review.

---

From: Ron Bonica <[email-masked]>
Date: Mon, 4 Jan 2021 17:30:31 +0000

Hi Darren,

Happy New Year.

Does this requirement apply more to "non-SRv6-solutions" than "pure-SRv6-solutions". If not, why is the new text required?

                                                                                                                            Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Sunday, January 3, 2021 3:22 PM
To: Ron Bonica <rbonica=[email-masked]>; [email-masked]
Subject: Re: [Srcomp] revision 03 candidate 01

Darren

________________________________
From: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Wednesday, December 23, 2020 11:28 AM
To: Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>>; Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: RE: revision 03 candidate 01

Darren,

As written, the second and third sentences in the description of Requirement 4.2.1 suggest that the requirement applies only to "non-srv6 solutions". Please fix this either by:

                                    Ron

From: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Sent: Tuesday, December 22, 2020 10:18 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: revision 03 candidate 01

Folks,

Two quick comments.

Doesn't this requirement apply equally to SRv6 and non-SRv6 based solutions? If so, the problem can be fixed by removing the second and third sentences.

                                                                                 Ron

For internal review.

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 4 Jan 2021 17:48:26 +0000

I believes the text provides the clarification you requested.

We should submit this version.

Darren

________________________________
From: Ron Bonica <rbonica=[email-masked]>
Sent: Monday, January 4, 2021 12:31 PM
To: Darren Dukes (ddukes); Ron Bonica; [email-masked]
Subject: RE: revision 03 candidate 01

Hi Darren,

Happy New Year.

Does this requirement apply more to “non-SRv6-solutions” than “pure-SRv6-solutions”. If not, why is the new text required?

                                                                                                                            Ron

Darren

Darren,

                                    Ron

Folks,

Two quick comments.

                                                                                 Ron

For internal review.

---

From: Ron Bonica <[email-masked]>
Date: Mon, 4 Jan 2021 17:49:24 +0000

Darren,

I disagree and object too the text.

               Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <[email-masked]>
Sent: Monday, January 4, 2021 12:48 PM
To: Ron Bonica <rbonica=[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: revision 03 candidate 01

Darren

To: Darren Dukes (ddukes); Ron Bonica; [email-masked]<mailto:[email-masked]>

Hi Darren,

Happy New Year.

                                                                                                                            Ron

To: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>; [email-masked]<mailto:[email-masked]>

Darren

Darren,

  1.  Removing those sentence
  2.  Proposing clarifying text.

                                    Ron

Folks,

Two quick comments.

                                                                                 Ron

For internal review.