Subject: [Srcomp] Proposed text for PS BCP Compliance.

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 19 Feb 2021 17:52:21 +0000

I propose that we document PS BCP Compliance requirement as a “SHOULD update the related document”.

PS BCP Compliance
Description: The compression mechanism SHOULD not violate any proposed standard or BCP. If it does violate any PS or BCP it
<OLD> MUST </OLD>
<NEW> SHOULD </NEW> update the related document.

There are three reasons for SHOULD vs MUST.

  *   The working group, and IESG, ensure updates, if necessary, are evaluated and made as part of its normal process.
  *   At early draft stages, it may not be clear if or what updates are required, and a draft may not yet document such updates.
  *   SHOULD, by definition, requires careful consideration and that will be provided by the design team analysis, working group and IESG.

SHOULD
   This word, or the adjective "RECOMMENDED", mean that there
   may exist valid reasons in particular circumstances to ignore a
   particular item, but the full implications must be understood and
   carefully weighed before choosing a different course.

Thanks
  Darren

---

From: Ron Bonica <[email-masked]>
Date: Fri, 19 Feb 2021 19:05:09 +0000

Darren,

The text that you propose suggests that the WG can ignore existing standards if, after careful consideration, they decide to do so. I'm sure that this isn't your intent.

Does the following text address your concern:

Description: The compression mechanism SHOULD not violate any proposed standard or BCP. If it does violate any PS or BCP it MUST update the related document. This update can be published at any time before the compression mechanism is standardized.

                                                                  Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Friday, February 19, 2021 12:52 PM
To: [email-masked]
Subject: [Srcomp] Proposed text for PS BCP Compliance.

[External Email. Be cautious of content]

I propose that we document PS BCP Compliance requirement as a "SHOULD update the related document".

PS BCP Compliance

SHOULD

Thanks
  Darren

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 22 Feb 2021 05:22:50 +0000

Hi Ron.

Should is the right level here.

As I stated.

“The working group, and IESG, ensure updates, if necessary, are evaluated and made as part of its normal process.”

Darren
________________________________
From: Srcomp <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: Friday, February 19, 2021 2:05 PM
To: Darren Dukes (ddukes); [email-masked]
Subject: Re: [Srcomp] Proposed text for PS BCP Compliance.

Darren,

The text that you propose suggests that the WG can ignore existing standards if, after careful consideration, they decide to do so. I’m sure that this isn’t your intent.

                                                                  Ron

PS BCP Compliance

SHOULD

Thanks
  Darren

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 22 Feb 2021 22:31:44 +0800

Hi Team,

Due to unclosed comments on the BCP requirement, I suggest that we delete
the item and upload -04 version to datatracker soon.

We will consider to add it to -05 version.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Darren Dukes (ddukes)
发送时间: 2021年2月22日 13:23
收件人: Ron Bonica; Darren Dukes (ddukes); [email-masked]
主题: Re: [Srcomp] Proposed text for PS BCP Compliance.

Hi Ron.

As I stated. 

“The working group, and IESG, ensure updates, if necessary, are evaluated
and made as part of its normal process.”

Darren

  _____  

From: Srcomp <[email-masked]> on behalf of Ron Bonica
<rbonica=[email-masked]>
Sent: Friday, February 19, 2021 2:05 PM
To: Darren Dukes (ddukes); [email-masked]
Subject: Re: [Srcomp] Proposed text for PS BCP Compliance. 

Darren,

The text that you propose suggests that the WG can ignore existing standards
if, after careful consideration, they decide to do so. I’m sure that this
isn’t your intent.

Description: The compression mechanism SHOULD not violate any proposed
standard or BCP. If it does violate any PS or BCP it MUST update the related
document. This update can be published at any time before the compression
mechanism is standardized.

                                                                  Ron

 

I propose that we document PS BCP Compliance requirement as a “SHOULD
update the related document”.

PS BCP Compliance

Description: The compression mechanism SHOULD not violate any proposed
standard or BCP. If it does violate any PS or BCP it 

<OLD> MUST </OLD>

*	The working group, and IESG, ensure updates, if necessary, are
evaluated and made as part of its normal process.
*	At early draft stages, it may not be clear if or what updates are
required, and a draft may not yet document such updates.
*	SHOULD, by definition, requires careful consideration and that will
be provided by the design team analysis, working group and IESG.

SHOULD   

Thanks

  Darren

---

From: Ron Bonica <[email-masked]>
Date: Tue, 23 Feb 2021 20:42:42 +0000

Darren.

Can you add a sentence that explains when it is OK for a compression proposal to violate an existing PS or BCP document without updating it?

If so, we may be able to replace the MUST with a SHOULD.

                                                                                               Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Monday, February 22, 2021 12:23 AM
To: Ron Bonica <[email-masked]>; Darren Dukes (ddukes) <[email-masked]>; [email-masked]
Subject: Re: Proposed text for PS BCP Compliance.

Hi Ron.

As I stated.

"The working group, and IESG, ensure updates, if necessary, are evaluated and made as part of its normal process."

Darren
________________________________
From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Friday, February 19, 2021 2:05 PM
To: Darren Dukes (ddukes); [email-masked]<mailto:[email-masked]>
Subject: Re: [Srcomp] Proposed text for PS BCP Compliance.

Darren,

                                                                  Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Darren Dukes (ddukes)
Sent: Friday, February 19, 2021 12:52 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] Proposed text for PS BCP Compliance.

PS BCP Compliance

SHOULD

Thanks
  Darren