Subject: [Srcomp] Analysis text

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 11 Feb 2021 21:35:58 +0000

Hi team, 春节快乐 (hopefully this says happy spring festival :)

I’ve been concerned lately that we are getting stuck in additional requirements that are bringing diminishing value to the requirements document.  I believe we’re delaying the teams work on the vast majority of the content that needs to go into the analysis document to help SPRING decide its next steps.

With this in mind I spent some time compiling my analysis, and added Cheng’s security analysis, of the three proposals against published requirements.  I wrote it in draft format, based on the template Ron provided.  I’ll update this text over the coming days for the remaining proposal(s).

I believe we can use this as a base to accelerate our mailing list discussion on analysis and move toward a draft to give SPRING before the end of the month.

Thanks
  Darren

---

From: Ron Bonica <[email-masked]>
Date: Fri, 12 Feb 2021 18:14:29 +0000

Darren,

I believe that your proposal is premature.

AFAIKS, the design team is likely to resolve all but one of the requirements in the backlog next week. While you may characterize the remaining requirement as “bringing diminishing value”, a few of us think that it is important. Let’s not rush things.

Regarding the analysis document, I think that the following would be a good idea:

  *   Allow next week for all of the design team members to do a close reading of all of the proposal
  *   Allow the proponents of each proposal to evaluate their own proposals
  *   Negotiate the results

I strongly object to the proponent of one proposal providing the initial evaluation of all proposals.

                                                                                                        Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Thursday, February 11, 2021 4:36 PM
To: [email-masked]
Subject: [Srcomp] Analysis text

[External Email. Be cautious of content]

Thanks
  Darren

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Wed, 17 Feb 2021 20:35:12 +0800

Hi Darren, 

Thanks a lot for preparing the draft.

I just looked through the text and I think it is a good start.

Next step, we should review the content of the text word by word and output
the deliverable text. 

For the first version, I think we can leave the tables blank.  

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Darren Dukes (ddukes)
发送时间: 2021年2月12日 05:36
收件人: [email-masked]
主题: [Srcomp] Analysis text

I’ve been concerned lately that we are getting stuck in additional
requirements that are bringing diminishing value to the requirements
document.  I believe we’re delaying the teams work on the vast majority of
the content that needs to go into the analysis document to help SPRING
decide its next steps.

With this in mind I spent some time compiling my analysis, and added Cheng’
s security analysis, of the three proposals against published requirements.
I wrote it in draft format, based on the template Ron provided.  I’ll
update this text over the coming days for the remaining proposal(s).

I believe we can use this as a base to accelerate our mailing list
discussion on analysis and move toward a draft to give SPRING before the end
of the month.

Thanks

  Darren