Subject: [Srcomp] Parsing Requirement

From: Ron Bonica <[email-masked]>
Date: Fri, 12 Feb 2021 17:54:08 +0000

Folks,

The following is a proposal for the parsing requirement:

Short Name: Parsing

Description: The node that consumes the compressed SID list must be able to parse the active and next segment. Therefore, the consuming node requires parsing information. Parsing information indicates the position at which the active and next segment begin. Parsing information MAY be conveyed in either the forwarding or control plane.

Rationale: Failure to parse the compressed SID list leads to undesired behaviors.

Metric: In the nominal case the producer and consumer of the SID list agree on the active segment and next segment.
In all failure modes it is possible to determine why the producer and consumer don't agree.

Juniper Business Use Only

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Wed, 17 Feb 2021 20:40:05 +0800

Let’s review the item at today’s meeting.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Ron Bonica
发送时间: 2021年2月13日 01:54
收件人: [email-masked]
主题: [Srcomp] Parsing Requirement

Folks,

Short Name: Parsing

Description: The node that consumes the compressed SID list must be able to
parse the active and next segment. Therefore, the consuming node requires
parsing information. Parsing information indicates the position at which the
active and next segment begin. Parsing information MAY be conveyed in either
the forwarding or control plane.

Rationale: Failure to parse the compressed SID list leads to undesired
behaviors.

Metric: In the nominal case the producer and consumer of the SID list agree
on the active segment and next segment.

In all failure modes it is possible to determine why the producer and
consumer don't agree.

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Thu, 18 Feb 2021 03:54:36 +0000

Hi Ron,

Are you proposing a new requirement item?  I guess it is.
IMHO, we should propose reqs earlier, since we are going to the end. Hope we still have time to handle this requirement before IETF110.

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Saturday, February 13, 2021 1:54 AM
To: [email-masked]
Subject: [Srcomp] Parsing Requirement

Folks,

Short Name: Parsing

---

From: Ron Bonica <[email-masked]>
Date: Thu, 18 Feb 2021 15:59:46 +0000

Cheng,

This is not a new proposal. A few weeks ago, there was a requirement that stated the compression mechanism should have explicit SID lengths. Darren objected to this requirement, so we worked out a compromise and called it a parsing requirement.

                                                                          Ron

Juniper Business Use Only
From: Chengli (Cheng Li) <[email-masked]>
Sent: Wednesday, February 17, 2021 10:55 PM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: RE: Parsing Requirement

[External Email. Be cautious of content]

Hi Ron,

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Saturday, February 13, 2021 1:54 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] Parsing Requirement

Folks,

Short Name: Parsing

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 19 Feb 2021 01:19:16 +0000

OK, thanks for your reply. Let's discuss in the meeting.

Cheng

From: Ron Bonica [mailto:[email-masked]]
Sent: Friday, February 19, 2021 12:00 AM
To: Chengli (Cheng Li) <[email-masked]>; [email-masked]
Subject: RE: Parsing Requirement

Cheng,

                                                                          Ron

Juniper Business Use Only
From: Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, February 17, 2021 10:55 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Parsing Requirement

Hi Ron,

Thanks,
Cheng

Folks,

Short Name: Parsing