Subject: [Srcomp] csid scale

From: Ron Bonica <[email-masked]>
Date: Thu, 22 Apr 2021 18:02:23 +0000

Darren,

I know that we have talked about this before, but I can't find your response in the mountain of emails that we have exchanged.

Assume that an SR domain lives in a single IS-IS level. It contains 1024 (i.e., 2^10 ) routers. Each router instantiates one prefix SID and 65 (i.e., (2^6) +1 ) adjacency SIDs. Can that network use CSID-16 encoding.

If so, consider an SR path that contains 4 adjacency SIDs and a VPN SID. What does the encoding look like. What information is encoded where?

                                                                                                                                                                   Ron

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 26 Apr 2021 14:36:51 +0000

Hi Ron, please see inline

On 2021-04-22, 2:02 PM, "Srcomp" <[email-masked]> wrote:

Darren,

I know that we have talked about this before, but I can’t find your response in the mountain of emails that we have exchanged.

[DD] Yes

If so, consider an SR path that contains 4 adjacency SIDs and a VPN SID. What does the encoding look like. What information is encoded where?
[DD] This segment list consisting of five segments can be encoded at an SR source node as five 16bit CSIDs from the LIB;  One CSID per adjacency segment and one CSID for the VPN SID.
[DD] With an SRv6 locator-block of 48bits, this 5 CSID segment list could be encoded in a single CSID container.

Darren

                                                                                                                                                                   Ron

---

From: Ron Bonica <[email-masked]>
Date: Mon, 26 Apr 2021 17:57:08 +0000

Darren,

Where does the extra bit come from? Please tell me where the following analysis gets it wrong:

  *   Because the domain contains 1024 nodes, you must dedicated 10 bits to the NF
     *   Each node advertises a /58 (i.e., 48 bit locator-block plus 10 bits NF)
  *   Because each node has 65 links that you might want to access with END.X, you must dedicate 7 bits to the FUNCTION part of the CSID
     *   2^^7> 65 > 2^^6

How does the GIB/LIB distinction change any of this?

                                                                               Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Monday, April 26, 2021 10:37 AM
To: Ron Bonica <[email-masked]>; 'srcomp' <[email-masked]>
Subject: Re: csid scale

[External Email. Be cautious of content]

On 2021-04-22, 2:02 PM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Darren,

Darren

                                                                                                                                                                   Ron

---

From: Ron Bonica <[email-masked]>
Date: Tue, 27 Apr 2021 22:36:46 +0000

Darren,

In order to answer this question, you might want to fill out the CSID section of this ppt.

                                                                                            Ron

Juniper Business Use Only
From: Ron Bonica
Sent: Monday, April 26, 2021 1:57 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]>; 'srcomp' <[email-masked]>
Subject: RE: csid scale

Darren,

                                                                               Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Sent: Monday, April 26, 2021 10:37 AM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; 'srcomp' <[email-masked]<mailto:[email-masked]>>
Subject: Re: csid scale

Darren,

Darren

                                                                                                                                                                   Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 28 Apr 2021 10:52:58 +0000

Hi Ron, I’m afraid you’re missing the point of the LIB.  Could you please re-read section 5 and 5.2 of the CSID draft and consider that text when reading what follows.

What you describe below is adjacency SIDs as global CSIDs in the GIB.
However, the specification recommends 16bit adjacency CSIDs as local CSIDs allocated from a LIB.

Using adjacency and VPN SIDs from the LIB an administrator could choose to define, for example, 128 LIB entries leaving the rest for GIB, partitioning their 16bit CSID space as:
LIB: 65408-65535
GIB: 0-65469

Darren

On 2021-04-26, 1:57 PM, "Ron Bonica" <rbonica=[email-masked]> wrote:

Darren,

Because the domain contains 1024 nodes, you must dedicated 10 bits to the NF

Each node advertises a /58 (i.e., 48 bit locator-block plus 10 bits NF)

Because each node has 65 links that you might want to access with END.X, you must dedicate 7 bits to the FUNCTION part of the CSID

2^^7> 65 > 2^^6

                                                                               Ron

Darren,

Darren

                                                                                                                                                                   Ron

---

From: Ron Bonica <[email-masked]>
Date: Wed, 28 Apr 2021 17:08:03 +0000

Darren,

What would the carrier SID look like in Slide 9  of the attached deck, where we three adjacency SIDs, terminating on Nodes 3, 4 and 5?

From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Wednesday, April 28, 2021 6:53 AM
To: Ron Bonica <rbonica=[email-masked]>; 'srcomp' <[email-masked]>
Subject: Re: [Srcomp] csid scale

Hi Ron, I'm afraid you're missing the point of the LIB.  Could you please re-read section 5 and 5.2 of the CSID draft and consider that text when reading what follows.

Darren

On 2021-04-26, 1:57 PM, "Ron Bonica" <rbonica=[email-masked]<mailto:rbonica=[email-masked]>> wrote:

Darren,

2^^7> 65 > 2^^6

                                                                               Ron

Darren,

Darren

                                                                                                                                                                   Ron