Subject: Re: [Srcomp] updated CRH numbers

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 7 Apr 2021 11:34:01 +0000

Hi Ron, can you explain what TPF and CRH only mean?
It also does not appear that these numbers contain a VPN segment with 0 or more transport segments as we discussed in the calls.
We can discuss in the call.

Thanks
Darren

On 2021-03-31, 11:49 AM, "Srcomp" <[email-masked]> wrote:

Folks,

Attached are updated CRH numbers and the code used to produce them.

                                     Ron

Juniper Business Use Only

---

From: Ron Bonica <[email-masked]>
Date: Wed, 7 Apr 2021 18:13:47 +0000

Darren,

Please include the following text somewhere in the analysis document.

                                                                        Ron

CRH compression efficiency statistics are derived as follows:

If an SR path contains no transport segments and a VPN segment, the SR path is encoded in a single IPv6 header (40 bytes). The destination address in the IPv6 header is a classic SRv6 SID (e.g., END.DT4, END.DT6).

If the SR path contains T transport segments and a VPN segment, and T is greater than 0, the SR path can be encoded:

  *   With an IPv6 Tunnel Payload Function (TPF) Option [draft-bonica-6man-vpn-dest-opt]
  *   Without a TPF Option

If the SR path is encoded with a TPF Option, the packet includes a single IPv6 Header (40 bytes), a CRH (variable length), and a Destination Options header (8 bytes). The destination address in the IPv6 header represents the IPv6 address of an interface on the first transport segment endpoint. The CRH must be large enough to contain the subsequent T segments.

If the SR path is encoded without a TPF Option, the packet includes a single IPv6 Header (40 bytes) plus a CRH (variable length). The destination address in the IPv6 header represents the IPv6 address of an interface on the first transport segment endpoin . The CRH must be large enough to contain T+1 segments. In the CRH, SID[1] maps to the IPv6 address of the PE router. SID[0] maps to a classic SRv6 SID (e.g., END.DT4) that is instantiated on the PE router.

In some deployment scenarios, each encoding strategy yields better compression.

                                                                                                                                       Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Wednesday, April 7, 2021 7:34 AM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: updated CRH numbers

[External Email. Be cautious of content]

Thanks
Darren

On 2021-03-31, 11:49 AM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Folks,

                                     Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 12 Apr 2021 11:45:06 +0000

Hi Ron, If I understand correctly this appears to indicate that a PE deploying a VPN for customer A using CRH must implement:

  1.  A classic SRv6 END.DT SRv6 SID for customer A
  2.  A CRH SID in CFIB  for customer A
  3.  A TPF VPN identifier in a TPF database for customer A

Is that correct?

You also say “If an SR path contains no transport segments and a VPN segment, the SR path is encoded in a single IPv6 header (40 bytes).”
To me this says CRH does not support VPN without transport segments so SRv6 SIDs must be used instead.  Is this what you intend to say?

Darren

On 2021-04-07, 2:14 PM, "Srcomp" <[email-masked]> wrote:

Darren,

                                                                        Ron

-          With an IPv6 Tunnel Payload Function (TPF) Option [draft-bonica-6man-vpn-dest-opt]

-          Without a TPF Option

                                                                                                                                       Ron

Thanks
Darren

Folks,

                                     Ron

---

From: Ron Bonica <[email-masked]>
Date: Mon, 12 Apr 2021 18:33:04 +0000

Inline.....

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Monday, April 12, 2021 7:45 AM
To: Ron Bonica <[email-masked]>; Darren Dukes (ddukes) <[email-masked]>; [email-masked]
Subject: Re: updated CRH numbers

[RB] An implementation MUST support either (1 and 2) or (3). Most implementations will support all three.

Is that correct?

You also say "If an SR path contains no transport segments and a VPN segment, the SR path is encoded in a single IPv6 header (40 bytes)."
To me this says CRH does not support VPN without transport segments so SRv6 SIDs must be used instead.  Is this what you intend to say?

[RB] There are two ways to achieve the goal. The PE supports 1 and 2 above, the solution is identical for basic-SRv6, CSID, and CRH. If the PE doesn't support 1 and 2 above, a TPF is required.

                                                                                                                             Ron

Darren

On 2021-04-07, 2:14 PM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Darren,

                                                                        Ron

-          Without a TPF Option

                                                                                                                                       Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Sent: Wednesday, April 7, 2021 7:34 AM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: updated CRH numbers

Thanks
Darren

Folks,

                                     Ron