Subject: [Srcomp] Section 2.3 Paragraph C.1

From: Ron Bonica <[email-masked]>
Date: Fri, 11 Jun 2021 20:10:49 +0000

Darren,

I think that Section 2.3 Paragraph C1 has a bug in it.

Assume that we have 11 domains, D1 through D11. Each domain has two border routers, B1 and B2. The B1 router in Domain D1 is connected to the B1 router in all of the other domains (10 connections). Likewise, the B2 router in Domain D1 is connected to all of the B2 routers in the other domains (another 10 connections).

The border routers in Domain D1 maintains state for:

  *   All of the routers in D1 (N = 1000)
  *   All of the border routers in Domains D2 through D11 (N = 20)

With only that amount of state, any node in Domain D1 can reach any destination in Dn using either of the following paths:

  *   D1B1, DnB1, Dest
  *   D1B2, DnB2, Dest

D1B1 doesn't need to maintains state for dest, because DnB1 does.

So, C1 should read:

OLD>
a CFIB entry per unique endpoint (N*D*I), assuming IP flex  algo is not implemented on non-CRH domain (I=1), plus inter- domain adjacency (2) (N*D*I+2=10002) *RON-REVIEW*
<OLD
NEW>
a CFIB entry per CRH node per IGP algorithm for local and remote  prefix segments (N*I=2000) plus a CFIB entry per local adjacency segment (A=100) plus a CFIB entry per connected remote border router (20)
<NEW

So, the value of C.1 should 2102, not 10002.

                                                                                                    Ron

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 11 Jun 2021 20:33:21 +0000

This is not what Appendix B of CRH draft says.  It says to instantiate state for every endpoint D1-DN at P.  Recall the destination is not a remote border node but a remote PE or segment in a remote SR sub-domain.

On 2021-06-11, 4:11 PM, "Srcomp" <[email-masked]> wrote:

Darren,

-          All of the routers in D1 (N = 1000)

-          All of the border routers in Domains D2 through D11 (N = 20)

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

D1B1 doesn’t need to maintains state for dest, because DnB1 does.

So, C1 should read:

OLD>

                                                                                                    Ron

---

From: Ron Bonica <[email-masked]>
Date: Fri, 11 Jun 2021 20:57:57 +0000

There is a difference between this use case and the one in Appendix B of the CRH draft. In this use case, there are three CRH-capable nodes in the picture. D1B1 only needs to maintain enough state to get the packet to DnB1. DnB1 maintains the state require to get the packet to Dest.

In Appendix B of the CRH draft, there are only two CRH-capable nodes in the picture. So, one has to maintain enough state to get all the way to the other.

                                                                                           Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Friday, June 11, 2021 4:33 PM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: Section 2.3 Paragraph C.1

[External Email. Be cautious of content]

On 2021-06-11, 4:11 PM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

                                                                                                    Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 11 Jun 2021 23:37:01 +0000

Two points.

There is no guarantee of the network between borders. It may be non sr and domains may not directly attached as shown in section 2.

There is a requirement for lossless compression. Srv6 need only use a single sid to reach the endpoint. It would be ecmp load balanced over any available borders. You are suggesting an alternate path for compressed SRv6 with multiple additional sids per border. The calculation, as is, preserves the SRv6 path without loss for compression.

________________________________
From: Srcomp <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: Friday, June 11, 2021 4:57:57 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Srcomp] Section 2.3 Paragraph C.1

                                                                                           Ron

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

---

From: Ron Bonica <[email-masked]>
Date: Sat, 12 Jun 2021 03:49:25 +0000

Darren,

Point 1: You are depicting the worst case scenario, where none of the P routers in the metro are CRH aware. If you want to do that, you have to admit that it is the worst case scenario, and one that should be avoided in network designs.

Point 2. If you want to replicate the behavior, map a SID to an anycast address and configure the anycast on D1B1 and D1B2.

P.S. *Do not publish without consensus*

                                                       Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Friday, June 11, 2021 7:37 PM
To: Ron Bonica <[email-masked]>; Darren Dukes (ddukes) <[email-masked]>; [email-masked]
Subject: Re: Section 2.3 Paragraph C.1

Two points.

________________________________
From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Friday, June 11, 2021 4:57:57 PM
To: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Srcomp] Section 2.3 Paragraph C.1

                                                                                           Ron

From: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Sent: Friday, June 11, 2021 4:33 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: Section 2.3 Paragraph C.1

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Sun, 13 Jun 2021 01:49:40 +0000

Hi Ron, I took the day off from SRComp to enjoy some sunshine, and now I understand your point.

How about we include both scenarios and identify the cases explicitly.  A subdomain without TE, supporting SR only at PE nodes is not uncommon (I fixed a couple math errors in both cases)?

<NEW>
    *  C.1) The remote sub-domain borders support CRH: a CFIB entry
         per CRH node per IGP algorithm for local and remote prefix
         segments (N*I) plus a CFIB entry per local adjacency segment
         (A) plus a CFIB entry per connected remote border router (20)
         (N*I+A+20=2120)
      *  C.2) The remote sub-domain borders do not support CRH: a CFIB
         entry per unique endpoint (N*D*I), plus a CFIB entry per local
         adjacency segment (A), assuming IP flex algo is not implemented
         on non-CRH border domain (I=1), plus inter-domain adjacency
         (20) (N*D*I+2=10120)
</NEW>

PS *Ack ;) we are almost there!*

________________________________
From: Srcomp <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: Friday, June 11, 2021 11:50 PM
To: Darren Dukes (ddukes); Darren Dukes (ddukes); [email-masked]
Subject: Re: [Srcomp] Section 2.3 Paragraph C.1

Darren,

                                                       Ron

Two points.

                                                                                           Ron

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

---

From: Ron Bonica <[email-masked]>
Date: Sun, 13 Jun 2021 03:20:15 +0000

Darren,

Much better, but not quite there yet.

If the two (or more) border routers do not support CRH, is N still equal to 1000? Or is it 998?

Are there a good number of CRH capable nodes in the remote domain? If so, we only need routes to the closest. If not, N is smaller than we think.

Ron

Sent from my iPhone

On Jun 12, 2021, at 9:50 PM, Darren Dukes (ddukes) <ddukes=[email-masked]> wrote:

<NEW>

Darren,

                                                       Ron

Two points.

                                                                                           Ron

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

--
Srcomp mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/srcomp__;!!NEt6yMaO-gk!WGqwjx_sdlbM15aABFYiJymKl0lGb83YgjsBFlTWM3SPFWOfqMRua1G3VWIz6j0t$

---

From: Ron Bonica <[email-masked]>
Date: Sun, 13 Jun 2021 03:27:45 +0000

I think that it is fair to say that the amount of state is larger and depends on the network topology, but I have idea how to determine the upper limit.

Maybe wiggle word like “significantly larger”.

Sent from my iPhone

On Jun 12, 2021, at 11:20 PM, Ron Bonica <[email-masked]> wrote:

 Darren,

Ron

Sent from my iPhone

<NEW>

Darren,

                                                       Ron

Two points.

                                                                                           Ron

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Sun, 13 Jun 2021 12:16:15 +0000

Hi Ron. N SR nodes  so still 1000.

With SR nodes As PE nodes, I think N and he result is of the correct order.

The takeaway is forwarding state is on the order of CRH nodes. Additional intermediate nodes are required to mitigate the state. This is inline with moving state from the packet to fib.

Darren

________________________________
From: Ron Bonica <rbonica=[email-masked]>
Sent: Saturday, June 12, 2021 11:20 PM
To: Darren Dukes (ddukes)
Cc: Ron Bonica; [email-masked]
Subject: Re: [Srcomp] Section 2.3 Paragraph C.1

Darren,

Ron

Sent from my iPhone

<NEW>

Darren,

                                                       Ron

Two points.

                                                                                           Ron

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Sun, 13 Jun 2021 21:50:57 +0800

Hi Darren and Ron,

Thanks for working at weekend.

It looks possible to get consensus. 

Is that possible we have a meeting for final text at your Sunday evening and My morning (such as 00:30am,  Monday  UTC time)

Monday is the Dragon Boat Festival in China,  which is is best known for its dragon-boat races, especially in the southern provinces where there are many rivers and lakes. 

The festival commemorates the death of Qu Yuan (475-221BC). He was upright, loyal and highly esteemed for his wise counsel that brought peace and prosperity to the people.

Hope we can get agreement on the special day J

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Darren Dukes (ddukes)
发送时间: 2021年6月13日 20:16
收件人: Ron Bonica
抄送: Ron Bonica; [email-masked]
主题: Re: [Srcomp] Section 2.3 Paragraph C.1

Darren

 

  _____  

Darren, 

Ron

Sent from my iPhone

<NEW>

         (N*I+A+20=2120)

         (20) (N*D*I+2=10120)

</NEW>

 

  _____  

Darren,

                                                       Ron

Two points. 

 

  _____  

                                                                                           Ron

 

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

---

From: Ron Bonica <[email-masked]>
Date: Sun, 13 Jun 2021 16:47:30 +0000

Darren,

It will always be possible to draw a border of CRH-capable nodes in the remote network. For example, assume that the two border routers in the SR network are not SR-aware. But each of them is connected to 100 CRH-aware nodes. In that case, you only need to lee 200 SIDs, not 1000.

So, the number of nodes you need to like is higher, but it depends upon the network topology.

There is some network topology that is the worst. But I don’t know a) what that topology is, b) how many SIDs it would need to leak, or c) why anybody would deploy it.

I think that the best we can do is to say that for some topologies, the amount of state is significantly higher.

                                                            Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <[email-masked]>
Sent: Sunday, June 13, 2021 8:16 AM
To: Ron Bonica <rbonica=[email-masked]>
Cc: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] Section 2.3 Paragraph C.1

Darren

________________________________
From: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Saturday, June 12, 2021 11:20 PM
To: Darren Dukes (ddukes)
Cc: Ron Bonica; [email-masked]<mailto:[email-masked]>
Subject: Re: [Srcomp] Section 2.3 Paragraph C.1

Darren,

Ron
Sent from my iPhone

On Jun 12, 2021, at 9:50 PM, Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>> wrote:

<NEW>

To: Darren Dukes (ddukes); Darren Dukes (ddukes); [email-masked]<mailto:[email-masked]>

Darren,

                                                       Ron

To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Two points.

                                                                                           Ron

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

Juniper Business Use Only
--
Srcomp mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/srcomp__;!!NEt6yMaO-gk!WGqwjx_sdlbM15aABFYiJymKl0lGb83YgjsBFlTWM3SPFWOfqMRua1G3VWIz6j0t$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/srcomp__;!!NEt6yMaO-gk!WGqwjx_sdlbM15aABFYiJymKl0lGb83YgjsBFlTWM3SPFWOfqMRua1G3VWIz6j0t$>

---

From: Ron Bonica <[email-masked]>
Date: Sun, 13 Jun 2021 16:53:49 +0000

Folks,

I can be free tonight.

Please text me at [email-masked]<mailto:[email-masked]> when we know what time we are meeting.

                                                                           Ron

Juniper Business Use Only
From: Weiqiang Cheng <[email-masked]>
Sent: Sunday, June 13, 2021 9:51 AM
To: 'Darren Dukes (ddukes)' <ddukes=[email-masked]>; 'Ron Bonica' <rbonica=[email-masked]>
Cc: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [Srcomp] Section 2.3 Paragraph C.1

Hi Darren and Ron,

Hope we can get agreement on the special day ☺

B.R.
Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Darren Dukes (ddukes)
发送时间: 2021年6月13日 20:16
收件人: Ron Bonica
抄送: Ron Bonica; [email-masked]<mailto:[email-masked]>
主题: Re: [Srcomp] Section 2.3 Paragraph C.1

Darren

Darren,

Ron
Sent from my iPhone

<NEW>

Darren,

                                                       Ron

Two points.

                                                                                           Ron

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Sun, 13 Jun 2021 23:46:28 +0000

I think we can conclude tonight. I scheduled the call for 0:30 UTC (8:30am Beijing, 8:00pm Eastern US/Canada)

I sent the meeting invite to all members individually.

As an aside, my daughter designed and printed this medal hanger out of steel for my wife several years ago, when my wife was competing in Ottawa dragon boat festivals.

On 2021-06-13, 9:51 AM, "Srcomp" <[email-masked]> wrote:

Hi Darren and Ron,

B.R.
Weiqiang Cheng

Darren

Darren,

Ron
Sent from my iPhone

<NEW>

Darren,

                                                       Ron

Two points.

                                                                                           Ron

Darren,

-          D1B1, DnB1, Dest

-          D1B2, DnB2, Dest

So, C1 should read:

OLD>

<OLD

NEW>

<NEW

                                                                                                    Ron