Subject: [Srcomp] Fw: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt, --about requirement of "SRv6 Base Coexistence"

From: "Weiqiang Cheng" <[email-masked]>
Date: Fri, 9 Jul 2021 12:14:24 +0800

Hi team,

According to Chongfeng’s comments, we have got agreement on the minor change on draft-srcompdt-spring-compression-requirement several month ago. 

Darren,

Could you generate a new version of requirement draft with the update according to following mail?

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Chongfeng Xie
发送时间: 2021年3月31日 19:27
收件人: Chengli (Cheng Li); srcomp
主题: Re: [Srcomp] FW: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt, --about requirement of "SRv6 Base Coexistence"

Hi， Li Cheng,

I  think your revision is fine.

Chongfeng

  _____  

[email-masked]

From: Chengli (Cheng Li) <mailto:[email-masked]> 

Date: 2021-03-31 10:57

To: Chongfeng Xie <mailto:[email-masked]> ; srcomp <mailto:[email-masked]> 

Subject: Re: [Srcomp] FW: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt, --about requirement of "SRv6 Base Coexistence"

Hi Chongfeng,

How about this? 

I removed the “existing”, and using simultaneous deployments

 <https://tools.ietf.org/html/draft-srcompdt-spring-compression-requirement-06#section-5.1> 5.1.  SRv6 Base Coexistence

   Description: The compression proposal MUST support simultaneous 

   deployment with SRv6 networks.

   Rationale: SRv6 is deployed today.  A compression proposal that

   interoperates well with SRv6, as deployed, will reduce the overhead

   and simplify operations.  For Network operators who would migrate to

   compressed SRv6 SID lists, the migration is expected to gradually

   occur over a period of time as they upgrade networks, domains, device

   families and software instances.

   Metric: A compliant compression proposal provides the following

   o  Supports simultaneous deployment at a node with current SRv6 SIDs.

   o  Supports simultaneous deployment at a node with current SRv6

      control plane.

   o  Supports simultaneous operation of current SRv6 paths with

      compressed paths.

   o  Supports the behaviors in

      [I-D.ietf-spring-srv6-network-programming <https://tools.ietf.org/html/draft-srcompdt-spring-compression-requirement-06#ref-I-D.ietf-spring-srv6-network-programming> ].

   o  Does not require removal of existing IPv6 address planning.

 

From: Srcomp [mailto:[email-masked]] On Behalf Of Chongfeng Xie
Sent: Wednesday, March 31, 2021 9:24 AM
To: srcomp <[email-masked]>
Subject: Re: [Srcomp] FW: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt, --about requirement of "SRv6 Base Coexistence"

Hi，folks

I'd like to talk about requirement of "SRv6 Base Coexistence" in section 5.1.  The requirement is  described as "The compression proposal MUST support deployment in existing SRv6 networks." I think we should give a clear definition of "existing SRv6 network", some opertators have deployed SRv6, such as China Telecom,  if the software and hardware of the network equipment need to be changed to support compressed SRv6, it is not "existing SRv6 network" any longer, for it has changed the network itself.  If we stick to the current description of this requirement 5.1, I think NONE of the existing compressed slutions can meet this requiement, unless it does not change the network at all.

Best regards

Chongfeng

  _____  

[email-masked]

From: Chengli (Cheng Li) <mailto:[email-masked]> 

Date: 2021-03-29 14:27

To: Weiqiang Cheng <mailto:[email-masked]> ; 'SPRING WG List' <mailto:[email-masked]> 

CC: 'srcomp' <mailto:[email-masked]> ; [email-masked]

Subject: Re: [Srcomp] FW: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt

Thanks Weiqiang!

Yes, I think the document is mature for WG adoption.  Let's nail it down, and then progress the analysis in parallel.

Respect,

Cheng

-----Original Message-----

From: Srcomp [mailto:[email-masked]] On Behalf Of Weiqiang Cheng

Sent: Monday, March 29, 2021 11:56 AM

To: 'SPRING WG List' <[email-masked]>

Cc: 'srcomp' <[email-masked]>; [email-masked]

Subject: [Srcomp] FW: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt

Hi Group,

There were some comments on section 5.2 of draft-srcomdt-spring-compression-requirements-05 which is about the PS or BCP Compliance.

Design team had discussed the comments with group chairs. We believe it is about an IETF process, not a technical topic. 

So we removed the chapter and generated -06 revision.

So far, DT have resolved all the comments received and believe the draft is mature.

We would like to ask for WG Adoption call for draft.

B.R.

Weiqiang Cheng

-----邮件原件-----

发件人: [email-masked] [mailto:[email-masked]] 

发送时间: 2021年3月29日 11:36

收件人: Cheng Li; Chongfeng Xie; Darren Dukes; Peng Shaofu; Ron Bonica; Shaofu Peng; Weiqiang Cheng; Wim Henderickx

主题: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt

A new version of I-D, draft-srcompdt-spring-compression-requirement-06.txt

has been successfully submitted by Weiqiang Cheng and posted to the

IETF repository.

Name: draft-srcompdt-spring-compression-requirement

Revision: 06

Title: Compressed SRv6 SID List Requirements

Document date: 2021-03-29

Group: Individual Submission

Pages: 16

URL:            https://www.ietf.org/archive/id/draft-srcompdt-spring-compression-requirement-06.txt

Status:         https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement/

Htmlized:       https://datatracker.ietf.org/doc/html/draft-srcompdt-spring-compression-requirement

Htmlized:       https://tools.ietf.org/html/draft-srcompdt-spring-compression-requirement-06

Diff:           https://www.ietf.org/rfcdiff?url2=draft-srcompdt-spring-compression-requirement-06

Abstract:

   This document specifies requirements for solutions to compress SRv6

   SID lists.

 

Please note that it may take a couple of minutes from the time of submission

until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

 

-- 

Srcomp mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/srcomp

-- 

Srcomp mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/srcomp

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 9 Jul 2021 13:11:44 +0000

Ack, the change is to remove the word “existing” from the current text.

Darren

On 2021-07-09, 12:15 AM, "Srcomp" <[email-masked]> wrote:

Hi team,

Darren,

B.R.
Weiqiang Cheng

Hi， Li Cheng,

Chongfeng
________________________________
[email-masked]

From: Chengli (Cheng Li)<mailto:[email-masked]>
Date: 2021-03-31 10:57
To: Chongfeng Xie<mailto:[email-masked]>; srcomp<mailto:[email-masked]>
Subject: Re: [Srcomp] FW: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt, --about requirement of "SRv6 Base Coexistence"
Hi Chongfeng,
How about this?
I removed the “existing”, and using simultaneous deployments

5.1<https://tools.ietf.org/html/draft-srcompdt-spring-compression-requirement-06#section-5.1>.  SRv6 Base Coexistence

      [I-D.ietf-spring-srv6-network-programming<https://tools.ietf.org/html/draft-srcompdt-spring-compression-requirement-06#ref-I-D.ietf-spring-srv6-network-programming>].

Hi，folks

Best regards
Chongfeng
________________________________
[email-masked]<mailto:[email-masked]>

From: Chengli (Cheng Li)<mailto:[email-masked]>
Date: 2021-03-29 14:27
To: Weiqiang Cheng<mailto:[email-masked]>; 'SPRING WG List'<mailto:[email-masked]>
CC: 'srcomp'<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Srcomp] FW: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt
Thanks Weiqiang!

Respect,
Cheng

-----Original Message-----
From: Srcomp [mailto:[email-masked]] On Behalf Of Weiqiang Cheng
Sent: Monday, March 29, 2021 11:56 AM
To: 'SPRING WG List' <[email-masked]<mailto:[email-masked]>>
Cc: 'srcomp' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] FW: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt

Hi Group,

B.R.
Weiqiang Cheng

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2021年3月29日 11:36
收件人: Cheng Li; Chongfeng Xie; Darren Dukes; Peng Shaofu; Ron Bonica; Shaofu Peng; Weiqiang Cheng; Wim Henderickx
主题: New Version Notification for draft-srcompdt-spring-compression-requirement-06.txt

Abstract:

The IETF Secretariat

--
Srcomp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/srcomp
--
Srcomp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/srcomp