Subject: [Srcomp] Summay of the SRCOMP design team-for review

From: "Weiqiang Cheng" <[email-masked]>
Date: Thu, 15 Jul 2021 21:26:39 +0800

Hi team,

As action 3 in last meeting, I prepared some text to summarize the work of
DT as follows.

Let me know your comments.

=======

Dear all,

After a year of hard working, the SRCOMP design team almost completed the
expected tasks, and here we would like to make a brief summary.

The goal of the design team

The design team is to produce (rough) consensus (of the DT) outputs to the
WG on two related topics [1]:

1) What are the requirements for solutions to compressing segment routing
information for use over IPv6;

2) An analysis of proposed approaches to compressing         segment routing
information for use over IPv6.

What we have achieved:

The DT numbers have exchanged over 1000 emails in the mailing list since the
first email sent in SRCOMP mailing list at July 17th, 2020 [2]. After nearly
100 meetings (once or twice meeting per week at the past year), the DT
members finally generated the required two documents as planned. The first
revision of draft-srcompdt-spring-compression-requirement[3] was submitted
at Oct 30th,  2020, and the first revision of
draft-srcompdt-spring-compression-analysis [4] was submitted at Feb 19th,
2021.

After several updates, the complete and stable revision of the
requirements[3] and analysis drafts[4] had been updated at July 8th , 2021. 

We believe the content of these two drafts can be a good input to the SPRING
WG. Many thanks for the patience from anybody. 

Acknowledgements:

We would like to thank all the members of the design team:

Ron Bonica(Juniper), Weiqiang Cheng(China Mobile), Darren Dukes(Cisco), Wim
Henderickx(Nokia),Cheng Li(Huawei), Shaofu Peng(ZTE),Sander Steffann(SJM
Steffann), and Chongfeng Xie(China Telecom) (in alphabetical order) 

Next Step:

Looking forward to the comments for the requirements draft[3] and analysis
draft[4].

Best regards,

Weiqiang Cheng on behalf of SRCOMP design team

[1].
<https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/>
https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/

[2].  <https://mailarchive.ietf.org/arch/browse/srcomp/>
https://mailarchive.ietf.org/arch/browse/srcomp/

[3].
<https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirem
ent>
https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requireme
nt

[4].
<https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis
https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 16 Jul 2021 02:12:53 +0000

Hi Weiqiang,

Agree with the text, many thanks for your work!

I make some editorial modifications. Please see below.

Respect,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Weiqiang Cheng
Sent: Thursday, July 15, 2021 9:27 PM
To: [email-masked]
Subject: [Srcomp] Summay of the SRCOMP design team-for review

Hi team,
As action 3 in last meeting, I prepared some text to summarize the work of DT as follows.
Let me know your comments.

=======
Dear all,
After a year of hard working, the SRCOMP design team almost completed the expected tasks, and here we would like to make a brief summary.

The goal of the design team
The design team('s goal) is to produce (rough) consensus (of the DT) outputs to the WG on(about?) two related topics [1]:
1) What are the requirements for solutions to compressing(compress?) segment routing information for use over IPv6;
2) An analysis of proposed approaches to compressing segment routing information for use over IPv6.

What we have achieved:
The DT numbers have exchanged over 1000 emails in the mailing list since the first email sent in SRCOMP mailing list at July 17th, 2020 [2]. After nearly 100 meetings (once or twice meeting per week at the past year), the DT members finally generated the required two documents as planned. The first revision of draft-srcompdt-spring-compression-requirement[3] was submitted at Oct 30th,  2020, and the first revision of draft-srcompdt-spring-compression-analysis [4] was submitted at Feb 19th, 2021.

After several updates, the complete and stable revision of the requirements[3] and analysis drafts[4] had been updated at July 8th , 2021.

We believe the content of these two drafts can be a good input to the SPRING WG. Many thanks for the patience from anybody.

Acknowledgements:
We would like to thank all the members of the design team:
Ron Bonica(Juniper), Weiqiang Cheng(China Mobile), Darren Dukes(Cisco), Wim Henderickx(Nokia),Cheng Li(Huawei), Shaofu Peng(ZTE),Sander Steffann(SJM Steffann), and Chongfeng Xie(China Telecom) (in alphabetical order)

Next Step:
Looking forward to the comments for the requirements draft[3] and analysis draft[4].

Best regards,

[1]. https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/
[2]. https://mailarchive.ietf.org/arch/browse/srcomp/
[3]. https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement
[4]. https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Fri, 16 Jul 2021 11:10:03 +0800

Thanks, Cheng.

Any other comments, please let me know.

I hope to send it to SPRING WG before weekend.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Chengli (Cheng Li)
发送时间: 2021年7月16日 10:13
收件人: Weiqiang Cheng; [email-masked]
主题: Re: [Srcomp] Summay of the SRCOMP design team-for review

Hi Weiqiang,

Respect,

Cheng

Hi team,

 

=======

Dear all,

The design team(’s goal) is to produce (rough) consensus (of the DT)
outputs to the WG on(about?) two related topics [1]:

1) What are the requirements for solutions to compressing(compress?) segment
routing information for use over IPv6;

What we have achieved:

Acknowledgements:

Next Step:

Best regards,

[1].

[3].

[4].

---

From: Ron Bonica <[email-masked]>
Date: Fri, 16 Jul 2021 03:32:31 +0000

Weiqiang,

Looks good to me. I see that we have 30 minutes on the spring agenda.

                                            Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Weiqiang Cheng
Sent: Thursday, July 15, 2021 9:27 AM
To: [email-masked]
Subject: [Srcomp] Summay of the SRCOMP design team-for review

[External Email. Be cautious of content]

Hi team,

=======
Dear all,

The goal of the design team
The design team is to produce (rough) consensus (of the DT) outputs to the WG on two related topics [1]:
1) What are the requirements for solutions to compressing segment routing information for use over IPv6;
2) An analysis of proposed approaches to compressing         segment routing information for use over IPv6.

What we have achieved:

Acknowledgements:

Next Step:

Best regards,

[1]. https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/__;!!NEt6yMaO-gk!SfCb0RFxXj2ZhKjlnZuFLcISvmu6xpRkrtwe6QKtF2Ilb3HkssWQkssu7mddigOV$>
[2]. https://mailarchive.ietf.org/arch/browse/srcomp/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/browse/srcomp/__;!!NEt6yMaO-gk!SfCb0RFxXj2ZhKjlnZuFLcISvmu6xpRkrtwe6QKtF2Ilb3HkssWQkssu7lGPpV6y$>
[3]. https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement__;!!NEt6yMaO-gk!SfCb0RFxXj2ZhKjlnZuFLcISvmu6xpRkrtwe6QKtF2Ilb3HkssWQkssu7j8Fjyrm$>
[4]. https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis__;!!NEt6yMaO-gk!SfCb0RFxXj2ZhKjlnZuFLcISvmu6xpRkrtwe6QKtF2Ilb3HkssWQkssu7tpAwlvQ$>

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 16 Jul 2021 13:17:39 +0000

Looks good.

On 2021-07-15, 9:27 AM, "Srcomp" <[email-masked]> wrote:

Hi team,

=======
Dear all,

What we have achieved:

Acknowledgements:

Next Step:

Best regards,

---

From: Chongfeng Xie <[email-masked]>
Date: Fri, 16 Jul 2021 22:34:58 +0800

Hi，Weiqiang，
I agree with the text you prepared. Thanks!

Chongfeng
> 2021年7月15日 下午9:26，Weiqiang Cheng <[email-masked]> 写道：
> 
> Hi team,
> [1]. https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/ <https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/>
> [2]. https://mailarchive.ietf.org/arch/browse/srcomp/ <https://mailarchive.ietf.org/arch/browse/srcomp/>
> [3]. https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement <https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement>
> [4]. https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis <https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis>
>  
> -- 
> Srcomp mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/srcomp <https://www.ietf.org/mailman/listinfo/srcomp>

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Sat, 17 Jul 2021 10:02:47 +0800

Thanks, Ron.

I will prepare some slides for the presentation and discussion, and I will
send it to SRCOMP for review next week.

Hope we can have some progress on compression topic.

B.R.

Weiqiang Cheng

发件人: Srcomp [mailto:[email-masked]] 代表 Ron Bonica
发送时间: 2021年7月16日 11:33
收件人: Weiqiang Cheng; [email-masked]
主题: Re: [Srcomp] Summay of the SRCOMP design team-for review

Weiqiang,

                                            Ron

Hi team,

 

=======

Dear all,

What we have achieved:

Acknowledgements:

Next Step:

Best regards,

[1].
<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/spring/e-c
98UhIyMu7MmLuTXvBE2cXCug/__;!!NEt6yMaO-gk!SfCb0RFxXj2ZhKjlnZuFLcISvmu6xpRkrt
we6QKtF2Ilb3HkssWQkssu7mddigOV$>
https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/

[2].
<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/browse/srcomp/
__;!!NEt6yMaO-gk!SfCb0RFxXj2ZhKjlnZuFLcISvmu6xpRkrtwe6QKtF2Ilb3HkssWQkssu7lG
PpV6y$> https://mailarchive.ietf.org/arch/browse/srcomp/

[3].
<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-srcompdt-
spring-compression-requirement__;!!NEt6yMaO-gk!SfCb0RFxXj2ZhKjlnZuFLcISvmu6x
pRkrtwe6QKtF2Ilb3HkssWQkssu7j8Fjyrm$>
https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requireme
nt

[4].
<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-srcompdt-
spring-compression-analysis__;!!NEt6yMaO-gk!SfCb0RFxXj2ZhKjlnZuFLcISvmu6xpRk
rtwe6QKtF2Ilb3HkssWQkssu7tpAwlvQ$>
https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Sat, 17 Jul 2021 10:02:47 +0800

Thanks, Chongfeng.

I will sent it soon.

B.R.

Weiqiang Cheng

发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2021年7月16日 22:35
收件人: Weiqiang Cheng
抄送: [email-masked]
主题: Re: [Srcomp] Summay of the SRCOMP design team-for review

Hi，Weiqiang，

Chongfeng

Hi team,

 

=======

Dear all,

What we have achieved:

Acknowledgements:

Next Step:

Best regards,

[1].  <https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/> https://mailarchive.ietf.org/arch/msg/spring/e-c98UhIyMu7MmLuTXvBE2cXCug/

[2].  <https://mailarchive.ietf.org/arch/browse/srcomp/> https://mailarchive.ietf.org/arch/browse/srcomp/

[3].  <https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement> https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-requirement

[4].  <https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis> https://datatracker.ietf.org/doc/draft-srcompdt-spring-compression-analysis

-- 
Srcomp mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/srcomp> https://www.ietf.org/mailman/listinfo/srcomp