Subject: [Srcomp] Meeting minutes July 7 2021

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 7 Jul 2021 14:22:12 +0000

Resolved:
========
Draft text for Address planning section...
<NEW4
All compression mechanism provide the encapsulation saving described in Tables 1 and 2. CRH provides this encapsulation savings regardless of the IPv6 addressing scheme. CSID adds a CSID container, or one compressed SID (END.X with XPS behavior), for each change in locator block in a segment list. VSID (via XPS behavior) and UIDSR add one compressed SID for each change in locator block in the segment list.

The xps behavior draws the new address block from the control plane. At the time of publication this control plane behavior is undefined. Therefore xps impact on the control plane is not entirely understood. While it may be possible to define these mechanisms without impacting the control plane, specifications are not yet available

Actions:
=======
1 – Darren to email new analysis draft version to the srcomp email list for confirmation of NEW4. If no substantive comments then Weiqiang to publish a new version of the draft

2 – Chongfeng to check on editorial change for requirements document.  Darren to change the draft and email to srcomp email list as needed

3 – Weiqiang to prepare a summary text (and send to srcomp for review). It will be sent to the SPRING working group to describe the completion of the requirements and analysis draft, and for the working group to proceed based on these. Ask next step for design team and drafts (i.e. adopt and publish as informational or not – perhaps wait some time for this - TBD).

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 8 Jul 2021 19:45:16 +0000

Attached is revision 2 candidate 2 text and diffs.

Please review, Weiqiang will publish over the weekend.

Darren

On 2021-07-07, 10:22 AM, "Srcomp" <[email-masked]> wrote:

Resolved:
========

Actions:
=======

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 9 Jul 2021 02:35:44 +0000

Hi Darren,

Agree, many thanks!

Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Darren Dukes (ddukes)
Sent: Friday, July 9, 2021 3:45 AM
To: Darren Dukes (ddukes) <ddukes=[email-masked]>; [email-masked]
Subject: Re: [Srcomp] Meeting minutes July 7 2021

Darren

On 2021-07-07, 10:22 AM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Resolved:
========

Actions:
=======
1 - Darren to email new analysis draft version to the srcomp email list for confirmation of NEW4. If no substantive comments then Weiqiang to publish a new version of the draft

2 - Chongfeng to check on editorial change for requirements document.  Darren to change the draft and email to srcomp email list as needed

3 - Weiqiang to prepare a summary text (and send to srcomp for review). It will be sent to the SPRING working group to describe the completion of the requirements and analysis draft, and for the working group to proceed based on these. Ask next step for design team and drafts (i.e. adopt and publish as informational or not - perhaps wait some time for this - TBD).

---

From: <[email-masked]>
Date: Fri, 9 Jul 2021 10:55:00 +0800 (CST)

Hi Darren,

For  6.  Conclusions:

   SRv6 Based

   o  CSID is SRv6 based, requiring no updates to existing SRv6
      standards, VSID and UIDSR require updates.  CRH is not strictly
      based on SRv6 but is able to provide equivalent functionality.
// How to identify "updates" ? In other threads of LSR WG, I have heard that the word "update" should be used cautiously. For compression schemes, is a new behavior (or flavor) regarded as "update" ? Is a new optional capability advertisement regarded as "update". If so, I believe all schemes require updates.

   SRv6 Functionality

   o  CSID supports SRv6 functionality.  CRH VSID and UID support SRv6
      functionality or equivalent with some new specifications.
//Similarly, I believe all schemes require new specifications.

Regards,
PSF

------------------原始邮件------------------
发件人：DarrenDukes(ddukes)
收件人：Darren Dukes (ddukes);[email-masked];
日 期 ：2021年07月09日 03:45
主 题 ：Re: [Srcomp] Meeting minutes July 7 2021
--
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Sun, 11 Jul 2021 20:51:12 +0800

Thanks for Shaofu's comments.
Last several weeks, we've got agreement on the text for SRv6 based and SRv6 Functionality. 
I would like to suggest that we keep the text in the revision -02, and start another thread to discuss the comments from Shaofu. 
Maybe we can resolve those comments in next version.

B.R.
Weiqiang Cheng

-----邮件原件-----
发件人: Srcomp [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年7月9日 10:55
收件人: ddukes=[email-masked]
抄送: [email-masked]; ddukes=[email-masked]
主题: Re: [Srcomp] Meeting minutes July 7 2021

Hi Darren,

For  6.  Conclusions:

   SRv6 Based

   SRv6 Functionality

Regards,
PSF

------------------原始邮件------------------
发件人：DarrenDukes(ddukes)