Subject: [Status] Comments on draft-filsfils-rtgwg-segment-routing (Entropy labels for segment routing)

From: Sriganesh Kini <[email-masked]>
Date: Tue, 30 Jul 2013 01:12:44 -0700

Hello Clarence and other authors,

Current architecture does not address the issue of entropy labels. It
should be listed as an open issue.

At the mic yesterday, Kireeti and others brought up this issue and the
related issue of label stack getting deeper. I think this is a valid
concern.

An EL for the entire stack is one approach. Another could be an EL per
segment. Both have their advantages and disadvantages. This issue needs to
be addressed.

- Sri

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 30 Jul 2013 08:40:48 +0000

Totally  agree.  In addition, some extension to ISIS and OSPF may also be needed for advertising the ELC.

Best regards,

Xiaohu

________________________________
发件人: [email-masked] [[email-masked]] 代表 Sriganesh Kini [[email-masked]]
发送时间: 2013年7月30日 16:12
到: [email-masked]
主题: [Status] Comments on draft-filsfils-rtgwg-segment-routing (Entropy labels for segment routing)

Current architecture does not address the issue of entropy labels. It should be listed as an open issue.

At the mic yesterday, Kireeti and others brought up this issue and the related issue of label stack getting deeper. I think this is a valid concern.

An EL for the entire stack is one approach. Another could be an EL per segment. Both have their advantages and disadvantages. This issue needs to be addressed.

- Sri

---

From: Loa Andersson <[email-masked]>
Date: Tue, 30 Jul 2013 11:23:01 +0200

Xiaohu and Sri,

I'm struggling to understand why entropy labels would ever occur in
a source routed label stack, load sharing would be be done as part of
creating the source routed routes.

/Loa

On 2013-07-30 10:40, Xuxiaohu wrote:
> ------------------------------------------------------------------------
> *发件人:* [email-masked] [[email-masked]] 代表
> Sriganesh Kini [[email-masked]]
> *发送时间:* 2013年7月30日 16:12
> *到:* [email-masked]
> *主题:* [Status] Comments on draft-filsfils-rtgwg-segment-routing
> (Entropy labels for segment routing)
>
> segment. Both have their advantages and disadvantages. This issue needs
> to be addressed.
>
> - Sri
>
>
> _______________________________________________
> status mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/status
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 30 Jul 2013 09:28:07 +0000

Hi Loa,

IMHO, entropy labels are useful in the loose source routing case.

Best regards,
Xiaohu

________________________________________
发件人: [email-masked] [[email-masked]] 代表 Loa Andersson [[email-masked]]
发送时间: 2013年7月30日 17:23
到: [email-masked]
主题: Re: [Status] 答复:  Comments on draft-filsfils-rtgwg-segment-routing (Entropy labels for segment routing)

Xiaohu and Sri,

/Loa

--

---

From: "Dolganow, Andrew (Andrew)" <[email-masked]>
Date: Tue, 30 Jul 2013 09:28:46 +0000

I would agree with Loa, the source routing through label stack should
negate the need for entropy label as different source routes could be used
to place traffic as required.

Andrew

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 30 Jul 2013 09:30:38 +0000

A concept of ADJ-SID-sets are defined which is a identifier/label on a
number of interfaces of a node. When the packet uses a label from the
ADJ-SID-set stack the packet is subject to hashing. In this scenario the
entropy label might be used.

For regular ADJ-SID tight to a given interface it is not required since
the ingress node will do the hashing with full packet header.

---

From: AshwoodsmithPeter <[email-masked]>
Date: Tue, 30 Jul 2013 11:18:13 +0000

In two cases a source of entropy is required at intermediate hops. 1) When strict source routing over a link group, or 2) when loose source routing and faced with > 1 choice of next hop. 

If you strict source route down to the exact link between neighbours entropy is decided once at the ingress however you still need a source of entropy at that ingress.

So an entropy label (or other source) is still useful to avoid DPI to manufacture it especially at tandem points.

Peter

---

From: <[email-masked]>
Date: Tue, 30 Jul 2013 13:42:18 +0200

Loa,

I think it is too early for a statement as yours below. Just because one can execute source routing one doesn't have to. Source routes may be used, if they are desireable from a provider point of view. The name of the technology to me is Segment Routing, not source routing.

Regards,

Ruediger

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Tuesday, July 30, 2013 11:23 AM
To: [email-masked]
Subject: Re: [Status] ??: Comments on draft-filsfils-rtgwg-segment-routing (Entropy labels for segment routing)

Xiaohu and Sri,

/Loa

--

---

From: Loa Andersson <[email-masked]>
Date: Tue, 30 Jul 2013 13:54:31 +0200

Ruediger,

I did not mean to make a statement - I merely asked a question.

While I agree that you don't need to do <anything> just because
you can; my question was scoped to a situation where you are
doing source routing.

I got some answers that I'm currently thinking about and might be
back with further questions. Still don't see exactly how it would
easily work and what the benefits would be to include EL's in the
stack. The strict case at least seems to be at least easier to
handle with the source label stack.

/Loa

--

---

From: Sriganesh Kini <[email-masked]>
Date: Tue, 30 Jul 2013 04:56:44 -0700

Loa,

Another scenario is where the Node-SIDs are used in the stack. To reach the
node if ECMP is required then EL is required.

- Sri

---

From: <[email-masked]>
Date: Tue, 30 Jul 2013 14:33:57 +0200

Loa,

I agree, if and how ELs are to be included in source routed packets needs further discussion. We'll certainly find more which requires further discussion, as we are still at the beginning of segment routing.

Regards,

Ruediger

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Tuesday, July 30, 2013 1:55 PM
To: [email-masked]
Subject: Re: [Status] ??: Comments on draft-filsfils-rtgwg-segment-routing (Entropy labels for segment routing)

Ruediger,

/Loa

--