Subject: Re: [Status] Updated charter - version 3 and maybe 4

From: "Stewart Bryant (stbryant)" <[email-masked]>
Date: Tue, 1 Oct 2013 07:29:32 +0000

We will look at how to better say this. The intent was that the rules at the end of the following paragraph would apply.

Stewart

Sent from my iPad

On 1 Oct 2013, at 02:45, "Loa Andersson" <[email-masked]> wrote:

> Adrian and Stewart,
> 
> what is the value of "conjuntion"? If one group develops a spec
> and sends it to the owner of the technology for wglc is that
> "in conjunction"?
> 
> /Loa
> 
> On 2013-10-01 03:24, Adrian Farrel wrote:
>> And Stewart wanted to say...
>> 
>> http://datatracker.ietf.org/wg/spring/charter/
>> 
>> *From:[email-masked] [mailto:[email-masked]] *On
>> Behalf Of *Stewart Bryant
>> *Sent:* 30 September 2013 16:52
>> *To:* [email-masked]
>> *Subject:* [Status] Updated charter - version 3 and maybe 4
>> 
>> Adrian and I took a close look the SPRING charter
>> 
>> and have edited it to get text that we think is more
>> 
>> likely to get through the review cycles.
>> 
>> 
>> 
>> The intent of the changes is not change the work
>> 
>> programme, the deliverables or the networks. The
>> 
>> purpose of the changes is to generate what we think
>> 
>> is a viable charter that matches the intent of
>> 
>> this list.
>> 
>> 
>> 
>> First we added a summary of what spring is and
>> 
>> why it is needed - that is covered by the first
>> 
>> paragraph, the list of *example* and the following
>> 
>> paragraph.
>> 
>> 
>> 
>> We then note that we need bot strict and loose
>> 
>> path specification.
>> 
>> 
>> 
>> We then discuss the trust model
>> 
>> 
>> 
>> We then say we start with single AS but must be
>> 
>> able to multi-AS
>> 
>> 
>> 
>> We call out centralized and distributed path comp.
>> 
>> 
>> 
>> We then call out SPRING as an OAM and the need
>> 
>> to manage SPRING.
>> 
>> 
>> 
>> Then for data plane, control plane and management
>> 
>> we say, try to use existing, but if that does
>> 
>> not work we specify the process for change.
>> 
>> Note that we talk about data planes in the plural.
>> 
>> 
>> 
>> We then provide the deliverable as an edited
>> 
>> version of the delivery plan.
>> 
>> 
>> 
>> We do not explicitly call out either MPLS or
>> 
>> IPv6 (or any other data plane), because,
>> 
>> 
>> 
>> 1) That emerges from the use cases.
>> 
>> 2) The charter says use the dataplanes (note the
>> 
>> plural) and protocols that are derived from
>> 
>> the use cases.
>> 
>> 
>> 
>> The charter therefore set a strong expectation
>> 
>> that whatever dataplanes need to to be used
>> 
>> to satisfy the network need is in scope.
>> 
>> 
>> 
>> Comments please
>> 
>> 
>> 
>> Stewart
>> 
>> 
>> 
>> PS you may see -04 with some cosmetic/layout changes.
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> _______________________________________________
>> status mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/status
> 
> -- 
> 
> 
> Loa Andersson                        email: [email-masked]
> Senior MPLS Expert                          [email-masked]
> Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Rob Shakir <[email-masked]>
Date: Tue, 1 Oct 2013 10:41:19 +0100

Hi Stewart, {SPRING,STATUS},

One thing that has gone missing from the charter is the specification of where state should be maintained in the solution. I think (and I think the feelings of the list are) that this is an absolute fundamental of the architecture, so it would be good to have this specified in the charter.

Kind regards,
r.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 1 Oct 2013 10:12:33 +0000

I agree.

s.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 1 Oct 2013 10:12:21 +0000

In the proposed text I read:

	SPRING should avoid modification to existing data 
	planes in order to remain compatible with existing 
	deployments. When a modification is necessary this 
	must be undertaken in conjunction with the working 
	group responsible for the definition and maintenance 
	of that data plane.

Note that a modification to existing data planes may still 
ensure backward compatibility so the above statement is 
not correct and I'd rephrase it as:

	SPRING should avoid modifications to existing data 
	planes that would make them non compatible with 
	existing deployments. When a modification is necessary 
	this must be undertaken in conjunction with the working 
	group responsible for the definition and maintenance 
	of that data plane.

s.