
From nobody Thu Jan 22 11:05:14 2015
Return-Path: <yana@jitsi.org>
X-Original-To: stox@ietfa.amsl.com
Delivered-To: stox@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 4363E1A1B80; Thu, 22 Jan 2015 11:05:13 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.9
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 tagged_above=-999 required=5 tests=[BAYES_00=-1.9] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id n5dgyIGm4qcB; Thu, 22 Jan 2015 11:05:11 -0800 (PST)
Received: from ietfa.amsl.com (localhost [IPv6:::1]) by ietfa.amsl.com (Postfix) with ESMTP id 6B2E91A1B2E; Thu, 22 Jan 2015 11:05:05 -0800 (PST)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: "Yana Stamcheva" <yana@jitsi.org>
To: alcoop@cisco.com
X-Test-IDTracker: no
X-IETF-IDTracker: 5.10.0.p8
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <20150122190505.1802.72941.idtracker@ietfa.amsl.com>
Date: Thu, 22 Jan 2015 11:05:05 -0800
Archived-At: <http://mailarchive.ietf.org/arch/msg/stox/00qnqBa2VzWjDheeCCXBNmXz8sI>
Cc: stox@ietf.org, stox-chairs@tools.ietf.org, iesg-secretary@ietf.org, yana@jitsi.org, draft-ietf-stox-chat.all@tools.ietf.org
Subject: [Stox] Publication has been requested for draft-ietf-stox-chat-08
X-BeenThere: stox@ietf.org
X-Mailman-Version: 2.1.15
List-Id: SIP-TO-XMPP Working Group discussion list <stox.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/stox>, <mailto:stox-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/stox/>
List-Post: <mailto:stox@ietf.org>
List-Help: <mailto:stox-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/stox>, <mailto:stox-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 22 Jan 2015 19:05:13 -0000

Yana Stamcheva has requested publication of draft-ietf-stox-chat-08 as Proposed Standard on behalf of the STOX working group.

Please verify the document's state at http://datatracker.ietf.org/doc/draft-ietf-stox-chat/


From nobody Thu Jan 22 11:08:33 2015
Return-Path: <yana@jitsi.org>
X-Original-To: stox@ietfa.amsl.com
Delivered-To: stox@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id E67151A1B8E; Thu, 22 Jan 2015 11:08:30 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.9
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 tagged_above=-999 required=5 tests=[BAYES_00=-1.9] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id nRwDSAbV9Lhz; Thu, 22 Jan 2015 11:08:26 -0800 (PST)
Received: from ietfa.amsl.com (localhost [IPv6:::1]) by ietfa.amsl.com (Postfix) with ESMTP id A47BE1A1B70; Thu, 22 Jan 2015 11:08:26 -0800 (PST)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: "Yana Stamcheva" <yana@jitsi.org>
To: alcoop@cisco.com
X-Test-IDTracker: no
X-IETF-IDTracker: 5.10.0.p8
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <20150122190826.30156.84756.idtracker@ietfa.amsl.com>
Date: Thu, 22 Jan 2015 11:08:26 -0800
Archived-At: <http://mailarchive.ietf.org/arch/msg/stox/vi5wLUAEuwM6ZlzLqcEkkwJJwsE>
Cc: stox@ietf.org, stox-chairs@tools.ietf.org, iesg-secretary@ietf.org, yana@jitsi.org, draft-ietf-stox-im.all@tools.ietf.org
Subject: [Stox] Publication has been requested for draft-ietf-stox-im-10
X-BeenThere: stox@ietf.org
X-Mailman-Version: 2.1.15
List-Id: SIP-TO-XMPP Working Group discussion list <stox.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/stox>, <mailto:stox-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/stox/>
List-Post: <mailto:stox@ietf.org>
List-Help: <mailto:stox-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/stox>, <mailto:stox-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 22 Jan 2015 19:08:31 -0000

Yana Stamcheva has requested publication of draft-ietf-stox-im-10 as Proposed Standard on behalf of the STOX working group.

Please verify the document's state at http://datatracker.ietf.org/doc/draft-ietf-stox-im/


From nobody Thu Jan 29 16:44:58 2015
Return-Path: <ietf-secretariat-reply@ietf.org>
X-Original-To: stox@ietfa.amsl.com
Delivered-To: stox@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 02DCF1A88A7 for <stox@ietfa.amsl.com>; Thu, 29 Jan 2015 16:44:56 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.9
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 tagged_above=-999 required=5 tests=[BAYES_00=-1.9] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id gTgUL8EeSIwu; Thu, 29 Jan 2015 16:44:54 -0800 (PST)
Received: from ietfa.amsl.com (localhost [IPv6:::1]) by ietfa.amsl.com (Postfix) with ESMTP id 93F841A88AB; Thu, 29 Jan 2015 16:44:54 -0800 (PST)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
To: stox@ietf.org, stox-chairs@tools.ietf.org, yana@jitsi.org, draft-ietf-stox-im.all@tools.ietf.org
X-Test-IDTracker: no
X-IETF-IDTracker: 5.10.1.p2
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <20150130004454.10957.95976.idtracker@ietfa.amsl.com>
Date: Thu, 29 Jan 2015 16:44:54 -0800
From: IETF Secretariat <ietf-secretariat-reply@ietf.org>
Archived-At: <http://mailarchive.ietf.org/arch/msg/stox/5d234PVo5oUwTprv5NpgtDdxyDo>
Subject: [Stox] ID Tracker State Update Notice: <draft-ietf-stox-im-10.txt>
X-BeenThere: stox@ietf.org
X-Mailman-Version: 2.1.15
List-Id: SIP-TO-XMPP Working Group discussion list <stox.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/stox>, <mailto:stox-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/stox/>
List-Post: <mailto:stox@ietf.org>
List-Help: <mailto:stox-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/stox>, <mailto:stox-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 30 Jan 2015 00:44:56 -0000

IESG state changed to AD Evaluation from Publication Requested
ID Tracker URL: http://datatracker.ietf.org/doc/draft-ietf-stox-im/


From nobody Fri Jan 30 09:40:42 2015
Return-Path: <ietf-secretariat-reply@ietf.org>
X-Original-To: stox@ietfa.amsl.com
Delivered-To: stox@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 788D31A90FE for <stox@ietfa.amsl.com>; Fri, 30 Jan 2015 09:40:39 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.899
X-Spam-Level: 
X-Spam-Status: No, score=-1.899 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, TVD_SPACE_RATIO=0.001] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id FLsYS_iRI2HC; Fri, 30 Jan 2015 09:40:37 -0800 (PST)
Received: from ietfa.amsl.com (localhost [IPv6:::1]) by ietfa.amsl.com (Postfix) with ESMTP id C544B1A1BFE; Fri, 30 Jan 2015 09:40:37 -0800 (PST)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
To: stox@ietf.org, stox-chairs@tools.ietf.org, yana@jitsi.org, draft-ietf-stox-chat.all@tools.ietf.org
X-Test-IDTracker: no
X-IETF-IDTracker: 5.10.1.p2
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <20150130174037.18504.39441.idtracker@ietfa.amsl.com>
Date: Fri, 30 Jan 2015 09:40:37 -0800
From: IETF Secretariat <ietf-secretariat-reply@ietf.org>
Archived-At: <http://mailarchive.ietf.org/arch/msg/stox/Xr3K3RneCHLzMJAo-yEIyAcwEKQ>
Subject: [Stox] ID Tracker State Update Notice: <draft-ietf-stox-chat-08.txt>
X-BeenThere: stox@ietf.org
X-Mailman-Version: 2.1.15
List-Id: SIP-TO-XMPP Working Group discussion list <stox.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/stox>, <mailto:stox-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/stox/>
List-Post: <mailto:stox@ietf.org>
List-Help: <mailto:stox-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/stox>, <mailto:stox-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 30 Jan 2015 17:40:39 -0000

IESG state changed to AD Evaluation from Publication Requested
ID Tracker URL: http://datatracker.ietf.org/doc/draft-ietf-stox-chat/


From nobody Sat Jan 31 16:09:24 2015
Return-Path: <alissa@cooperw.in>
X-Original-To: stox@ietfa.amsl.com
Delivered-To: stox@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 52FC81A1B14 for <stox@ietfa.amsl.com>; Sat, 31 Jan 2015 16:09:22 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 0
X-Spam-Level: 
X-Spam-Status: No, score=0 tagged_above=-999 required=5 tests=[BAYES_50=0.8, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_LOW=-0.7] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id t7SirmHIYCPo for <stox@ietfa.amsl.com>; Sat, 31 Jan 2015 16:09:20 -0800 (PST)
Received: from out3-smtp.messagingengine.com (out3-smtp.messagingengine.com [66.111.4.27]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id AB72D1A1AAB for <stox@ietf.org>; Sat, 31 Jan 2015 16:09:20 -0800 (PST)
Received: from compute4.internal (compute4.nyi.internal [10.202.2.44]) by mailout.nyi.internal (Postfix) with ESMTP id 957CC20431 for <stox@ietf.org>; Sat, 31 Jan 2015 19:09:19 -0500 (EST)
Received: from frontend1 ([10.202.2.160]) by compute4.internal (MEProxy); Sat, 31 Jan 2015 19:09:19 -0500
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=cooperw.in; h= x-sasl-enc:from:content-type:content-transfer-encoding:subject :message-id:date:to:mime-version; s=mesmtp; bh=PdeX7+rT41sw19fwK L4/hUFiCss=; b=cribi1B7Px3BgGGToN+zEEb6Br6Iy7PSa291xOUH3fhhPAdZ/ hBkqvDHZrpm9CT6c1O16MeOXI0aVVcLyOvwOguXyqUORMboD1sLAQRYF10+WBl5K o7TQuicrY4eRXcdis2kPI/gQFoF95fQ1x3VY8ZW/7BLUEyoYvRVv4WaFw0=
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d= messagingengine.com; h=x-sasl-enc:from:content-type :content-transfer-encoding:subject:message-id:date:to :mime-version; s=smtpout; bh=PdeX7+rT41sw19fwKL4/hUFiCss=; b=FDE ofxRS6nSpY44pXkxaFtNN+piyfZBIzAGlhGIceJ9iY19K8MtyzQV9lIxnGLmEqUM Ypr8OHMXYcirwxs80mhXgs81hLJp/r1K+NV6xqhgc0D4vZfQLS3sT8EmpJjBWDOu FPnZ9vknRO661Qrfl6lSHeDOvLT6RRJx38e76VEg=
X-Sasl-enc: Nw4NAM7TxNkEhq/Miti/4rJ4qsJjjr7i+XMwSYB9iO8X 1422749359
Received: from sjc-alcoop-8817.cisco.com (unknown [128.107.239.233]) by mail.messagingengine.com (Postfix) with ESMTPA id EF590C0028A for <stox@ietf.org>; Sat, 31 Jan 2015 19:09:18 -0500 (EST)
From: Alissa Cooper <alissa@cooperw.in>
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: quoted-printable
Message-Id: <48B4925F-747B-4453-AF7F-3B1E9505A549@cooperw.in>
Date: Sat, 31 Jan 2015 16:09:18 -0800
To: stox@ietf.org
Mime-Version: 1.0 (Mac OS X Mail 7.3 \(1878.6\))
X-Mailer: Apple Mail (2.1878.6)
Archived-At: <http://mailarchive.ietf.org/arch/msg/stox/foGk-Rs7rSW_9MeulpUTvzuH02g>
Subject: [Stox] AD evaluation: draft-ietf-stox-im-10
X-BeenThere: stox@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: SIP-TO-XMPP Working Group discussion list <stox.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/stox>, <mailto:stox-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/stox/>
List-Post: <mailto:stox@ietf.org>
List-Help: <mailto:stox-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/stox>, <mailto:stox-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sun, 01 Feb 2015 00:09:22 -0000

I have reviewed this draft in preparation for IETF LC, along with the =
-chat and -groupchat drafts. Overall the document appears in good shape. =
I have a comment I=92d like to discuss before proceeding to IETF LC, =
along with an editorial nit to be addressed with any LC comments.=20

You will note some commonality across my comments on all three drafts. =
In general, these drafts could do a better job of precisely specifying =
what is minimally required (normatively) for interoperability, versus =
what is optional or likely to differ between implementations. I think if =
at least the syntax mappings are normatively specified that should be =
sufficient, but the authors and WG might want to consider doing another =
pass at these documents to see if they could be more clear about which =
protocol exchanges the various gateways must support for STOX to work at =
all, versus which ones are suggested or optional.

Comment:

To achieve minimal interoperability, I think the syntax mappings in =
Section 4 need to be MUST-level requirements rather than SHOULD. Or, if =
there are cases envisioned in which different implementations might map =
the elements differently, those should be explained. But I assume there =
are not.

Nit:

If GRUUs are generally not human-readable in use, I would suggest =
changing the ones in Section 4 to random identifiers.=


From nobody Sat Jan 31 16:09:32 2015
Return-Path: <alissa@cooperw.in>
X-Original-To: stox@ietfa.amsl.com
Delivered-To: stox@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id CF4251A6FDB for <stox@ietfa.amsl.com>; Sat, 31 Jan 2015 16:09:30 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.7
X-Spam-Level: 
X-Spam-Status: No, score=-2.7 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_LOW=-0.7] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id YscYxrsPYin5 for <stox@ietfa.amsl.com>; Sat, 31 Jan 2015 16:09:29 -0800 (PST)
Received: from out3-smtp.messagingengine.com (out3-smtp.messagingengine.com [66.111.4.27]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 4305F1A1BE0 for <stox@ietf.org>; Sat, 31 Jan 2015 16:09:29 -0800 (PST)
Received: from compute5.internal (compute5.nyi.internal [10.202.2.45]) by mailout.nyi.internal (Postfix) with ESMTP id AB1B720746 for <stox@ietf.org>; Sat, 31 Jan 2015 19:09:28 -0500 (EST)
Received: from frontend1 ([10.202.2.160]) by compute5.internal (MEProxy); Sat, 31 Jan 2015 19:09:28 -0500
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=cooperw.in; h= x-sasl-enc:from:content-type:content-transfer-encoding:subject :message-id:date:to:mime-version; s=mesmtp; bh=3KWpQBDb1KPKBOwKG IiFgRTUX3o=; b=tEU3KNJ4Go8qbg/0cR64UQpJ0Mw5ogHFarrf+AhKiQ9pFsCez PmAiEy5tiD0p9Hhv+0f1Rfybrfsi+CCdHLKQxVJ4MFfwHBsvsZ37FXUIfnXPO9Ps UEnX8LLf2/9z7xk1XIbd78SfqaP+FLhJoKnHMEQ2X7tOYxD2FPqhkb6r1w=
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d= messagingengine.com; h=x-sasl-enc:from:content-type :content-transfer-encoding:subject:message-id:date:to :mime-version; s=smtpout; bh=3KWpQBDb1KPKBOwKGIiFgRTUX3o=; b=Z4H FkLvVanfg3me51Dy/AoVT4s3aNffRmva4zM5rELe7Xvxemb/DDohKBHS9aGzFnMH 2XuiCcU6EZrWiwlhDEctUGg4cq4OQssNXlco4C0epLy6eKcIOkeoevUc48yPNWnL SjoXrTxhH1oOOmK/oWUy47VPX5TwJwj8mDoH4tYw=
X-Sasl-enc: RT30y7CyFj3N31TV4SBJj0Q1MKxkO4oVXXDPPtkNm/Xh 1422749368
Received: from sjc-alcoop-8817.cisco.com (unknown [128.107.239.233]) by mail.messagingengine.com (Postfix) with ESMTPA id 1EC7AC0028C for <stox@ietf.org>; Sat, 31 Jan 2015 19:09:27 -0500 (EST)
From: Alissa Cooper <alissa@cooperw.in>
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: quoted-printable
Message-Id: <0C205FB7-2C6B-4773-830F-B8354CC65A75@cooperw.in>
Date: Sat, 31 Jan 2015 16:09:28 -0800
To: stox@ietf.org
Mime-Version: 1.0 (Mac OS X Mail 7.3 \(1878.6\))
X-Mailer: Apple Mail (2.1878.6)
Archived-At: <http://mailarchive.ietf.org/arch/msg/stox/UBVx5gPsQXxtr--ffc2MlxInWQE>
Subject: [Stox] AD evaluation: draft-ietf-stox-chat-08
X-BeenThere: stox@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: SIP-TO-XMPP Working Group discussion list <stox.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/stox>, <mailto:stox-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/stox/>
List-Post: <mailto:stox@ietf.org>
List-Help: <mailto:stox-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/stox>, <mailto:stox-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sun, 01 Feb 2015 00:09:31 -0000

I have reviewed this draft in preparation for IETF LC. Overall the =
document appears in good shape. I have a couple of comments/questions =
regarding normative requirements that I=92d like to discuss before =
issuing the LC. I=92ve also included some editorial nits that should be =
addressed together with any LC comments.

Comments/questions:

=3D Sections 4 and 5 =3D
Same comment as on the -im document: To achieve minimal =
interoperability, I think the syntax mappings in these sections need to =
be MUST-level requirements rather than SHOULD. Or, if there are cases =
envisioned in which different implementations might map the elements =
differently, those should be explained. But I assume there are not.

=3D Section 7 =3D
Is all of the delivery report behavior meant to be entirely optional to =
support, or should there be some normative requirements listed in this =
section?


Editorial nits:

=3D General =3D
If GRUUs are generally not human-readable in use, I would suggest =
changing them to random identifiers throughout the examples in this =
document.

=3D Section 4 =3D
"The XMPP-to-SIP gateway at the XMPP server would then initiate an
   MSRP session with Romeo on Juliet's behalf (since there is no
   reliable way for the gateway to determine if Romeo's client supports
   MSRP, it simply needs to guess).=94

=93Guessing=94 makes it sound like the gateway might use heuristics or =
some such to determine whether to initiate an MSRP session, and that in =
some cases it might not initiate a session. Would it be more accurate to =
say that MSRP session initiation may yield an error since there is no =
reliable way for the gateway to determine if Romeo's client supports =
MSRP?

=3D Section 6.1 =3D
s/can server/can serve/=


From nobody Sat Jan 31 16:10:12 2015
Return-Path: <alissa@cooperw.in>
X-Original-To: stox@ietfa.amsl.com
Delivered-To: stox@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C95F81A1B65 for <stox@ietfa.amsl.com>; Sat, 31 Jan 2015 16:10:10 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 0
X-Spam-Level: 
X-Spam-Status: No, score=0 tagged_above=-999 required=5 tests=[BAYES_50=0.8, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_LOW=-0.7] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id xx3WsR1a_TnP for <stox@ietfa.amsl.com>; Sat, 31 Jan 2015 16:10:08 -0800 (PST)
Received: from out3-smtp.messagingengine.com (out3-smtp.messagingengine.com [66.111.4.27]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 9BA0E1A1B14 for <stox@ietf.org>; Sat, 31 Jan 2015 16:10:08 -0800 (PST)
Received: from compute1.internal (compute1.nyi.internal [10.202.2.41]) by mailout.nyi.internal (Postfix) with ESMTP id 15A55202A2 for <stox@ietf.org>; Sat, 31 Jan 2015 19:10:08 -0500 (EST)
Received: from frontend1 ([10.202.2.160]) by compute1.internal (MEProxy); Sat, 31 Jan 2015 19:10:08 -0500
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=cooperw.in; h= x-sasl-enc:from:content-type:content-transfer-encoding:subject :message-id:date:to:mime-version; s=mesmtp; bh=UUKhE+EBk42e6rnct W9Q0NlQt4s=; b=QRzQF9UmL8Gi0Fl6Mpwd1dGDNcgpFYv1WJmPMKPX+8u6URWZe zC3XnpCsiXipuiSwHQa6rYJ8PPBtFkztWR5Dj12ANeLTCAFcXMy+nhM2xH/ei1+k c1qzTIZorkirQ428XzPJElxN5A0piwrwciY6U+JT7//wyKeK+zl/bvGZLU=
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d= messagingengine.com; h=x-sasl-enc:from:content-type :content-transfer-encoding:subject:message-id:date:to :mime-version; s=smtpout; bh=UUKhE+EBk42e6rnctW9Q0NlQt4s=; b=Btv X4Qsic6D4DgMT29e9MraQxwP6uxOq7L7LtYjlJzD26+MV53YtAyrCYEuNqvxjidG /prPAGuZHfhL6NHdJKrdQCkpmhYmIVmKjhOIM81dXRRTpdasfkHJIjkBo/4gncsx j92M9Dn3NBF8K2Wldl4XXWW3f9LWI/FIBEMCmr5c=
X-Sasl-enc: eDpM7iW4cjAONpvkorUNz/IkGRIgzdoCJD5W6Er99Di/ 1422749407
Received: from sjc-alcoop-8817.cisco.com (unknown [128.107.239.233]) by mail.messagingengine.com (Postfix) with ESMTPA id 64C46C0028C for <stox@ietf.org>; Sat, 31 Jan 2015 19:10:07 -0500 (EST)
From: Alissa Cooper <alissa@cooperw.in>
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: quoted-printable
Message-Id: <71D99F08-87C8-4E4A-9DC3-2DC3C2991B1B@cooperw.in>
Date: Sat, 31 Jan 2015 16:10:07 -0800
To: stox@ietf.org
Mime-Version: 1.0 (Mac OS X Mail 7.3 \(1878.6\))
X-Mailer: Apple Mail (2.1878.6)
Archived-At: <http://mailarchive.ietf.org/arch/msg/stox/pxiDc9qJhGGsV5ducb3kvjJGQa8>
Subject: [Stox] AD evaluation: draft-ietf-stox-groupchat-08
X-BeenThere: stox@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: SIP-TO-XMPP Working Group discussion list <stox.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/stox>, <mailto:stox-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/stox/>
List-Post: <mailto:stox@ietf.org>
List-Help: <mailto:stox-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/stox>, <mailto:stox-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sun, 01 Feb 2015 00:10:11 -0000

I have reviewed this draft in preparation for IETF LC. I have a couple =
of comments/questions that I=92d like to discuss before issuing the LC. =
I=92ve also included some editorial nits that should be addressed =
together with any LC comments.

=3D Section 5 =3D
All of the flow labels as used in the text and the examples need to be =
checked against the labels in the diagram. I found a bunch of =
inconsistencies where the labels used in the text are not describing the =
right flows in the diagram (e.g., Example 20, all the labels in Section =
5.8). This is sort of editorial but given that the spec is basically =
defined by the diagrams and examples, I think it needs to be fixed =
before IETF LC. It confused me quite a bit.

In fact, I would suggest checking every label in the document to make =
sure it corresponds to the appropriate diagramed flow.

=3D Section 5.1 =3D
"As specified in [RFC7247], the mapping of XMPP syntax elements to SIP
   and [RFC4566] syntax elements is as shown in the following table.=94

This doesn=92t seem quite right since RFC 7247 doesn=92t actually =
provide the mapping of from->=46rom and to->To =97 that=92s what the =
table right here is doing. I would suggest that the text here follow the =
same pattern used in the -im draft, namely:

"The mapping of XMPP syntax to SIP syntax [MUST] be as shown in the =
following table.

Table 1: Message syntax mapping from XMPP to SIP/SDP

       +-----------------------------+-----------------------------+
       |  XMPP Element or Attribute  |  SIP Header or SDP Contents |
       +-----------------------------+-----------------------------+
       |  from                       |  =46rom                       |
       |  to (without the /nick)     |  To                         |
       +-----------------------------+=97=97=97=97=97=97=97=97=97=97=97=97=
=97=97+

As shown in the foregoing example and described in [RFC7247], the
       XMPP-to-SIP gateway [MUST] map the bare JID
       ("localpart@domainpart") of the XMPP sender to the SIP From
       header and include the resourcepart of the full JID as the GRUU
       portion [RFC5627] of the SIP URI.=94

Note that I=92ve replaced the SHOULDs with MUSTs as explained in my =
comments on the -im draft.

=3D Section 5.4 =3D
OLD
The following table shows the syntax mapping from the RFC 4575
   payload to the XMPP participant list.

NEW
The syntax mappings from the RFC 4575
   payload to the XMPP participant list MUST be as shown in the =
following table.

OLD
The mapping of SIP and [RFC4575] payload syntax elements to XMPP
   syntax elements is as shown in the following table.

NEW
The mapping of SIP and [RFC4575] payload syntax elements to XMPP
   syntax elements MUST be as shown in the following table.

=3D Section 5.5 =3D
OLD
The mapping of XMPP syntax elements to MSRP syntax elements is as
   shown in the following table.

NEW
The mapping of XMPP syntax elements to MSRP syntax elements MUST be as
   shown in the following table.

=3D Section 6 =3D
As in Section 5, something is awry with the labels of the protocol flows =
in this section, both in the diagram and the examples that follow. I =
believe the first flow in the diagram, SIP INVITE from the SIP user to =
the SIP proxy, should be F35, not F33.

Then in 6.1 the SUBSCRIBE flow is listed in Example 29 as F40, but it =
should be F38 as in the diagram. =46rom there, the flow numbers listed =
in the examples are all off by 1 or 2.

=3D Section 6.3 =3D
OLD
The mapping of MSRP syntax elements to XMPP syntax elements is as
   shown in the following table.

NEW
The mapping of MSRP syntax elements to XMPP syntax elements MUST be as
   shown in the following table.

=3D Section 6.3.1 =3D
Why does the SIP-to-XMPP gateway send an MSRP 200 OK back to the sender =
before seeing that the groupchat message has been reflected back? =
Doesn=92t this give the sender the wrong impression in the event that a =
transport error causes the groupchat message to fail to reach the XMPP =
MUC?

"In MSRP this reflected message is unnecessary."

What does it mean for it to be =93unnecessary=94? Why does the MSRP =
gateway send it (F48 in the diagram)?

=3D Section 7 =3D
"Implementations are strongly encouraged to apply the
   rules for preparation and comparison of nicknames specified in
   [I-D.ietf-precis-nickname].=94

draft-ietf-precis-nickname is listed as a normative reference. Should =
its use be a normative requirement?

"Therefore, for display purposes SIP implementations
   ought to use the <display-text/> element if the XCON 'nickname'
   attribute is not present, and XMPP implementations ought to use the
   resourcepart of the occupant JID if the <nick/> element is not
   present.=94

Should these be normative requirements?

=3D Section 9 =3D

I don=92t think it=92s sufficient to refer to the security =
considerations of the underlying specifications.

This section omits discussion about whether the gateways needed for =
groupchat are expected to support the security requirements of the =
protocols they are gatewaying. The other two drafts address this point =
and it needs to be addressed here as well. Same goes for end-to-end =
security protections =97 some discussion is needed.

Also, many of the groupchat features that are left unspecified in this =
draft could be considered to be application security features: room =
administration, moderation, semi-anonymous rooms/anonymous =
participation, kicking and banning, etc. It seems at least worth =
mentioning that implementations supporting the feature set specified =
here cannot afford users with those features as they may be accustomed.


Editorial nits:

=3D Section 4 =3D
s/By contrast, in MSRP sessions/By contrast, in MSRP, sessions/

=3D Section 5.1 =3D
s/establising/establishing/

s/the that message (F7)./that message (F7)./

=3D Section 5.2 =3D
s/such =93JuliC"/such as =93JuliC=94/

=3D Section 5.4 =3D
s/translate the participant list/translates the participant list/

=3D Section 5.6 =3D
s/the gateway might generate a new nickname request/the gateway might =
generate a new nickname request with a different nickname/

=3D Section 6.3.1 =3D
s/then generate and send/then generates and sends/

