Subject: Re: [Supa] [email-masked]: Validation issue

From: Georgios Karagiannis <[email-masked]>
Date: Mon, 8 May 2017 14:54:22 +0000

Dear Benoit,

Thanks very much for stimulating the SUPA work.
I hope that Joel and John can provide answers to the fact that the YANG tools are not being able compile the SUPA DM.

Best regards,
Georgios

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Tuesday, April 18, 2017 10:44 PM
To: [email-masked]
Cc: [email-masked] 
Subject: [Supa] [email-masked]: Validation issue

Dear authors,

See http://www.claise.be/IETFYANGPageCompilation.html

Regards, B.

_______________________________________________
Supa mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/supa

---

From: Joel Halpern <[email-masked]>
Date: Mon, 8 May 2017 15:01:39 +0000

The problems reported by that spreadsheet are generated by an error in the tool.
Yours,
Joel

-----Original Message-----
From: Georgios Karagiannis [mailto:[email-masked]] 
Sent: Monday, May 08, 2017 10:54 AM
To: Benoit Claise <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: [Supa] [email-masked]: Validation issue

Dear Benoit,

Best regards,
Georgios

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Tuesday, April 18, 2017 10:44 PM
To: [email-masked]
Cc: [email-masked] 
Subject: [Supa] [email-masked]: Validation issue

Dear authors,

Regards, B.

---

From: Andy Bierman <[email-masked]>
Date: Mon, 8 May 2017 10:47:56 -0700

Hi,

I ran the 3 latest versions of yangdump-pro on the file
[email-masked].
I am not seeing these false identityref errors:

[email-masked]:662: error: the value
"POLICY-COMPONENT-TERM-TYPE" is not valid for the base type - identityref
not derived from SUPA-ROOT-TYPE

There are no errors in this module.
I will work with Benoit to make sure his tool setup is getting the same
results as seen in the lab.

Andy

On Mon, May 8, 2017 at 8:01 AM, Joel Halpern <[email-masked]>
wrote:

> I hope that Joel and John can provide answers to the fact that the YANG
> tools are not being able compile the SUPA DM.
>
> Best regards,
> Georgios
>
>

---

From: Georgios Karagiannis <[email-masked]>
Date: Tue, 9 May 2017 08:05:36 +0000

Hi Andy,

Thanks very much for the clarification.

Best regards,
Georgios

From: Andy Bierman [mailto:[email-masked]]
Sent: Monday, May 08, 2017 7:48 PM
To: Joel Halpern
Cc: Georgios Karagiannis; [email-masked]
Subject: Re: [Supa] [email-masked]: Validation issue

Hi,

I ran the 3 latest versions of yangdump-pro on the file [email-masked]<mailto:[email-masked]>.
I am not seeing these false identityref errors:

[email-masked]:662<mailto:[email-masked]:662>: error: the value "POLICY-COMPONENT-TERM-TYPE" is not valid for the base type - identityref not derived from SUPA-ROOT-TYPE

There are no errors in this module.
I will work with Benoit to make sure his tool setup is getting the same results as seen in the lab.

Andy

On Mon, May 8, 2017 at 8:01 AM, Joel Halpern <[email-masked]<mailto:[email-masked]>> wrote:
The problems reported by that spreadsheet are generated by an error in the tool.
Yours,
Joel

-----Original Message-----
From: Georgios Karagiannis [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, May 08, 2017 10:54 AM
To: Benoit Claise <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Supa] [email-masked]<mailto:[email-masked]>: Validation issue

Dear Benoit,

Best regards,
Georgios

-----Original Message-----
From: Supa [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Benoit Claise
Sent: Tuesday, April 18, 2017 10:44 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Supa] [email-masked]<mailto:[email-masked]>: Validation issue

Dear authors,

Regards, B.

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa