Subject: [Supa] SUPA Update

From: "King, Daniel" <[email-masked]>
Date: Thu, 15 Jun 2017 11:39:53 +0000

Dear supa'rs,

We have cancelled our formal meeting in Prague. This decision was taken based on a proposed plan to focus effort on completing the existing WG items and prepare for closure of the supa working group sometime between IETF 99 and 100. A plan that is yet to be approved by Benoit.

During the last working group meeting Benoit stated:

"the WG will be closed at IETF 99 (Prague, 16 July) unless there is substantive progress on the Information Model and especially on the Data Model draft by one month before the Prague meeting."

The authors of the Data Model and Information Model I-Ds did submit new versions but we only received one review. However, Nevil and I are working with the IM and DM authors to gather reviewers in preparation of Last Call. Essentially, we are working to prep folks who would be able to review the documents we Last Call, ideally these should be from policy/yang implementers.

The Framework I-D has also received a review which is positive, and I am in the process of reviewing the document myself to also help prepare the document for Last Call. Additionally, the Applicability I-D (a non-working group document) received a review which is also useful.

We have also seen notifications from other SDOs following supa, specifically:
- ONUG: Investigating I2NSF combined with the SUPA data model and framework
- ETSI Experiential Networked Intelligence (ENI): New initiative defining context aware networking systems, SUPA was identified as a key building block
- MEF Open Lifecycle Service Orchestrator (LSO): Using SUPA between functional components

However, the indication from ONUG, ETSI and MEF does not materially change the situation of SUPA but it does demonstrate wider interest in our work, and at least some responsibility for supa/IETF to complete it (if possible). If you are aware of near-term implementations now is the time to highlight them.

Again, we felt we did not need a WG meeting in Prague to progress the working group I-Ds, and given the IETF agenda coordination call (is today) we had to cancel the supa WG session request ASAP, and unfortunately before we had a chance to communicate the current situation to the rest of the working group. Apologies for any surprise when you saw the cancellation notification, and the lack of opportunity for wider discussion.

As mentioned our proposed plan has been submitted to Benoit and is yet to be approved, therefore we will wait for his thoughts and ultimate decision.

The SUPA Chairs would sincerely like to thank everyone for their participation and especially the authors of I-Ds for their efforts.

BR, Nevil and Dan.

---

From: Benoit Claise <[email-masked]>
Date: Thu, 15 Jun 2017 14:46:30 +0200

Dear all,

After the last IETF, I put a calendar reminder on June 16th to decide on 
the next steps for SUPA.
This is inline with the our previous meeting minutes, so it should not 
come as a surprise.
Granted, this is one day earlier than foreseen, but the IESG agenda 
coordination call takes place today, and it was important from a 
scheduling point of view to understand if SUPA would meet. The chairs 
informed me that no SUPA meeting is required in Prague. That triggered 
this discussion, just one day earlier.

Our meeting minutes: 
https://www.ietf.org/mail-archive/web/supa/current/msg01612.html

    At the SUPA WG at IETF 98 (Tuesday, 28 March) we discussed the
    progress of the WG.  Benoit (our AD) summed up the situation, pointing
    out that our drafts are not updated very frequently, and that the SUPA
    mailing list has been very quiet between meetings.

    At the meeting the authors of the SUPA Information model and the SUPA
    Data Model drafts said that those drafts should be ready for WG Last
    Call by 1 June, so that they could be sent to IESG for approval by
    about 1 July.

    After summing up the pros and cons for SUPA continuing, Benoit
    concluded by saying that the WG will be closed at IETF 99 (Prague, 16
    July) unless there is substantive progress on the Information Model
    and especially on the Data Model drafts by one month before the Prague
    meeting.  'Substantive progress' here means seeing comments on and/or
    reviews of these drafts demonstrating that people - outside the small
    group of authors - have carefully read the drafts, or better, that they
    are actually using SUPA's Information and Data Models.

I've been watching the list.
Since the last IETF meeting, we received two new drafts ...

         draft-ietf-supa-generic-policy-info-model-03.txt
         draft-ietf-supa-generic-policy-data-model-03.txt

... and some draft reviews:

        [email-masked] on on
        draft-ietf-supa-policy-based-management-framework:

            Good feedback but it seems like only editorial to me.

        Tony [email-masked] on draft-cheng-supa-applicability:

            Some editorial comments and three technical ones:

            1.       I wonder the meaning of section 3, the part copied
            from framework draft, may not be needed.

            2.       I suggest to replace the title of 4.2.2.and 4.2.3
            with detailed information instead of writing just   Example
            1 / 2.

            3.       The writer wrote “We will define "edgeInterface"
            role and "EnterpriseDomain" later in  this note” but I
            failed to find the explanation for these two term.

            Benoit => it's more like one technical comment, the last one.

        Haining Wang: [email-masked] on
        draft-ietf-supa-generic-policy-data-model-03:

            I understand that the GPIM YANG model provides an example of
            how to convert IM to DM (for general policy), and John’s
            SNMP blocking example
            (https://mailarchive.ietf.org/arch/msg/supa/DWEzaSBK6KBdsmQ0FE2-eypTzeY)
            exposes some details. But I am sorry that the whole picture
            is still not clear to me. It would be nice if the ECA Data
            Model part can explain in more details.

        March Blanchet on draft-ietf-supa-policy-based-management-framework:

            - larger comment: I’m not sure what to do with this
            document. It looks like a large wish list of features. I
            guess I’m probably too used to implementation/protocol
            details. I guess I will wait until to see the actual
            protocol/yang models. 

Let's analyze the situation:
I don't consider those reviews (btw a single one the DM, none on the IM) 
as "substantive progress".
I don't see interest from YANG module authors, ready to reuse the SUPA 
YANG constructs.
Being a year late according to the charter milestones, the window of 
opportunity to produce reusable work has been closing rapidly.
I believe that SUPA had multiple chances to make it happen, and failed 
to deliver.
With this in mind, I don't see how I should conclude anything else than 
this WG will be closing at IETF 99.

Regards, Benoit (OPS AD)
>
> Dear supa’rs,
>
> We have cancelled our formal meeting in Prague. This decision was 
> taken based on a proposed plan to focus effort on completing the 
> existing WG items and prepare for closure of the supa working group 
> sometime between IETF 99 and 100. A plan that is yet to be approved by 
> Benoit.
>
> “the WG will be closed at IETF 99 (Prague, 16 July) unless there is 
> substantive progress on the Information Model and especially on the 
> Data Model draft by one month before the Prague meeting.”
>
> The authors of the Data Model and Information Model I-Ds did submit 
> new versions but we only received one review. However, Nevil and I are 
> working with the IM and DM authors to gather reviewers in preparation 
> of Last Call. Essentially, we are working to prep folks who would be 
> able to review the documents we Last Call, ideally these should be 
> from policy/yang implementers.
>
> The Framework I-D has also received a review which is positive, and I 
> am in the process of reviewing the document myself to also help 
> prepare the document for Last Call. Additionally, the Applicability 
> I-D (a non-working group document) received a review which is also 
> useful.
>
> - ETSI Experiential Networked Intelligence (ENI): New initiative 
> defining context aware networking systems, SUPA was identified as a 
> key building block
>
> However, the indication from ONUG, ETSI and MEF does not materially 
> change the situation of SUPA but it does demonstrate wider interest in 
> our work, and at least some responsibility for supa/IETF to complete 
> it (if possible). If you are aware of near-term implementations now is 
> the time to highlight them.
>
> Again, we felt we did not need a WG meeting in Prague to progress the 
> working group I-Ds, and given the IETF agenda coordination call (is 
> today) we had to cancel the supa WG session request ASAP, and 
> unfortunately before we had a chance to communicate the current 
> situation to the rest of the working group. Apologies for any surprise 
> when you saw the cancellation notification, and the lack of 
> opportunity for wider discussion.
>
> As mentioned our proposed plan has been submitted to Benoit and is yet 
> to be approved, therefore we will wait for his thoughts and ultimate 
> decision.
>
> The SUPA Chairs would sincerely like to thank everyone for their 
> participation and especially the authors of I-Ds for their efforts.
>
> BR, Nevil and Dan.
>

---

From: youlizhao <[email-masked]>
Date: Tue, 20 Jun 2017 07:37:40 +0000

Dear Benoit AD,

Thanks for pushing and monitoring the SUPA WG progress.

I am sorry to see the email below. I am an engineer in Huawei, and recently we have been developing the code of SUPA ECA policy to control the network. In particular, we provide restful interface to users for configuring ECA policies following the ECA DM.

To be honest, IMO, the ECA IM and DM are not mature enough for direct implementation. We are revising some parts facilitating the implementation.

Although the SUPA IM and DM still contain flaws, we hoped to see them completed (also other documents, e.g., SUPA framework) so that we can complete our own implementations based on SUPA standard work.

Thanks for your consideration.

Regards,
Leo

From: SUPA [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: 2017年6月15日 20:47
To: King, Daniel <[email-masked]>; SUPA list <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Supa] SUPA Update

Dear all,

After the last IETF, I put a calendar reminder on June 16th to decide on the next steps for SUPA.
This is inline with the our previous meeting minutes, so it should not come as a surprise.
Granted, this is one day earlier than foreseen, but the IESG agenda coordination call takes place today, and it was important from a scheduling point of view to understand if SUPA would meet. The chairs informed me that no SUPA meeting is required in Prague. That triggered this discussion, just one day earlier.

Our meeting minutes: https://www.ietf.org/mail-archive/web/supa/current/msg01612.html

about 1 July.

are actually using SUPA's Information and Data Models.
I've been watching the list.
Since the last IETF meeting, we received two new drafts ...
    draft-ietf-supa-generic-policy-info-model-03.txt
    draft-ietf-supa-generic-policy-data-model-03.txt
... and some draft reviews:
[email-masked]<mailto:[email-masked]> on on draft-ietf-supa-policy-based-management-framework:
Good feedback but it seems like only editorial to me.
Tony [email-masked]<mailto:[email-masked]> on draft-cheng-supa-applicability:
Some editorial comments and three technical ones:
1.       I wonder the meaning of section 3, the part copied from framework draft, may not be needed.
2.       I suggest to replace the title of 4.2.2.and 4.2.3 with detailed information instead of writing just   Example 1 / 2.
3.       The writer wrote “We will define "edgeInterface" role and "EnterpriseDomain" later in  this note” but I failed to find the explanation for these two term.
Benoit => it's more like one technical comment, the last one.

Haining Wang: [email-masked]<mailto:[email-masked]> on draft-ietf-supa-generic-policy-data-model-03:
I understand that the GPIM YANG model provides an example of how to convert IM to DM (for general policy), and John’s SNMP blocking example (https://mailarchive.ietf.org/arch/msg/supa/DWEzaSBK6KBdsmQ0FE2-eypTzeY) exposes some details. But I am sorry that the whole picture is still not clear to me. It would be nice if the ECA Data Model part can explain in more details.
March Blanchet on draft-ietf-supa-policy-based-management-framework:
- larger comment: I’m not sure what to do with this document. It looks like a large wish list of features. I guess I’m probably too used to implementation/protocol details. I guess I will wait until to see the actual protocol/yang models.

Let's analyze the situation:
I don't consider those reviews (btw a single one the DM, none on the IM) as "substantive progress".
I don't see interest from YANG module authors, ready to reuse the SUPA YANG constructs.
Being a year late according to the charter milestones, the window of opportunity to produce reusable work has been closing rapidly.
I believe that SUPA had multiple chances to make it happen, and failed to deliver.
With this in mind, I don't see how I should conclude anything else than this WG will be closing at IETF 99.

Regards, Benoit (OPS AD)

Dear supa’rs,

“the WG will be closed at IETF 99 (Prague, 16 July) unless there is substantive progress on the Information Model and especially on the Data Model draft by one month before the Prague meeting.”

BR, Nevil and Dan.

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 20 Jun 2017 07:57:01 +0000

Hi Benoit,

While I cannot talk for YANG module authors, and it is true that the WG has a significant delay in its deliverables, I ‘d like to stress that SUPA has produced reusable work that is being used elsewhere, and a closing of the group before it finishes its commitments would damage these other works. I am directly involved in the I2NSF WG (that is progressing quite well in my opinion), and in several collaborative European projects related with 5G and security, including a number of network operators that are experimenting with SUPA-based policy statements. And I am aware of the ONUG interest as well, though not being involved I cannot detail what they are targeting now.

So I would ask you to reconsider the decision of closing SUPA at IETF 99.

Be goode,

On 15 Jun 2017, at 14:46 , Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Regards, Benoit (OPS AD)
Dear supa’rs,

BR, Nevil and Dan.

_______________________________________________
SUPA mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Ying Cheng <[email-masked]>
Date: Tue, 20 Jun 2017 16:55:56 +0800

Dear Benoit,

We are focusing on the update of applicability draft based on the valuable comments received during Chicago meeting. Current use cases in applicability draft come from the real service scenarios of operators and SUPA IM and DM are potential and valuable to support them as policy based mechanism. 

I am grateful for your continuous help and suggestion for creation and progress of SUPA. Hasty closure of this working group will cut off the half-done promising standardization work, which is a huge waste of time and effort. I would like to ask for your reconsideration on this significant decision.

BR,
Ying

2017-06-20 

Ying CHENG  程莹
Technology Department, China Unicom 中国联通集团技术部
Tel: +86-10-66259394
Mobile: +86-18601102971 

发件人： Benoit Claise 
发送时间： 2017-06-15  20:46:49 
收件人： King, Daniel; SUPA list 
抄送： [email-masked]; [email-masked] 
主题： Re: [Supa] SUPA Update 
 
Dear all,

[email-masked] on on draft-ietf-supa-policy-based-management-framework: 
Good feedback but it seems like only editorial to me.

Haining Wang: [email-masked] on draft-ietf-supa-generic-policy-data-model-03:

Regards, Benoit (OPS AD)

Dear supa’rs,

 

 

 

BR, Nevil and Dan.

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 21 Jun 2017 10:15:51 +0800

hi, Beonit.

Sorry to see this email. We don’t want to see SUPA closing right now as we just finished our trial of address management framework which may need SUPA policy to guide the policy part.
As far as we are concerned, our goal is to develop a policy module that guides address management. The policy module defines the control logic (policies), and should be separated from implementation details so that they can be configured or adjusted through open interface.
 
SUPA WG defines uniform formats and models for policies, serves as the foundation for policy-based control across different system components, and enables automation. We believe the model-based method could potentially avoid manual intervention and reduce our OPEX.

Thank you!

Chongfeng

[email-masked]
 
From: Benoit Claise
Date: 2017-06-15 20:46
To: King, Daniel; SUPA list
CC: [email-masked]; [email-masked]
Subject: Re: [Supa] SUPA Update
Dear all,

are actually using SUPA's Information and Data Models.I've been watching the list.
[email-masked] on on draft-ietf-supa-policy-based-management-framework: Good feedback but it seems like only editorial to me.
3.       The writer wrote “We will define "edgeInterface" role and "EnterpriseDomain" later in  this note” but I failed to find the explanation for these two term. Benoit => it's more like one technical comment, the last one.

Regards, Benoit (OPS AD)
Dear supa’rs,

 

 

 

BR, Nevil and Dan.

---

From: Benoit Claise <[email-masked]>
Date: Thu, 22 Jun 2017 07:58:26 +0200

Hi Diego,

Can you expand on the re-usability aspects.
What is being reused? the information model, the data model, something 
else? I hope more than the concepts.
What are you, yourself, reusing?

Regards, Benoit
> Hi Benoit,
>
> While I cannot talk for YANG module authors, and it is true that the 
> WG has a significant delay in its deliverables, I ‘d like to stress 
> that SUPA has produced reusable work that is being used elsewhere, and 
> a closing of the group before it finishes its commitments would damage 
> these other works. I am directly involved in the I2NSF WG (that is 
> progressing quite well in my opinion), and in several collaborative 
> European projects related with 5G and security, including a number of 
> network operators that are experimenting with SUPA-based policy 
> statements. And I am aware of the ONUG interest as well, though not 
> being involved I cannot detail what they are targeting now.
>
>> informed me that no SUPA meeting is required in Prague. That 
>> triggered this discussion, just one day earlier.
>>
>> Our meeting minutes: 
>>             1.       I wonder the meaning of section 3, the part
>>             copied from framework draft, may not be needed.
>>
>>             2.       I suggest to replace the title of 4.2.2.and
>>             4.2.3 with detailed information instead of writing just
>>             Example 1 / 2.
>>
>>             I understand that the GPIM YANG model provides an example
>>             of how to convert IM to DM (for general policy), and
>>             John’s SNMP blocking example
>>             exposes some details. But I am sorry that the whole
>>             picture is still not clear to me. It would be nice if the
>>             ECA Data Model part can explain in more details.
>>
>>         March Blanchet on
>>> sometime between IETF 99 and 100. A plan that is yet to be approved 
>>> by Benoit.
>>>
>>> new versions but we only received one review. However, Nevil and I 
>>> are working with the IM and DM authors to gather reviewers in 
>>> preparation of Last Call. Essentially, we are working to prep folks 
>>> who would be able to review the documents we Last Call, ideally 
>>> these should be from policy/yang implementers.
>>>
>>> The Framework I-D has also received a review which is positive, and 
>>> I am in the process of reviewing the document myself to also help 
>>> change the situation of SUPA but it does demonstrate wider interest 
>>> in our work, and at least some responsibility for supa/IETF to 
>>> complete it (if possible). If you are aware of near-term 
>>> implementations now is the time to highlight them.
>>>
>>> Again, we felt we did not need a WG meeting in Prague to progress 
>>> the working group I-Ds, and given the IETF agenda coordination call 
>>> (is today) we had to cancel the supa WG session request ASAP, and 
>>> situation to the rest of the working group. Apologies for any 
>>> surprise when you saw the cancellation notification, and the lack of 
>>> As mentioned our proposed plan has been submitted to Benoit and is 
>>> yet to be approved, therefore we will wait for his thoughts and 
>>> ultimate decision.
>>>
>> [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su 
> destinatario, puede contener información privilegiada o confidencial y 
> es para uso exclusivo de la persona o entidad de destino. Si no es 
> usted. el destinatario indicado, queda notificado de que la lectura, 
> utilización, divulgación y/o copia sin autorización puede estar 
> prohibida en virtud de la legislación vigente. Si ha recibido este 
> mensaje por error, le rogamos que nos lo comunique inmediatamente por 
> esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and 
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, 
> distribution or copying of this communication is strictly prohibited. 
> If you have received this transmission in error, do not read it. 
> Please immediately reply to the sender that you have received this 
> communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu 
> destinatário, pode conter informação privilegiada ou confidencial e é 
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa 
> senhoria o destinatário indicado, fica notificado de que a leitura, 
> utilização, divulgação e/ou cópia sem autorização pode estar proibida 
> em virtude da legislação vigente. Se recebeu esta mensagem por erro, 
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e 
> proceda a sua destruição