Subject: Re: [Supa] WG Last Call started for SUPA Framework draft version -03

From: "[email-masked]" <[email-masked]>
Date: Mon, 24 Jul 2017 14:41:23 +0800

Hi all,

I'm glad to see that the update fixed the issues of my comments. For my side, I confirm the document is ready to move forward.

Best wishes
Tony Tina

China Mobile

-----------------------------------------------------------
发件人: SUPA [mailto:[email-masked]] 代表 Nevil Brownlee
发送时间: 2017年7月18日,星期二 13:34
收件人: SUPA list
主题: [Supa] WG Last Call started for SUPA Framework draft version -03

Hi SUPA folk:
 
A new revision of the SUPA Framework draft has just been posted.
This version addresses all reviewer concerns to date, so we've started
a two-week WG Last Call for it.
 
Please take another look at it, and send coments to the SUPA list.
Even a brief "I agree with pubishing" note is useful at this stage!
 
Cheers, Nevil
 
--
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand
 
_______________________________________________
SUPA mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/supa

[email-masked]

---

From: Ying Cheng <[email-masked]>
Date: Fri, 28 Jul 2017 19:29:55 +0800

Hi all, 

I took a look at draft-ietf-supa-policy-based-managemetn-framework-03. The relationship between SUPA framework and network components (e.g., orchestrator/controller/NE) is well elaborated. How to generate DM is also well explained. I appreciate the efforts. 

I support this document publication. This is a good start for the SUPA work. 
 
Some small comments:
 
(1) IMO, in addition to Generic & ECA DMs, there should be specific & ECA DMs that are directly used for managing the network. For example, the SNMP blocking case and the virtual machine migration cases are different, implying different Events, Conditions and Actions definitions. 
 
The authors do not mention the specific DMs in the draft. But I believe, the Service Interface Logic (in Figure 1) can be extended (or are already defined but not explicitly written down) to generate such specific DMs, since its inputs are generic DM and resource/service YANG DM (network specific DMs). 
 
(2) I do not see the Resource and Service YANG Data models block in Figure 2, although they are mentioned in the texts descripting Figure 2 (Page 7, the paragraph above Figure 2). 
 
I believe, they might be added into SUPA Policy Data Model block, and based on the resource/service YANG DM, the management system generates configuration commands to impact orchestrator, controller and NE. 
 
(3) For the subtitle of 3.4., do the authors mean Generic YANG *Data* Modules?
 
(4) The texts contain *Note from Editor*. There are two places. Are they temporary remarks?

BR,
Ying

2017-07-28 

Ying CHENG  程莹
Technology Department, China Unicom 中国联通集团技术部
Tel: +86-10-66259394
Mobile: +86-18601102971 

发件人： Nevil Brownlee 
发送时间： 2017-07-18  13:34:18 
收件人： SUPA list 
抄送： 
主题： [Supa] WG Last Call started for SUPA Framework draft version -03 
 
Hi SUPA folk: