Subject: [Supa] review for draft-ietf-supa-policy-based-management-framework-02

From: Yangyang Wang <[email-masked]>
Date: Sun, 9 Jul 2017 17:58:44 +0800

I have reviewed  draft-ietf-supa-policy-based-management-framework. My
comments are as follows:

1) This draft contains many concepts that are very abstract. I suggest this
draft may briefly describe the contents and the goal  of this draft and its
significance. Some simple and concrete instances can be added in the
descriptions of the management framework to help clarify the abstract
concepts and framework in this draft.

2) "Traffic flow over increasingly complex enterprise and service provider
network becomes more and more important" may be change to "The management
of Traffic flow over increasingly complex enterprise and service provider
network becomes more and more important ?

3) "OSS:Operations/Operational Support System, are computer systems" should
be "OSS: Operations/Operational Support Systems, are computer systems".

4) "Imperative policy rules require additional management functions, which
are explained in section 2.2 below" may be  "Imperative policy rules
require additional management functions, which are explained in section 3.2
below"

5) "(1:1..n) in (1) and (2) below figure 3 shows one policy rule is able to
manages and can adjust one or multiple services/resources." may be
"(1:1..n) in (1) and (2) below figure 3 show one policy rule is able to
manage and adjust one or multiple services/resources." ?

6) "The Operator actor shown can interact with SUPA in other ways not shown
in Figure 1" may be "The Operator actor, shown in figure 1, can interact
with SUPA in other ways not shown in Figure 1"

Best regards,
Yangyang

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Mon, 17 Jul 2017 21:40:09 +0000

Hi Yangyang,

Many thanks for your comments. Some responses below inline.

From: Yangyang Wang [mailto:[email-masked]]
Sent: Sunday, July 09, 2017 11:59 AM
To: [email-masked]
Cc: Liushucheng (Will Liu) <[email-masked]>; Jun Bi <[email-masked]>
Subject: review for draft-ietf-supa-policy-based-management-framework-02

I have reviewed  draft-ietf-supa-policy-based-management-framework. My comments are as follows:

1) This draft contains many concepts that are very abstract. I suggest this draft may briefly describe the contents and the goal  of this draft and its significance. Some simple and concrete instances can be added in the descriptions of the management framework to help clarify the abstract concepts and framework in this draft.
[Will] The goal of this draft is describing the SUPA basic framework, its elements and interfaces. I guess you wanted to ask about the goal of SUPA? The SUPA working group defines a data model, to be used to represent high-level, possibly network-wide policies, which can be input to a network management function (within a controller, an orchestrator, or a network element). Processing that input most probably results in network configuration changes.
Some simple instances will be added and also refer to the applicability draft [I-D.cheng-supa-applicability].

2) "Traffic flow over increasingly complex enterprise and service provider network becomes more and more important" may be change to "The management of Traffic flow over increasingly complex enterprise and service provider network becomes more and more important ?
[Will] No exactly.  Here we mean firstly the traffic is more and more important, second the variety makes deploying new service more difficult, leading to the mechanisms of policy-based management which deals with above issues.

3) "OSS:Operations/Operational Support System, are computer systems" should be "OSS: Operations/Operational Support Systems, are computer systems".

4) "Imperative policy rules require additional management functions, which are explained in section 2.2 below" may be  "Imperative policy rules require additional management functions, which are explained in section 3.2 below"

5) "(1:1..n) in (1) and (2) below figure 3 shows one policy rule is able to manages and can adjust one or multiple services/resources." may be "(1:1..n) in (1) and (2) below figure 3 show one policy rule is able to manage and adjust one or multiple services/resources." ?

6) "The Operator actor shown can interact with SUPA in other ways not shown in Figure 1" may be "The Operator actor, shown in figure 1, can interact with SUPA in other ways not shown in Figure 1"
[Will] All the above are fixed.

Regards,
Will