Subject: [Syslog-sec] -transport-udp, section 4.4 - UDP checksums

From: "Rainer Gerhards" <[email-masked]>
Date: Thu, 17 Jun 2004 14:08:28 +0200

WG,

section 4.4 demands UDP checksums in all cases (which means on IPv4,
too). I am in doubt if all IPv4 stacks support UDP checksums (e.g.
minimalistic stack in embedded device). So I propose that we just
recommend them, but not demand them.

Rainer
_______________________________________________
Syslog-sec mailing list
[email-masked]
http://www.employees.org/mailman/listinfo/syslog-sec

---

From: "Anton Okmianski" <[email-masked]>
Date: Thu, 17 Jun 2004 10:51:29 -0400

Rainer, I think it is a good point. 

I am fine with changing this to SHOULD if hear no objections.  Note,
UDP checksums are already required in IPv6. The SHOULD will only apply
to IPv4. 

Anton. 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> Of Rainer Gerhards
> Sent: Thursday, June 17, 2004 8:08 AM
> To: [email-masked]
> Subject: [Syslog-sec] -transport-udp, section 4.4 - UDP checksums
> 
> 
> WG,
> 
> section 4.4 demands UDP checksums in all cases (which means 
> on IPv4, too). I am in doubt if all IPv4 stacks support UDP 
> checksums (e.g. minimalistic stack in embedded device). So I 
> propose that we just recommend them, but not demand them.
> 
> 
> Rainer
> http://www.employees.org/mailman/listinfo/sysl> og-sec
>